Old 24th March 2011, 01:33   #41
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 669
Quote:
Originally Posted by Koopa View Post
...Best would be, if you'd download the whole installer again, then it should look like it does on the attached image...
I just downloaded and ran the installer. The date still shows March 17. Is there somewhere else that has an up-to-date installer? Maybe wherever MrSinatra downloaded from.

Jim

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 24th March 2011, 01:41   #42
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
Quote:
Originally Posted by DJ Egg View Post
Winamp 5.61, Build 3133 (5.6.1.3133) - 17 Mar 2011 - Revised: 22 Mar 2011

Winamp 5.61 Full (US English version)
this thread, first post, first link.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 24th March 2011, 02:06   #43
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 669
Quote:
Originally Posted by MrSinatra View Post
this thread, first post, first link.
I used that link for the third time and still show March 17.
I guess I'll wait until the next documented release.
Stuff like this happens so often when updates are released. I broke my own rule by installing the "new" release too quickly!

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 24th March 2011, 02:14   #44
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
thats really weird. i wish egg would respond!

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 24th March 2011, 02:29   #45
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
There is no updated winamp.exe in the patch, so you will not see a difference there in date or build; the changes are only to plugins. Unfortunately they didn't bother to bump the version numbers on the plugins either, so the only way to tell is that the modified dates on ml_online, gen_ml and gen_hotkeys are all 03/22 after installing the patch.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 24th March 2011, 04:30   #46
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Yup, the patch only contains files with changed code:
ml_online.dll, ombrowser.w5s, gen_ml.dll, gen_hotkeys,dll, player-normal-group.xml

If you want winamp.exe, elevator.exe, winampa.exe and all the other unchanged files to have the new timestamp, then you'll need to reinstall the full installer.

No version or build number bump, hence a silent update.

We were giving it a week of testing before enabling the internal updater notification.
DJ Egg is offline   Reply With Quote
Old 24th March 2011, 06:05   #47
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
That still doesn't explain, why MrSinatra's winamp.exe was reverted to the version from March the 17th after installing the patch.

osmosis:

The full installer for sure has a different winamp.exe, dated with march the 22th.

ryerman:

You may want to clear your browser cache. Maybe this allows you to download latest installer without any issue.

Egg:

Silent updates and update packs are one thing, but simply shipping a winamp.exe with a modified build number and date is no big deal, isn't it? We have tons of postings now, just because of the fact, that there is no visual indicator for people, who've downloaded the update patch. If I can remember, we always shipped a modified winamp.exe in the past.

That 'waiting a week' thing I don't check either. I doubt that the majority of users will wait, until you've turned that lame update notification on (furthermore I guess it's disabled on most systems).

Also many websites host Winamp 5.61 on their sites, since it was originally released (March the 17th). Many people download their software from these sites, so I guess most users already got their (buggy) 5.61 install and this it is.

And the past also showed, that websites like BetaNews etc don't notice, that there was a silent update, especially if even the build number hasn't changed. :/ You cannot blame these sites, how do they should know, that there is a newer version, if the newer version has the same build number like the old version? Neither are you able to force people to download Winamp from Winamp.com only.

People who've downloaded directly from Winamp.com probably never will know, that there was a silent update either.

I completely fail to see, what's wrong with a 5.61a or 5.61.1 release or at least a new build number. If there is a major crash bug, they simply should push a new version and not fixing it without any note.

So shall we recommend, that people should wait a week in future, before they download their version, just to make sure, that they have latest version? Sorry that was sarcasm.
Koopa is offline   Reply With Quote
Old 24th March 2011, 06:29   #48
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
lets not be too hard on the devs koopa, i'd rather get the fixes then have them worry about our reaction! i'm sure they'll reflect on it, but for now i'm very happy with this wonderful version of winamp! (apple polishing over)

Quote:
Originally Posted by Koopa View Post
That still doesn't explain, why MrSinatra's winamp.exe was reverted to the version from March the 17th after installing the patch.
i'm not sure i follow you here? i had the orig full 17 mar install. then when i saw the patch was out, i applied it twice. the patch probably worked both times, it just didn't update the winamp.exe, (since winamp.exe isn't in the patch) thus the lightning bolt about screen still said 17 mar. when i did the full install, as you suggested i do, it did update, to 22 mar.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 24th March 2011, 06:34   #49
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Originally Posted by MrSinatra View Post
i'm not sure i follow you here? i had the orig full 17 mar install. then when i saw the patch was out, i applied it twice. the patch probably worked both times, it just didn't update the winamp.exe, (since winamp.exe isn't in the patch) thus the lightning bolt about screen still said 17 mar. when i did the full install, as you suggested i do, it did update, to 22 mar.
My bad, I've misunderstood your posting, sounded like you've installed the full installer, the date was fixed then and you applied the patch after again, which reverted the date to 17th. Remembers me to not post lately after midnight in future again, hehe.
Koopa is offline   Reply With Quote
Old 24th March 2011, 11:21   #50
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 669
Quote:
Originally Posted by Koopa View Post

...You may want to clear your browser cache. Maybe this allows you to download latest installer without any issue...
Koopa

Thank-you. Clearing the browser cache allowed the latest installer to be downloaded. Date is now correct.
And I agree with your comments to DJ Egg. There's nothing wrong with a little constructive criticism.

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 24th March 2011, 16:29   #51
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
Quote:
Originally Posted by MrSinatra View Post
i had the orig full 17 mar install. then when i saw the patch was out, i applied it twice. the patch probably worked both times, it just didn't update the winamp.exe, (since winamp.exe isn't in the patch) thus the lightning bolt about screen still said 17 mar. when i did the full install, as you suggested i do, it did update, to 22 mar.
Yup, that's just because in the full installer they have bumped the dates, nothing has actually changed though.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 25th March 2011, 10:49   #52
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Or I could just delete the update patch and all the posts related to it....
DJ Egg is offline   Reply With Quote
Old 25th March 2011, 12:15   #53
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Quote:
Originally Posted by DJ Egg View Post
Or I could just delete the update patch and all the posts related to it....
Anything to stop the complaining!
Juanus is offline   Reply With Quote
Old 25th March 2011, 17:48   #54
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Originally Posted by DJ Egg View Post
Or I could just delete the update patch and all the posts related to it....
But that wouldn't resolve any of the issues with the full installer, which has the same build number like the old and is already hosted on tons of websites....
Koopa is offline   Reply With Quote
Old 26th March 2011, 05:05   #55
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
That's not really our problem. The download links on other websites should lead to download.nullsoft.com

Re: timestamps
winamp.exe, winampa.exe, elevator.exe, 95% of all the other files in the installer.... where do I stop?
If people want files that have unchanged code in them just for the newer timestamp, then they'll need to redownload the full installer.
The update patch only includes files with actual code changes.

Other than that, I'll put my hands up and admit it... it's all my fault. I liked 3133 as the build number and didn't want it to change :-)

Note: The internal update notification has now been enabled.
DJ Egg is offline   Reply With Quote
Old 26th March 2011, 12:27   #56
DARcode
Junior Member
 
DARcode's Avatar
 
Join Date: Aug 2009
Posts: 17
Easy to check IMO:
DARcode is offline   Reply With Quote
Old 27th March 2011, 20:17   #57
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
Quote:
Originally Posted by DJ Egg View Post
Oops. We still need to add some code to the WFA apk so it actually uses the new Album Artist code in pmp_wifi/android...

Thanks for pointing it out. Will be fixed in next apk.

And there was me in the first post saying not to discuss issues with the apk in this thread, lol.
Egg, what exactly do you mean above? i'm not following you.

also, please be aware of this thread:

http://forums.winamp.com/showthread.php?t=328403

since users are trying to figure out workarounds. how do you devs intend to solve the problem?

note that there are a lot of threads about this in the WfA forum.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 27th March 2011, 20:23   #58
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by MrSinatra View Post
note that there are a lot of threads about this in the WfA forum.
there's a lot of unanswered posts in that forum in general but i guess it just shows that no one who tries to give tech support basically uses WFA.

from what i understand, WFA doesn't use the AA aspect (for whatever reason) and so requires a newer version to be able to recognise / use it (or at least how i understood it when it was talked about elsewhere).

DARcode: that information isn't easily viewable on Vista / Windows 7 as part of the simplification of what is displayed to the user.

-daz
DrO is offline   Reply With Quote
Old 27th March 2011, 20:56   #59
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Quote:
Originally Posted by DJ Egg View Post
___________________________________________________________________________

Please do not post anything related to the WfA app in this thread. Use the WfA forum instead!
Winamp for Android forum | Winamp for Android Discussion thread


___________________________________________________________________________
Whats so hard to understand about this?
Juanus is offline   Reply With Quote
Old 29th March 2011, 16:08   #60
Scarecrow237
Junior Member
 
Join Date: Mar 2010
Posts: 8
Send a message via AIM to Scarecrow237
Quote:
Originally Posted by Koopa View Post
I also wonder, that nobody noticed, that the 'Create Playlist' button was replaced by a 'Generate Playlist' button, which isn't listed in the changelog, hehe
Or that the 'Generate Playlist' doesn't behave the same way that the 'Create Playlist' button did.

I'd like to have my 'Create Playlist' button and functions back please.
Scarecrow237 is offline   Reply With Quote
Old 13th April 2011, 05:30   #61
crazymunda
Junior Member
 
Join Date: Apr 2011
Posts: 2
Winamp is the one of the best source to watch videos and listen music, it provide lots of facilities. it is very fast in process and response , i Hope Winamp 5.61 will also be popular like old versions of Winamp
crazymunda is offline   Reply With Quote
Old 21st April 2011, 09:47   #62
_Marian
Junior Member
 
Join Date: Apr 2011
Posts: 33
I really like Winamp 5.61, I don't have problems with it so far.
_Marian is offline   Reply With Quote
Old 27th April 2011, 19:23   #63
jscupa
Junior Member
 
Join Date: Apr 2011
Posts: 1
I'm having trouble running this on windows 7.

Is anyone else having this problem?
jscupa is offline   Reply With Quote
Old 27th April 2011, 21:48   #64
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
anyone: I just noticed that "Adjustment for files without Replay Gain" doesn't seem to have any affect anymore.. and what's more, the Replay Gain preamp seems to apply to all files now, even those without. Can anyone else reproduce this?

jscupa: I've been running it on Windows 7 generally without issue since Windows 7 RTM'd. What type of issue are you seeing?

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 17th May 2011, 19:56   #65
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
Another thing.. not a bug report per say, or a feature request either.. more cosmetic I guess(?):

In the Format Converter, VBR new is still listed, even though it has now become VBR default with 3.98+. I believe VBR mtrh has also been deprecated.

http://wiki.hydrogenaudio.org/index....te.29_settings

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 23rd May 2011, 09:48   #66
Coxos
Junior Member
 
Join Date: May 2011
Posts: 1
here's the winamp discussion, not a bug - reporting thread!
just a little rspct
Coxos is offline   Reply With Quote
Old 23rd May 2011, 14:29   #67
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
Actually the release threads do often contain bug reports early on. This is a little later in the game, but really I wasn't posting bug reports. You'll notice my first post was discussing something I was seeing, looking for corroboration; my second didn't fit as bug report or feature request. Welcome to the forums, however! Always great to have new contributors.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump