Prev Previous Post   Next Post Next
Old 25th February 2013, 21:14   #1
xwwwx
Junior Member
 
Join Date: Feb 2013
Posts: 2
Exclamation Temp path problem with UAC Plugin

I am using the UAC plugin, I am testing with W7. My installer needs to drop a file on windows temp folder and execute it as user so I have something like this:

code:
SetOutPath $Temp
File "build.exe"
!insertmacro UAC_AsUser_ExecShell "" "$Temp\build.exe" "" "" ""



The problem is that the build.exe file is not being executed, it works if I use $DESKTOP or any other folder that wont change depending on the user level. So I suspect the error is that, the file build.exe is being dropped in C:\Users\admin\AppData\Local\Temp (i can confirm this browsing the folder), and UAC_AsUser_ExecShell tries to execute it on C:\Users\normaluser\AppData\Local\Temp (i cant confirm this but i dont know what else could cause the file to not execute)

I don't want to drop the files on the desktop or some folder like that, i wanted to use temp because I dont want to delete the file since i wont know when it ends the execution and didnt want to handle that.

Is there any solution to this?
xwwwx is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Tags
folder, plugin, uac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump