Old 10th November 2003, 03:43   #1
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
Remove silence

I tried the rmove silence option in the others tab in the out_ds but it seem to only cut off 2 seconds at the end only no matter what.

How do I make this function work right?

Thanx

Last edited by iron2000; 10th November 2003 at 04:41.
iron2000 is offline   Reply With Quote
Old 10th November 2003, 06:45   #2
Omega X
Forum King
 
Omega X's Avatar
 
Join Date: Feb 2003
Location: A Parallel Dimension
Posts: 2,253
Send a message via AIM to Omega X Send a message via Yahoo to Omega X
I think it might be a bug since It dosen't work for me completely sometimes. Have you tried extending the buffer size?
Omega X is offline   Reply With Quote
Old 10th November 2003, 07:01   #3
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,874
With what file formats are you testing with?

Gapless play in Winamp:

out_ds config -> Buffering tab
Increase "buffer ahead on track change" slider value to taste
(eg. anywhere between eg. 200ms to 1500ms)

For files recorded with silence at beginning or end, or for mp3 (which is not gapless by default due to a flaw in the mp3 technology)

out_ds config -> Other tab
Checkmark "remove silence"
Adjust "cut off" value to taste
Default = -40dB

eg.
Adjusting "cut off" to -100dB (moving slider to the right) will cut off less.
Adjusting it to -30dB (moving slider to the left) will cut off more.

The lowest value of -15dB will cut off much more than any 2 seconds.
Usually somewhere between 3 to 10 seconds are lost.
-15dB is not really a recommended value, and I wouldn't really go much lower than -30 / -25 ish.

Cut Off @ -40dB with Buffer Ahead @ ~1000ms produces perfect gapless play for me, with all formats. Buffer Ahead slider can be lower, but a higher value works better for Audio CD's (gapless mix cd's).

Note: There's a bug in the Sonic Engine with Winamp 5.0 Beta 2
where gapless Audio CD playback doesn't work when "Enable DAE" with "Use Sonic Engine" is checkmarked (in_cdda config).
The workaround is to checkmark "Enable DAE" and uncheck "Use Sonic Engine".
This makes Winamp fall back to ASPI first (all OS) or, if no ASPI layer found, then SPTI (Win2k/XP).

I know that you're using Win98
and the ASPI Layer is installed by default on this OS.

This bug is fixed in Beta 3
DJ Egg is offline   Reply With Quote
Old 10th November 2003, 15:41   #4
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
Ok I get it now, thanks guys.

Thanx
iron2000 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump