Old 27th November 2013, 19:41   #1
Legendarion
Junior Member
 
Join Date: Aug 2013
Posts: 16
Is this a known bug?

WinAmp is *Always On Top* or in front when you want to watch a video or something else in fullscreen even when the function is not enabled. It has been doing it since version 5.63 or 5.64.
Legendarion is offline   Reply With Quote
Old 29th November 2013, 17:39   #2
lostinsound
Senior Member
 
Join Date: Jul 2009
Posts: 139
I was having something similar happen for me but I never posted a bug report because it didn't happen that often and I couldn't figure out how to reliably reproduce it. It seemed to happen at random. A couple weeks ago I unchecked the 'Disable Always on Top when fullscreen applications are focused' under 'General Preferences' and I haven't had it happen since. I'm not sure that's definitively fixed it but I'm holding out hope. I never have Winamp set as 'Always on Top' to it's no loss for me.

For me it usually happened when I was watching something in fullscreen and when I would hit Esc to exit fullscreen, Winamp would jump to the top of all the windows and would be stuck on top until I clicked on the Winamp window and then clicked on another window. Like it was stuck temporarily on "Always on Top" mode. And I think there was one time where it got stuck on top when I went into fullscreen mode, but other than that one time it had always happened the other way.
lostinsound is offline   Reply With Quote
Old 29th November 2013, 17:51   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
there's a known weirdness with the video window and modern skins where it'll bring Winamp to the front and seems to be much like is being described. it was briefly looked into before the notice of termination but there wasn't anything obvious found which was causing it (as it happens generally when using modern skins - was never able to get it to happen with a classic skin).
DrO is offline   Reply With Quote
Old 12th December 2013, 21:52   #4
Legendarion
Junior Member
 
Join Date: Aug 2013
Posts: 16
Are you sure that this has something to do with modern skins?! Since I use a skin created in 2007 and I find it a bit unlikley that a skin cause a such problem/bug when it never happend with earlier versions.
Legendarion is offline   Reply With Quote
Old 12th December 2013, 22:06   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
yes because that's what was found during testing and is due to the modern skin engine, not the skin itself, but what does the skin. and whatever is causing it is too deep rooted into the code that i've not been able to determine it and now won't be able to as we're finishing off one last patch build and that's definitely it.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump