Old 28th July 2017, 11:15   #1
querschnitt
Junior Member
 
Join Date: Jul 2017
Posts: 4
Stereo MP3 to 4 Speakers

Hey Guys!

I'm using winamp 5.666 and Windows 10 Pro
I have a Creative Soundblaster Z Soundcard and a 5.1 Speaker System connected with analog cables.

I was wondering if I can listen to mp3's also on the rear speakers? I can check "surround" in my Soundcard Config, but then the mp3 will be upmixed to all 6 channels. I just want the mp3 to be mirrowed to the rear speakers. Is that possible?

Also: When I listen to Stereo MP3 my subwoofer is not used at all (crossover frequency is configured correctly). what can I do about it?
querschnitt is offline   Reply With Quote
Old 28th July 2017, 16:12   #2
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 527
Send a message via AIM to musicf8
Are you connected via analog cables or optical? Is this all set up?
Click image for larger version

Name:	Capture.JPG
Views:	70
Size:	65.7 KB
ID:	53415

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp 5.8: 9/14/2017

Winamp v5.63 (used w/ ml_ipod) bumping through Windows 10 Pro w/ Logitech Z-5500
musicf8 is offline   Reply With Quote
Old 28th July 2017, 20:11   #3
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Quote:
Originally Posted by querschnitt View Post
...

I was wondering if I can listen to mp3's also on the rear speakers? I can check "surround" in my Soundcard Config, but then the mp3 will be upmixed to all 6 channels. I just want the mp3 to be mirrowed to the rear speakers. Is that possible?
Simply disable the center channel in your 5.1 soundcard speaker configuration. Then when you enable "surround", you will only hear sound upmixed to the remaining 5 channels.

See the box with the checkmark to the left of the optional center speaker in the screenshot in the post above. Click on this checkmark and it disappears, disabling the center speaker. When you want to hear sound from the center speaker again, click in the box and the checkmark reappears, enabling the speaker again.

Alternatively, you could just select the 4.1 speaker configuration (when you don't want the center channel to be used), which would provide the same result.

Also, you can leave your soundcard speaker configuration alone and use the Windows Playback Devices controls. Go to the balance controls on the levels tab of the Speakers Properties in the control panel Sound app and set the output level of the center channel to zero.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 28th July 2017, 20:19   #4
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 527
Send a message via AIM to musicf8
i'm thinking a plugin might be a better choice though because that keeps the 'alteration' for music only... though I am not sure which one

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp 5.8: 9/14/2017

Winamp v5.63 (used w/ ml_ipod) bumping through Windows 10 Pro w/ Logitech Z-5500
musicf8 is offline   Reply With Quote
Old 28th July 2017, 20:29   #5
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Quote:
Originally Posted by musicf8 View Post
i'm thinking a plugin might be a better choice though because that keeps the 'alteration' for music only... though I am not sure which one
Yes, there is a plug-in (https://sourceforge.net/projects/winampmatrixmix/). I use it, but some people find it difficult to setup.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 28th July 2017, 20:30   #6
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 527
Send a message via AIM to musicf8
Thanks, i'll have to check it out when i get home

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp 5.8: 9/14/2017

Winamp v5.63 (used w/ ml_ipod) bumping through Windows 10 Pro w/ Logitech Z-5500
musicf8 is offline   Reply With Quote
Old 28th July 2017, 20:57   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Winamp Matrix Mixer lets you simply mirror input channels to up to 6 output channels or do much more. It can resample the input and/or let you control how much of each input channel is directed to each output channel. It can also delay the sound sent to each output channel to make up for non-optimal speaker placements and/or control echo effects.

It is an output plug-in that sends it's output to another selectable output plug-in such as the Winamp DirectSound output plug-in.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 29th July 2017, 02:51   #8
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 527
Send a message via AIM to musicf8
interesting enough it kills my sub, there's like zero output even trying to play with all the settings nothing goes to the sub

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp 5.8: 9/14/2017

Winamp v5.63 (used w/ ml_ipod) bumping through Windows 10 Pro w/ Logitech Z-5500
musicf8 is offline   Reply With Quote
Old 29th July 2017, 16:15   #9
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Quote:
Originally Posted by musicf8 View Post
interesting enough it kills my sub, there's like zero output even trying to play with all the settings nothing goes to the sub
Are you using an analog or digital connection to your speakers? Can you post a screenshot of your setup of the Mixer tab's settings in the Matrix Mixer configuration dialog?

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 30th July 2017, 21:54   #10
querschnitt
Junior Member
 
Join Date: Jul 2017
Posts: 4
i am using analog connection. Deactivating the center kinda works, but the music coming out from the rear speakers sound different than from the front speakers

the plugin is really confusing! I managed to get the rear speakers to work, but they are really quite! if I try to get them louder the front speakers get quiter and If I activate 4.1 I get an error when I try to play music
querschnitt is offline   Reply With Quote
Old 31st July 2017, 02:23   #11
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Quote:
Originally Posted by querschnitt View Post
...

the plugin is really confusing! I managed to get the rear speakers to work, but they are really quite! if I try to get them louder the front speakers get quiter and If I activate 4.1 I get an error when I try to play music
Can you post a screenshot of your setup of the Mixer tab's settings in the Matrix Mixer configuration dialog?

If you were using your soundcard's surround feature (instead of the plug-in) that might explain why the rear speakers sound different that the front. The surround feature of some soundcards is designed to do that. A true 'surround' effect (in games and movies and multi-channel audio) is supposed to have different sounds coming thru each output channel. Try Window's audio fill feature instead, it simply mirrors the front channels to the rear and/or side channels for stereo music (and combines the front channels to send to the center and sub-woofer channels).

The configurations for the OS (Windows) sound, your soundcard, and the plug-in (if you want to use it) must not conflict with one another. It's confusing at first (because of all the options available), but once you understand how they interact with each other, it soon becomes fairly simple to direct the audio source's input channels to the sound device's output channels in various ways.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system

Last edited by Aminifu; 31st July 2017 at 03:25.
Aminifu is offline   Reply With Quote
Old 31st July 2017, 19:44   #12
querschnitt
Junior Member
 
Join Date: Jul 2017
Posts: 4
Quote:
Originally Posted by Aminifu View Post
Try Window's audio fill feature instead, it simply mirrors the front channels to the rear and/or side channels for stereo music (and combines the front channels to send to the center and sub-woofer channels).

The configurations for the OS (Windows) sound, your soundcard, and the plug-in (if you want to use it) must not conflict with one another. It's confusing at first (because of all the options available), but once you understand how they interact with each other, it soon becomes fairly simple to direct the audio source's input channels to the sound device's output channels in various ways.
Windows Audio fill feature sounds exactly like what I need! But I never heard off it. I will google it and try to activate it.

and of course I've disabled surround in my creative software so there's no conflict

here are the screenshots:



The error is the one I get when I enable 4.1




querschnitt is offline   Reply With Quote
Old 1st August 2017, 16:07   #13
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Hi querschnitt,

The matrix mixer is not setup correctly for the result you are trying to accomplish. Set your overall volume control to a very low level. Change all of your settings on the Mixer tab to what is shown in the screenshot below. This will set up basic mirroring of the left and right input channels to the left and right front and rear/side output channels and the sub-woofer output channel. Click on the attached image for a larger view. Each column in the mixing matrix corresponds to an input channel and each row corresponds to an output channel.

The reason this setup works is a bit technical (geeky) to explain. I'm happy to provide the reasoning and point you to some technical documentation, if you're interested.

It is also important that your OS sound and soundcard output format configurations be setup to correspond with the plug-in's output format settings (i.e. number of channels, number of bits, and frequency). The error message you got is probably due to the OS sound and/or the soundcard configurations not being set to 2/2 quadro.

To establish a baseline for this mirroring mode, be sure that all of your soundcard's other special features (i.e. crystal sound, cinematic, mixer, equalizer, etc.) and Winamp's equalizer are disabled. You can reapply 1 or more of these features, as appropriate, after you know what the basic mirroring mode sounds like. Check that the output channel levels in the OS sound configuration are all set to the same value (ask if you need help with doing this).

Start some music playing and slowly increase the overall volume. You don't want to overdrive your speakers! This could cause distortion and may damage your speakers. Monitor the graphic representation of your input channel levels while the music is playing. If either input level frequently goes all the way to the top, use the input gain controls (on the plug-in's Gains tab) to lower the appropriate input level(s). Enter values in "-0.1" increments.

If any front or rear/side output channel is much louder relative to the others, then use the output gain controls (on the plug-in's Gains tab) to lower the volume of the loud channel(s). If the sub-woofer is too loud, then change the values in the mixing matrix row for the Sub output from "1" to "0.707" or "0.3535" before adjusting it's gain control. A value of "1" sends the full input level to the output, "0.707" sends 50%, and "0.3535" sends 25%.

After all this is working, I suggest you enable the full range options for your front and surround speakers in both the OS sound and your soundcard's configurations. If this causes distortion, then disable these full range options.



Click image for larger version

Name:	matrixmixer1.jpg
Views:	42
Size:	65.7 KB
ID:	53433


P.S.
The decoder info in your screenshot shows that the music you were playing is encoded with 24 bits. If most of your music is encoded with 24 bits, then select PCM 24 instead of PCM 16 in the plug-in and OS sound configurations (soundcard configuration too, if applicable).

If the decoder info is showing 24 bits because you used the Winamp option to resample your music (and your music files are not actually encoded with 24 bits), I suggest you disable that Winamp option. Winamp doesn't do true resampling to 24 bits, it just adds zeros to turn a 16 bit value into a 24 bit value.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system

Last edited by Aminifu; 1st August 2017 at 18:00.
Aminifu is offline   Reply With Quote
Old 1st August 2017, 16:17   #14
webchaat
Junior Member
 
Join Date: Aug 2017
Posts: 1
Thanks, I was also looking for this.
webchaat is offline   Reply With Quote
Old 2nd August 2017, 09:37   #15
querschnitt
Junior Member
 
Join Date: Jul 2017
Posts: 4
Quote:
Originally Posted by Aminifu View Post
Hi querschnitt,


P.S.
The decoder info in your screenshot shows that the music you were playing is encoded with 24 bits. If most of your music is encoded with 24 bits, then select PCM 24 instead of PCM 16 in the plug-in and OS sound configurations (soundcard configuration too, if applicable).

If the decoder info is showing 24 bits because you used the Winamp option to resample your music (and your music files are not actually encoded with 24 bits), I suggest you disable that Winamp option. Winamp doesn't do true resampling to 24 bits, it just adds zeros to turn a 16 bit value into a 24 bit value.
Hey! First of all i am really thankful for your help! i really, really appreciate it and your patience with me! thx

With your help I managed that the Front and Rear speakers sounding equal, but i'm still not 100% happy. I'm also not sure if I understand everything correctly

I'm not quite happy with the subwoofer. I can configure a crossover frequency in my soundcard software. My Subwoofer manufacture suggest a frequency of 150hz. Do I still need to configure the frequency in winamp just like in your screenshot?

And yes I have audio in 24 bit and also in 16 bit. Do I really have to change it every time? :-\ because that would be pretty annoying! I just wanna listen to some music. If the solution to my problem is gonna be this complicated I'll probably stick with 2 speakers

here are new screenshots:



querschnitt is offline   Reply With Quote
Old 5th August 2017, 17:15   #16
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Quote:
Originally Posted by querschnitt View Post
Hey! First of all i am really thankful for your help! i really, really appreciate it and your patience with me! thx

With your help I managed that the Front and Rear speakers sounding equal, but i'm still not 100% happy. I'm also not sure if I understand everything correctly
No problem. I enjoy trying to help people with this kind of stuff. Here is a link to some documentation for "AC3 Filter", which this plug-in is based on (http://www.ac3filter.net/wiki/AC3Filter). The layout of the configuration tabs are not exactly the same in this documentation, but the info on how to use the various options still applies. You can google for the definitions of any technical terms you don't understand and/or post questions. There is no such thing as a dumb question. I don't have all the answers, but I'm happy to share what I know.


Quote:
Originally Posted by querschnitt View Post
I'm not quite happy with the subwoofer. I can configure a crossover frequency in my soundcard software. My Subwoofer manufacture suggest a frequency of 150hz. Do I still need to configure the frequency in winamp just like in your screenshot?
In order for me to try and help you, you need to be specific (more descriptive) about what you're not happy with.

You can change the crossover frequency for the Bass redirection feature in the plug-in (just change the "45" to "150"), but I suggest you either use the Bass redirection feature in the plug-in or the one in your soundcard configuration (not both at the same time). Also, sub-woofers are not normally used for generating bass frequencies. They are best used for producing very low frequency sounds. These are sounds that you feel more than you actually hear. The speakers in old stereo component systems usually had at least 1 of 3 different types of speakers in each speaker cabinet. A tweeter for treble (high) frequencies, a woofer for bass (low) frequencies, and a mid-range type for the frequencies between treble and bass. Here is a link to an article that explains which frequencies do what (http://digitalprosound.digitalmedian...le.jsp?id=8953).

Today, the speakers in most speaker systems made for use with computers, use 1 kind of full range speaker that generates the treble, mid-range, and bass frequencies. It may sound better to let the full range speakers generate the low end of the bass frequencies than redirecting them to the sub-woofer.

This is why I suggested enabling the full range options in both the OS sound and your soundcard configurations. The image attached below shows the Windows 10 dialog for doing this. The image in post #2 above shows these options on a soundcard configuration panel. I assume your soundcard configuration panel looks similar.

Click image for larger version

Name:	fullrangespeakers.JPG
Views:	26
Size:	39.0 KB
ID:	53457


Quote:
Originally Posted by querschnitt View Post
And yes I have audio in 24 bit and also in 16 bit. Do I really have to change it every time? :-\ because that would be pretty annoying! I just wanna listen to some music. If the solution to my problem is gonna be this complicated I'll probably stick with 2 speakers
Since you have some music files encoded with 24 bits, then you should use the Winamp option to "Allow 24bit" and also change the output format in the plug-in from "PCM 16" to "PCM 24". Also make sure the OS sound configuration is also set up to use 24 bits. The image attached below shows the Windows 10 dialog for doing this. Optimally (for best sound reproduction), you should use the number of bits values encoded in your actual music files, but you don't really need to change back and forth from 24 bits to 16 bits. Just set everything up for the largest number of bits values your music files will ever have.

Click image for larger version

Name:	soundformat.JPG
Views:	28
Size:	59.0 KB
ID:	53458

Winamp will pass thru the 24 bit values from your 24 bit music files unchanged and turn 16 bit values from your 16 bit music files into 24 bit values (like I explained in my last post). The plug-in will then work with these 24 bit values without changing them. As you can see in the Decoder info box on your Main tab screenshot, when the plug-in is set for "PCM 16", it downsamples 24 bit input values to 16 bit output values (which you don't want it to do). The OS sound configuration will also upsample or downsample values to match what it is set for (which you also don't want to happen). It is best to do any resampling in 1 place (i.e. let Winamp do it) and then have everything else work with the same number of bits values.

Of course if you use Winamp to play music files encoded with values greater than 24 bits, it will downsample the values to 24 bit when the "Allow 24bit" option is enabled (or 16 bit values when it is not). But that is a problem for another day.



Sorry this post is so long, but there is 1 more thing I want to mention and I have a question.

First, I suggest you set the master gain option in the plug-in to "0" and use the controls on the Gains tab to adjust the input and/or output levels on a channel by channel basis. Each channel will normally rise to different levels as music plays, but you don't want any channel to regularly rise to it's maximum level. It's ok to get close to maximum and momentarily reach it from time to time, but it can distort the sound and may damage your speakers if any of the levels stay maximized. Also use 1 control for overall volume. I set the Winamp volume control to 100% and use the volume control on my speaker system to change the overall volume. It may be more convenient for you to do the reverse (i.e. set the speaker system volume control to a certain level and use the Winamp volume control to change the overall volume). Make sure that the levels for the OS sound output channels you use are set to the same value. The image attached below shows the Windows 10 dialog for doing this.

Click image for larger version

Name:	speakersbalance.JPG
Views:	31
Size:	50.7 KB
ID:	53456

Second, why are using the plug-in's AGC (automatic gain control) option? If some of your songs are soft and others are loud for the same overall volume level, there are better ways to deal with volume leveling between songs than using this AGC option.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 25th August 2017, 11:35   #17
estherbcn
Junior Member
 
Join Date: Aug 2017
Posts: 5
plugin might be a better choice
estherbcn is offline   Reply With Quote
Old 7th September 2017, 08:04   #18
Jack93
Junior Member
 
Join Date: Aug 2017
Posts: 3
Play mp3 with your phone. You think it good for listen mp3...
Google Play Music provides free, ad-supported radio for what you’re doing, how you’re feeling, or what you want to hear. Instantly start radio stations based on songs, artists, or albums, or browse by genre, mood, activity, decade, and more. Bring your own music collection with you by uploading 50,000 of your own songs; then listen to them on Android, iOS, and the web, for free.
Jack93 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump