Old 6th March 2012, 18:32   #1
dj001
Senior Member
 
dj001's Avatar
 
Join Date: Mar 2005
Location: Who's asking?
Posts: 452
.qtl script for Shoutcast stream

I need a .qtl script that works for all Shoutcast streams. This one worked with my old streamhost, but will not work with my new streamhost:

code:

<?xml version="1.0"?>
<?quicktime type="application/x-quicktime-media-link"?>

<embed
autoplay="true"
controller="true"
type="video/quicktime"
quitwhendone="false"
loop="false"
src="http://myURL:myPORT/listen.pls"
/>

dj001 is offline   Reply With Quote
Old 6th March 2012, 20:51   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm surprised a link to a pls file instead of what is basically another playlist file even works (i know it probably should but a lot of players don't handle things nicely).

i'd just go with src="http://myURL:myPORT/" and give the actual url of the stream instead of trying to get things to go through another level.

then again, i cannot remember if you're on a v1 or a v2 DNAS, so you'd need to apply /stream/xxx/ if necessary.

-daz
DrO is offline   Reply With Quote
Old 6th March 2012, 21:01   #3
dj001
Senior Member
 
dj001's Avatar
 
Join Date: Mar 2005
Location: Who's asking?
Posts: 452
I removed /listen.pls from the .qtl script, and it still doesn't work.

What do you mean by
Quote:
apply /stream/xxx/ if necessary
?
dj001 is offline   Reply With Quote
Old 6th March 2012, 21:13   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
the /stream/xxx/ part is how to access a stream in a v2 dnas where xxx is the streamid if it's the v2 DNAS you're using.

as for not working, is the DNAS even acknowledging anything of the connection attempt. that's the only thing which i can suggest.

-daz
DrO is offline   Reply With Quote
Old 6th March 2012, 21:22   #5
dj001
Senior Member
 
dj001's Avatar
 
Join Date: Mar 2005
Location: Who's asking?
Posts: 452
QuickTime is activated and this message spits out:
Quote:
Error -2048. Couldn't open the file myfile.qtl because it is not a file that QuickTime understands.
It worked perfectly with my previous streamhost.
dj001 is offline   Reply With Quote
Old 6th March 2012, 21:33   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
well if that's what quicktime is reporting then clearly something must be wrong or something with quicktime has changed. however i really don't know as i don't have access to quicktime currently to even attempt to try it out myself. though if that's the error then it points at quicktime over being the dnas i'd have thought.

-daz
DrO is offline   Reply With Quote
Old 11th March 2012, 08:05   #7
dj001
Senior Member
 
dj001's Avatar
 
Join Date: Mar 2005
Location: Who's asking?
Posts: 452
For some reason I cannot fathom, the qtl script must be on the same domain as the page with the listen-link button. This was not required with the old streamhost.
dj001 is offline   Reply With Quote
Old 11th March 2012, 18:15   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
k, well i might look to add in native qtl support to the v2 dnas to complement the pls, m3u, asx and xspf (coming in the next drop) playlists already supported. since there's more qtl usage than i thought was the case from doing some other work i've had to do recently.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Site Design

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump