Old 4th August 2010, 11:32   #1
theaskingman
Junior Member
 
Join Date: Jul 2010
Posts: 16
[solved] LangString in function not available?

Hi,
in my MUI_FINISHPAGE I'd like to show depending on the installed section different _TEXT.
This _TEXT needs to be localized. I check for the installed section with a _CUSTOMFUNCTION:
code:

...
Var textFinish
...
!define MUI_PAGE_CUSTOMFUNCTION finishPre
!define MUI_FINISHPAGE_TEXT $textFinish
!insertmacro MUI_PAGE_FINISH

...
!insertmacro MUI_LANGUAGE "German"
!insertmacro MUI_LANGUAGE "English"


LangString InstallerName ${LANG_GERMAN} "Deutsche Version"
LangString InstallerName ${LANG_ENGLISH} "english version"

....

Function finishPre
$(If) ${SectionIsSelected} ${LicenceManager}
StrCpy $textFinish $InstallerName
${EndIf}
FunctionEnd



I use the langstring in the sections and for the name of the installer, but it's not found in the function (unknown variable/constant). Can someone tell me whats wrong?

thx


Just had to edit $InstallerName to $(InstallerName), tried it with curly braces ...
Unlike defines that use curly braces - {}, language strings use parenthesis - ().

Last edited by theaskingman; 4th August 2010 at 11:46. Reason: stupid...
theaskingman is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump