Old 22nd April 2017, 10:56   #1
Number_1
Junior Member
 
Join Date: Jan 2012
Posts: 43
m3u playlist no special characters - problem

Hi all,

problem as mentioned in the subject line
I have a workaraund for it but want to know where the problem is.

steps to reproduce:
- put some songs to a winamp playlist (some songs with äöüøå or similar unusual characters for example)
- export playlist
- copy songs + playlist to mobile phone (android)
- open sony music app, open playlist
- all songs with special characters are missing in the playlist.


First I´ve tried to create m3u file with "Yar-matey!_Playlist_Copier_v1_12".
Next I exported m3u file directly from winamp . (had to delete the full path of every song so that it can be played on another device) - both the same problem...

Workaround1 is to open the m3u file with windows editor, safe with utf8 coding and copy to the mobile phone.
Workaround2 ist to crate m3u playlist from windows media player and copy it to the mobile phone.
But I´d like to know if it is a winamp or a sony music app problem. (if its sony i could write them a mail...)
Any ideas??

---
specs: win10, winamp5.666, sony xperia z3c, sony xperia m
Number_1 is offline   Reply With Quote
Old 22nd April 2017, 11:42   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
Hi

You need to save as unicode .m3u8 in Winamp

The only problem there being that Android might only support .m3u not .m3u8...

(so you'll probably need to rename the .m3u8 to .m3u first)
DJ Egg is online now   Reply With Quote
Old 22nd April 2017, 15:08   #3
Number_1
Junior Member
 
Join Date: Jan 2012
Posts: 43
Thanks a lot

exactly - the Sony Android player seems to not support m3u8. Thats a problem too. So the only way is m3u which causes the issues.
Number_1 is offline   Reply With Quote
Old 30th April 2017, 09:51   #4
Number_1
Junior Member
 
Join Date: Jan 2012
Posts: 43
Hi again,
I forgot to say that renaming .m3u8 to .m3u doesn´t work. (not recognized in Android player)
Do you have any idea which app causes the issue?
Number_1 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump