Old 7th December 2014, 09:58   #1
partyvibe
Member
 
Join Date: May 2008
Posts: 50
Daily DNAS v2.4.2.167 posix (linux x64) "crashes"

Hi,

I'm running Centovacast 3.1.1 with SHOUTcast Server v2.4.2.167 posix (linux x64) and Liquidsoap 1.1.1. Having recently upgraded from ices-cc and shoutcast 1.9.x because I was getting very occasional ices-cc crashes my streams have all been very unstable since. The main symptom started with the odd stream going silent daily on Centovacast 3.1 and I'm not exactly sure which version of Shoutcast exactly while still accepting new connections. But it has now shifted to several DNAS' daily no longer accepting connections despite both Shoutcast and Centovacast control panels showing everything is seemingly fine. The streams may also still be going silent but I haven't experienced the problem while connected yet so it's hard to be sure. I should also say that I've run mp3check and mp3val and fixed all errors.

Anyway any help you can offer on this issue would be greatly appreciated because these problems have negatively impacted my station as you can imagine.

Thank you.

Hugh
Attached Thumbnails
Click image for larger version

Name:	dnas.png
Views:	273
Size:	36.2 KB
ID:	51580  
partyvibe is offline   Reply With Quote
Old 7th December 2014, 14:26   #2
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
I'll paraphrase (in the style of Ren And Stimpy) what the experts are likely to say:

All troubleshooters love logs

P.S. as far as the up, but silent stream goes, I've seen liquidsoap do that just because! Liquidsoap logs may also be appropriate.

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 7th December 2014, 16:18   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
there's a known issue with the recent DNAS builds since changing over to libcurl that can lock the yp / networking threads and thus make the DNAS not respond but still appear to be up. We've not resolved all of those issues yet (hindered by sys admins refusing to install newer builds because they're not "final") so we don't have a fully patched build we can guarantee fixes said issues.

As for liquidsoap, it seems to be an issue it has and is not related to the DNAS issue and is one to report to Centova/Liquidsoap as its not something we can help with.
DrO is offline   Reply With Quote
Old 7th December 2014, 22:13   #4
partyvibe
Member
 
Join Date: May 2008
Posts: 50
Thanks Dr0! Assuming I can use it with Centovacast I would be happy to help that build if you like...
partyvibe is offline   Reply With Quote
Old 7th December 2014, 22:14   #5
partyvibe
Member
 
Join Date: May 2008
Posts: 50
Quote:
Originally Posted by jaromanda View Post
I'll paraphrase (in the style of Ren And Stimpy) what the experts are likely to say:

All troubleshooters love logs

P.S. as far as the up, but silent stream goes, I've seen liquidsoap do that just because! Liquidsoap logs may also be appropriate.
I appreciate the feedback but if you could give me an idea of what to look for in my logs I would be grateful because I've poored over them but haven't been able to find the error.
partyvibe is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Tags
centovacast, crash, dnas, liquidsoap, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump