Old 13th December 2013, 02:47   #1
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
Winamp 5.666 crashes every time I try to rip a CD

I just upgraded to Winamp 5.666, and now Winamp crashes every time I try to rip a CD. Not sure why it's happening but my info is below.

A minor, though annoying, unrelated issue (the reason I went looking for the upgrade, though it persists): When I load up Winamp for the first time after Windows has started and insert a CD, the track display area of the Winamp Library remains an empty blue rectangle until I select another line in that vertical shortcut menu and then back on "Audio CD (E". It seems the last few Winamp versions don't automatically load that pane and one must refresh to get the CD info to appear. (I hope that was clear...)

Thanks.
Donovan
Attached Files
File Type: txt Winamp_Info_Report_12-12-2013.txt (28.0 KB, 362 views)
Sl1pStream is offline   Reply With Quote
Old 13th December 2013, 05:03   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,780
Hi

5.666 build 3516 has just been released (you're still on build 3512)

Afaik, you'll need to install the Sonic Engine for CD Ripping, because we had to remove functionality for using alternative methods due to legal reasons (not Sonic related, I might add). So make sure Sonic Ripping/Burning Engine is checkmarked on the Choose Components page of the Installer Options.

Let us know if it still crashes with 3516...

Other than that, also try removing these plugins from the old Essentials Pack:

in_wav.trb
gen_classicart.dll
gen_nopro.dll
gen_skinmanager.dll
gen_timerestore.dll
gen_undo.dll

Most of them need updating to be 5.666 compatible.
A revitalized/reborn Extras Pack is hopefully coming in the next few days....
DJ Egg is offline   Reply With Quote
Old 13th December 2013, 11:32   #3
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
I will follow the instructions you gave regarding the Sonic Engine and see if that helps, but it was unused for a reason. In the past whenever I used it it would cause mp3s to be the wrong length. If there was a 3:00 minute track followed by a 4:00 track it would often put the break between songs at something like 3:17, ie 17 seconds into the second song. This was especially true for very short tracks or the last track on a disc. I can only speak for myself, but I've always considered it broken.

I'll let you know once I've tested it (time to go to work, so it'll have to wait).

Thanks.
Donovan
Sl1pStream is offline   Reply With Quote
Old 14th December 2013, 03:37   #4
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
I upgraded to build 3516 as suggested, clicked yes to using Sonic Engine for ripping and also removed all those plugins listed.

Winamp continues to crash upon attempting to rip any songs.

Any further help would be MUCH appreciated since this would be a truly sour note to end Winamp with.

Thanks.
Donovan
Sl1pStream is offline   Reply With Quote
Old 14th December 2013, 17:44   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,780
Hmm, strange.

I've tried with your Output File Settings > Naming Convention, and the rip works fine for me,
with the mp3 encoder active in Encoder tab (--alt-preset fe), sonic engine enabled in Ripping tab / speed = unlimited...
though this is on Win7 not XP.

If anyone else reading this has a WinXP machine, please could you test cd ripping.
Alas, the HDD died on my old WinXP system, and I still haven't got round to replacing it.

Is a crash report generated?
If yes, please attach it.
DJ Egg is offline   Reply With Quote
Old 14th December 2013, 22:55   #6
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
It took me a while to find the log of the crash. The error logging plugin would attempt to send an e-mail with Outlook (I use Thunderbird) and when I clicked on "Open Folder" it would say it didn't know where the report was located. But I found it!

Hopefully that'll point out the problem somehow. While I firmly believe things will be running smoothly in no time, it would be a horrible to end the life of Winamp with a big bug.

Anyways, the file's attached. Good luck
Donovan
Attached Files
File Type: zip report.zip (49.7 KB, 195 views)
Sl1pStream is offline   Reply With Quote
Old 14th December 2013, 23:14   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,780
Thanks for the crash log. Hopefully DrO will look at it...

Please could you confirm if it still crashes after removing ml_enqplay.dll
(which is another plugin from the old Essentials Pack, which needs updating).

The WavPack plugin from the EP is also present (in_wv.dll)....
DJ Egg is offline   Reply With Quote
Old 14th December 2013, 23:20   #8
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
Sadly yes; still crashes
I removed both of those plugins (first just ml_engplay and then in_wv too) and it still crashed.

Donovan
Sl1pStream is offline   Reply With Quote
Old 15th December 2013, 22:23   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
none of those plug-ins were responsible for the crash and is something i'd hoped i'd managed to find a fix for in 3516 but clear not. all i can see at the moment (haven't looked that much into it tbh seeing as it's sunday night) is that it fails when trying to determine the length inside of in_cdda (which is one of the seemingly buggier native plug-ins based on the crash reports which i've looked at since the 5.7 beta appeared).

so unfortunately i don't have any suggestions / work arounds at the moment and would need to do some testing on XP as time allows (though how well that'll go i don't know as i've only got a VM of my old real XP machine to work with now).
DrO is offline   Reply With Quote
Old 15th December 2013, 22:35   #10
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
What're the chances this could be fixed before Dec 20th? ie, should I go to a site that has old versions of programs and re-install 5.6, or will there be any kind of continuing service past the 20th?

Thanks for looking into it.
Donovan
Sl1pStream is offline   Reply With Quote
Old 15th December 2013, 22:38   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
i really don't know.
DrO is offline   Reply With Quote
Old 15th December 2013, 22:39   #12
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
Fair enough. Best of luck to all of you
Sl1pStream is offline   Reply With Quote
Old 15th December 2013, 22:42   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'll try to find some time to look into the crash report deeper, but no guarantees.
DrO is offline   Reply With Quote
Old 15th December 2013, 22:44   #14
Sl1pStream
Junior Member
 
Join Date: Jan 2003
Posts: 24
Understood.
Sl1pStream is offline   Reply With Quote
Old 18th December 2013, 00:22   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
check your pm please.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
5.666, crash, ripping

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump