Old 27th November 2003, 14:31   #1
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
I need help with the length of some MP3s.

I just finished converting over one-hundred SPC files to MP3 format using WinAmp and an SPC plug-in. All of the files were exactly three minutes long. Now that I am checking all of the MP3 files, I notice that they are all three minutes and two seconds long and have a fade-out at the end, which I don't want because the files are meant to repeat over and over. Is there any way for me to take out that extra two seconds and fadeout? I really don't want to re-convert all of the SPCs to MP3 format again, because it took me over five hours. Please help.

By the way, if it matters at all, I used the SNESAmp plug-in.
MaxVdub is offline   Reply With Quote
Old 27th November 2003, 15:09   #2
Lion King
Major Dude
 
Join Date: Jan 2001
Posts: 1,670
uhm, your spc files aren't tagged with their actual playing time. 3:00 minutes is the default for files with unknown playing time. you can disable the fadeout under 'time' in the snesamp configuration. the fade length can also be stored in the id666 tag (that your files probably don't have).

the songs actually fade for 10 seconds and snesamp adds 2 seconds silence at the end. just look at the settings in snesamp's configuration.

you can cut mp3s with mp3directcut but i don't know any batch tool for this purpose. reencoding would be easier imho.

btw. many spc rips contain playing time information. maybe it would be better to look for other spc rips from the same games
Lion King is offline   Reply With Quote
Old 27th November 2003, 17:09   #3
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
Should I put a check in the box that says, "Default to binary ID666 tags"?
MaxVdub is offline   Reply With Quote
Old 27th November 2003, 17:19   #4
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
I can't get it not to fade out. I was able to get it so it would sound right if it repeats, but it still fades out. I changed the fade length to zero, but it still fades. How do I prevent this?
MaxVdub is offline   Reply With Quote
Old 27th November 2003, 17:49   #5
Lion King
Major Dude
 
Join Date: Jan 2001
Posts: 1,670
you have to edit the fade times in the id666 tags if it still fades. highlight a spc file in the playlist editor and hit alt+3.
i can't believe though that your spc files have fade times set in the tag but not playing times. disabling the fading for files without tags works fine here.
are you using the latest version of snesamp (3.05)?
Lion King is offline   Reply With Quote
Old 27th November 2003, 18:37   #6
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
Yep.

Edit: Er... So I figured out how to turn off the fade out on the SPCs... But now do I have to go and re-convert all those SPCs to MP3s and do I have to edit the ID666 thing for each file?
MaxVdub is offline   Reply With Quote
Old 28th November 2003, 17:29   #7
Lion King
Major Dude
 
Join Date: Jan 2001
Posts: 1,670
Quote:
Originally posted by MaxVdub
Er... So I figured out how to turn off the fade out on the SPCs
how?
Lion King is offline   Reply With Quote
Old 29th November 2003, 00:41   #8
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
Never mind, I finally got everything I need. Thanks.
MaxVdub is offline   Reply With Quote
Old 29th November 2003, 17:59   #9
MaxVdub
Junior Member
 
Join Date: Nov 2003
Posts: 6
Arg! The MP3s are still messed up. They're not the right length. Should I try downloading SPCs with the correct length programmed into them?
I tried the MP3 cutting thing, but I couldn't delete specifically enough to get it exactly right.

Last edited by MaxVdub; 29th November 2003 at 19:32.
MaxVdub is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump