Old 4th December 2003, 00:21   #1
40044004
Junior Member
 
Join Date: Dec 2003
Posts: 12
SPC titles in WA5

I noticed that the titles of snes SPC files are shown as their filename titles (such as 01, 02, etc) in the media library and playlist, as well as in the songticker, instead of actual song titles like in WA 2.9X. I'm not sure if this is the plugin's problem. It does this for snesamp and in_spc. The files play fine, however, but it would be helpful to know what song each file is before having to play every single one to find the one I want.
The "view file info" function doesn't seem to work for these either.

And keep up the good work with Winamp 5. It's much more than I could have wished for.
40044004 is offline   Reply With Quote
Old 4th December 2003, 00:36   #2
Rellik
Major Dude
 
Rellik's Avatar
 
Join Date: Oct 2003
Location: localhost
Posts: 1,099
It depends, whoever ripped the SPC files may have been lazy and not set any titles(you can check by viewing the file info), otherwise you may need to configure the SPC input plugin in the input preferences.

Curently I am using Alpha-II SPC Player, and I have the title string for that plugin set to
code:
%2[%9[%8[%8-]%9 ]%3 - %2|%1]
which will under normal circumstances, display "game - song title" before it displays the filename
Rellik is offline   Reply With Quote
Old 5th December 2003, 00:05   #3
40044004
Junior Member
 
Join Date: Dec 2003
Posts: 12
The problem is that the titles embedded in the files themselves used to show up when I used WA 2.91. My preferences are set up like that in Alpha II's player. Plus the file info doesn't show up when I use WA5. Oh well, if it's the plugins' problem, I guess I'll use 2,91 to play spcs then. Thanks anyway.
40044004 is offline   Reply With Quote
Old 5th December 2003, 00:23   #4
squall14716
Senior Member
 
Join Date: Oct 2002
Location: 127.0.0.1
Posts: 349
Send a message via ICQ to squall14716 Send a message via AIM to squall14716 Send a message via Yahoo to squall14716
What is annoying is that when adding files to the media library, it doesn't ready the ID666 tags.
squall14716 is offline   Reply With Quote
Old 6th December 2003, 06:19   #5
shins
Senior Member
 
shins's Avatar
 
Join Date: Feb 2003
Posts: 157
alpha II SPC player 2.99+winamp5 RC10 displays the id666 tags properly in playlist and media library. Not sure what could be wrong, other than the tags not being filled in properly. Only problem I could see with the media library and view info, is that if you have winamp set to always on top, and the ML fills most of the screen, the id666 window gets stuck behind the ML. Also, the new winamp should be able to rename spcs indirectly by storying their info in the ML database file, and not the tags themselves. Still a quick way of fixing the bad name problems.
shins is offline   Reply With Quote
Old 6th December 2003, 08:42   #6
pbmage
Junior Member
 
pbmage's Avatar
 
Join Date: Sep 2001
Location: Somewhere Else
Posts: 7
I have the same id666 tag problem and if you don't use the media library, you won't have any problems with the playlist. That and the fact that I haven't found a way to dump my 210:41:17, 6392 song playlist into local media makes the media library useless to me. A more functional media library would be nice.
pbmage is offline   Reply With Quote
Old 6th December 2003, 08:51   #7
Sawg
Guest
 
Posts: n/a
Third party plug-ins need to be updated to take advantage of the Media Library. This is the responsibility of the plug-in author, and has nothing to do with the Media Library.
  Reply With Quote
Old 6th December 2003, 08:57   #8
squall14716
Senior Member
 
Join Date: Oct 2002
Location: 127.0.0.1
Posts: 349
Send a message via ICQ to squall14716 Send a message via AIM to squall14716 Send a message via Yahoo to squall14716
It seems more like the responsibility of the plugin, but yeah. The media library does NOT ready the ID666 tags, it guesses at the filenames which makes it completely useless when the filenames are like ff4-01.spc. The same could be said for PSFs I believe.
squall14716 is offline   Reply With Quote
Old 6th December 2003, 09:00   #9
pbmage
Junior Member
 
pbmage's Avatar
 
Join Date: Sep 2001
Location: Somewhere Else
Posts: 7
True, but some plugins haven't been updated sence the 1.x days. Would it be possable to create a tag reading plugin?
pbmage is offline   Reply With Quote
Old 6th December 2003, 09:04   #10
Sawg
Guest
 
Posts: n/a
The Media Library doesn't read any tags, the input plug-ins do and they pass the ML info. You will need an updated SPC plug-in.
  Reply With Quote
Old 6th December 2003, 09:51   #11
pbmage
Junior Member
 
pbmage's Avatar
 
Join Date: Sep 2001
Location: Somewhere Else
Posts: 7
Let me rephrase that; an input plugin that only reads and edits tags of a file. YMAMP was last officially updated on 06/06/00. It plays Genesis GYM and Callus CYM files. It is also the newest plugin to do either and the only one I know of that does both.
Instead of creating a new plugin from scratch or trying to figure out someone else's uncommented code, wouldn't it be easier to create something else that does what the current plugin doesn't.
Or, better yet, make Advanced Title Formatting plugin based. Unless I've missed something, ATF and the ML use the same process to get their info. That would solve a lot of problems.
pbmage is offline   Reply With Quote
Old 6th December 2003, 12:16   #12
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
The default input plugins already have internal Title Formatting options in their respective configs (in_mp3, in_vorbis, in_midi, in_mod). However, if Advanced Title Formatting is activated in Prefs -> Titles, then this overrides all individual plugin settings.

It is entirely up to the 3rd-party plugin author to either/both supply Title Formatting options in the plugin's options, or to update the plugin so that it correctly parses metadata. It has got nothing to do with Winamp code, the media library, or anyone here.

As with all 3rd-party plugins, if you are experiencing problems, contact the authors of any/all of the available SPC plugins. There's nothing we can do about it here.

Some previous potentially helpful threads:
http://forums.winamp.com/showthread.php?threadid=157797
http://forums.winamp.com/showthread.php?threadid=138787
http://forums.winamp.com/showthread.php?threadid=64589
DJ Egg is offline   Reply With Quote
Old 6th December 2003, 21:08   #13
D&B
Banned
 
Join Date: Mar 2001
Posts: 1,027
Quote:
Originally posted by Rellik
Curently I am using Alpha-II SPC Player, and I have the title string for that plugin set to
code:
%2[%9[%8[%8-]%9 ]%3 - %2|%1]
which will under normal circumstances, display "game - song title" before it displays the filename
Thanks for sharing that setup.
D&B is offline   Reply With Quote
Old 6th December 2003, 21:13   #14
Lion King
Major Dude
 
Join Date: Jan 2001
Posts: 1,670
plugin developers aren't to blame for this, nullsoft hasn't released an updated input plugin sdk yet that documents the metadata interface

btw. title formatting with input plugins that don't support the metadata interface (most plugins don't) works fine if you disable (guessed) metadata reading for those files:

ctrl+p > preferences > general > media library > library options > uncheck 'use library data for winamp title formatting'

you could also disable advanced title formatting completely if you don't need it for mp3 files
Lion King is offline   Reply With Quote
Old 6th December 2003, 21:52   #15
Rellik
Major Dude
 
Rellik's Avatar
 
Join Date: Oct 2003
Location: localhost
Posts: 1,099
Quote:
Originally posted by badrad
Thanks for sharing that setup.
When I first installed the plugin, it always bugged me that files w/out the Id666 tags would show up as " - " rather then displaying the filename.

I'm no programmer by any means, but I do have a pretty good grasp on if|then|else behavior, so I figured out that by adding %2[x|%1] where x is the prefered Id666 string, it corrected the behavior.

The logic that it uses is: if the title(%2) exists then dispay the the x id666 string(%9[%8[%8-]%9 ]%3 - %2), otherwise just dispay the filename(%1).
Rellik is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump