Old 10th January 2007, 22:13   #1
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
Inconsistent Listbox Sorting

Hey there,

I just made a bunch of changes to my library, and went to sync up with my library, and I noticed that the sorting in the two listboxes didn't match each other at all. I didn't think to grab a screen shot for reference at the time, but I couldn't discern any sort of pattern to the madness.

I expected for it to be sorted alphabetically, or at the very least in an identical manner so that it'd be that much easier to compare the lists, for safety's sake. What's going on with this -- is it set to something I haven't figured out? Either way, is there a way it could be changed/set to sort alphabetically?


Thanks,
Chris
asbo is offline   Reply With Quote
Old 11th January 2007, 10:57   #2
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Which listboxes are you talking about? And which version do you use? have you tried the latest dev build?

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 12th January 2007, 15:48   #3
AtmaWeapon
Member
 
Join Date: Nov 2006
Posts: 66
I think for "listboxes" asbo means the Local Media and the default iPod ML views. I also have noticed that by default ml_ipod sorts items by First Added, showing in top of the list the first items that were added to the iPod. If this is the case, clicking on the preferred sort column in both the "Audio" Local Media view and the iPod view should fix the issue.
AtmaWeapon is offline   Reply With Quote
Old 22nd January 2007, 05:48   #4
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
Sorry; I thought I'd subscribed to changes in the thread, but apparently I hadn't

By listboxes, I meant those shown during a sync that show a side-by-side comparison of files to be transferred and files to be deleted from the iPod. Sorry for not being clearer.

I'm using v2.01, and will grab the dev version right now. I'm not entirely sure when this behavior showed up; it was sometime after you took over the project, but I'm unsure when (not to throw blame).

Also, I noticed that intermittently, ml_ipod decides that several of my songs have changed and need to deleted and re-transferred. Another no-biggie issue, just curious.
asbo is offline   Reply With Quote
Old 22nd January 2007, 07:16   #5
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Ah, these are the boxes you meant! Actually I always thought they are not sorted at all. That bugged me often... but I did not change anything in that area (at least not intentionally ) I've never seen them in a consistent order, but I will give it a look. Would be much nicer to have them sorted.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 22nd January 2007, 15:29   #6
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Fixed it. In 2.01p16.
Actually, there was never a sorting routine in the code, I added it. Now both listboxes are sorted alphabetically.
Could you give it a try?

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 22nd January 2007, 20:53   #7
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
Glorious I have nothing to sync, but I will in a couple days time and will make sure to report back.

Thanks for the quick responses!
asbo is offline   Reply With Quote
Old 25th January 2007, 15:46   #8
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Any feedback?

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 25th January 2007, 20:52   #9
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
Hmm, not quite. Check the attached image.
Attached Images
File Type: jpg sorting.jpg (34.0 KB, 112 views)
asbo is offline   Reply With Quote
Old 25th January 2007, 21:07   #10
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Huh... gotta recheck this

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 25th January 2007, 21:16   #11
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Ok, 2.01v21 should do the trick...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 26th January 2007, 04:42   #12
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
Thanks, will be checking back in soon ...
asbo is offline   Reply With Quote
Old 30th January 2007, 03:05   #13
asbo
Junior Member
 
Join Date: Dec 2004
Posts: 26
abu,

Everything looks good! Thanks for your help with this!

I've made a [meager] donation for your efforts. Thanks for all the effort you put into the project :]
asbo is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump