Old 19th October 2011, 22:53   #1
cromer2
Junior Member
 
Join Date: Oct 2011
Posts: 4
no dyndns-works, no transmit of titles

hi,

I install the server
SHOUTcast DNAS Server Version 2 (sc_serv)(Last Updated 28 July 2011) with sc_serv.exe, sc_serv_basic.conf, ...
and have three problems:


first:
http:// 81.71.81.61:8000 (actual internet-IP)
ok, it plays :-)


but:

I would like to listen too by a stream with
1. ## dyndns.org
and
2. ## by the website of winamp: the internet site of shoutcast DNAS status/administrator (click on "listen" etc.)


and with
http:// myname.dyndns.org:8000
I get a timeout (on my running apache server, I´ve two ports open: for apache (HTTP-Server TCP :80) and for winamp (HTTP-WinAmp TCP:8000-8001) )


with the internet site of shoutcast DNAS status/administrator there where "wrong" paths appended:

# intraNet- bzw. intern IP (stream URL: 192.168.81.61) > http:// 81.71.81.61:8000/192.168.81.61 > open with standard-application: its loading and loading ... without playing
# with click to "listen" a STREAM/1/ paths append > http:// 81.71.81.61:8000/stream/1/ > timeout ...





The last point
3. ## how to transmit the track and the interpret (or filename). What I´ve to insert into my sc_serv.conf



thanx a lot for some helps & hints,
regards, crome
cromer2 is offline   Reply With Quote
Old 20th October 2011, 16:34   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm really struggling to follow what you're trying to say other than you're having an issue with dyndns which isn't something really covered by these forums (unless someone knows about it and wants to reply to your post).

with point #3 - i'm not sure what you're meaning by 'transmit the track'? do you mean sending the original file or metadata (e.g. track titles) or something else.

-daz
DrO is offline   Reply With Quote
Old 20th October 2011, 22:50   #3
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,030
Send a message via Skype™ to thinktink
I think he's talking about the listen link from the DNAS pointing to his private IP address instead of the public one. I can't test that theory though because I can't seem to connect to the server at the address and port he provided.
thinktink is offline   Reply With Quote
Old 21st October 2011, 21:27   #4
cromer2
Junior Member
 
Join Date: Oct 2011
Posts: 4
hi,

yes, I hoped, someone knows about dyndns.
Its better to have a fix URL, so that I don´t have to look & type everytime ..


to point #3:
yes, the listener should see in his winamp "interpret - title" and not the stream URL.
When I start the server, I choose "8" & enter.
I think SHOUTcast uses than sc_trans_dj.conf and I have to add something here, but can´t find what?
There a some tracks with "interpret - title" inside winamp, but too some without,
and they have this info just into their filename. Hope it becomes interpreted too by SHOUTcast?

thanx,
regards, crome
cromer2 is offline   Reply With Quote
Old 21st October 2011, 21:37   #5
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,030
Send a message via Skype™ to thinktink
Probably not going to be of much help as:
  1. It is extremely difficult to understand you.
  2. You have not provided any true, whole, and/or accurate information to be able to test with.
  3. You have not provided any logs or configuration files.
thinktink is offline   Reply With Quote
Old 21st October 2011, 23:04   #6
cromer2
Junior Member
 
Join Date: Oct 2011
Posts: 4
sorry!!

on SHOUTcast I didn´t change anything in the config-files (11),
so you should have them?

I open the SHOUTcast-folder, doubble-click on sc_serv.exe and
into the "consol" I type "8" for "dj_config".
The sc_trans_dj.conf
------------------
include=sc_trans_basic.conf
djport=8500
djport2=8505
djlogin_1=dj
djpassword_1=noise
djpriority_1=1
calendarfile=calendar\dj_calendar.xml
------------------
#here I have to insert more directives for "interpret - title"?


In WinAmp, I open DSP/effects and the DSP v1.9.0 is running.
The "Connection"-button is pressed.
On "Output 1" I have the configuration address: "192.168.81.61" (intranet-URL), Port 8000, Encoder 1, Input Device "Winamp".
On the other "Output´s" I tried configuration address: "http://dnsdyn", "localhost", ...
#you think, the URLs are ok?

As "listener" on my WLAN-Laptop I can connect the DNAS-server
by the internet or the intranet.

by the internet I use this address: http:// 81.71.81.61:8000,
by the intranet I use this address: http:// 192.168.81.61:8000 (my main-PC)

typing the _internet-URL_ into the browser, I reach a Shoutcast-Website "DNAS Status" with current stream Infos:
-----------
Server Status: Server is currently up and private
Stream Status: Stream is up at 320 kbps with 0 of 32 listeners (0 unique)
Listener Peak: 3
Stream Name: PC1
Content Type: audio/mpeg
Stream Genre: mix
Stream URL: 192.168.81.61
Stream IRC: #shoutcast
-----------
here the Link-path looks like:
http:// 81.71.81.61:8000/192.168.81.61
That opens a browser-popup, asking which software to handle for the file "192.168.81.61" (wrong?!).
I choose my standard-software / Winamp and than its downloading .... but no music.

Klicking on the Shoutcast-Website on "Listen" opens a URL:
http:// 81.71.81.61:8000/listen.pls?sid=1
In my Laptop that opens Winamp but: "timout" because of the very _different_ URL
"http:// 192.168.1xx.xxx:8000/STREAM/1/" (witch seems to be my personal Winamp-Stream-URL - independend of my providers URL?). But "funny" - that works on my server-PC itself, with the "Listen"-Link and foobar2000 and herein with this URL "http:// 192.168.1xx.xxx:8000/stream/1/" (so I sent it with Winamp and listen with foobar ... ) .

regards, crome
cromer2 is offline   Reply With Quote
Old 22nd October 2011, 14:32   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
another painful post to try to read (am guessing english is not your first language).

firstly, upgrade your DSP to the current version from http://www.shoutcast.com/broadcast-tools as v1.9.0 is not supported in _anyway_ and is probably causing some of the issues.

secondly, if you use the new DSP, you need to use djport2 on the DSP's configuration and using the LAN IP is correct if running it on a different machine from the DNAS, otherwise just use localhost.

thirdly, listen.pls?sid=1 will generate a playlist which will work as applicable for how that link has been accessed, so http:// 192.168.1xx.xxx:8000/STREAM/1/ is correct if done on the same network, whereas if accessed off network (as most clients will do) then it should appear as http:// 81.71.81.61:8000/STREAM/1/ for them.

fourthly, i'm not at all sure where you're getting the following from (or even quite what you mean)
Quote:
here the Link-path looks like:
http:// 81.71.81.61:8000/192.168.81.61
will need some better clarification or even a screenshot of where it is that you're looking as it's really not too clear.


otherwise, the status you've provided seems to indicate the DNAS is working and the (old) source you've got connected is working for a private stream setup (as seems to be how you've got it configured at the moment).

-daz
DrO is offline   Reply With Quote
Old 22nd October 2011, 15:09   #8
rockouthippie
Banned
 
rockouthippie's Avatar
 
Join Date: Jun 2004
Location: Oregon
Posts: 11,002
Quote:
I would like to listen too by a stream with:

1. ## dyndns.org
Dyndns has nothing to do with your shoutcast stream. It just turns a url into an IP address. You will need to run an update program to keep your IP updated. My router will do that, so I don't need to run an update TSR on a PC.

Quote:
and
2. ## by the website of winamp: the internet site of shoutcast DNAS status/administrator (click on "listen" etc.)
That means being added to the YP. You not only have to "open" the ports by un-firewalling them. You also have to do port forwarding. Consult your router manual and follow the instructions for port forwarding a web server. Instead of port 80, you'll use port 8000. Otherwise it is the same. In the config file there is a setting to make your stream public or published.

Don't expect your stream to appear in the YP directory instantly. It could be hours or even days. You do not need dyndns for the YP to keep track of your IP address. Assigning a domain name to your stream is generally for human use... i.e. you wanted to link the stream from a web page.

--------I'm guessing what you might mean-----

You wanted a domain name for the shoutcast server inside your lan?.... maybe...?

Most routers will use the network name you assign to the computer and route lan requests that way. This machine I am using now is named fum. If I ran a shoutcast server on it .... from any computer on the lan

code:
http://fum:8000
would access the shoutcast stream.

Make sure the firewall on your server computer passes port 8000.

You can also use the hosts file to create domain names that resolve locally:

http://en.wikipedia.org/wiki/Hosts_(file)
rockouthippie is offline   Reply With Quote
Old 22nd October 2011, 15:31   #9
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,030
Send a message via Skype™ to thinktink
If you really wanna warp your mind you could install a DNS server that has a forced entry to resolve all requests to your dyndns hostname to the private IP address and then have the router send client DNS traffic to that nameserver which would then redirect requests it doesn't have to the ISP's DNS host. That's what I did for my crap when I had it. But that's probably too complicated for most people.
thinktink is offline   Reply With Quote
Old 22nd October 2011, 15:47   #10
rockouthippie
Banned
 
rockouthippie's Avatar
 
Join Date: Jun 2004
Location: Oregon
Posts: 11,002
DD-wrt has a hosts file, so you can change how things resolve for the whole lan. My router sucks up my hosts file from the internet and blocks a lot of phishing and spam sites by assigning them 0.0.0.0 as an IP.

{EDIT} One other thing you might consider. If you aren't running a web server on your server, you should probably use port 80 and not 8000. This will get you past some company firewalls.

Port 80 could be blocked by your ISP. So check. Mine isn't. My brothers Comcast was and now isn't.
rockouthippie is offline   Reply With Quote
Old 23rd October 2011, 22:21   #11
cromer2
Junior Member
 
Join Date: Oct 2011
Posts: 4
hi DrO,
[so, here another continent-english-post
(thought till now, my english ist acceptable, it isn´t ... maybe its no UK-english, but this new global-english - but I try ...)]

Well!!
I updated servers, PlugIn, but now I don´t hear anything on my Laptop -
I don´t get the stream to my Laptop-WinAmp.

The good thing: On the Shoutcast DNAS Status-Website,
I can read the current song. :-)
But when I click on the top-navigation´s "Listen",
the order goes to WinAmp, but it runs into a timeout - with
the URL: http:// 192.168.1xx.xxx:8000/STREAM/1/

First I had trouble with the passwords:
Finally
sc_serv_basic.conf (password=testing)
sc_trans_dj.conf (djpassword_1=noise, djlogin_1=dj)
are appropriate for the server-config-type "8"?

On the DSP-Plugin, I just need "testing". Wherefor the dj.conf´s are?
Where I´ve to enter on my laptop the password?
May be thats the reason for timeout?


supplemented to the "current-song transfer":
on my console-server-window, I see that the "comment" becomes transmitted too.
Thats nice - but not for me. Can I switch that off anywhere?

(the software seems to work nice :-) )


What you mean with
> you need to use djport2 ...
how?

> fourthly, i'm not at all sure where you're getting ...
>> http:// 81.71.81.61:8000/192.168.81.61
that doesn´t appear anymore. It was been the "Stream URL". Now its www.shoutcast.com
But not anymore in these calling-URL.



regards, cromer

------------------------------
2011-10-24 00:08:53 I msg:[SRC 192.168.1xx.xx:2629] SHOUTcast 2 source connection.
2011-10-24 00:08:53 I msg:[SRC 192.168.1xx.xx:2629] Password accepted. Stream id is 1
2011-10-24 00:08:53 E msg:[YP2] No authhash found for stream config #1. Aborting registering stream with YP.
2011-10-24 00:08:53 I msg:[SRC 192.168.1xx.xx:2629 sid=1] stream configuration complete. [
type=SHOUTcast 2
mimeType=audio/mpeg
maxPayloadSize=16377
avgBitrate=192000
maxBitrate=192000
desiredBufferSize=480
minimumBufferSize=0
icyName=Unnamed Server
icyGenre=Misc
icyURL=http://www.shoutcast.com
icyPub=1
]
2011-10-24 00:08:53 I msg:[SRC 192.168.1xx.xx:2629 sid=1] Got complete metadata message type=3902 [372 bytes] id=24 span=1 content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata><TIT2>rrrrrrrrrrrr</TIT2>
<TALB>gggggggg</TALB>
<TPE1>ddddddddddd</TPE1>
<TYER>1979</TYER>
<COMM>gggggggg</COMM>
<TENC>SHOUTcast Source DSP v2.2.3.112</TENC>
<TRSN>Unnamed Server</TRSN>
<WORS>http://www.shoutcast.com</WORS>
<extension>
<title seq="1">ddddddddddd - rrrrrrrrrrrr | ggggggggg</title>
</extension>
</metadata>
------------------------------
cromer2 is offline   Reply With Quote
Old 24th October 2011, 11:01   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by cromer2 View Post
The good thing: On the Shoutcast DNAS Status-Website,
I can read the current song. :-)
But when I click on the top-navigation´s "Listen",
the order goes to WinAmp, but it runs into a timeout - with
the URL: http:// 192.168.1xx.xxx:8000/STREAM/1/
from what you've posted and from the log snippet at the bottom, the main issue is that you don't have an authhash associated for the stream which is why the client connection won't work -> see http://wiki.winamp.com/wiki/SHOUTcas...ash_Management on how to get an authhash. If you don't want the stream to be public then on the 'YP' tab of the DSP you need to uncheck 'Make this stream public'.

However, it sounds like you're not actually running / using the Transcoder so only the DNAS -> DSP details need to be followed (as you seem to have now done).

Quote:
Originally Posted by cromer2 View Post
First I had trouble with the passwords:
Finally
sc_serv_basic.conf (password=testing)
sc_trans_dj.conf (djpassword_1=noise, djlogin_1=dj)
are appropriate for the server-config-type "8"?

On the DSP-Plugin, I just need "testing". Wherefor the dj.conf´s are?
Where I´ve to enter on my laptop the password?
May be thats the reason for timeout?
i think you're getting confused over things. If connecting to just the DNAS then what has been set in sc_serv_basic.conf in your case is the details to enter in the DSP as per http://wiki.winamp.com/wiki/Source_D...v2_DNAS_Server
If connecting to the Transcoder (assuming that is configured to connect to the DNAS correctly), then you need to enter in the DSP as per http://wiki.winamp.com/wiki/Source_D...UTcast_v2_Mode

Quote:
Originally Posted by cromer2 View Post
supplemented to the "current-song transfer":
on my console-server-window, I see that the "comment" becomes transmitted too.
Thats nice - but not for me. Can I switch that off anywhere?
there's no option to switch that off, the only way is to not have it in the file tag since the v2 system will transmit additional information about the file incase clients want to use it (though none really use it at that moment).

Quote:
Originally Posted by cromer2 View Post
What you mean with
> you need to use djport2 ...
how?
you'd just need to enter what has been set for djport2 in the config file into the 'port' field in the DSP if you want to connect to the Transcoder instead of directly to the DNAS (as you've currently got running).

Quote:
Originally Posted by cromer2 View Post
> fourthly, i'm not at all sure where you're getting ...
>> http:// 81.71.81.61:8000/192.168.81.61
that doesn´t appear anymore. It was been the "Stream URL". Now its www.shoutcast.com
But not anymore in these calling-URL.
ok, i know see where you mean and that's something already internally fixed for the next v2 DNAS release (no proper eta on that).

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump