Old 18th August 2007, 04:54   #1
QuietStorm
Junior Member
 
Join Date: Aug 2007
Posts: 1
Ultra slow windowed performance

here's the deal all: I'm running a HP Pavillion Slimline with an Radeon Xpress 200 motherboard graphics card and my windowed and desktop FPS setting are horrible. I've set all the mesh sizes as far down as I can and it still doesn't help. Also, it works fine when full-screen but in windowed mode the larger I resize the window the higher my CPU usage goes.

Any idea why this is? I've tried this on both 1.04 and 1.05 and the results are about similar in terms of load. Please help!!
QuietStorm is offline   Reply With Quote
Old 21st October 2007, 21:35   #2
qorron
Junior Member
 
Join Date: Oct 2007
Posts: 7
I had the same problem.
windowed: slow and cpu@100% (except for very small windows)
fullscreen(1920x1200): fast as hell and <10% cpu.

seems that all rendering was done by the cpu and not the gpu.

this was also true with all other 3d-vis plugins.

_but_ my problem has disappeared. I dont know what caused it and why it is gone now.
qorron is offline   Reply With Quote
Old 27th October 2007, 17:22   #3
geiss
Nullsoft Visualization Developer
 
Join Date: May 2001
Posts: 147
It could have been just the first time you ran it, it was scanning the list of preset files, which can take a while. The files will then be cached (by the OS), so if you start milkdrop up again, it'll be zippy. If you reboot, the cache is cleared, and it'll have to scan again.

The new release coming soon (2.0a - will ship with the next update to winamp) uses a separate thread to do the scan, which hides all the file access latencies, so it's waaaaay nicer.
geiss is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Visualizations > MilkDrop > MilkDrop Troubleshooting Forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump