Old 10th May 2005, 14:25   #1
jakoby
Member
 
Join Date: Oct 2004
Posts: 71
Why won't out_lame let me save my config?

I'm using the lastest version of out_lame (1.6.3, I think) and Winamp 5.09, and out_lame won't let me save my mp3 encoding settings - is anyone else having this problem?

I really want to keep using out_lame, I don't know of another mp3 encoder that keeps your tag info, including cover art, when encoding from mp3 to mp3.

Unless someone knows of another mp3 encoder that keeps tag info and cover art?
jakoby is offline   Reply With Quote
Old 10th May 2005, 18:01   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
Re: Why won't out_lame let me save my config?

Quote:
Originally posted by jakoby
...is anyone else having this problem?
Yup. Me.
DJ Egg is offline   Reply With Quote
Old 10th May 2005, 21:13   #3
jakoby
Member
 
Join Date: Oct 2004
Posts: 71
Well, it's nice to know I'm not the only one at least...
do you know of another mp3 plugin that keeps tag & cover info after encoding?
jakoby is offline   Reply With Quote
Old 10th May 2005, 23:15   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
I'm not sure about keeping tag and cover info, but there's a full list of mp3 output plugins here

I'm not so fussed about the bug, because all I have to do is go back into the out_lame config and select --alt-preset standard, and it keeps that setting throughout the session. But yeah, it would be nice if it was fixed, heh.
DJ Egg is offline   Reply With Quote
Old 21st May 2005, 04:03   #5
Nos402
Junior Member
 
Join Date: Dec 2004
Posts: 29
I'm having the same problem. There are no choices under the "settings" drop down and no changes that I make to the settings are saved after I close Winamp.
Nos402 is offline   Reply With Quote
Old 21st May 2005, 04:14   #6
Nos402
Junior Member
 
Join Date: Dec 2004
Posts: 29
Somehow I just fixed mine. I'm not sure what did. It was one of two things. First I uninstalled the output plugin "nullsoft diskwriter" I think it was called. Then I went to my winamp/plugins folder and opened "out_lame.xml" with wordpad. I saw the different settings in there, and I changed my output directory in the XML file to see if that would indeed change that setting permanently. Next time I started winamp, I now had drop down selections in the "settings" box and it properly saved all my individual settings.

I'm not sure which step actually fixed it.
Nos402 is offline   Reply With Quote
Old 23rd May 2005, 00:56   #7
jakoby
Member
 
Join Date: Oct 2004
Posts: 71
Wow, it worked!

But I also don't know what I did...exactly.

I DIDN'T uninstall the Nullsoft diskwriter plugin, but I did open the out_lame.xml file in wordpad. Then I changed the directory to what I wanted, saved it. And that was it.

After that all the options show up in the dropdown menu as they should.
Weird, but good
jakoby is offline   Reply With Quote
Old 2nd October 2005, 15:39   #8
tatsudoshi
Member
 
Join Date: May 2003
Posts: 59
Fix updated

I have just tested this fix and it is not the change of the path that make it work, but the actual save from wordpad.

So just open it in wordpad and hit the save button and that made it work for my
tatsudoshi is offline   Reply With Quote
Old 2nd October 2005, 16:44   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
Yup, that worked for me too. Just save it in Wordpad (I was using Notepad, heh).
DJ Egg is offline   Reply With Quote
Old 20th April 2020, 09:17   #10
Cunione
Junior Member
 
Join Date: Apr 2020
Posts: 1
Oldest Topic digging ever : 15 years later !!!

Yes, I'm still using Winamp since it's beginning : he's still the best, lightest and most powerful player ever created for me !

So, about that problem, the solution is quite simple (I had it and fixed it) : you just have to adjust the writing permissions to Winamp's folder (Program files/Winamp) by right-clicking on it then "Security".

That's it.

WinAmp: it really whips the llama's ass!
Long life to Winamp !
Cunione is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump