Old 15th August 2014, 22:11   #1
varsik
Junior Member
 
Join Date: Oct 2002
Posts: 4
Send a message via AIM to varsik
File Info bug

-Winamp 5.666 (5.6.6.3516) - clean install, standard included plugins, using Bento skin
-Winamp Language Pack used: English
-System specs e6750 @ 2.7ghz, 4gb
-Windows OS: win7 64bit sp1
-Video Card: geforce gtx 480
-Sound Card: gigabyte realtalk hd 6.0.1.6433
-DirectX version: 11.0

-Repro Steps:
1. Start winamp
2. View file info of a song currently playing, in playlist, or in media player
3. press okay
4. Play a song
5. Song title in marquee is not correct! Instead is shown the song of step#2. Prior songs in playlist also shows song of step #2. Current song information incorrect, shows song of step#2, however, album art and 'show more information' is correct.

6. Exit winamp
7. Launch winamp
8. Issue still noticeable!

Repeating step #2 with another song, now 'another' song will be shown as noticed in step#5
Switching skins does not alleviate issue. Looks like a ptr/memory problem. ;(
varsik is offline   Reply With Quote
Old 15th August 2014, 23:54   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,247
Send a message via AIM to MrSinatra
Varsik,

please post your info report, and patch your winamp if not patched already.

also, you need to detail the exact way you are "viewing file info" or "playing a song" etc since there are multiple methods that work, but not all may exhibit your symptoms.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 16th August 2014, 03:07   #3
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,622
Hi varsik,

Some screenshots would also help explain your issue. Not sure what you mean by marquee.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 30th August 2014, 01:46   #4
varsik
Junior Member
 
Join Date: Oct 2002
Posts: 4
Send a message via AIM to varsik
Re: File Info bug

Quote:
Originally Posted by MrSinatra View Post
Varsik,

please post your info report, and patch your winamp if not patched already.

also, you need to detail the exact way you are "viewing file info" or "playing a song" etc since there are multiple methods that work, but not all may exhibit your symptoms.
@MrSinatra, I attached the info report. I cannot say exactly what causes the initial step as this issue is so pervasive (and annoying!) that I cannot return to the working state even after rebooting, uninstallation, and re-install! My guess is that many methods of playing a song can cause this.... However I can repro step #2 via the keyboard shortcut (ALT-3), the pull down menu, and by right clicking on a song in the playlist or in the media library!

The only case where this bug is not noticed is when i open a file directly from the file system and not from within winamp. It appears that winamp writes the currently playing state to disk so that it can be continued (what file/reg entry is this stored in??!) and unfortunately the current playing data is (incorrectly) coming from the last file info.

Quote:
Originally Posted by Aminifu View Post
Hi varsik,

Some screenshots would also help explain your issue. Not sure what you mean by marquee.
@Aminifu See file I attached, bug.png.


Please tell me where winamp stores the current play state, so I can clear it or debug this.

_Varsik
Attached Thumbnails
Click image for larger version

Name:	bug.png
Views:	186
Size:	121.5 KB
ID:	51364  
Attached Files
File Type: zip Winamp_Info_Report_08-29-2014.zip (7.0 KB, 155 views)
varsik is offline   Reply With Quote
Old 30th August 2014, 10:31   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
as a starting point, you've not applied the 2 required plug-in updates - link in my signature.

i'd also suggest running a re-scan of your library (once the plug-in updates have been applied) and then seeing if the issue (which i cannot replicate from your steps) is still present.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump