Old 15th March 2015, 17:04   #1
KaiserD2
Junior Member
 
Join Date: Jun 2005
Posts: 41
Crash on loading iPod due to 3rd party tool

I just was adding some music via my older version of Winamp. It suddenly crashed. That was not too unusual. Unfortunately, it began crashing instantly every time I opened it.

I found this forum/thread again and downloaded the 5.666 from the January 29 post link. It downloaded/installed but it's doing exactly the same thing.

I don't have time to read 13 pages of this thread--what exactly is the situation now? My crashes have generated error reports, and I will attach one now. Thank you. Please.

DK
Attached Files
File Type: zip report.zip (32.7 KB, 185 views)

Listener
KaiserD2 is offline   Reply With Quote
Old 15th March 2015, 17:11   #2
KaiserD2
Junior Member
 
Join Date: Jun 2005
Posts: 41
Good news, bad news

OK, I did some searching in the thread, found Danton Q's post of February 1, downloaded, and it's coming up. Just one huge problem. It isn't recognizing my IPOD classic which is the main thing I use it for. Any ideas? Again, much appreciated.

Please let me know if there's one or more plugins that might do the trick--the plug-in page at
http://winampplugins.co.uk/Winamp/ doesn't mention this. Thanks again.

DK

Listener
KaiserD2 is offline   Reply With Quote
Old 15th March 2015, 17:27   #3
KaiserD2
Junior Member
 
Join Date: Jun 2005
Posts: 41
Oops--bad news again

Back to square 1. I shut down that new version to see if would find my ipod when I re-opened. It won't reopen at all. It generated another error report, presumably the same one, but here it is anyway. Thanks.

DK
Attached Files
File Type: zip report.zip (39.4 KB, 180 views)

Listener
KaiserD2 is offline   Reply With Quote
Old 16th March 2015, 10:04   #4
Raj_09
Member
 
Raj_09's Avatar
 
Join Date: Oct 2011
Location: Melbourne Australia
Posts: 84
Quote:
Originally Posted by KaiserD2 View Post
Back to square 1. I shut down that new version to see if would find my ipod when I re-opened. It won't reopen at all. It generated another error report, presumably the same one, but here it is anyway. Thanks.

DK
Are you using the updated patched in_mp3 plugin?

Powering through with the bolt
Raj_09 is offline   Reply With Quote
Old 16th March 2015, 11:33   #5
KaiserD2
Junior Member
 
Join Date: Jun 2005
Posts: 41
Winamp, ipod classic, other options?

I have decided to update the whole forum on my situation and ask for advice.

As of yesterday AM I was using winamp to add new songs and playlists to my ipod classic as usual. However, through no fault of my own, really, I had a catastrophic event. I have bought a set of download programs called Free Studio that download from youtube, and I decided to try their downloader/mp3 converter. It worked very quickly. But it had an additional feature I didn't know about: it automatically opened itunes when the download was over. Itunes immediately began synching my ipod. I had discovered a few months ago that pulling out the USB port wasn't the thing to do, and I got itunes closed before it had wiped out the ipod hard drive--everything is still there. However, winamp wouldn't work with the ipod anymore--it crashed. Indeed, it crashed when I tried to re-open it.

I checked through this forum, as indicated above, and found where I could download 5.6666 again, and I did. The situation now is as follows:

1. I can open, and use, winamp on my computer if the ipod is not attached. I can then attach the ipod, but although my system (Windows 7) immediately recognizes it, winamp does not.

2. If I try to open winamp with the ipod already attached, it won't open. As soon as I eject the ipod, it opens.

The ipod plug in, last updated 12/2013, is still in my program files for winamp, but I'm wondering if itunes managed to corrupt it somehow and if there is somewhere I could download it. I didn't download any new plugins yesterday. To answer Raj3's question, I don't see an mp3 plug-in in my program files, no. I also note that this latest version states:

Removed all Gracenote provided dlls since Winamp no longer has access to the Gracenote services

Loss of the Gracenote functionality breaks CDDB lookups, Auto-Tagger and Playlist Generator

Removed Auto-tagger (ml_autotag.dll) plug-in
Removed Playlist Generator (ml_plg.dll) plug-in

For some it may still work depending on the existing local playlist generator database but for most it is not even able to initialise to start using it

Removed Winamp Detector browser plug-ins

These weren't installed by default in 5.666 anyway and are useless now post-sale

So I wonder if the lack of any of those plug-ins might be a problem.

Alternatively, can anyone recommend other non-itunes programs that work for adding individual songs? I have found a free one called podtrans and there appear to be others but I would like some impartial opinion first. But I'm very frustrated because I've been using winamp with my ipod for about a decade and I can't believe that there isn't some way to restore the situation that existed exactly 24 hours ago.

Thanks.

Listener
KaiserD2 is offline   Reply With Quote
Old 16th March 2015, 22:14   #6
KaiserD2
Junior Member
 
Join Date: Jun 2005
Posts: 41
test

test

Listener
KaiserD2 is offline   Reply With Quote
Old 16th March 2015, 22:23   #7
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 198
Send a message via ICQ to ravermeister
I don't use winamp with USB MP3 Player, but I think I remember that Winamp
creates an pmp_usb.ini on the MP3 Player maybe try to delete it (but better save it to another location prior to that)
or maybe this thread could help you: http://forums.winamp.com/showthread.php?threadid=268729

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 17th March 2015, 04:31   #8
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 622
Quote:
Originally Posted by KaiserD2 View Post
test
For me, I use ml_ipod, and it works great with my 120gb ipod... buuuuuut... I am forced to use winamp v5.63 as any newer version causes it to crash when I plug in my ipod

You might want to give that a shot. I also don't use last.fm as I heard that causes issues.
musicf8 is offline   Reply With Quote
Old 23rd March 2015, 19:22   #9
Supra107
Member
 
Supra107's Avatar
 
Join Date: Oct 2014
Posts: 64
Quote:
Originally Posted by musicf8 View Post
For me, I use ml_ipod, and it works great with my 120gb ipod... buuuuuut... I am forced to use winamp v5.63 as any newer version causes it to crash when I plug in my ipod

You might want to give that a shot. I also don't use last.fm as I heard that causes issues.
You should show the report of the crash after you plug in your iPod on Winamp 5.666.
Supra107 is offline   Reply With Quote
Old 23rd March 2015, 19:26   #10
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 622
Quote:
Originally Posted by Supra107 View Post
You should show the report of the crash after you plug in your iPod on Winamp 5.666.
I made a comment on the ml_ipod forum, but that plugin is a 3rd party, abandoned and not supported by the winamp team (tmk)
musicf8 is offline   Reply With Quote
Old 23rd March 2015, 19:45   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
crash reports were submitted for pmp_ipod and ml_ipod (as seen in the posts above - which also show that the patched install was then installed), with the pmp_ipod crash yet to be fully triaged and ml_ipod showing as a failure in a memory allocation on loading (that's all I can tell without a debug build of that plug-in). i answered most of the other points / questions in KaiserD2's posts in the responses provided to the crash reports received from the bug reports address.

simple summary, pmp_ipod might be fixable, ml_ipod needs someone who can code and has an iPod device to be able to resolve it's issues with newer Winamp releases (so that's pretty doubtful of ever happening now - so much for the wonders of open source software....).
DrO is offline   Reply With Quote
Old 23rd March 2015, 19:54   #12
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 622
Quote:
Originally Posted by DrO View Post
simple summary, pmp_ipod might be fixable, ml_ipod needs someone who can code and has an iPod device to be able to resolve it's issues with newer Winamp releases (so that's pretty doubtful of ever happening now - so much for the wonders of open source software....).
Thanks for the insight DrO, I knew there was a lot of (legacy/compatibility?) changes that happened in 3.65-.666, so I figured that caused something to break in that old plug-in.

I kind of given up hope for a new ml_ipod, because I figure once my ipod finally dies I will switch to just a usb drive since my car supports it and upgrade to 5.666 or whatever the current version is at that time.
musicf8 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump