Old 22nd September 2007, 23:48   #161
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
As for the scrolling problem in Windows Taskbar...
No problems for me
Kn0tte is offline  
Old 23rd September 2007, 00:01   #162
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
I'm not seeing that one either, sorry ;\

Normally I have Winamp running in the system tray instead anyways. I tend to disable the Winamp agent as well.
soulstace is offline  
Old 23rd September 2007, 00:12   #163
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
@soulstace

When you click the "Clear Media Library" button, and then OK the confirmation,
can you please confirm/clarify the following:

1. main.dat and main.idx in the "Winamp\Plugins\ml" folder are either deleted or reset to 0kb

(note that the location of these files depends on whether you setup Winamp to use shared or separate settings per user - shared is in the install dir, separate is in %appdata%)

2. Do any other files get deleted/zeroed in that folder?

I think it's also meant to delete the albumart cache, if it exists
(art.dat/idx, art_60.dat/idx, art_90.dat/idx, art_120.dat/idx)

I'm not sure if it also deletes the corresponding *.vmd files
(which are just the config files for each individual smart view, eg. columns present, column sizes, filters, panes, etc)
Or whether it deletes the references to those .vmd files in Winamp\Plugins\gen_ml.ini
(eg. query1_meta=met4135.vmd)


The only other issue I can possibly think of is that maybe you've got the TimeRestore & Autoplay plugin set to autoplay (and possibly enabled some of the other settings for that plugin)
but you've wiped the playlist, so it's got nothing to play at startup....

I'm not sure how the TRAP plugin deals with situations like that, or even if it's an issue. Likewise for the Waveform Wrapper.

Please also note that the Essentials Pack isn't officially supported.
We're mainly concerned with the default 5.5 installation without any extra/3rd-party plugins whatsoever.

Of course, if a Winamp build breaks a whole heap (or certain types) of 3rd-party plugins, then it would be a fairly major concern (though I think that in most cases, it's just the odd plugin here and there which needs bringing up to spec to support new winamp features).
DJ Egg is offline  
Old 23rd September 2007, 00:21   #164
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
I will check.

The Time Restore plugin has nothing to do with winamp freezing though. It just makes the seekbar not getting colored sometimes in the Bento skin. DrO says this is actually something to do with the gen_ff plugin.

Edit -

Those files you mentioned, are still there. And when opening them with Notepad++ it appears to be lots of gibberish.

However, that doesn't appear to be the problem. I can delete the entire ml folder, and winamp still hangs at startup.

I will not worry so much about this issue. Even though I can reproduce it on a couple machines, it is probably not much to be concerned with. DrO may send me a test build and we can get it sorted out once other major things have been dealt with.

Quote:
Please also note that the Essentials Pack isn't officially supported.
We're mainly concerned with the default 5.5 installation without any extra/3rd-party plugins whatsoever.
I fully understand. None of these issues resulted from a clean install of Winamp itself, which I think is a good thing. And honestly, I would probably not have used the essentials pack anyway, if it wasn't for me joining the forum and helping out with beta testing (I never knew about the essentials pack before).

Last edited by soulstace; 23rd September 2007 at 00:54.
soulstace is offline  
Old 23rd September 2007, 03:51   #165
40044004
Junior Member
 
Join Date: Dec 2003
Posts: 12
I'm really liking the new Bento theme, but some things I want to ask - Is there a way to turn off the media library/video/visualization/browser tabs? Also a way to turn off the browser turning on when you click title/artist/album/etc in the file info view?
40044004 is offline  
Old 23rd September 2007, 04:22   #166
vjacques
Junior Member
 
Join Date: Jul 2006
Posts: 17
is it possible to implement the "regular" behaviour to the playlist buttons in the bento skin, when you click "-" and then click the same spot to "remove selected" without moving the cursor around, etc?
vjacques is offline  
Old 23rd September 2007, 07:09   #167
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
@DJ Egg:

Any progress about the scrollbars flickering issue?

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 23rd September 2007, 09:11   #168
drunknm6nky
Junior Member
 
Join Date: Jan 2007
Posts: 12
ID3v2 tags: GENRE label

First off, have to give you tech people props for the new look of Winamp 5.5

However, I've noticed a small recurring glitch in 5.5 and that's whenever i try to edit the Genre label in the ID3v2 tag of an mp3 file. I type in the genre into the field, and then i hit Ok. I check the same file again and the Genre field is blank. I've tried multiple times and it always shows up blank once i check it again. Or if there's already a text entry in the Genre field of the mp3's ID3v2 tag right after i've downloaded it, and i try to edit it through Winamp, the genre label does not change from the original genre to the genre that i have typed in, after i hit Ok and check the file's ID3v2 tags once again.

Hopefully you guys can fix it? thanks!
drunknm6nky is offline  
Old 23rd September 2007, 09:17   #169
Papyrus
Junior Member
 
Join Date: Sep 2007
Posts: 1
I've been using the Bento skin over the past week or so (this is actually the first I've used Winamp in quite some time - looks pretty nice) and I've come across a couple things I'd like to mention.

First - In any pane where there is a Rating column, the column just before it (what ever that may be) will always be truncated to it's original width when the player is closed/reopened or the view is changed.

The other thing is a bit of a suggestion, but I'd like to see the Publisher/Record Label field in the album art view. In my current configuration, I am unable to see the Publisher in anything but the Tracks pane, and it would be nice to have it listed beside the album art for easy reference.

Thanks.
Papyrus is offline  
Old 23rd September 2007, 09:48   #170
Ojay
Junior Member
 
Join Date: Sep 2006
Posts: 21
Re: ID3v2 tags: GENRE label

Quote:
Originally posted by drunknm6nky
However, I've noticed a small recurring glitch in 5.5 and that's whenever i try to edit the Genre label in the ID3v2 tag of an mp3 file. I type in the genre into the field, and then i hit Ok. I check the same file again and the Genre field is blank.
Similar things have been reported by me before for Build 1550 (not only the genre disappeared but other entries as well) and it wasn't reproducible so far (it happened or it did not happen).

Bugs:
- When editing tags of OGG Vorbis files, hitting the button "Delete ALL" crashes Winamp immediately if there was at least one entry in the tagging fields. This bug was also present in the builds 1504 and 1550.

- When editing tags of OGG Vorbis files, hitting the button "Delete" for single entries and then "OK" does not crash Winamp, as long as there is still one entry left. Removing the last tag entry with "delete" then hitting "OK" crashes Winamp.

- Replaygain tags stored in APEv2 tags are not recognized by Winamp (I tested it for mp3 files only).

Wishlist:
- an "undo" button to revert the selection done by "Auto tagging".
Ojay is offline  
Old 23rd September 2007, 10:46   #171
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Winamp doesn't support APEv2 tags for MP3s, that is not a standard tagging scheme.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline  
Old 23rd September 2007, 11:15   #172
Ojay
Junior Member
 
Join Date: Sep 2006
Posts: 21
Quote:
Originally posted by Sawg
Winamp doesn't support APEv2 tags for MP3s, that is not a standard tagging scheme.
You missed my point: I did not mean TAGGING, I meant recognizing important info!
Ojay is offline  
Old 23rd September 2007, 11:22   #173
DrO
 
Join Date: Sep 2003
Posts: 27,873
winamp doesn't know anything about APE tags so it wouldn't recognise them no matter. APE tag support is on the wishlist but there's no guarantee it'll ever be implemented.

-daz
DrO is offline  
Old 23rd September 2007, 11:41   #174
kafkef
Junior Member
 
Join Date: Sep 2007
Posts: 36
suggestion: make the notifier 'click passtrough' like the notifier in the toaster plug-in.
kafkef is offline  
Old 23rd September 2007, 12:15   #175
MrEcks
Junior Member
 
Join Date: Sep 2007
Posts: 1
Hi.

Just want to say a few words about the font problem. I had the same problem when using both Bento and Modern skin. The first time I experienced the problem I had a custom install of Winamp (older Winamp was uninstalled). Then I read something about having a clean install of Winamp and it should probably fix the problem. So what I did was uninstalling Winamp then searching all harddrives for any folder/file with 'winamp' and deleted them. Then I opened 'regedit' and search for 'winamp' and deleted every entry it could find. Then I installed Winamp again with every components checked, and now the problem is gone. My guess is, either the problem is caused by some old registry settings or maybe a some of components needs to be installed, but I don't know wich one. Just a thought :-)

Edit: Previous version was 5.35 and current version is 5.5 build 1568

Last edited by MrEcks; 23rd September 2007 at 12:54.
MrEcks is offline  
Old 23rd September 2007, 13:06   #176
Krycek
Junior Member
 
Join Date: Jul 2007
Posts: 1
Since installing Vista on my machine i'm still having the same problem:

When I add certain files to my playlist winamp often crashes. Has to be an issue with long filenames or long folder name because when i renamed a file from "Scooter_-_The_Question_is_what_is_the_Question_(Radio_Mix).mp3" to something like: "abcdef.mp3" it would load fine.

So when I'm trying to add my whole mp3-folder (which usually takes about 5 minutes or so because i like loading the metadata in advance it's not doing it because after 10 seconds it tries to load the winamp error feedback and fails to report the bug then showing this: http://www.krycek.de/pic/winamp.jpg.
Krycek is offline  
Old 23rd September 2007, 13:59   #177
sypher_nl
Junior Member
 
Join Date: Sep 2007
Posts: 4
Great, one of the issues i reported (the Artist not being shown correctly on my Logitech G15 LCD) is resolved in this build.

The only thing that remains is that the media info wastes too much space.
sypher_nl is offline  
Old 23rd September 2007, 14:48   #178
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
@40044004
It's a SingleUI skin, which means that everything is available all in one window.
1) You can use the button towards the bottom right corner to collapse/expand the entire bottom pane.
2) Don't click them.

@vjacques
That is a Classic skins only feature. Modern skins don't behave that way.

@TheUniqueTiger
Scrollbars flickering issue? Which scrollbars? Where? How?
Sorry, we're not seeing that here, and no-one else has reported it.
Unless you're referring to the AOL Videos view in Online Services, maybe?
That's the only place where I know of any weird scrollbar flickering, but that's some bug/issue in serverside code.

@drunknm6nky
Hmmm, I can't reproduce the ID3v2 genre not saving problem.
I did however notice that if using the Auto-Tag button, and the genre is blank, then it stays blank after clicking OK and going back in. Maybe that's related to your issue... not sure.
[Edit] Okay, we might have found something here... stay tuned...

@Papyrus
Reproduced the 'column to the left of Rating not remembering resize' bug. Thanks.

@Ojay
Reproduced the 'Delete All' crash in Advanced tab of File Info for vorbis files. Thanks.

@kafkef
Click passthrough? Sorry, I've never used the Toaster plugin, so don't know what you mean.

@MrEcks
The weird fonts problem is a bug, and is fixed for the next build
(see Known Bugs/Issues section of first post in thread)

@Krycek
Hmmmm.... we can't reproduce the problem, but hopefully it will be looked into.
It would seem that anything's possible to go wrong where Vista is concerned....
DJ Egg is offline  
Old 23rd September 2007, 16:34   #179
kafkef
Junior Member
 
Join Date: Sep 2007
Posts: 36
basically the "click passtrough" option enables clicking through the notifier so you can, for example, click on an icon that's behind the notifier.
(without the notifier opening winamp)
kafkef is offline  
Old 23rd September 2007, 17:08   #180
synthetiq
Senior Member
 
Join Date: Nov 2004
Location: Portugal
Posts: 153
we also want album art in the notifyer of the modern skin !!
............please !!

thankx
synthetiq is offline  
Old 23rd September 2007, 18:50   #181
kafkef
Junior Member
 
Join Date: Sep 2007
Posts: 36
^^ good one. i second that.
kafkef is offline  
Old 23rd September 2007, 19:42   #182
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
Quote:
Originally posted by synthetiq
we also want album art in the notifyer of the modern skin !!
............please !!

thankx
there is!!!!

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 23rd September 2007, 20:04   #183
kafkef
Junior Member
 
Join Date: Sep 2007
Posts: 36
^^ oops.. when did that get there :P
kafkef is offline  
Old 23rd September 2007, 20:20   #184
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
The scrollbars issue was the one I had referred to in the 5.36 beta thread. Its still happening on my comp here with both modern & bento skins. Whenever you move the mouse over any scrollbar in any ML view, the scrollbar flickers. Even if you move over horizontal scrollbar, both horizontal & vertical scrollbars flicker. Since nobody else reported this issue, I'm increasingly thinking that it may be limited to myself. Still I thought about reporting it...

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 23rd September 2007, 21:01   #185
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
I think the flickering scrollbars is a Windowblinds issue.
soulstace is offline  
Old 23rd September 2007, 21:19   #186
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
Clickthrough is pretty neat. I recently used it in one of my own projects. I attached the code (C#).

P.S. - Sorry for double post. For some reason I couldn't edit my last post with an attachment.
Attached Files
File Type: txt clickthrough.txt (2.5 KB, 355 views)
soulstace is offline  
Old 23rd September 2007, 21:41   #187
Hawk
Senior Member
 
Hawk's Avatar
 
Join Date: May 2000
Location: Netherlands
Posts: 157
Quote:
Originally posted by soulstace
I think the flickering scrollbars is a Windowblinds issue.
You are right! I added Winamp to the windowsblind exclusion list and no more flickering scrollbars.
Hawk is offline  
Old 23rd September 2007, 21:45   #188
Znyper2
Junior Member
 
Join Date: Nov 2006
Location: Sweden
Posts: 13
Some Bento suggestions

Hi there,

I have a few small suggestions/requests regarding the Bento skin. First of all; I totally love it!

No 1: I have been thinking of this question for a while now.. The main player window shows either played time or remaining time. Why not both? In the Bento skin, there is a void available where this could go and then the "show played or show remaining" function could just swap the two fields.. The location for this could be the space between the play time and the bitrate.

Is this an easy fix? It would be really useful for me..

No 2: Is it possible to make the Main Player resizable in width? Or just have it a bit wider, since my play list info just cannot fit without scrolling.

Super TIA!
Znyper2 is offline  
Old 23rd September 2007, 22:59   #189
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Re: flickering scrollbars

From what I remember, Winamp is supposed to be in WindowsBlinds exclusion list by default.
DJ Egg is offline  
Old 24th September 2007, 00:03   #190
denilson3
Junior Member
 
Join Date: May 2000
Posts: 42
Send a message via AIM to denilson3 Send a message via Yahoo to denilson3
On Vista (same as the [buffering %] problem I reported earlier) I somehow moved Bento window above the viewable screen. The issue is this: right clicking on the taskbar to use the move option does not work.
denilson3 is offline  
Old 24th September 2007, 00:17   #191
Perseid
Junior Member
 
Join Date: Sep 2005
Posts: 27
@DJEgg:
Regarding the portable player issue - my issue was not related to Winamp at all. The device itself would freak if all of its songs were removed. I mentioned it because it might solve the other person's problem too.
Perseid is offline  
Old 24th September 2007, 01:02   #192
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by denilson3
On Vista (same as the [buffering %] problem I reported earlier) I somehow moved Bento window above the viewable screen. The issue is this: right clicking on the taskbar to use the move option does not work.
If you turn off the notifier (in skin settings), does the buffering problem go away?
Benski is offline  
Old 24th September 2007, 05:31   #193
J.Heezy
Junior Member
 
Join Date: Mar 2001
Posts: 47
Send a message via Yahoo to J.Heezy
i switched from the classic skin to the bento skin. i can't seem to open the playlist editor in the bento skin. its supposed to appear right next to the file info window, but there nothing there.
J.Heezy is offline  
Old 24th September 2007, 06:56   #194
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Just a few minor issuers that I have encountered.

during install, I did not install the playlist generator but I did install the auto tagger.
when I try to auto tag a song, an error pops up that says, "Gracenote tools not installed"
I can see why these would be connected, but I am not sure if this is a bug or not

This next issue is a little harder to explain.
Modern skin
album artist/album art view
album art at medium details

If you move the bottome seperator up, past the dividing line of the album art
choose a different album artist on the left pane
the album art window will be blank if you have one album (you will have to move the scrool bar up)
or if you have more than one album art, it will pop to the second album and you can move the scrollbar up to see the first album art

Thanks for all of the hard work
Juanus is offline  
Old 24th September 2007, 07:53   #195
40044004
Junior Member
 
Join Date: Dec 2003
Posts: 12
Quote:
Originally posted by DJ Egg
@40044004
It's a SingleUI skin, which means that everything is available all in one window.
1) You can use the button towards the bottom right corner to collapse/expand the entire bottom pane.
2) Don't click them.
Fair enough. However whenever I try to access the browser by clicking on a "browse artist/title/whatever" link, winamp crashes with a fatal script error, which is why I was wondering if there's a way to hide it. I guess I should have asked if it's a known issue first (I couldn't find anything useful with search).

The exact error i get is:
Guru Meditation
#0021.008A3EEB.25
Script Fatal error
40044004 is offline  
Old 24th September 2007, 12:01   #196
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
@ J.Heazey

You may have the righthand edge of the file info window pulled right over to the side. Does it look like it has a double frame on the far right?
If so, pick up the inner edge and move it to the left. You may need to move it quite a way over before the playlist reappears.

UJ
ujay is offline  
Old 24th September 2007, 14:11   #197
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Thanks soulstace & Hawk, I've excluded Winamp.exe from Windowblinds and this issue is solved. Sorry DJ Egg for bothering you.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 24th September 2007, 14:49   #198
PC Gamer
Banned
 
Join Date: Sep 2007
Posts: 37
I optimized modern skin spectrum analizer to the fastest fps, but it's so xtreme slow, & also text scroll speed.
PC Gamer is offline  
Old 24th September 2007, 14:59   #199
pEar 242
Member
 
pEar 242's Avatar
 
Join Date: Feb 2006
Location: Moscow, Korolev
Posts: 97
BENTO SKIN:
Add fade effect for album art panel.
Add scrolling (songticker?) for File Info Panel
Make options 4 line in File Info Panel (show track number or year). If it is switched off starrating

WINAMP
add * function for artwork type

and.... scroll buttons in playlist window, like in ml playlists. I so expect it!!! How it is fast to appear in Winamp?
pEar 242 is offline  
Old 24th September 2007, 15:15   #200
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
@Juanus
ml_autotag was a last-minute addition to the installer (English translation only) and therefore there wasn't enough time to make sure that all the Gracenote libraries are installed, if checked. In this build, you probably also need to have CDDB and/or Playlist Generator checked for the Gracenote libraries to be installed.

@40044004
Hmm. Does the Browser open ok for you when you click the Browser tab, or do you get a crash there as well?
If it opens ok, check to see if the default search is set to "Web search" (click the 'looking glass' button to the left of the search field, and make sure 'Web search' is checkmarked).
Other than that, I'm not sure what could be causing the problem.
What's your Windows OS and Internet Explorer version?
Is Internet Explorer in working order? Or have you maybe disabled certain features in Control Panel?
DJ Egg is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump