Old 22nd October 2018, 04:06   #1
vkaku
Junior Member
 
Join Date: Oct 2018
Posts: 10
5.8 Beta Bugs Thread

1. lame_enc.dll not Uninstalled during Installation.
2. pmp_activesync.dll shows as not loaded on Windows 10 (10.0.16299). Only an option to Uninstall is available.
vkaku is offline   Reply With Quote
Old 22nd October 2018, 12:48   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,817
1. Fixed for next build. Thanks.

2. Requires MS ActiveSync to be installed.
DJ Egg is offline   Reply With Quote
Old 23rd October 2018, 21:50   #3
PeterK.
Quinto Black CT Developer
 
Join Date: Sep 2016
Posts: 504
Go to Skins tab and uncheck Prompt on install.
Close Winamp.
Start Winamp.
Open Preferences.
Prompt on install is checked again. (and I still see the message box "Are you sure that you want to install ...")
PeterK. is offline   Reply With Quote
Old 23rd October 2018, 21:51   #4
ariszlo
Senior Member
 
Join Date: Jun 2015
Location: Hungary
Posts: 379
Switch skins during playing a video and Vid_Info will disappear from the statusbar of the Video window.
ariszlo is offline   Reply With Quote
Old 28th October 2018, 02:44   #5
Marctraider
Junior Member
 
Join Date: Oct 2018
Posts: 1
Been using WASAPI output plugin on Win7 since release, no problems with playback so far.

The only bug I've found so far is that every time i change songs manually/enqueue the WASAPI volume output resets back to something extremely quiet (close to 1%)

Really annoying.
Marctraider is offline   Reply With Quote
Old 28th October 2018, 08:29   #6
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
please see my thread for the various bugs and issues i've identified:

http://forums.winamp.com/showthread.php?t=453692

thanks.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 29th October 2018, 08:42   #7
Klausi2007
Junior Member
 
Klausi2007's Avatar
 
Join Date: Mar 2007
Location: Wuppertal, Germany
Posts: 30
Hi,

it seems there are some problems with the audio buffer while playing NSV streams:
The default settings for streaming at in_nsv.dll is
10000ms Buffer size
2000ms Prebuffer at start
3000ms Rebuffer on Underrun

This settings were working perfect in 5.666.
With 5.8 3660, you get stuttering sound most times if you start an NSV stream.
This can be solved by the user by setting Prebuffer to 3000ms,
but in 5.666 you can also set 1000ms or 500ms, it works always fine.

Also, if you change "Buffer size", you can never change it back to 10000 - The GUI only allows 4 digits

euer-radio.de - Shoutcast Radio/TV from Germany since 2006
Klausi2007 is offline   Reply With Quote
Old 4th November 2018, 15:56   #8
justtesting
Junior Member
 
Join Date: Nov 2018
Posts: 8
Hi,

Winamp 5.8 3660 beta doesn't seem to store correctly the last position of the main player window when using the Modern skin -- it always goes back to the top left of the screen. Classic skin behaves OK. Even when starting the program the first time, it'll align to the top left instead of screen center (5.6 behavior).

If 5.8 3660 inherits the position file on the roaming folder made with latest 5.6, it'll apply the previously stored position for the main window, but is then unable to store a new one (resetting to it instead of top left on a fresh install). I've posted some more info in this previous thread (link).
justtesting is offline   Reply With Quote
Old 8th November 2018, 21:28   #9
Shark321
Junior Member
 
Join Date: Nov 2008
Posts: 13
I've also noticed that the window position is not stored with modern skins. Went back to 5.6, and it's fine again.
Shark321 is offline   Reply With Quote
Old 8th November 2018, 21:32   #10
Shark321
Junior Member
 
Join Date: Nov 2008
Posts: 13
I have also noticed that studio.xnf is stored as c:\Program Files (x86)\Winamp\studio.xnf, which is a very bad idea in 2018. It should be in the users folder.
Shark321 is offline   Reply With Quote
Old 9th November 2018, 07:42   #11
PeterK.
Quinto Black CT Developer
 
Join Date: Sep 2016
Posts: 504
Quote:
Originally Posted by Shark321 View Post
I've also noticed that the window position is not stored with modern skins. Went back to 5.6, and it's fine again.
This is not quite correct. "Winamp Modern" and its Player Window in 5.8 seem to "suffer" from this oddity, my skin does not show this kind of behavior.

Quote:
Originally Posted by Shark321 View Post
I have also noticed that studio.xnf is stored as c:\Program Files (x86)\Winamp\studio.xnf, which is a very bad idea in 2018. It should be in the users folder.
And the studio.xnf is there where it belongs: C:\Users\***\AppData\Roaming\Winamp


Last edited by PeterK.; 14th November 2018 at 18:19.
PeterK. is offline   Reply With Quote
Old 9th November 2018, 17:00   #12
ZomBrony
Junior Member
 
Join Date: Aug 2014
Posts: 4
I just had a really weird bug with Winamp 5.8 where it was only playing music out of my left speaker for some reason..

I did the windows sound test and I tried it with Spotify and Windows Media Player as well and I know it's still working fine, but whenever I try to play something on Winamp it only plays out of the left speaker.
ZomBrony is offline   Reply With Quote
Old 9th November 2018, 17:52   #13
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
Winamp has it's own built in balance control.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 9th November 2018, 21:26   #14
Saetiah
Junior Member
 
Join Date: Nov 2018
Posts: 2
I allowed Winamp to play 24bit files but it cannot do it and it crashes. This wasn't happening with the previous version.
Saetiah is offline   Reply With Quote
Old 9th November 2018, 23:05   #15
justtesting
Junior Member
 
Join Date: Nov 2018
Posts: 8
Quote:
Originally Posted by PeterK. View Post
This is not quite correct. "Winamp Modern" and its Player Window in 5.8 seem to "suffer" from this oddity, my skin does not show this kind of behavior.



And the studio.xnf is there where it belongs: C:\Users\***\AppData\Roaming\Winamp

I confirm this. It only seems related to the inbuilt "Winamp Modern" skin, it doesn't affect custom modern type skins. Also, it's using studio.xnf on the roaming folder and can successfully load previously created position info for that skin (made on 5.6); it just fails to store a new position for the player window.
justtesting is offline   Reply With Quote
Old 10th November 2018, 03:38   #16
ZomBrony
Junior Member
 
Join Date: Aug 2014
Posts: 4
Quote:
Originally Posted by MrSinatra View Post
Winamp has it's own built in balance control.
Well that would have been good to know.. Can you tell me where it is?
ZomBrony is offline   Reply With Quote
Old 10th November 2018, 07:07   #17
PeterK.
Quinto Black CT Developer
 
Join Date: Sep 2016
Posts: 504
Quote:
Originally Posted by ZomBrony View Post
Well that would have been good to know.. Can you tell me where it is?
Here:




Attached Thumbnails
Click image for larger version

Name:	balance.png
Views:	633
Size:	37.3 KB
ID:	54189  
PeterK. is offline   Reply With Quote
Old 13th November 2018, 22:33   #18
Hellgore
Junior Member
 
Join Date: Nov 2018
Posts: 2
Winamp crashes completely

After getting Winamp to work the way I want it, I rebooted my machine and since then WA crashes with the errormessage shown in the uploaded screenshot. Reinstallation was no use. I have win 10 pro.
Anyone experienced this, too?
Attached Thumbnails
Click image for larger version

Name:	2018-11-13 23_29_48-Clipboard.png
Views:	77
Size:	47.3 KB
ID:	54191  
Hellgore is offline   Reply With Quote
Old 13th November 2018, 22:35   #19
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
What skin r u using?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 14th November 2018, 06:06   #20
Hellgore
Junior Member
 
Join Date: Nov 2018
Posts: 2
WMP11 Blu VU

interestingly - over night WA "self-repaired"
I left the "Assertion failed" window open and when I returned to my PC this morning, the WA Gui was there just as if nothing happened.

Strange bug
Hellgore is offline   Reply With Quote
Old 14th November 2018, 19:51   #21
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
Sounds like the skin has some weird kind of issue.

Different bug:

http://forums.winamp.com/showthread.php?t=453836

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th November 2018, 00:53   #22
Lowprofile
Junior Member
 
Join Date: Nov 2018
Posts: 2
Winamp crashes when scanning a folder for music

Winamp crashes a quarter of the way through when i select a folder with music on a different drive to add to the library.
Lowprofile is offline   Reply With Quote
Old 15th November 2018, 00:55   #23
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
see the link in my post above yours, likely that issue.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th November 2018, 00:57   #24
Lowprofile
Junior Member
 
Join Date: Nov 2018
Posts: 2
Quote:
Originally Posted by Lowprofile View Post
Winamp crashes a quarter of the way through when i select a folder with music on a different drive to add to the library.
https://imgur.com/a/yeyOX2Z
Lowprofile is offline   Reply With Quote
Old 15th November 2018, 02:29   #25
BradyBunchFan
Junior Member
 
Join Date: Jul 2017
Posts: 46
Winamp is crashing and giving me an error report.
BradyBunchFan is offline   Reply With Quote
Old 15th November 2018, 02:34   #26
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
Quote:
Originally Posted by BradyBunchFan View Post
Winamp is crashing and giving me an error report.
come on, how can we help with just that?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th November 2018, 02:42   #27
BradyBunchFan
Junior Member
 
Join Date: Jul 2017
Posts: 46
Quote:
Originally Posted by MrSinatra View Post
come on, how can we help with just that?
Whenever I start it up, I'm getting nothing but an error report message when trying to close out the add media to library option.
BradyBunchFan is offline   Reply With Quote
Old 15th November 2018, 10:34   #28
BradyBunchFan
Junior Member
 
Join Date: Jul 2017
Posts: 46
Could the theme I'm using also have something to do with it?
BradyBunchFan is offline   Reply With Quote
Old 16th November 2018, 20:24   #29
spenk018
Junior Member
 
Join Date: Nov 2018
Posts: 2
Winamp client version: 5.8 Build 3660
winamp caused an Access Violation (0xc0000005) in module ntdll.dll at 0023:7755109e.

Exception handler called in Winamp.

Using the Bento skin. Win 10 64 bit.

It crashes (shuts down the program) when I have tried to rescan my library every time. I then just left it running a playlist and it crashed 40 odd minutes in. That time it generated the above message.

Anyone got any ideas?
spenk018 is offline   Reply With Quote
Old 16th November 2018, 22:50   #30
heinz57g
Junior Member
 
Join Date: Feb 2006
Posts: 36
Positions not kept

.. >> doesn't seem to store correctly the last position of the main player
.. >> window when using the Modern skin


nor any other windows, visualisation, cover art, whatever. i size and set them nicely
onto the desktop, and the next time i start WINAMP they are all over, but not where
i had put them.

a real bother - i wish somebody could look into this - it worked fine with all earlier
versions, so a solution should not be too far away.

.. >> This is not quite correct. "Winamp Modern" and its Player Window in 5.8
.. >> seem to "suffer" from this oddity, my skin does not show this kind of behavior


but all the earlier comments did refer to ''Modern'' - so as such it is correct. but if it does
work on other skins, it shouldnt be too difficult to find out why it misbehaves with the
plain 'Modern' skin.

please, pretty please, somebody look into this. going back to 5.6 is not really the most
elegant solution.

greetings - heinz -




greetings
heinz57g is offline   Reply With Quote
Old 17th November 2018, 16:07   #31
spenk018
Junior Member
 
Join Date: Nov 2018
Posts: 2
I've just tried deleting the app, going through Regedit to delete all references to Winamp and then re-installed it. It crashes while trying to add files to the library (just closes itself - no error messages). I've tried it using the Classic skin but get the same result, although when I restarted it it started in the Classic skin, so it knew that had been changed. However, it still asks to add library location again. I even tried installing an older version over the top, but get the same results. Unfortunately it looks like this version is now unusable.
spenk018 is offline   Reply With Quote
Old 23rd November 2018, 00:05   #32
Saetiah
Junior Member
 
Join Date: Nov 2018
Posts: 2
Quote:
Originally Posted by Saetiah View Post
I allowed Winamp to play 24bit files but it cannot do it and it crashes. This wasn't happening with the previous version.
no answer on this?
Saetiah is offline   Reply With Quote
Old 23rd November 2018, 12:40   #33
heinz57g
Junior Member
 
Join Date: Feb 2006
Posts: 36
Positions not kept

moved this particular issue to its own thread - see there.

think it is important enough for many of us, and hope it gets due attention there.

greetings - heinz -
heinz57g is offline   Reply With Quote
Old 28th November 2018, 11:18   #34
DekuKamikiXZ
Junior Member
 
Join Date: Nov 2018
Posts: 1
i have found a bug when playing FLAC 24-bit..
this is the report :
https://mega.nz/#!wWhzwAJA!TEw27Frwq...8yaWjXl0S98Fkc

i want to play file Error - GARNiDELiA.flac, but after double-click and start the Winamp, it just crashed after showing the app...
DekuKamikiXZ is offline   Reply With Quote
Old 4th December 2018, 22:09   #35
iSPY
Junior Member
 
Join Date: Jan 2013
Posts: 21
I found two bugs @ win10

this new audio plugin nullsoft wasapi always mutes and goes to 0% in windows mixer, play /change song

and new search bar by playlist @ bigbento doesn't hide by fresh start if in compact mode. If I expand it and then shrink back to compact it stays that way until I quit.

iSPY is offline   Reply With Quote
Old 9th December 2018, 02:19   #36
Chad Cloman
Junior Member
 
Join Date: Dec 2018
Posts: 3
Winamp 5.8b - Forgets previous window position w/ Modern Skin
Chad Cloman is offline   Reply With Quote
Old Today, 07:03   #37
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,393
Send a message via AIM to MrSinatra
Quote:
Originally Posted by DekuKamikiXZ View Post
i have found a bug when playing FLAC 24-bit..
this is the report :
https://mega.nz/#!wWhzwAJA!TEw27Frwq...8yaWjXl0S98Fkc

i want to play file Error - GARNiDELiA.flac, but after double-click and start the Winamp, it just crashed after showing the app...
http://forums.winamp.com/showthread.php?t=454005

related?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump