Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 4th June 2013, 19:11   #1
data.enterprise
Junior Member
 
Join Date: Feb 2010
Posts: 32
Winamp crashes, unavailable email address for Bug report

Hi all
Winamp crashes and tried to send a "winamp error Feedback" to 'Nullsoft Bug Reporting' an a zip-File as attachment.

This can't be send, until using a valid Mailadress.

best regards
Martin

P.S.

see attached File
Attached Files
File Type: zip report.zip (89.2 KB, 257 views)
data.enterprise is offline   Reply With Quote
Old 4th June 2013, 21:57   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,697
Hi

At what point does it crash? What are the steps to reproduce the crash? What functionality/feature are you using at the time?

Which lang pack are you using?
Please also confirm whether it crashes with the default English translation (ie. when not using a lang pack).

Also confirm whether it crashes without any of these 3rd-party plugins present:

gen_intro.dll
gen_MiniLyrics.dll
gen_playa_control.dll
gen_lazik.dll
gen_CUENavigator.dll
gen_cue.dll
in_cue.dll

Let us know which of those plugins is to blame, if any...
DJ Egg is online now   Reply With Quote
Old 4th June 2013, 23:14   #3
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,139
Send a message via AIM to MrSinatra
perhaps try it in "safe mode" (in prefs) first, then try to narrow it down if necessary.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 5th June 2013, 17:48   #4
data.enterprise
Junior Member
 
Join Date: Feb 2010
Posts: 32
Hi
I can't reproduce the Crash. It happend by the third start maybe.
I'am using along the given german Translation.
The main failure i think is creating a bug Report, that can't be send, because there is no valid mail-recipient given.
I just updated to bd.3402. If happend again i will further investigate.

best regards
data.enterprise is offline   Reply With Quote
Old 6th June 2013, 11:21   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,697
Hmm, ok....

Do you not have an email client on the pc using a pop3/imap account?

Have you tried changing the relevant settings via: Winamp > Prefs > Error Feedback?

If no default email program is available, then you can try using the smtp option instead....

Server needs to be your server's smtp, eg. for gmail it's: smtp.gmail.com
Port for gmail: 465 (will be different for other providers)
Sender address = your email address (eg. bob@gmail.com)
Server requires auth = checkmarked for gmail (most other providers also require this)
User = your email address (some providers only require the username before the @, others require the full email address)
Password = as provided

If not using gmail, then you'll need to get the relevant settings from your provider....


The reports are automatically sent to bug (at) winamp.com
Any emails which don't have the default subject and attachment filename are automatically discarded.
DJ Egg is online now   Reply With Quote
Old 6th June 2013, 19:42   #6
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,139
Send a message via AIM to MrSinatra
so using gmail works now?

I thought when this was discussed in the other LONG thread it was determined gmail wouldn't work even if the user could set the port used?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 9th June 2013, 08:54   #7
data.enterprise
Junior Member
 
Join Date: Feb 2010
Posts: 32
Further investigate:
Not the Crash is the main, seems that sending the Report Fails because of a Outlook behaviour.
Winamp crahes and builds a Report through the Standard Mailer (in my case is Outlook the PIM).
The Mail looks something like that i recreate. Outlook has a problem with the single Quote in the recipient field.
Is there a way to produce an error-report for testing?
Attached Files
File Type: zip Winamp Bug.zip (339.8 KB, 225 views)
data.enterprise is offline   Reply With Quote
Old 11th June 2013, 15:48   #8
DrO
 
Join Date: Sep 2003
Posts: 27,880
i've sent you a pm with something to try out as so far i've not been able to see the issue (though i've only access to Thunderbird and not Outlook). however i doubt the issue is the single quotes as we don't apply them and from what i remember of Outlook Express, that's just how it shows things in the UI.
DrO is offline   Reply With Quote
Old 15th June 2013, 19:55   #9
omaudio
Member
 
omaudio's Avatar
 
Join Date: Jan 2005
Location: Los Angeles
Posts: 63
Send a message via ICQ to omaudio
same issue here- crash report email in Outlook fails-

Your message did not reach some or all of the intended recipients.

Subject: winamp error feedback
Sent: 6/15/2013 10:49 AM

The following recipient(s) cannot be reached:

'Nullsoft Bug Reporting' on 6/15/2013 10:49 AM
None of your e-mail accounts could send to this recipient.

Win7x64, 8GB RAM, Winamp Pro 5.666 b3516
Android: Winamp Pro 1.4.15
omaudio is offline   Reply With Quote
Old 15th June 2013, 19:59   #10
DrO
 
Join Date: Sep 2003
Posts: 27,880
omaudio: pm also sent to you to try something out (as i've not heard anything back from data.enterprise yet).
DrO is offline   Reply With Quote
Old 15th June 2013, 20:34   #11
omaudio
Member
 
omaudio's Avatar
 
Join Date: Jan 2005
Location: Los Angeles
Posts: 63
Send a message via ICQ to omaudio
Thanks I tried that but same result. Looks like an issue with the address- see attached- thanks!
O
Attached Thumbnails
Click image for larger version

Name:	winamp-error.jpg
Views:	331
Size:	35.9 KB
ID:	50604   Click image for larger version

Name:	winamp-error2.jpg
Views:	284
Size:	48.6 KB
ID:	50605  

Win7x64, 8GB RAM, Winamp Pro 5.666 b3516
Android: Winamp Pro 1.4.15
omaudio is offline   Reply With Quote
Old 15th June 2013, 20:59   #12
data.enterprise
Junior Member
 
Join Date: Feb 2010
Posts: 32
same issue, now you're using double quotes?

Click image for larger version

Name:	15.06-Sending Mail.png
Views:	255
Size:	66.9 KB
ID:	50608
Click image for larger version

Name:	15.06-Error Sending Mail.png
Views:	319
Size:	14.5 KB
ID:	50607
data.enterprise is offline   Reply With Quote
Old 15th June 2013, 21:10   #13
DrO
 
Join Date: Sep 2003
Posts: 27,880
yes i tried putting it in double-quotes just to see how that'd affect things or not (as we don't put quotes around it normally).

will sort out something else to try in an hour or two.
DrO is offline   Reply With Quote
Old 17th June 2013, 21:29   #14
DrO
 
Join Date: Sep 2003
Posts: 27,880
got a bit delayed on things, sorry. pm now sent with something else to try out (goes back to the original email address and just drops trying to set a sender name to see if that helps). if that doesn't do it then it means the API and/or Outlook is doing things incorrectly.

[edit]
didn't work, back to searching for me...
DrO is offline   Reply With Quote
Old 25th November 2016, 05:54   #15
anthonyfiretto
Junior Member
 
Join Date: Feb 2016
Posts: 1
Crashed winamp and unable to send report with zipfile

Winamp crashed again and I was unable to send the report.

It tends to crash every couple of weeks and it is very inconvenient. Help!

Thanks


Winamp client version: 5.666 Build 3516
winamp caused an Access Violation (0xc0000005)
in module MSVCR90.dll at 0023:7324b9f0.
anthonyfiretto is offline   Reply With Quote
Old 12th December 2016, 07:46   #16
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,139
Send a message via AIM to MrSinatra
why post in this old thread?

are u using the correct patched ver of in_mp3.dll?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump