Old 25th January 2007, 09:23   #2281
ON7RK
Junior Member
 
Join Date: Jan 2007
Posts: 2
Question about DL

hello all,

I have played around with this nice plugin...but i have a few questions... v1.03

1)Is there a way to remove the .mu3 extention in the tree view.

2) The scroll bars right and under in file window don't work.

3)When i click on a playlist or folder in the tree view and click on PLAY, is it possible to play the whole playlist,and when click in list on 1 file and click on PLAY to play only that file?

I saw that there's an option to submit on all items in list... but then it plays always the colmplete list..

tnx
Koen
ON7RK is offline   Reply With Quote
Old 2nd February 2007, 06:23   #2282
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
I should've abandoned this project long ago. Never been this inspired before. *been coding DL all week*
Joonas is offline   Reply With Quote
Old 2nd February 2007, 07:07   #2283
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 2nd February 2007, 11:37   #2284
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
excellent
this brings hopes back

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 2nd February 2007, 12:26   #2285
DrO
 
Join Date: Sep 2003
Posts: 27,873
he's such a tease is funny how the urge to code comes and goes

-daz
DrO is offline   Reply With Quote
Old 4th February 2007, 14:31   #2286
colorspace
Member
 
colorspace's Avatar
 
Join Date: Jan 2006
Location: Netherlands
Posts: 69
colorspace is offline   Reply With Quote
Old 5th February 2007, 06:53   #2287
maurits
Junior Member
 
Join Date: Mar 2005
Posts: 26
maurits is offline   Reply With Quote
Old 7th February 2007, 07:39   #2288
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
I think I am getting around to a beta release of DL soon.
A lot of features will be missing and some won't even make it back (as discussed before).

I was not thinking of an open beta test this time around, since so many bugs were reported that was caused by old versions last time.

So if you are interested in beta testing you can drop me an e-mail.
Joonas is offline   Reply With Quote
Old 7th February 2007, 14:59   #2289
jojo 544
Major Dude
 
jojo 544's Avatar
 
Join Date: Nov 2003
Location: Nowhere near the apeland
Posts: 623
Great, count me in,
i'll send the mail later

*sigh (still) under construction*
jojo 544 is offline   Reply With Quote
Old 10th February 2007, 11:07   #2290
francescoNemesi
Junior Member
 
Join Date: Feb 2007
Posts: 4
DL Window has disappeared!?!

Hi there, thanks for the great plugin!... I've been using it for a while without any problems, but now something weird is happening... When I activate it I can'tsee its window

If I alt-tab I can see it is there, but I can't see the window anywhere... so I can't use it... I have tried to uninstall and install 3 times with no success.

I have noticed that the gen_dl.ini config file is not created when I install the plugin. Any ideas? Please help.

Thanks!
francescoNemesi is offline   Reply With Quote
Old 10th February 2007, 12:24   #2291
poisonborz
Member
 
poisonborz's Avatar
 
Join Date: May 2005
Location: Hungary
Posts: 86
Quote:
If I alt-tab I can see it is there, but I can't see the window anywhere...
Just press alt-d, or select "dynamic library" from the winamp preferences context menu.

More and more posts like these are popping up, we should have a separate support thread...
poisonborz is offline   Reply With Quote
Old 10th February 2007, 17:23   #2292
francescoNemesi
Junior Member
 
Join Date: Feb 2007
Posts: 4
that's exactly the point... the DL window does not come up after I press Alt-D, but I can see an instance of it is running. It's there, but invisible...
francescoNemesi is offline   Reply With Quote
Old 10th February 2007, 17:25   #2293
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Check the ini-file where the coordinates are set. Maybe it's ends up far outside the desktop window?
Joonas is offline   Reply With Quote
Old 10th February 2007, 17:43   #2294
francescoNemesi
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks for your reply... below my ini file... I am puzzled...


[Columns]
Column #1=36
Column #2=100
Column #3=100
Column #4=100
Column #5=100
Column #6=100
Column #7=100
Column #8=100
Column #9=100
Column #10=100
Column #11=100
Column #12=100
Column #13=100
Column order=0123456789ABC
[Window]
Minimized=0
Window x=100
Window y=100
Window width=500
Window height=300
Divider=128
Show on load=1
[General]
File types=mp3;mp2;mp4;aac;ogg;wma;wav;m3u
Mode=1
Double-click listview action=0
Double-click treeview action=0
Warn if slow=1
Search only until found=0
Enqueue button action=1
Search=9
Playlist confirmation=1
Load playlist=0
Autosave playlists=0
Action button behaviour=0
Internal drag default action=0
External drag default action=0
[Display]
Display playlist entries in Search mode=1
Display Thinger icon=1
Lightning-click=0
Path type=0
Use sub-folders=1
Use playlist font=0
Display playlists as nodes=0
Expand nodes=1
Show empty folders=1
Disregard the in sort=0
Sort by=12
Sort order=-1
Warn before physical file operation=1
[Tags]
Read ID3-tags when available=1
Auto-read tags=0
Guess tags=1
Thread priority=2
francescoNemesi is offline   Reply With Quote
Old 10th February 2007, 18:02   #2295
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Looks okay, try deleting it and see if it helps.
Joonas is offline   Reply With Quote
Old 10th February 2007, 18:51   #2296
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
If you're using a modern skin, also try deleting studio.xnf (in C:\Program Files\Winamp) while Winamp is closed. That will reset all modern skin settings (including window sizes/positions).

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 11th February 2007, 07:08   #2297
francescoNemesi
Junior Member
 
Join Date: Feb 2007
Posts: 4
!!!!!

Siebe! Thanks a lot! that did it.... I can see DL again, now

Joonas, just to let you know... I have noticed that on closing winamp, the gen_dl.ini file was written with the following values:

[Window]
Minimized=0
Window x=-5
Window y=1103
Window width=1287
Window height=386
Divider=128

which is why I think that on opening back Winamp DL would disappear... no idea why it was doing that.

Thanks again! Keep up the good work
francescoNemesi is offline   Reply With Quote
Old 15th February 2007, 04:01   #2298
mrthefter
Junior Member
 
Join Date: Feb 2007
Posts: 2
Hey, great work on the plugin. To me, it's much more useful than the built-in media library. And now, for a request...
Since Winamp5.3 added unicode support for ml_local, you think you can beat Winamp to the punch (not really..it's in their beta) and release a unicode Dynamic Library?
mrthefter is offline   Reply With Quote
Old 15th February 2007, 06:58   #2299
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by mrthefter
Hey, great work on the plugin. To me, it's much more useful than the built-in media library. And now, for a request...
Since Winamp5.3 added unicode support for ml_local, you think you can beat Winamp to the punch (not really..it's in their beta) and release a unicode Dynamic Library?
The new DL I am writing is entirely unicode compliant, but it will require the 5.33 release (currently in beta).
Joonas is offline   Reply With Quote
Old 15th February 2007, 10:45   #2300
DrO
 
Join Date: Sep 2003
Posts: 27,873
5.33 is final now

-daz
DrO is offline   Reply With Quote
Old 15th February 2007, 14:12   #2301
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by DrO
5.33 is final now

-daz
Great, then I can actually release a beta of DL soon
Probably this weekend!
Joonas is offline   Reply With Quote
Old 15th February 2007, 22:03   #2302
mrthefter
Junior Member
 
Join Date: Feb 2007
Posts: 2
Hmm...
so when people said unicode was in 5.33 beta...
They were just talking about ml_local? Because it looks like names are still displayed incorrectly in the ML (not the playlist though. =D)
mrthefter is offline   Reply With Quote
Old 16th February 2007, 12:52   #2303
DrO
 
Join Date: Sep 2003
Posts: 27,873
if you've done an upgrade with an already filled media library then you'd need to reload the metadata on the files already in there so that it can be updated and stored in unicode (since the database needs to be saved out as unicode compatible and the metadata reload allows for that to happen)

-daz
DrO is offline   Reply With Quote
Old 19th February 2007, 06:12   #2304
drugo
Senior Member
 
Join Date: Dec 2006
Posts: 300
why don't add a "sent to " feature
drugo is offline   Reply With Quote
Old 19th February 2007, 14:10   #2305
verachtung
Junior Member
 
Join Date: Nov 2005
Posts: 9
Hi

great to see my favoriteplugin is also in dev! but the versions are some curious, can you say/give me a link to the newest version of DL?

at moment i use DL 2.0 Beta 32.3 on Winamp 5.32, should i update when i don't occur bugs?
verachtung is offline   Reply With Quote
Old 19th February 2007, 14:15   #2306
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by verachtung
Hi

great to see my favoriteplugin is also in dev! but the versions are some curious, can you say/give me a link to the newest version of DL?

at moment i use DL 2.0 Beta 32.3 on Winamp 5.32, should i update when i don't occur bugs?
You are using an abandoned branch of DL-development.

The last official version of DL is 1.03. Then I was working on the DL 2.0 branch for a few months (the versions you are using, but it was abandoned).

That branch was just an add-on of the the 1.03 code. The code I am using now is rewritten from scratch.
Joonas is offline   Reply With Quote
Old 19th February 2007, 17:42   #2307
verachtung
Junior Member
 
Join Date: Nov 2005
Posts: 9
Ah ok!

You've written betatesters have to write you a eMail - is that actual or is "latest beta" link on your webpage this beta?
verachtung is offline   Reply With Quote
Old 19th February 2007, 17:47   #2308
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by verachtung
Ah ok!

You've written betatesters have to write you a eMail - is that actual or is "latest beta" link on your webpage this beta?
The homepage still lists the "old" betas.

I'll take that link down when the new beta testing begins.
Joonas is offline   Reply With Quote
Old 19th February 2007, 18:09   #2309
verachtung
Junior Member
 
Join Date: Nov 2005
Posts: 9
OK Thanks, i'll use them till then, seems they still work good
Have fun
verachtung is offline   Reply With Quote
Old 26th February 2007, 14:32   #2310
EnsconcE
Junior Member
 
Join Date: Jan 2002
Location: Holland
Posts: 12
Hey Joonas, i was wondering what the progress of your development is? I'm pleased to read that you have continued the development of DL!
EnsconcE is offline   Reply With Quote
Old 26th February 2007, 15:04   #2311
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by EnsconcE
Hey Joonas, i was wondering what the progress of your development is? I'm pleased to read that you have continued the development of DL!
Yeah, I am working on some optimizations since the query of the database got really slow...but it could be released any day really. A BETA mind though. It's far from complete, but I need bug reports and a general idea what features that really should be implemented.
Joonas is offline   Reply With Quote
Old 27th February 2007, 09:24   #2312
EnsconcE
Junior Member
 
Join Date: Jan 2002
Location: Holland
Posts: 12
Quote:
Originally posted by Joonas
Yeah, I am working on some optimizations since the query of the database got really slow...but it could be released any day really. A BETA mind though. It's far from complete, but I need bug reports and a general idea what features that really should be implemented.
Count me in if you need Beta testers, i use DL always with Winamp so i can give some feedback on bugs and features.

Keep up the good work !
EnsconcE is offline   Reply With Quote
Old 27th February 2007, 09:49   #2313
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by EnsconcE
Count me in if you need Beta testers, i use DL always with Winamp so i can give some feedback on bugs and features.

Keep up the good work !
Send me an e-mail. There won't be an open beta testing this time.
Joonas is offline   Reply With Quote
Old 1st March 2007, 08:23   #2314
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
I have created a Google Group with an accompanying mailing list. I have sent invitations to those that stuck to my betalist. If you are interested and haven't received an invitation go here: http://groups.google.com/group/dynam...ary-beta-group
Joonas is offline   Reply With Quote
Old 1st March 2007, 20:13   #2315
codydog
Junior Member
 
Join Date: Mar 2007
Posts: 3
Help!

Hi folks. I've searched all over for a solution to this one but I can't find any reference to my problem anywhere. All was well with my 'Dynamic Library' plug-in until tonight. Suddenly I can only see one column, i.e. my folder tree. When I click to expand the folder and then click a folder I used to get the files within that folder shown to the right. Now I only have the one window and so cannot see the files within the folders. This is very weird. Has anyone got an idea what could be wrong? Winamp doesn't really work for me without this plug-in.

Thanks in advance.

Sorry, I'm using version 1.03 of 'Dynamic Library' with version 5.32 of Winamp on Windows XP Pro.
codydog is offline   Reply With Quote
Old 1st March 2007, 20:25   #2316
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
http://nunzioweb.com/joonas/dl/docum...n/#Terminology see in the picture, there is a bar between the folders and the files, well you have it moved all the way over to the edge of DL. Hover over the edge and your cursor should change to a double arrow to correct your problem.
billyvnilly is offline   Reply With Quote
Old 1st March 2007, 21:32   #2317
codydog
Junior Member
 
Join Date: Mar 2007
Posts: 3
Quote:
Originally posted by billyvnilly
http://nunzioweb.com/joonas/dl/docum...n/#Terminology see in the picture, there is a bar between the folders and the files, well you have it moved all the way over to the edge of DL. Hover over the edge and your cursor should change to a double arrow to correct your problem.
OMG, I am a horses ass! Thanks for helping. Yes, I do feel really stupid. For some reason that never even crossed my mind. Thanks again
codydog is offline   Reply With Quote
Old 12th March 2007, 19:41   #2318
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
The beta group is now closed.
Joonas is offline   Reply With Quote
Old 16th March 2007, 14:00   #2319
planet gaffnet
Junior Member
 
Join Date: Feb 2006
Posts: 2
I've been using Winamp and the DL plugin for quite a while now and have been pretty pleased with it.

Recently, when running low on drive space, I added an external (USB2) hard drive to my system (FYI a Buffalo 300gb DockStation) and moved all my media over to that drive. I find now that when booting up Winamp (5.33) the whole PC hangs while Winamp and DL fetches the data on the new drive - it might be five or six minutes before Winamp (and the PC) becomes available. While I hate to say it, I actually installed WMP11 and am not having any issues.

I'd be grateful if anyone could let me know how if there's any tweaks I could use to speed things up.

Aside from the DL plug-in I use the ML_iPod and Audioscrobbler plug-ins. Running XP2 SP2.

Thanks
P
planet gaffnet is offline   Reply With Quote
Old 16th March 2007, 14:18   #2320
Joonas
Forum King
 
Join Date: Mar 2004
Location: Sweden
Posts: 2,263
Quote:
Originally posted by planet gaffnet
I've been using Winamp and the DL plugin for quite a while now and have been pretty pleased with it.

Recently, when running low on drive space, I added an external (USB2) hard drive to my system (FYI a Buffalo 300gb DockStation) and moved all my media over to that drive. I find now that when booting up Winamp (5.33) the whole PC hangs while Winamp and DL fetches the data on the new drive - it might be five or six minutes before Winamp (and the PC) becomes available. While I hate to say it, I actually installed WMP11 and am not having any issues.

I'd be grateful if anyone could let me know how if there's any tweaks I could use to speed things up.

Aside from the DL plug-in I use the ML_iPod and Audioscrobbler plug-ins. Running XP2 SP2.

Thanks
P
Since you are using an unsupported beta version of DL, this questions is null and void. Try the new DL when it's ready (In betatesting now)

I will pick down the old DL betas from the site today or tomorrow.
Joonas is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > Winamp Development

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump