Old 8th November 2006, 20:55   #1
NiklasGbg
Junior Member
 
Join Date: Nov 2006
Location: Gothenburg, Sweden
Posts: 3
How do I use multiple playback devices simultaneously?

I have just bought a wireless bluetooth 2.1 speaker system, Saitek A-250, which seems to work very well. I’m very pleased with the sound and the design. The reason for this apparatus is that I wanted to listen to my music in the kitchen.

One thing is bothering me though, whenever I activate the bluetooth speakers they somehow take priority over my desktop speakers. Is there someway to use both sets of speakers simultaneously?

I’ve tried a plug-in called "Multiple Output Plugin 1.5", this seems to be the right path to go but it only takes my so far.

If I activate a second output device I have sound in both sets of speakers although the sound isn’t synchronized, I use the following settings:

Primary output: waveOut output v2.1 -> Device: SoundMAX Digital Audio

Secondary output: DirectSound output v2.43 -> Device: 02: Saitek A-250 wireless 2.1 speaker

Perhaps I'm not making me clear enough?
NiklasGbg is offline   Reply With Quote
Old 28th November 2006, 17:12   #2
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
For best sync try to use a copy of the same output engine...

That is, copy, out_wave.dll to out_wave2.dll, (or the same with out_ds.dll) and use the same buffer settings for both instances of the same plugin.

I have found that waveOut sync works much better.
Sync also it works much better on start/stop second instances or pause/resume songs if,
Prebuffer on both active instances (in either , DirectSound or waveOut) is MAXed ... (eg if Buffer is 2000 which is the default, prebuffer should be set to 2000 as well)

[Also make sure that in Windows Control Panel]
Sounds And Audio Devices Properties > Audio Tab
uncheck "Use only default devices"

for windows to be able to use both soundcards.

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 28th November 2006, 20:07   #3
NiklasGbg
Junior Member
 
Join Date: Nov 2006
Location: Gothenburg, Sweden
Posts: 3
I have tried the things you recommend but I cant get it to work, assuming Im doing it the right way.

I assume I'm supposed to do this with the help of the plugin I mentioned?! I copy the out_ds.dll file and rename it but I can't get sound out of the two devices simultaneously, have I missunderstood something?

Thank you very much for the reply!, I had already given up but perhaps with your help I can get this to work! :-)
NiklasGbg is offline   Reply With Quote
Old 28th November 2006, 20:22   #4
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
Yeah, using the said plug-in
you should also do what you did before assigning the devices

Primary output: (out_ds.dll): DirectSound output v2.43 -> Device: SoundMAX Digital Audio

Secondary output: (out_ds2.dll): DirectSound output v2.43 -> Device: 02: Saitek A-250 wireless 2.1 speaker

[also try removing in_wm.dll because it causes some problems occasionally]

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 3rd December 2006, 18:37   #5
NiklasGbg
Junior Member
 
Join Date: Nov 2006
Location: Gothenburg, Sweden
Posts: 3
Sorry, it doesnt work. If a tamper with anything in the plugin directory I cant start Winamp, it says "...has encountered a problem and has to shutdown..." or something similar.

The same thing applies if I try to uninstall the in_wm.dll from within Winamp! Very strange, perhaps my installation of XP or Winamp is unstable?
NiklasGbg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump