Prev Previous Post   Next Post Next
Old 4th October 2012, 13:22   #1
neuralnet
Junior Member
 
Join Date: Oct 2012
Posts: 7
clients can't connect to sc_serv

Aim:

DJ Input 192k MP3 (8500/8505) -> sc_trans (8080) -> sc_serv (8080) -> 3 streams a) mp3 b) aac & c) aac low

I gave up writing my own config & went for the config builder..

I can connect to the dj port and stream to the transcoder but nothing gets to the mount points, and the client gets asked for password for realm (null) when I connect using vlc indicating there's a problem somewhere (stream connection errors in sc_trans assume when connecting to sc_serv..?) can someone please have a quick look at my configs and show me where I'm going wrong? Hair is at stake here! Thanks!

sc_serv.conf

code:

;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

yp1debug=1
yp2debug=1
shoutcastsourcedebug=1
uvox2sourcedebug=1
shoutcast1clientdebug=1
shoutcast2clientdebug=1
relayshoutcastdebug=1
relayuvoxdebug=1
relaydebug=1
streamdatadebug=1
httpstyledebug=1
statsdebug=1
microserverdebug=1
threadrunnerdebug=1
rtmpclientdebug=1
webclientdebug=1
password=[removed]
adminpassword=[removed]
portbase=8080
srcip=[server IP removed]
dstip=[server IP removed]
requirestreamconfigs=1
logfile=/home/stream/shoutcast2/sc_serv.log
w3clog=/home/stream/shoutcast2/sc_w3c.log
banfile=/home/stream/shoutcast2/sc_serv.ban
ripfile=/home/stream/shoutcast2/sc_serv.rip
maxuser=1024

streamid_1=1
streampath_1=streamname.mp3
streammaxuser_1=512
streamauthhash_1=[removed]
streamadminpassword_1=[removed]

streamid_2=2
streampath_2=streamname.aac
streammaxuser_2=512
streamauthhash_2=[removed]
streamadminpassword_2=[removed]

streamid_3=3
streampath_3=streamname_low.aac
streammaxuser_3=512
streamauthhash_3=[removed]
streamadminpassword_3=[removed]




streamadminpassword and streamadminpassword_x are all the same. Streamauthhash is same for each of the streams.

sc_trans.conf

code:

;Transcoder configuration file
;Made with the SHOUTcast 2 Configuration Builder

;Debug Options
shuffledebug=1
shoutcastdebug=1
uvoxdebug=1
gaindebug=1
playlistdebug=1
mp3encdebug=1
mp3decdebug=1
resamplerdebug=1
rgcalcdebug=1
apidebug=1
calendardebug=1
capturedebug=1
djdebug=1
flashpolicyserverdebug=1
fileconverterdebug=1
sourcerelaydebug=1
sourceandendpointmanagerdebug=1

;Configs
streamtitle=[removed]
streamurl=[removed]
genre=[removed]
adminport=8079
adminpassword=[removed]
adminuser=admin
inheritconfig=/home/stream/shoutcast2/sc_serv.conf
unlockkeyname=[removed]
unlockkeycode=[removed]
logfile=/home/stream/transcoder/sc_trans.log
public=1
playlistfile=/home/stream/transcoder/playlist.lst
shuffle=0
serverip=[server IP removed]
serverport=8080

encoder_1=mp3
mp3quality_1=1

bitrate_1=192000
bitrate_2=96000
bitrate_3=48000

djport=8500
djlogin_1=dj
djpassword_1=[removed]
djpriority_1=1

djport2=8505
djlogin_2=dj
djpassword_2=[removed]
djpriority_2=1




adminpassword is same as serverpassword in sc_serv.conf above. djpassword_x is same as password in sc_serv.conf above.

calendar.xml

code:

<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>
<event type="dj">
<dj archive="1">dj</dj>
<calendar starttime="00:00:00"/>
</event>
</eventlist>




help gratefully appreciated ! Thanks.
neuralnet is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump