Old 5th May 2011, 21:51   #1
texaspapa
Junior Member
 
Join Date: May 2011
Posts: 6
EclipseNSIS not working on Server 2008 64bit

Trying to use EclipseNSIS 9.8 on a Windows Server 2008 R2 system.

When I start Eclipse Helios an error is generated indicating that EclipseNSIS only supports Windows NT4.0, Windows 2000, Windows XP, Windows Server 2003 and Windows Vista.

I was under the impression the EclipseNSIS 9.8 allows 64 bit support.

Are there any other install / configuration requirements I should check?
texaspapa is offline   Reply With Quote
Old 6th May 2011, 06:00   #2
T.Slappy
Major Dude
 
T.Slappy's Avatar
 
Join Date: Jan 2006
Location: Slovakia
Posts: 517
Send a message via ICQ to T.Slappy
I suppose this is problem of Eclipse, not EclipseNSIS, maybe try Eclipse forums?

Cool looking skinned Graphical Installers: www.graphical-installer.com
I offer NSIS scripting, C/C++/C#/Delphi programming: www.unsignedsw.com
Develop NSIS projects in Visual Studio 2005-2017: www.visual-installer.com
or RAD Studio 2009, 2010, XE-10.2 Tokyo: www.rad-installer.com
T.Slappy is offline   Reply With Quote
Old 11th July 2014, 17:54   #3
solkim
Junior Member
 
Join Date: Jul 2014
Posts: 1
Smile

Once you have installed Eclipse, NSIS, GEF and EclipseNSIS on a Windows Server 2008 R2
1) Open ..\eclipse\plugins\net.sf.eclipsensis_0.9.8.1.jar with 7-Zip
2) Navigate to ..\eclipse\plugins\net.sf.eclipsensis_0.9.8.1.jar\net\sf\eclipsensis\
3) Open EclipseNSISPluginResources.properties
4) Add 'Windows Server 2008 R2' to the supported.os, nt.os, 2K.os, vista.os and win7.os properties e.g.

supported.os=Windows NT#4.0,Windows 2000,Windows XP,Windows 2003,Windows Vista,Windows NT (unknown),Windows Server 2008,Windows Server 2008 R2,Windows 7
nt.os=Windows NT,Windows 2000,Windows XP,Windows 2003,Windows Vista,Windows NT (unknown),Windows Server 2008,Windows Server 2008 R2,Windows 7
2K.os=Windows 2000,Windows XP,Windows 2003,Windows Vista,Windows NT (unknown),Windows Server 2008,Windows Server 2008 R2,Windows 7
vista.os=Windows Vista,Windows NT (unknown),Windows Server 2008,Windows Server 2008 R2,Windows 7
win7.os=Windows Server 2008 R2,Windows 7

5) Save and Exit EclipseNSISPluginResources.properties
6) Allow 7-Zip to save the change to ..\eclipse\plugins\net.sf.eclipsensis_0.9.8.1.jar
7) Launch Eclipse and hopefully the EclipseNSIS plugin will load without errors.
solkim is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Tags
64-bit, server 2008

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump