Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Closed Thread
Thread Tools Search this Thread Display Modes
Old 30th September 2006, 21:14   #201
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'll consider it since that'd involve some reworking of the preferences to implement as well...

-daz
DrO is offline  
Old 30th September 2006, 21:42   #202
yaomtc
Member
 
Join Date: Feb 2006
Location: Over there!
Posts: 68
Hm, okay. Also, I ran into a strange problem. I had an album on my playlist, and once it got to deleting the last song... The other songs of the playlist began flashing on and off of the playlist, like some kinda seizure. Then Winamp froze up.
yaomtc is offline  
Old 23rd October 2006, 02:53   #203
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
Request: If the song being removed is the last under a separator, can the separator be removed?

Thanks DrO
billyvnilly is offline  
Old 13th December 2006, 23:10   #204
woodspring
Junior Member
 
Join Date: Jun 2006
Location: Sweden
Posts: 7
Haven't checked this thread for a while so I've only just discovered that Dro had updated the plug-in.
The reload function now works fine.
The randomise on load/reload on the other hand, doesn't...
at least not as I'd like it to.
On auto-reload the playlist is loaded as "sorted by title".
If I manually load the playlist though it randomises it?
Anything you've noticed Dro?
woodspring is offline  
Old 15th December 2006, 13:54   #205
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'll have to check the handling of the randomise option since i don't think i've modified/really verified that code since it was added in - hopefully it's a quick fix if i can confirm the issue

-daz
DrO is offline  
Old 16th December 2006, 03:49   #206
woodspring
Junior Member
 
Join Date: Jun 2006
Location: Sweden
Posts: 7
Cheers mate.
I wait with bated breath.
woodspring is offline  
Old 28th March 2007, 22:12   #207
DawgY
Junior Member
 
Join Date: Mar 2007
Posts: 1
Removal of currently playing track from Winamp playlist ONLY via hotkey

I have tried to use the Playlist File Remover for one purpose only. I want to be able to remove files ONLY from the playlist by using a hotkey. I'm not sure what I'm doing incorrectly, but the hotkeys won't work. Can someone give me some additional help? I've spent hours trying to get this to work. Thanks everyone!!

-DawgY-

BTW: I'm using v5.32 of Winamp. I have selected "enable played file removal from the playlist" in the General Options tab. I have selected "enable hotkey support for removal of the current playlist file" as well as "only remove the playlist entry" from the hotkey support tab. Then I went into the "Global Hotkeys" tab of Winamp and made a new hotkey with the plugin's default name "Playback: Delete current song from playlist" and I assigned "CTRL + D" for the combo. Please let me know what I'm doing wrong, because when I use that combo, nothing happens. Thanks for the help!!
DawgY is offline  
Old 20th September 2007, 06:57   #208
chotto
Junior Member
 
Join Date: Mar 2006
Posts: 7
....

Last edited by chotto; 20th September 2007 at 09:20.
chotto is offline  
Old 14th November 2007, 07:17   #209
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
version 2.2 doesn't loop the last track in playlist when repeat is on with sqr crossfader plugin.
It just abruptly stops playing before the end of the track.

2.1 works fine though...

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline  
Old 7th May 2008, 21:25   #210
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
I couldn't find this plug-in in the plug-ins section, but I found it on the author's site.

It still works fine with the latest version of WINAMP, so I don't know why it has been removed.
dypsis is offline  
Old 7th May 2008, 23:19   #211
DrO
 
Join Date: Sep 2003
Posts: 27,873
i don't remember ever having this plugin submitted to winamp.com and since submissions haven't properly worked for the last few years i've no intention of ever bothering to make a submission to the site (is why i had all of my old submissions removed).

most of the plugin should still work with the current winamp version but there's a number of compatability issues present from the 5.3x days that i've at some point got to try to find the time to work on and fix (not looking too promising at the moment to happen at all).

-daz
DrO is offline  
Old 18th May 2008, 15:07   #212
Moon
Junior Member
 
Join Date: Oct 2002
Posts: 25
Hi there DrO!

I've been using your beta 1.6 plugin since the beginning of this thead and only now it failed me for the first time when I upgraded to Winamp 5.531 Lite. I was happy to see you'd been working on it in the meantime but unfortunately even the 2.2 doesn't work properly.

Though the removal option is checked, Winamp does not remove the songs from the playlist when "next" is clicked but only when the song is played through. Sometimes I can make it work by entering the plugin settings and unchecking, closing, and then again checking this option but this is quite tedious. I really hope you can find the time to look into this matter. Thanks!

www.c64-longplays.de
Complete C64 game walkthroughs as videofiles
Moon is offline  
Old 18th May 2008, 23:40   #213
DrO
 
Join Date: Sep 2003
Posts: 27,873
there's quite a number of issues with the plugin and Winamp versions above 5.2x but is a matter of no time to work on such things and i know i need to update it but i can't say when that's ever going to happen (though i'd have thought the issue you're seeing is more than likely related to the complete mess that's been caused by accelerator changes in Winamp's core).

-daz
DrO is offline  
Old 19th May 2008, 07:08   #214
Moon
Junior Member
 
Join Date: Oct 2002
Posts: 25
When you say accelerator changes you're speaking of hotkeys that have been changed to work system-wide lately? Cause I haven't installed these hoping it would make a difference. As you can see from my previous post I am no version junkie, I simply upgraded Winamp for security reasons. So I'm now in a fix having to decide between possible security issues and functionality I'm used to. Your 'ever' sounds discouraging but I know from personal experience how RL can get in the way, oh well...

www.c64-longplays.de
Complete C64 game walkthroughs as videofiles
Moon is offline  
Old 27th May 2008, 01:17   #215
DrO
 
Join Date: Sep 2003
Posts: 27,873
yeah those changes (well i'm hoping we're talking on the same lines).

i have started tonight on updating the plugin at long last but i'm not sure how long it's going to take as such to get it ready for a new version (need to check over every option and sort out things to work correctly on the different client versions though a few things won't work right on 5.2x-5.3x in some cases).

also need to work through what else has been requested and see if there's anything suitable to add in... like this request.

-daz
DrO is offline  
Old 7th June 2008, 16:16   #216
DrO
 
Join Date: Sep 2003
Posts: 27,873
work on updating this is slowly happening (just not as fast i'd like) so:
* it's now not causing unicode issues in the player itself (so no more ???? in the taskbar for unicode files)
* most of the deletion override code is working now (can't remember what version that broke but was during the winamp.exe ansi->unicode conversion so most of 5.3x i'd have thought)
* lang support has been brought uptodate to allow it to use a plfr_auto.ini from the currently loaded language pack
* the preferences are now by default parented to the main 'playlist' preferences option (old location can be set if wanted but it's more logical to be there).
* all hotkey actions will have a bookmark file option (just need to finish this off as i've had to change the internal structures to not cause more mem usage)

there's still a load more to be done especially with unicode integration/implementation of features and also full feature checks to make sure everything is correctly working but it's getting at last.

-daz
DrO is offline  
Old 12th June 2008, 11:53   #217
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
keep up the good work Dr.
I have used 2.1 religiously for years without any issues.

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline  
Old 15th June 2008, 08:37   #218
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
I haven't noticed any issues with 2.2.2.

Once again, I must say that this is a great plug-in.

Should be installed by default.
dypsis is offline  
Old 15th October 2008, 05:50   #219
b3ckpwnzuall
Junior Member
 
Join Date: Oct 2008
Posts: 1
now if you could have it reload the playlist, and randomize it, then play it, and repeat the process =)

-b3ck
b3ckpwnzuall is offline  
Old 17th October 2008, 13:40   #220
DrO
 
Join Date: Sep 2003
Posts: 27,873
you didn't really check out the preferences then as the options to do that are shown in the lower part of the following screenshot:


http://nunzioweb.com/daz/plfr.html may have some more information in the changelog or whatever else has been posted in this thread (though i've still got to find time to finish the new release... if only, heh)

-daz
DrO is offline  
Old 2nd January 2009, 19:06   #221
Veev
Junior Member
 
Join Date: Dec 2008
Posts: 10
Sorry to bother, but I'm having trouble setting up a hotkey for file removal. I have 'enable hotkey support' checked, the options are set up how I want them to be by default (recyle), but when I click "Set" nothing happens, tried clicking set and then my hotkey, my hotkey and then set, just doesn't seem to take anything.
Veev is offline  
Old 5th January 2009, 18:56   #222
DrO
 
Join Date: Sep 2003
Posts: 27,873
once the option is setup in the plfr preference page, you then need to go to winamp's global hotkeys page and select in that list the name of the hotkey you've entered in the plfr hotkey page. once that's done things should work. is an unfortunate limitation of how i've done hotkeys in this plugin that i need to address or at least better document within the plugin in future builds (hopefully that'll be coming soonish).

-daz
DrO is offline  
Old 5th January 2009, 23:30   #223
Veev
Junior Member
 
Join Date: Dec 2008
Posts: 10
Thanks a ton!
Veev is offline  
Old 13th January 2009, 01:42   #224
bashy
Junior Member
 
Join Date: May 2005
Posts: 4
Link is down? Can someone help out with fresh link for v2.2.2 please.
bashy is offline  
Old 13th January 2009, 01:48   #225
DrO
 
Join Date: Sep 2003
Posts: 27,873
edit @ 14:30
link removed as site is now running

--------------

<link removed> and looks like it's a temporary issue with the site as ftp is still working for it.

-daz
DrO is offline  
Old 19th April 2009, 22:30   #226
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist File Remover v2.5 Beta 1
  • Made this 5.34+ compatible (so shouldn't set the taskbar to ??? when playing unicode related files)
  • Updated the language file support to better match with 5.5+ - it still works on an ini file but has a .lng file for the dialogs (if needed in a wlz)
  • Updated a load of common base code (in particular the preferences handling)
  • Moved the preferences pages to be a child off the 'Playlist' preferences page (add plfr_prefs_old=1 into the [Playlist File Remover] section of winamp.ini if you prefer the old location)
  • Added option on the hotkey preferences tab to add the file to be deleted and added into Winamp's bookmark list
  • Added plugin uninstall support
  • Enabling the playlist delete shortcut option will now add an entry on the playlist editor right-click menu
  • Playlist editor delete shortcut now prefers Shift+Alt+Delete but Ctrl+Shift+D will still work
  • Added handling of Winamp 5.3+ for deletion overrides (wouldn't really work with the previous versions due to the unicode changes in 5.3+ clients)
  • Anything else i've forgotten to note down...
get v2.5 Beta 1

Hopefully this will resolve all unicode related issues that were outstanding with the plugin (i know it's taken far too long to get a newer version out, soz). Other than bugs reported with this version, i'll be looking through the older posts in the thread and seeing what else needs to be implemented that i can do in a reasonable timescale to get a final version in the next few weeks. Enjoy (and if you delete files accidentally it's not my fault )

-daz
DrO is offline  
Old 30th April 2009, 21:39   #227
bashy
Junior Member
 
Join Date: May 2005
Posts: 4
DrO thank you for the work on this, just grabbed the new ver and will let you know how it goes.
bashy is offline  
Old 3rd May 2009, 20:26   #228
DrO
 
Join Date: Sep 2003
Posts: 27,873
For the next build of the plugin, there is going to be changes to (at least) the hotkeys support which will allow for in-place setting of the hotkey and also for it to automatically applied in the Global Hotkey's plugin (though things will revert to the previous 'manual' option if you don't allow this plugin to restart winamp when prompted to do so).

There is also some changes going on to the preferences which i hope will make it easier to add additional features in future for hotkey actions and allows me to add some additional 'info' to the prefs page (like the screenshot below):


-daz
DrO is offline  
Old 15th May 2009, 00:52   #229
ljeremias
Junior Member
 
Join Date: Apr 2009
Posts: 2
Problem with Vista /Winamp 5.552

Hi,
I have Vista installed (Portuguese language), and installed Playlist_File_Remover_v2_5_Beta_1
Winamp works fine without it, but when I install the plugin I cannot access the Preferences, winamp just crashes. The debugger says:
Unhandled exception at 0x042c78f0 in winamp.exe: 0xC0000005: Access violation reading location 0x8c000084.

If I remove gen_play_remove.dll from the plugins folder, winamp works well.

I use the same winamp version and the plugin in a XP machine, and have no problems.

Is there any known issue with Vista ? Can you help ?

Thanks
ljeremias is offline  
Old 15th May 2009, 15:14   #230
retroman
Junior Member
 
Join Date: May 2007
Location: New Jersey, USA
Posts: 43
2.5 Beta 1 Install Fails on Vista

I am unable to install Playlist File Remover v2.5 Beta 1 on my Vista Home Basic (SP1) system. After clicking on the exe file, a command prompt window flashes briefly (no text visible). There is no error message, but the DLL does not appear in my Plug-ins folder. There is no new entry in the Preferences dialog.

I tried turning off my AV program and running the Beta 1 exe file as administrator, with no luck. It's almost as if Beta 1 doesn't detect my Winamp 5.552 Pro installation.

The only unusual thing about my installation is that it is in C:\Winamp rather than in Program Files. I had to install it there because some pre-Vista plug-ins were blocked from writing to their ini files under Program Files, and (in this case) virtualization did not work.

Thank you for giving us so many plug-ins, DrO, and I hope there is way around this glitch!

Doug M. in NJ

Doug M. in NJ
retroman is offline  
Old 16th May 2009, 12:30   #231
DrO
 
Join Date: Sep 2003
Posts: 27,873
ljeremias: i'll have to have a check out of things though i think it's very likely due to needing a newer build of the gen_jumpex.dll due to a mass of changes in my code handling for the preferences (which is shared across a number of my plugins). will check against things and see if i can improve compatability with older versions.

retroman: that's strange since i'm not able to reproduce that on my Vista64 install. if i was you i'd try redownloading the installer again and making sure that it's valid (the command prompt window makes me think it's a corrupted download). you can even check the installer with 7zip to see if it will allow you to look in the installer (is a good and quick way i find to check that the installer is valid).

-daz
DrO is offline  
Old 16th May 2009, 21:49   #232
retroman
Junior Member
 
Join Date: May 2007
Location: New Jersey, USA
Posts: 43
Installed OK but crashing

Thank you for the prompt response. The previous download was 29 kb, but the new one is 59 kb. This one does appear to install properly and the DLL appears in the Plugins folder. However, on attempting to open the Winamp Preferences dialog, a crash occurs:

Problem signature:
Problem Event Name: APPCRASH
Application Name: winamp.exe
Application Version: 5.5.5.2460
Application Timestamp: 49ef5b54
Fault Module Name: gen_play_remove.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 49eb9677
Exception Code: c0000005
Exception Offset: 000078f0
OS Version: 6.0.6001.2.1.0.768.2
Locale ID: 1033
Additional Information 1: 1d0d
Additional Information 2: 71bdbb801d95257da83b5e2b65cc7c04
Additional Information 3: e51c
Additional Information 4: d97c1237000ec98c6888b5e73cb5060f


At this point I don't have a clue. To stop the crash, I had to remove the DLL from the Plugins folder. I tried a clean reinstall of Winamp and Beta 1, with no change. My OS is Vista Home Basic SP1, x86, with UAC on.

Doug M. in NJ
retroman is offline  
Old 16th May 2009, 23:25   #233
DrO
 
Join Date: Sep 2003
Posts: 27,873
i think it's the same issue as ljeremias is seeing (the crash offset is the same). it's going to take me a few days to see what i can do to work around the issue and will post back/pm test builds as needed.

-daz
DrO is offline  
Old 30th May 2009, 11:16   #234
supernova777
Junior Member
 
Join Date: Apr 2009
Posts: 23
hey dro just touchin bass with u man did u get a chance to implement what we were discussing in the other thread re: moving files?
supernova777 is offline  
Old 31st May 2009, 22:37   #235
DrO
 
Join Date: Sep 2003
Posts: 27,873
just haven't had the time due to trying to keep hold onto my real life job (and sort of still am from the fallout of that) so really can't say when i'm going to get round to connecting the ui changes upto the internal logic.

-daz
DrO is offline  
Old 23rd June 2009, 13:06   #236
Antaeras
Junior Member
 
Join Date: Feb 2003
Location: Wellington, New Zealand
Posts: 31
Send a message via ICQ to Antaeras
crash

I'm getting that same crash when opening Preferences. Winamp 5.551

test everything. hold on to the good.
Antaeras is offline  
Old 24th June 2009, 22:32   #237
Joe Danski
Junior Member
 
Join Date: Sep 2007
Posts: 7
DrO: will this pluin also take care of files changing locations. Say I move all my files from c: to e:, how can I link the existing ML to the new location (and keep all playcounts and ratings of course)

Note that the trick with export ML, edit xml, import edited xml doesn't seem to work: I miss files and some tags do not come over...
Joe Danski is offline  
Old 5th August 2009, 23:11   #238
Mersine
Junior Member
 
Join Date: Aug 2009
Posts: 1
I'm getting the crash to preferences as well.
Mersine is offline  
Old 11th August 2009, 21:57   #239
DrO
 
Join Date: Sep 2003
Posts: 27,873
Joe Danski: the plugin will eventually be upgraded to attempt to inform the library of changes to hopefully keep things in check but that is still further down the todo list at the moment.

@people experiencing the preference crashes: i'm working with koopatrooper to try and track down the issue but it's going to take a while with time/commitment issues. so i've not forgotten, just not had the time/means to get it resolved (sorry)

-daz
DrO is offline  
Old 16th August 2009, 23:58   #240
DrO
 
Join Date: Sep 2003
Posts: 27,873
@people experiencing the preference crashes: it looks like i've fixed the bug (missing a bounds check on a variable that was causing memory corruption under certain Winamp configurations) and just need to finish a few things in the code changed since the first beta so it is safe to use (as at the moment some of the new code isn't correctly checking filepaths to ensure it doesn't move/delete files instead of copying them).

-daz
DrO is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump