Old 4th November 2005, 13:14   #1
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Relay question for the pros...

Every once in a while, there's a momentary loss of connectivity between my source SHOUTcast server and my relaying SHOUTcast server. The drop lasts about a second.

But the relaying server takes 30 seconds before it tries to reconnect to the source DNAS. I've looked for a way to change this to a shorter time, but have had no luck. Am I screwed? Is it hard-coded?

If yes, any other suggestions? My listeners don't get kicked, but they're treated to 30 seconds of elevator music (backup file) on the relay server while it waits to reconnect to the source DNAS and I'd like to make that go away.

Anyone?

Thanks
dotme is offline   Reply With Quote
Old 5th November 2005, 04:37   #2
ravetrax
Major Dude
 
ravetrax's Avatar
 
Join Date: Apr 2003
Location: Clearwater, FL ~~~~~~~~~~~~~~~ My name is Rava www.ravetrax.com
Posts: 541
Send a message via ICQ to ravetrax Send a message via AIM to ravetrax Send a message via Yahoo to ravetrax
this happens to us too at times... i don't have a backup file set, so it sometimes loops, but most of the time it is never noticed... i have even tested this, the lower the botrate, the more the server has in its buffer and the less noitceable it is.

however, have you tried to lower the amount of time that your server drops connection?

; AutoDumpSourceTime specifies how long, in seconds, the source stream is
; allowed to be idle before the server disconnects it. 0 will let the source
; stream idle indefinately before disconnecting. The default is 30.
AutoDumpSourceTime=30

maybe try setting it to something lower?

Echo34 - A music related irc network for the socially challenged. [ website | chat now ]

Stream Solutions - The next level of Shoutcast server hosting! [ website | forums ]

RaveTrax - Its not a state of mind, Its a way of life. [ website | forums | chatroom ]
» Gen2 A/V Streams - NSV Video [vp6.2 & 64k aacPlus v2] - 64k aacPlus v2 - 24k aacPlus v2
» AMPX Player - Web based player that plays ALL streams! [Audio & Audio/Video]
» Other Streams - 160k MP3 - 64k MP3 - 24k MP3
ravetrax is offline   Reply With Quote
Old 5th November 2005, 13:43   #3
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Hi ravetrax - thanks for the response

Yeah - I played with that. Set to zero, it never drops the source... what happens then is that the 1 or 2 second outage kills the relay and it never tries to reconnect. So I upped that setting to 5 seconds. Now, 5 seconds after the outage, it does disconnect the source. That's excellent. Except that it's 30 seconds after that disconnect before it reconnects.

I think you're right about listeners not noticing, and this only happens maybe once every 36 hours - I'd just like to see if I can reduce that 30 second delay. I'm beginning to think it's not possible.

Does anyone know if increasing the buffer size in the relay server will help? Weekends are quiet for my station (not that I'm that busy on weekdays...lol) so I might try a few tests of my own. I'll post back if I find a solution.
dotme is offline   Reply With Quote
Old 8th November 2005, 20:00   #4
ravetrax
Major Dude
 
ravetrax's Avatar
 
Join Date: Apr 2003
Location: Clearwater, FL ~~~~~~~~~~~~~~~ My name is Rava www.ravetrax.com
Posts: 541
Send a message via ICQ to ravetrax Send a message via AIM to ravetrax Send a message via Yahoo to ravetrax
hum... not sure then.

Echo34 - A music related irc network for the socially challenged. [ website | chat now ]

Stream Solutions - The next level of Shoutcast server hosting! [ website | forums ]

RaveTrax - Its not a state of mind, Its a way of life. [ website | forums | chatroom ]
» Gen2 A/V Streams - NSV Video [vp6.2 & 64k aacPlus v2] - 64k aacPlus v2 - 24k aacPlus v2
» AMPX Player - Web based player that plays ALL streams! [Audio & Audio/Video]
» Other Streams - 160k MP3 - 64k MP3 - 24k MP3
ravetrax is offline   Reply With Quote
Old 9th November 2005, 02:06   #5
chuckeh
SHOUTcast Freak
 
chuckeh's Avatar
 
Join Date: Jun 2004
Location: NRW, Germany
Posts: 323
Thanks dotme for that question and thanks ravetrax for the answer. I have also often asked myself that damn question and I will test it soon, if it works better.
chuckeh is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump