Old 20th November 2003, 00:17   #1
Dazog
Moderator Alumni
 
Join Date: Jun 2002
Posts: 418
Known Winamp 5 Bugs (read this before posting)


List of Winamp 5.6x Known Bugs - as of Dec 2013

Any threads started in this forum which report known bugs will be locked or deleted.

Note: Some minor bugs are listed in the internal bugtracker but not listed here.


KNOWN BUGS / ISSUES:

1. For anyone experiencing issues with the Milkdrop v2.23 vis plugin in v5.6-5.601, or v2.24 in 5.62, or v2.25c in 5.64+,
Milkdrop v2.2 from v5.58 is still available.

2. 'Animate video/vis drawer' is broken in Winamp Modern skin

3. Playlist Generator crashes during scan or Auto-Tag crashes on some files:
We need to update to the latest Gracenote SDK. Big job. Sorry :-(


KNOWN GLITCHES (Bugs? Or Unimplemented Features?)

1. Autotagger might return wrong results for some tracks if songs are not in the online Gracenote database.
Alas, there's not much that we can do about this....

2. in_wave v3.x doesn't support riff-wav's (ie. mp3 with wav header, or mp3 files that have been renamed with the .wav extension) or any codecs not supported by libsndfile library (eg. dsp truespeech or aud) *
Known Workarounds (choose one method only, #1 recommended):
1. Install the Nullsoft Waveform Wrapper plugin, by DrO from the Winamp Essentials Pack. Problem solved (more info).
2. Use the DirectShow Decoder (in_dshow) for WAV Support instead of in_wave | info (no 24bit output or transcoding support).
3. Use old in_wave from 5.13 instead (no support for multiuser profile setups, distortion with 32bit float wav playback).
4. If they are riff-wav's with embedded mp3 or mp3 files that have been (wrongly) renamed with the .wav extension, rename them back from *.wav to *.mp3 and let in_mp3.dll decode them instead.

_______________________________________________________________


Temp Section: 5.58-5.6x-specific issues/regressions

-[ml_playlists] Relative paths broken when using 'Import Active Playlist'

-[in_mp4] Some Hi-Res/HD h.264/mp4 videos not playing in Winamp Pro (audio-only, no video)

-[video] Support for multi-audio tracks broken in 5.57-5.6x

-[winamp] Using "Reset" button in 5.66x to clear history in Open URL dialog causes newer URLs not to be remembered

-[in_mp3] Some mp3 files cause 5.666 build 3516 to crash. Use in_mp3 from build 3512 instead (installer also available) *

-[notifier] Weird black pixels on corners of Bento & Modern skin notifier. Fixed png files available here *

-[gen_tray] Preferences window doesn't show the currently used Icon Pack in the dropdown list, always shows 'Standard Icon Pack' instead


_______________________________________________________________


Known Jump To File Extra (gen_jumpex.dll) regressions/bugs

JTF dialog not remembering skinned window setting inbetween Winamp sessions (fixed in v1.33) **


_______________________________________________________________


Lang Pack Bugs / Updates


_______________________________________________________________


Legend
* = Fixed via update patch
** = Fixed in latest JTFE internal/dev build
* = Use Known Workaround


_______________________________________________________________

{ Maintained by DJ Egg : Last updated 13th Dec 2013 - Egg }
_______________________________________________________________


Last edited by Dazog; 1st August 2004 at 00:07.
Dazog is offline  
Old 1st June 2005, 17:17   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,767
ARCHIVES

THESE WERE 2.9x/5.x KNOWN BUGS, FIXED IN WINAMP 5.05 to 5.6x

5.5x-5.6x bugs - all fixed in 5.6-5.666
-Enqueue from Explorer acting as Enqueue & Play (5.66-specific) (info / workaround)
-Some old input plugins (in_qt, in_vgm from chipamp, etc) crashing Winamp (5.66-specific)
-[ml_local] Unicode characters in ML Search not displaying/remembered correctly when 'Remember search filters' option enabled (5.66)
-Sporadic crashes when importing local library in 5.64
-[in_wave] Custom mldb info reset after using View File Info (Alt+3)
-[ml_playlists] Crash on drag+drop files from one ml playlist to another
-[playlist] Relative paths broken when filename is already relative
-[vis_milkdrop] Broken presets editor in v2.21 (unicode/font related)
-Select All (Ctrl+A) not working in JTFE window -> Manage Mode
-JTFE: Broken/Erratic behaviour with Move After Current feature
-Media Library Prefs pages messed up with French lang pack
-[pmp_ipod] Files not showing on some ipod models after sync & eject

5.58-specific bugs - all fixed in 5.581
-CD Drives not appearing in ML tree if Winamp was previously closed with ML not-visible
-pmp_android settings not being saved
-Crash when trying to checkmark "Add to Winamp's Bookmarks" under "Folder Context Menu" in Prefs -> Shell Options

5.57x-specific bugs - all fixed in 5.58
-Rating lost when updating mp3 file info
-Notifier not showing when using keyboard's multimedia keys

5.57-specific bugs - all fixed in 5.572
-Can't unassociate extensions via Prefs -> File Types
-EasyMove broken for classic video window
-Crashing on consecutive videos with different height but same width
-Crashing on (corrupt) AVI files with missing RIFF header or when seektable indexes are in wrong place
-Ghost JTF dialog appears when restarting Winamp in a minimized state with a modern skin active

5.5x-specific bugs - all fixed in 5.57
-Some presets don't work or crash with AVS v2.82
-Crash in in_mod.dll when trying to add some .s3m files to playlist or ml
-Remove Missing Files broken for Local Media rescan
-Elevator issues on Vista/Win7 (m3u & other file associations / Pro reg key invalid)

5.5x-specific bugs - all fixed in 5.55
-New version check can't be disabled when anon stats is enabled (in General Prefs)
-[in_mp4] Genre field not saving when transcoding, eg. flac to m4a (info)
-[in_mp4] Long hangs on slow network drives (info)
-[ml_local] Broken 'Create Playlist' button
-[ml_local] Remove missing files broken with some older/corrupt databases
-[gen_jumpex] The JTFE items in the Playlist's 'Send To' menu (Add to Queue, etc) don't work
-[gen_jumpex] Playlist paths change to all lower-case after using 'Remove Duplicate Entries'
-[gen_jumpex] First enqueued item in list repeating when using the B (Next Track) hotkey
-[gen_jumpex] Shell Options broken (Enqueue+Play, Remove shell menus, etc) (info)

5.5x-specific bugs - all fixed in 5.541
- ML sometimes appears behind other Winamp windows in Winamp Modern skin
- AlbumArt icon background selection glitch in Local Media views
- Last item cut off when scrolling to bottom of an AlbumArt pane in Local Media
- Local Media Info Pane crashes Winamp if Modern Skin Support was unchecked in the Installer Options (due to required but missing dlmgr.w5s file)
- Play & Enqueue reversed in ML Playlists when Enqueue is default action
- Keyboard shortcuts (z,x,c,v,b,etc) not working in Winamp Modern skin Playlist windowshade mode

5.5x-specific bugs - all fixed in 5.54
- Bento skin (doesn't happen with other skins): Drag+Drop from Open/Add Files Dialog to Playlist wipes playlist and plays file instead of just dropping it into place
- Playlist contents are blank when in docked toolbar mode and Winamp is minimized
- Winamp won't restore if minimized whilst Milkdrop & AVS config/about dialogs are open
-Auto-Tag dialog is hidden underneath Winamp when 'always on top' is enabled
- Weird flashing behaviour at startup if Winamp was previously closed whilst minimized to the systray.
- Metadata for ogg vorbis streams no longer shows in View File Info (Alt+3)
- Shift+Enter etc weirdness in ML Playlists
- Multiple "icons" in Alt+Tab when using any non-sui Modern skin and Winamp is minimized to Systray
- Enter/Shift+Enter broken for ml treeview items
- CDDB crash if CD contains per-track Conductor metadata (eg. for Classical CD's)
- All hotkey/accelerator focus issues are known
- 404/Timeout with manual podcast subscriptions under Vista
- Problems with installing new skins on Vista
- Close (Alt+S) etc accelerators not working in JTF dialog

5.5x-specific bugs - all fixed in 5.531
-Bento browser redirecting some url's to Winamp Search
-Bento collapse/expand button bug
-Recent URL's not saving (5.53-specific)
-Total time display of selected tracks in Classic playlist (5.53-specific)
-AOL Radio skipping/buffer issue
-[ml_local] Right-click Play/Enqueue all items issue in 3-pane views
-[ml_playlists] Broken right-click context menu items (5.53-specific)

5.5x-specific bugs - all fixed in 5.53
-Gracenote-powered features (CDDB, Playlist Generator, AutoTagger) might be a bit slow to respond when accessed for for the first time in a Winamp session (caused by reading of local CDDB, and especially noticable with larger cddb.db files). If you still experience this problem, delete the %AppData%\Winamp\Plugins\Gracenote\cddb.db file (make a backup first).
-Editing CDDB genre may still be a bit buggy (eg. Electronica saves as Pop Electronica, or Alt-Metal becomes Nu-Metal).
-Switching between language packs or from/to English (US) can lead to some of the online related media library tree items (effectively ml_orb and ml_online) losing their position and dropping to the bottom of the tree.
-Classic EQ window appears after minimizing a classic skin, restoring it, and then switching to a modern skin and minimizing then restoring it.
-"Play -> Playlist From ML" opens playlist view in the ML instead of playing it.
-Crash when trying to mass Auto-Tag files that aren't in Gracenote database.

5.5x-specific bugs - all fixed in 5.52
-Crash when attempting to play non-existent M4A files
-Crash when clearing existing metadata fields in Vorbis File Info

5.5-specific bugs - all fixed in 5.51
-Delete Art doesn't work in Alt+3 for embedded art
-New CDDB features may be a bit buggy (eg. genre saves with "General" at front)
-Column sorting order is broken for pmp_usb devices (info)
-No 'Burn' button when system IMAPI service is disabled (unconfirmed!) (info)
-MPG videos might display the wrong length in pledit/ml (eg. 1:19 shows as 9:39)
-Collapse/Expand Playlist in Bento skin doesn't respect 'Show Album Art' setting
-Stereo indicator, bitrate & freq don't display in main player area, or Audio is always the active ml view on Winamp restarts with French & Spanish Lang Packs (info)
-ASX Parser converts all stream links in .asx playlists to upper case
-Winamp Setup might reset position of Desktop icons
-Setup: Winamp Agent typo in Registry Run key (wianmpa.exe)
-Winamp/in_mp3 crashing on some mp3's (when playing/adding to playlist, or scanning Watch Folders, or using Auto-Tagger or Playlist Generator, etc) (info
-Shift+Enter hotkey for ML Playlist tree item Plays/Replaces instead of Enqueues (when "Plays selected items" ML setting is active)
-Gracenote/MusicID features (CDDB, Playlist Generator, Auto-Tag) not using Winamp's proxy setting
-Playlist Generator crash when stopping scan before completion or resetting database
-Crash caused by an incompatibilty with spectrum vis and some 3rd-party input plugins (eg. usf, tfmx) (info)
-Global Hotkeys list destroyed when switching language packs
-Local Media views: Last Updated and Album Gain column sort order broken
-Local Media views: Artist column in descending order after sorting by Year
-Winamp won't restore properly, or a weird titlebar appears onscreen if reopening after closing it when minimized to systray
-Media Library is initially blank when restarting Winamp from a minimized state

5.3x-specific bugs - all fixed in 5.5
-Choppy spectrum vis for FLAC files (could be a LibFlac 1.1.4 related bug)
-"Error in Insert" message for some PlaysForSure (P4S) Devices
-Garbage characters when editing filetypes in in_wm config
-Filepaths corrupted when opening Winamp via Explorer context menu under Win2k
-Long filenames/paths corrupted under Win2k/Vista
JTFE (gen_jumpex) bugs:
-Crash/hang or multiple instances trying to open when using Explorer context menus to open multiple files/folders (info)
-Remove Duplicate Entries command in playlist = broken
-Time and queue# disappear in pledit when queuing up tracks longer than 100mins

5.34-specific bugs - all fixed in 5.35
-cddb crash with non-english chars in path to inidir (info) (5.3x bug)
-Horizontal scrollbar in JTF dialog disappears after queuing items
-Gapless CD playback broken with Sonic Engine again
-P4S Devices crashing on sync (info)
-Some mp3's don't display the tracktime in the playlist (info)

5.33-specific bugs - all fixed in 5.34
-Album tag is removed for OGG files when using ml 'edit selected items'
-Total filesize (Gb) missing in local media views
-Duplicate entries in Local Media after rescanning Watch Folders Reindex
-JTFE causes slowness in playlist window when unicode characters present
-JTFE doesn't support/display unicode characters in Jump To File search
-in_flac / msvcp71.dll not found (info & fix) (5.34 build 1273 bug, fixed in b1278)
-ml_pmp "copy to local media" doesn't add files to mldb (5.34 b1273 bug, fixed in b1278)

5.32-specific bugs - all fixed in 5.33
-'Static' in ml playlists instead of total tracks/time display
-Some avs presets don't work properly
-Crash when sorting by ReplayGain columns in local media views
-Local Media column sorting logic broken due to new Disc # column
-Loading folders via playlists broken (again)
JTFE (gen_jumpex) bugs:
-Queue List cleared when drag+dropping files above queued items in pledit
-Playlist entry text disappearing when queuing items under Win9x

5.31-specific bugs - all fixed in 5.32
-Classic skin playlist total time drawing glitch
-Slow load-time with large playlists of remote or network share files
-Docked playlist toolbar mode not remembered
-Silent crash when disabling then re-enabling History view in ml prefs
-Crash when viewing File Info (Alt+3) for dead FLAC links in playlist

5.3-specific bugs - all fixed in 5.31
-Ripping CDs with international characters broken
-Crash on exit after playing an Audio CD (info)
-Updated in_mp3.dll available which fixes a number of 5.3-specific issues (info)
-filereader.w5s missing from installer (breaks thinger icons - info)
-dir loading via playlist files broken
-Logarithmic/Hybrid volume control broken in out_ds config (always uses Linear)
-Remember Last View in Shoutcast Radio config is inverted (serverside issue - info)
-Issue with Unicode titles and %track% in atf when "use library info for playlist title formatting" option is unchecked (info )

5.23/4-specific bugs - all fixed in 5.3
-Winamp closing when coming out of hibernation/standby (jtfe plugin bug)
-Random crashes when editing ID3 tags
-Delay/hang when loading dead stream url's/bookmarks (eg. if server is down)
-Shared ID3v1/v2 tags (eg. Comment/Genre) updates linked
-Titles for streams in stored ml playlists changing from streamtitle to url
-Time display changes to 0:00 when using File Info Editor in ml playlists
-Some MIDI files no longer play (5.24-specific)
-Freezeup when exiting via System Tray icon

5.2.3.669 (7th June) bugs fixed in 5.2.3.672 (8th June)
-Send To from local media to an ml playlist replaces instead of enqueues.
-Fixed ml_playlists.dll available separately here
-(note, fixed ml_playlists is now included in the silently updated 5.23 installer).

5.22-specific bugs - all fixed in 5.23
-Portable Media Player syncing duplicates bug
-Stored ml playlists not being saved/imported
-Imported playlists named by containing dir instead of m3u filename
-Add Folder adds all filetypes (not just all-supported)
-Rt-click Enqueue not working
-Drag & drop folder into ml playlists not working
-Drag & drop file into ml playlists not dropping in correct place
-Dbl-clicking a stored playlist title doesn't follow
-Playback restarts from beginning when editing tags of a currently playing wma file
-Streams ending in .aac extension can't be played

5.2/5.21-specific bugs - all fixed in 5.22
-JTFE (gen_jumpex): 'On end of queue' options broken
-Media Library size/position not remembered when switching from Classic to Modern and back to Classic skin (gen_jumpex.dll bug)
-Modern skin playlist in docked toolbar mode not remembered (gen_jumpex.dll bug)
-[in_wave] Error: "Can't open decoder" when trying to burn .wav files
(temp fix is to switch back to in_wave.dll from v5.13)
-[in_wave] Locking files (Wav's can't be renamed/moved/deleted)
-Clicking Next in fullscreen OSD for AVI/MPG files acts as clicking Next twice
-Hang when using $abbr() in ATF string (info)
-CD Ripping not creating artist/album metadata under Win9x (info)
-Stop With Fadeout broken with WaveOut Output

5.2-specific bugs - all fixed in 5.21
-[pmp_p4s.dll] Entry Point Not Found in DRMClien.DLL startup error (fix)
-[in_vorbis] No Artist metadata in stream titles (shows Title only)
-Keyboard shortcuts don't work from video window
-[in_mp3] Wordwrap disabled in Info Editor Comments field

5.13-specific bugs - all fixed in 5.2
-Changes made w/ Windows Media Attribute Editor not updating in ML/Playlist (info)
-Video Options from video window right-click context menu = broken

5.112-specific bugs - all fixed in 5.12
-Hang after hiding main window and restarting winamp (info)

5.111-specific bugs - all fixed in 5.112
-Fixed: Crash when burning with EQ on, or with any DSP/Effects plugin enabled
-Fixed: [in_mp3] id3v1->id3v2 track# copy glitch
-Fixed: [in_mp3] crash when playing mp2 files with 'fast layer eq 1/2' enabled
-Fixed: [out_ds] Volume shows as "f dB/f dB" in config > Status tab

5.11-specific bugs - all fixed in 5.111
-AutoLoad EQ Presets crash Winamp (info)
-ATF : $upper(%artist%) crash with non-english characters (info)
-Shoutcast Station Info crash / Ad blocker app conflict (info)
-Crash on Next after clearing playlist (info)
-MIDI Lyrics window broken (info)
-proxy settings ignored if "port 80 only selected" (info)

5.1-specific bugs - all fixed in 5.11
-Crash with multichannel aacPlus files with EQ on (info)
-Internet Connectivity (cddb, online media, etc) not working for dialup modem users (need to select 'always connected' in prefs instead) (info)
-Windows shutdown error/freeze caused by ml_wire.dll (info)
-EQ dB value changes not showing in main window (classic skin) (info)
-ml_wire always creates My Music dir (info)
-in_cdda.dll crashes when ripping cd without sonic engine (info)
-msvcp60.dll linked dynamically in in_cdda, in_mp3, ml_predixis, enc_wma (needs to be static link for older OS'es without msvcp60) (info)
-After pause/unpause, WMA plays for a few seconds then stops (info)
-out_ds > 'fade on seek' always enabled after winamp restart (info)
-Predixis MusicMagic plugin: Play/Enqueue actions reversed when Enqueue is set as default ML action (info)
-SHOUTcast streams removed from playlist on Winamp exit (Browser-related) *

5.094-specific bugs - all fixed in 5.1
-Draw issues with Online Media vids/sidecar when using custom scaling

5.093-specific bugs - all fixed in 5.094
-[in_wm] can't choose different device in out_ds with multiple instances
-[in_wm] out_ds fade on start custom value in effect when not checked

5.092-specific bugs - all fixed in 5.093
-Fullscreen video OSD doesn't reappear after using Pause (info)
-OSD stays onscreen in DirectDraw Mode (ie. with Overlay off)
-Vis data for in_mod (and possibly other input plugins) broken (in_wm related)
-msvcp60.dll linked dynamically in in_mp4
-Drag+drop from external apps seems to be broken... (info)
-Open Files dialog not accessible with 'always on top' enabled (info)
-Crossfade "fade on start" feature not working - in_wm related (info)
-Freeze when switching audio tracks on videos with multi-audio streams
-Custom scale video window resizing when exiting fullscreen (info)

5.091-specific bugs - all fixed in 5.092
-High cpu and slow shutdown when closing Winamp with large playlist loaded (info)
-Large playlists take longer to save (related to above)
-msvcp60.dll not found error on win2k/9x systems (was linked dynamically in in_wm.dll)

5.09-specific bugs - all fixed in 5.091
-Drag+Drop from Explorer to ML broken
-Freeze/crash with seekbar in fullscreen vid
-Broken vid/vis multi-monitor support
-WMCreateReader Failed error when scanning/adding WMA Files in ML
-Edit File Info for some WMA's broken
-Slower startup due to dynamic Online Media check
-Issues with fullscreen videos (info)
-Now Playing broken
-Drag+drop from IE to playlist broken
-Drag+drop from Add Files dialog to playlist broken
-Ctrl+B (End of List) crash
-Vid window Easy Move broken (classic skins)
-Catagory typo in AOL Video view (category)
___________________________________________________________

GENERAL FIXES

-Winamp 5.55 libsndfile.dll update patch (More Info) (fixed in 5.551)

-[pmp_p4s] Crash when deleting songs from P4S devices (fixed in 5.55)

-Ultravox streaming metadata stack overflow security vulnerability (fixed in 5.52)

-Transcoding of floating point WAV files produces silence (fixed in 5.52)

-TV button in video window does nothing (fixed in 5.5)

-Some ASX playlists/streams don't load or work properly (fixed in 5.5)

-MP4 buffer overflow vulnerabilty (in_mp4.dll / v5.2-5.34) (Info & Fix)

-MusicIP Mix (fka: Predixis MusicMagic) plugin uses 100% cpu during processing (Removed in 5.35)

-Memory leak when adding .AAC files to playlist/ml (Info) (fixed in 5.34)

-CD Burning broken under Win98/ME (5.22-5.31 Sonic Engine bug) (fixed in 5.32)

-Memory leak when switching between 2 or more large ml playlists (fixed in 5.31)

-ml_local.dll breaks 'always on top' for other programs (fixed in 5.31)

-There is no disc in the drive error (pmp_ipod/usb/p4s conflict) (info) (fixed in 5.31)

-Some 3rd-party modern skins show weird green scrollbars or 'image not found' | More info here and here. (fixed in 5.31)

-Winamp 2.x/5.x doesn't read ID3v2 tags in streaming mp3's (Implemented in 5.3)

-Seeking m4a files with rt-cursor goes beyond end of song/counter (fixed in 5.23)

-Seeking wma files with rt-cursor goes beyond end of song/counter (fixed in 5.23)

-[ml_wire] Some podcast subscriptions only list 1 entry (fixed in 5.23)

-[in_mp3] doesn't play high bitrate MPEG-2.5 Layer 3 files (info) (fixed in 5.22)

-Media Library > Playlists: root view slowness bug (fixed in 5.22)

-Delete key not working in Online Services or SC Wire search (fixed in 5.22)

-Seeking m4a files with rt-cursor goes beyond end of song/counter (fixed in 5.22)

-Memory leak w/ Winamp Modern skin playlist in winshade mode (info) (fixed in 5.2)

-High cpu usage when stopping/pausing music whilst Milkdrop is running (fixed in 5.2)

-GDI Object leak with Current Skin prefs page (info) (fixed in 5.2)

-32bit float point WAV playback distortion (info) (fixed in 5.2)

-Winamp Modern skin > Main window > File menu > Internet TV/Radio = broken
(goes to AOL Radio/Video views instead) (fixed in 5.2)

-JTFE 0.96ff - hitting J hotkey twice causes ghost JTF skinned window to appear (occurs only when "Skin JTF..." is unchecked in Prefs) (fixed in 5.2)

-Known issues with in_vorbis.dll can be found here (fixed in 5.2)

-in_mp3 Info Editor shows aacPlus as LC-AAC 22050Hz (instead of HE-AAC 44.1KHz) (fixed in 5.2)

-m3u playlist handling security vulnerability (fixed in 5.2)

-in_mp3 Extremely Critical Buffer Overflow Security Vulnerability (info) (fixed in 5.13)

-mms:// video streams are still broken with in_dshow, if filename.ext isn't specified at the end of the url, eg. bbcworld or maniatv
(just enters endless buffer loop and never plays). (fixed in 5.12)

-splashscreen freezes when double-clicking agent icon (info) (fixed in 5.12)

-video window scaling bug (5.09-specific and later) (info) (fixed in 5.12)

-Seeking may no longer work with some ASF/WMV videos (fixed in 5.11)

-Manual Playlist Advance makes Winamp Videos play only intro ads (fixed in 5.11)

-Media Library crash on user profiles with no write access privileges (fixed in 5.11)

-out_ds > config > status tab > copy function broken (fixed in 5.1)

-First few seconds of Audio CD tracks repeated (Sonic Engine / out_ds bug) (info) (fixed in 5.1)

-Modern Skins > "Dock windows at" setting not remembered if unchecked, and closing/reopening winamp (needs checking/unchecking again to take effect).
<"Dock Windows" value="*"> not being saved to studio.xnf (fixed in 5.094)

-Large Playlist shuffle bug (info) (fixed in 5.094)

-[gen_ml] issues with # in album name (info) (fixed in 5.094)

-[gen_ml] sort by 'albums' or 'tracks' not remembered in Artist pane (info) (fixed in 5.094)

-JTFE plugin not working when WinXP/2003 DEP is enabled for all programs (info) (fixed in 5.094)

-Editing tags of M4A files created with iTunes causes corruption (info/workarounds) (fixed in 5.094)

-Winamp doesn't support url's longer than 260 characters (info) (fixed in 5.094)

-Incorrect file length/time reported on long mp3's (300-600mins long) (info) (fixed in 5.094)

-Artist name with parentheses (brackets) still causes each track to be listed as a separate artist in ML > Artist/Album views. Issue with "()" in Album name is also known. [info | 2] (fixed in 5.093)

-Album title with ellipsis (...) at end causes "error ripping track/can't open destination file" error when trying to rip said CD [info] (fixed in 5.093)

-VP6.2 videos still play upside-down in 5.05-5.09 (info) (fixed in 5.093)

-ML Playlists buttons stealing focus from listview (eg. Sel > Select All) (fixed in 5.093)

-Winamp doesn't return volume to level when closed with 'mute' enabled
..(mute.maki fix: if closed with mute 'on', winamp now reopens with mute still 'on',
.. and toggling mute 'off' restores previous volume level)
(fixed in 5.093)

-Memory leak with paused WMA (fixed in 5.091)

-Hitting Eject then dragging a file in Explorer to any folder causes winamp to go crazy (fixed in 5.09)

-Seeking with some mp3 streams is broken as from v5.06+ [info] (fixed in 5.08c)

-No module playback without midi support (read_file.dll is also required by in_mod, but isn't installed if midi support is unchecked). (fixed in 5.07)

-Shuffle Bug From Winamp 2/3 still around [info] (fixed in 5.06)

-Seekbar is seekable with nonseeking wmv videos, causing video to freeze (fixed in 5.06)

-Crash in gen_ml when right clicking songticker with empty playlist (fixed in 5.06)

-Jump to File Extra 0.96c plugin bug with Playlist Entry dialog appearing when using Q hotkey (fixed in 5.06 / JTFE v0.96ff)

-Rating from main window > songticker not updating/working (fixed in 5.06)

5.06 specific bugs

-Broken proxy support (always uses IE proxy setting, even if proxy field in winamp is blank) - (fixed in 5.07)

-in_nsv and in_mp3 do not work/appear under Win95 (fixed in 5.07)


THESE WERE 2.9x/5.0x KNOWN BUGS, FIXED IN WINAMP 5.04

-Repeat Track not working in modern winshade mode

-Proxy authentication setting not remembered when changing streams (info)

-Docked toolbar scaling bug [info]

-Settings not saved on close when using docked pledit toolbar

-Notifier not fading with "link all windows.." enabled

-Issues with "apostrophes" and (brackets) in library metadata [info | 2]

-Gap in Modern skin main window when opening config drawer (with attached vid/vis drawer closed), and stretching window out horizontally.

-CD Ripper playlist generated even with option unchecked

-Zero-byte .mp3 files crash winamp 5.03 with in_mp3 from update patch.

-broken mms:// streaming support with in_dshow
Note: only affects mms:// streams which don't specify a filename and extension at the end of the url,
and if in_dshow is disabled then in_wm handles them properly (mms://stream/.wma)
(Note: mms audio stream bug is fixed in 5.04, but not mms video streams)
(Example 1 | Example 2)

-Spectrum analyzer dies ~7 mins into an Audio CD track [more info]

-Tracklength/seekbar issue with WMA files longer than 7:09 (v5.03 only)

-in_wm.dll v2.0 incompatibilty issue (crash) with wmvcore.dll v8.x and earlier. (info)

-Media Library delay issue in 5.02 and 5.03...
Noticeable lag when doubleclicking playlist/view items with "play all.." checkmarked in Prefs -> Media Library -> Library Options.
Caused by bug in gen_hotkeys.dll as reported and diagnozed here.

-Constant accessing of winamp.ini (related to above)

-Corrupt id3v2 tags causing Winamp to use large amount of memory

-Inaccurate bitrate calculation on some mp3's


_____________________________________



THESE WERE 2.9x, 5.0 AND 5.01 BUGS, FIXED IN 5.02 AND 5.03

-Classic skins: Playlist/video windows visible on reopening Winamp after closing in minimized state. Note: Main, EQ, and ML windows are correctly minimized & clicking taskbar icon restores them. Tempfix (unzip to: Winamp\Plugins) [fixed in 5.03]

(note: bug still exists if setting shortcut to "run minimized" - fixed in 5.04)

-Vorbis plugin does not display unicode characters [tempfix] [fixed in 5.02]

-Modern Skin pledit winshade bug - keyboard shortcuts linked to main window menus instead of pledit menus [fixed in 5.02]

-Allow Multiple Instances appears to be broken, ie. playing files from Explorer context menus = opening in same instance of Winamp, instead of in new instance (update: apparently, this is now expected behaviour, not a bug - further info)


Full list of fixed bugs

_____________________________________


Things what not to report:

NOT BUGS:

1) Some old 3rd-party Winamp3 skins don't work at all or make Winamp 5 crash
(not our problem, contact said 3rd-party skin author instead)

2) Some 3rd-party general/input plugins mess up the main menus, or don't work
(not our problem, contact said 3rd-party plugin author instead)

3) Anything else caused by any 3rd-party plugin (some might need updating).

4) Multimedia Keyboard buttons not working. Inform the keyboard manufacturer and ask for updated drivers.

5) Forced crashes, such as: rapidly clicking video/vis buttons/tabs causes freeze/crash

6) Unimplemented features. Feature requests posted here will be ignored/deleted.


_______________________________________________________________________________
Anchors: known glitch regress fixed 557 555 554 553 552 551...52 513 5112...general notreport notbugs

_______________________________________________________________________________
DJ Egg is offline  
Closed Thread
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump