Old 11th April 2017, 23:08   #1
alecs26
Junior Member
 
Join Date: Apr 2017
Posts: 4
Shortcut doesn't work

Hello,

My NSIS script installs some shortcuts (desktop and start menu). It works well on several computers I tested.
code:
CreateShortCut "$SMPROGRAMS\AssystMouseBeta\AssystMouseBeta.lnk" "$INSTDIR\AssystMouseBetaV0R1.exe"
CreateShortCut "$DESKTOP\AssystMouseBeta.lnk" "$INSTDIR\AssystMouseBetaV0R1.exe"



However, on some computers, none of the shortcut is created. The thing they have in common is that I am not admin on these computers. When I run the installer, the administrator must give his user name and password.

Thank you very much,

Alex
alecs26 is offline   Reply With Quote
Old 12th April 2017, 02:19   #2
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,588
Are you using SetShellVarContext in your script?

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Old 12th April 2017, 09:38   #3
alecs26
Junior Member
 
Join Date: Apr 2017
Posts: 4
Thanks for your answer.
I am a newbie with NSIS and I used HM NIS Edit to create the script.

There is no SetShellVarContext in the script and I don't know what it does !

Thanks,

Alex
alecs26 is offline   Reply With Quote
Old 15th April 2017, 03:15   #4
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,588
You could use Process Monitor to see where it tries to write and why it fails. Only Administrators can write to the shared startmenu folder in ProgramData.

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Tags
shortcut

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump