Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 30th January 2008, 15:24   #1
Shock
Junior Member
 
Join Date: Feb 2005
Location: Japan
Posts: 38
Winamp Crash with MTP (Plays for Sure) device and WMP11

I've seen several threads asking for help about this and it has happened to me. Here's how it works:

If you have Windows Media Player 11 (and the SDK, it seems) installed on your system and also Winamp, plugging in an MTP device will crash Winamp (whether plugging in before or after starting Winamp, doesn't make a difference). Uninstalling WMP11 and the SDK will alleviate the problem, but it would be nice to have the two play nicely.

I have confirmed this with an iRiver Clix2, and have seen examples in the forum with Toshiba GigaBeat and others.
Shock is offline   Reply With Quote
Old 30th January 2008, 15:31   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
Maybe try using HijackThis to disable WMP11's Portable Device management service:

O21 - SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - C:\WINDOWS\system32\WPDShServiceObj.dll

At a guess, a conflict arises when more than one application tries to manage a portable device at the same time - and seeing as WMP11's service is already loaded, then this makes Winamp be the one to suffer.
DJ Egg is offline   Reply With Quote
Old 30th January 2008, 15:34   #3
Shock
Junior Member
 
Join Date: Feb 2005
Location: Japan
Posts: 38
Thanks! Will try it out and see what happens.

I'm sure it's not high on any priority lists but just thought it should be reported as a bug which might need attention sometime...
Shock is offline   Reply With Quote
Old 30th January 2008, 20:24   #4
Shock
Junior Member
 
Join Date: Feb 2005
Location: Japan
Posts: 38
UPDATE:

I can't find that service using HijackThis. I tried scanning with/without the device plugged in, with WMP11 open and closed...

I'm surviving by simply leaving WMP11 uninstalled, but I think it should be something the developers are aware of. Unfixed, it basically means that owners of a Zune (uses WMP11 engine) and another MTP-based device can't sync them on the same computer.

Thanks!
Shock is offline   Reply With Quote
Old 31st January 2008, 21:44   #5
Laogeodritt
Junior Member
 
Join Date: Nov 2005
Location: Quebec, Canada
Posts: 15
I'd like to note that this problem has occurred for me, as well. I did not have WMP11 nor the SDK installed, per se; however, one piece of software that "came with" my MP3 player installed a WMP11 Runtime.

This problem occurred with my Sansa e280v2.

Details can be found in my bug report in the Plugin bug reports topic: http://forums.winamp.com/showthread....25#post2292925
...as well as in the topic I posted in Tech Support: http://forums.winamp.com/showthread....hreadid=284027
Laogeodritt is offline   Reply With Quote
Old 20th February 2008, 04:47   #6
LoopyLyle
Junior Member
 
Join Date: Feb 2008
Posts: 1
I would also like to report WinAmp crashing after connecting my Ibiza Rhapsody player. The crash happens immediately after the player has been scanned and its playlists are displayed under the "Portables" header.

The Ibiza is a MTP PlaysForSure device. My computer is a WindowsXP box with SP2 and all the latest patches, etc. I also have WMP11 installed (which I don't wish to uninstall).

This is a very serious problem for me, but I have found nothing in the forums to suggest it is being worked on. Can someone let me know if this is on WinAmp's fix list?

Thanks.
LoopyLyle is offline   Reply With Quote
Old 3rd February 2009, 18:51   #7
LtRimmer
Junior Member
 
Join Date: Jan 2009
Posts: 1
WMP11

I also had the same issue with WMP11 and WINAMP, I am now having to use Media Monkey as this works perfectly. I do however check back now and again to see if it's been fixed as I prefer WINAMP.

The only way I can use WINAMP is to roll back WMP11 to version 10, but this doesn't support Digital Rights Management so I'm stuck with MM.

If anybody could update us when a fix for this may be available, (as other software developers have got it working) it would be greatly appreciated.
LtRimmer is offline   Reply With Quote
Old 3rd February 2009, 18:57   #8
Shock
Junior Member
 
Join Date: Feb 2005
Location: Japan
Posts: 38
Don't hold your breath :(

This seems to be one of those problems that inevitably gets shoved to the end of the "to do" list. That, or it is completely ignored.

I have been following this problem for a long time now (two years maybe?) and nothing has ever moved on it. I too prefer Winamp but have been forced to use MM and even WMP to get a proper MTP-based sync with my portable devices.

I guess at this point our best hope is that the entire MTP plugin gets magically rewritten with a new major release of Winamp. Yeah right.
Shock is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump