Old 11th September 2014, 05:23   #1
mjbrown
Senior Member
 
Join Date: Aug 2001
Posts: 114
DNAS 2.4 (Linux) v2 mode failing on FreeBSD

I didn't see a download link for a FreeBSD build of the new 2.4.0 DNAS, so I'm trying to drop in the 32-bit Linux build of 2.4.0 as a replacement for a fully working 2.0.0.29 (FreeBSD build) on FreeBSD 8.4.

On my FBSD system, I run the default kernel with Linux binary emulation enabled, and I have the linux_base-f10 package (Fedora 10 libs) installed. This was sufficient in the past to run the Linux binaries of the 1.9.x DNAS.

So, with this combo, the DSP (2.3.4 in Winamp 5.666) connects OK to the 2.4.0 DNAS in v1.x mode, but fails to fully connect in v2.x mode. (The same DSP can connect fine in v2 mode to the 2.4 DNAS, Win64 build, running on Windows 7.)

The DSP log says:
Cipher Response Received
Disconnecting

The DNAS log says:
SHOUTcast 2 source connection starting.
SHOUTcast 2 source disconnected.


Not much to go on. Did I overlook something?
mjbrown is offline   Reply With Quote
Old 11th September 2014, 10:48   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
its something that appears to be an issue with the Source DSP in that configuration as per a thread in the steaming service sub-forum which we've still got to find a solution for (as we had to get 2.4 released on time).

we dropped the BSD build as covered in the 2.2.2 release thread (around post 20 or something like that).
DrO is offline   Reply With Quote
Old 11th September 2014, 15:33   #3
mjbrown
Senior Member
 
Join Date: Aug 2001
Posts: 114
OK, cool. Let me know if I can help diagnose.
mjbrown is offline   Reply With Quote
Old 15th September 2014, 15:22   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
reason determined -> http://forums.winamp.com/showthread....12#post3008112 with a fix to come soon.
DrO is offline   Reply With Quote
Old 18th September 2014, 21:38   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
pm sent.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump