Old 15th December 2014, 03:50   #1
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
OGG Embeded Album art not showing

Hi guys Im using nullsoft mpeg audio decoder v2.94[Tags v1,v2 enabled] and nullsoft Vorbis Decoder. Currently, my winamp can display embeded album art in mp3 file but not in ogg file. I used mp3tag to add album art. Anyone has any solutions?
kaiteck is offline   Reply With Quote
Old 15th December 2014, 03:53   #2
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Renaming the picture to cover.jpg works but it applies to all ogg files in that folder. I want different album art to display on each individual ogg file.
kaiteck is offline   Reply With Quote
Old 15th December 2014, 04:28   #3
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Update: I synced my ogg to my android poweramp and the album art is displayed properly there. This proved that the problem is within my Winamp. Will be posting my Winamp settinGS.
kaiteck is offline   Reply With Quote
Old 15th December 2014, 05:29   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,827
Hi. As well as attaching your Winamp Info Report log, please could you also provide a download link to a sample ogg file?

Winamp 5.666 build 3516 (patched) with the default Nullsoft Vorbis Decoder v1.77 supports the reading of embedded album art....
DJ Egg is offline   Reply With Quote
Old 15th December 2014, 08:54   #5
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Sample ogg file : https://www.dropbox.com/s/k66rg24xtn...rning.ogg?dl=0
Attached Files
File Type: zip Winamp_Info_Report_12-15-2014.zip (7.7 KB, 119 views)
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:03   #6
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
My Nullsoft Vorbis Decoder is v1.76 Running winamp 5.666 build 3516.
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:09   #7
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,649
Send a message via AIM to MrSinatra
I can confirm that winamp does not display the artwork, but mp3tag does.

Kaiteck, how were these oggs made? were they wma files to start?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th December 2014, 09:13   #8
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
I have no idea. My big brother got it from a game called flyff.
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:28   #9
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Fortunately, it works when I sync it to my poweramp using winamp.

The ogg file is recorded in around year 2004. Whether if it is wma file from the start.. I doubt so, since I got it by extracting the original game.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-12-15-17-17-52.png
Views:	145
Size:	907.3 KB
ID:	51592  
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:30   #10
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Well to answer your question, I didnt convert it from wma to ogg. I got them as ogg files by extracting the original game. But the game maker could have done it which...I highly doubt so.
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:41   #11
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
More ogg samples : https://www.dropbox.com/s/7ba096i6ek...neral.ogg?dl=0

https://www.dropbox.com/s/1dc5jun8jw...arkon.ogg?dl=0

https://www.dropbox.com/s/wfy3be83gf...Music.ogg?dl=0
kaiteck is offline   Reply With Quote
Old 15th December 2014, 09:57   #12
kaiteck
Junior Member
 
Join Date: Jul 2014
Posts: 13
Foobar2000 is able to display its album art!
Problem is within winamp
kaiteck is offline   Reply With Quote
Old 15th December 2014, 11:08   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
it doesn't show in Winamp as it doesn't recognise the recommended METADATA_BLOCK_PICTURE field (as is present in the first sample file). this lack of implementation probably affects all official input plug-ins which have VorbisComment support though i wouldn't know for certain until it's looked into at some point in 2015.
DrO is offline   Reply With Quote
Old 15th December 2014, 13:51   #14
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 694
Quote:
Originally Posted by DJ Egg View Post
... with the default Nullsoft Vorbis Decoder v1.77 ....
Is v1.77 a typo?
I get v1.76 with DrO's patched "redux" installer.

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 26th December 2019, 20:24   #15
TimbreWolf
Member
 
Join Date: Jul 2008
Posts: 56
Quote:
Originally Posted by DrO View Post
it doesn't show in Winamp as it doesn't recognise the recommended METADATA_BLOCK_PICTURE field (as is present in the first sample file). this lack of implementation probably affects all official input plug-ins which have VorbisComment support though i wouldn't know for certain until it's looked into at some point in 2015.
It looks like embedded art in ogg files still isn't displayed by 5.666. Is this fixed in WACUP or 5.8?
TimbreWolf is offline   Reply With Quote
Old 26th December 2019, 21:46   #16
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 760
Quote:
Originally Posted by TimbreWolf View Post
It looks like embedded art in ogg files still isn't displayed by 5.666. Is this fixed in WACUP or 5.8?
Did you see what's new/fixed in 5.8?

Can't speak for Wacup, you could ask in that forum

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp: (Winamp 5.8) is not an ongoing project get wacup

5.8 beta issue quick fix - Install 5.666 (there's no further 5.8 releases)
musicf8 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump