Old 7th April 2008, 14:57   #1
madjerry
Junior Member
 
Join Date: Apr 2008
Posts: 7
MUI problem

Hi,

I'm having some problems with MUI, the problem is that i dont want to have MUI_LANGUAGE here is a part of my script:
; MUI Settings
!define MUI_ABORTWARNING
!define MUI_ICON "${NSISDIR}\Contrib\Graphics\Icons\modern-install.ico"
!define MUI_UNICON "${NSISDIR}\Contrib\Graphics\Icons\modern-uninstall.ico"

!define MUI_HEADERIMAGE
!define MUI_HEADERIMAGE_BITMAP "up.bmp"
!define MUI_HEADERIMAGE_UNBITMAP "up.bmp"
!define MUI_WELCOMEFINISHPAGE_BITMAP "left.bmp"

; Language Selection Dialog Settings
!define MUI_LANGDLL_REGISTRY_ROOT "${PRODUCT_UNINST_ROOT_KEY}"
!define MUI_LANGDLL_REGISTRY_KEY "${PRODUCT_UNINST_KEY}"
!define MUI_LANGDLL_REGISTRY_VALUENAME "NSIS:Language"

; Welcome page
!insertmacro MUI_PAGE_WELCOME
; License page
!insertmacro MUI_PAGE_LICENSE "license.txt"
; Directory page
!insertmacro MUI_PAGE_DIRECTORY
; Instfiles page
!insertmacro MUI_PAGE_INSTFILES
; Finish page
!define MUI_FINISHPAGE_RUN "$INSTDIR\StoneLoops.exe"
!insertmacro MUI_PAGE_FINISH

; Uninstaller pages
!insertmacro MUI_UNPAGE_INSTFILES

; Language files
!insertmacro MUI_LANGUAGE "English"

; Reserve files
!insertmacro MUI_RESERVEFILE_INSTALLOPTIONS

; MUI end ------

if i remove !insertmacro MUI_LANGUAGE "English" i get following error:
resolving install function "Nsis2Io" in function "mui.Welcome_82.5.9"
Does anyone know how to fix this ? Or how to make uninstaller not ask for language selection ?
thx
madjerry is offline   Reply With Quote
Old 7th April 2008, 15:21   #2
mauvecloud
Junior Member
 
mauvecloud's Avatar
 
Join Date: Mar 2008
Location: Hayward, CA
Posts: 35
You have to at least have 1 MUI_LANGUAGE macro called for MUI to even work (even the "Basic" example for MUI includes one), but the language selection only appears if you use the macro MUI_LANGDLL_DISPLAY. If you're not calling that function, the MUI_LANGDLL_REGISTRY defines are unnecessary.
mauvecloud is offline   Reply With Quote
Old 7th April 2008, 15:45   #3
madjerry
Junior Member
 
Join Date: Apr 2008
Posts: 7
Thx,

all seems to work now
I can be happy again
madjerry is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump