Old 11th October 2010, 16:23   #1
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
BUG: id3v1 tags added when they shouldn't be

5.581 win7

ok, this is a weird one, so i need some help from the Pro's here, but...

...what i think is happening is this: i use mp3tag to strip ALL id3v1 tags from ALL my files. i use ONLY id3v2.3 tags in my files. for that reason, i have configured winamp to NOT create v1 tags. you can do that when you configure in_mp3 in prefs. on that id3 tab in prefs, thats the only thing UNchecked; so in my winamp setup, winamp is NOT to create v1 tags.

HOWEVER, i am finding files which i KNOW had v1 removed, suddenly have v1 reappear. these are single tracks on albums which i did some minor tag editing on with winamp, like adding a rating or making an edit to the "Composer" field/frame.

winamp should NOT be readding the v1 tag!

i am not sure what edits / changes are causing this, but SOMETHING is, and yes it is winamp, not something else.

can someone, like Egg, please confirm?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 12th October 2010, 19:04   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
...ugh... ok, strike all that, doing more testing...

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing

Last edited by MrSinatra; 12th October 2010 at 19:12. Reason: reproduction issues
MrSinatra is offline   Reply With Quote
Old 22nd October 2010, 21:24   #3
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
ok... good news and bad news...

the good news, such that it is, is that i can absolutely confirm this issue exists. i have had v1 tags reappear on files that nothing else other than winamp touched.

the bad news is i haven't come up with a way to always reproduce the issue. it seems relatively rare, and intermittent. it may also be a combo of factors, or not.

so i am certain the bug exists, but is that enough for you to go on to stamp it out?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 14th November 2010, 04:38   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
FINALLY...

i have discovered at least ONE scenario where this bug can be reproduced:

remember, i have configured winamp to NOT create v1 tags. you can do that when you configure in_mp3 in prefs.

so take a file which has v2 tags, but doesn't have v1 tags. then as it plays, click the song ticker, and get the "file info" dialog. then make an edit on the basic info tab, like to the title for instance. even before you save it/click ok, you can click the v1 tab and see that winamp has updated the title field, and put a checkmark in for including v1 tags! if you then click ok, it WILL save the v1 tag to the file, even tho that violates the pref.

so obviously, there is a bug here.

my guess is that isn't the ONLY backdoor way winamp keeps adding v1 tags, so i think there needs to be some kind of bigger solution, where winamp is prevented from reading or writing v1 tags, if the user specifies it, that the app couldn't over-ride, as it does here.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 14th November 2010, 07:01   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Yeah, I can reproduce it.

I unchecked all three id3v1 options in in_mp3 config
then went to edit file info for an mp3,
changed Title in Basic tab
and sure enough, it was also written to Title in id3v1 tab.

Thanks
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Tags
id3, id3v1, id3v2, id3v2.3, tags

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump