Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 23rd October 2012, 13:03   #1
RLM
Junior Member
 
Join Date: Oct 2012
Posts: 2
Has anyone noticed that AVS doesn't work for **** in Windows 7?

I'm a Winamp user for a VERY long time. When I discovered the AVS visualizer at least 10 years ago I was so happy because it was so unbelievably cool. I haven't used Winamp for a while, but today I decided to restart using it after getting tired of WMP, and I was very sad to see the pathetic state of instability the AVS visualizer is into. It seriously doesn't work at all, keeps crashing, presets have missing effects, it crashes when changing presets or using the editor.

Why? Is there any way to fix it? I tried it in a virtual machine with XP and it works fine there. I think it's really a shame that it's no longer compatible with Win7 and everything you do makes it crash, I can't believe nobody has noticed or complained about this before.
RLM is offline   Reply With Quote
Old 23rd October 2012, 13:14   #2
DrO
 
Join Date: Sep 2003
Posts: 27,880
AVS has always been unstable, it just shows up more so on Vista / Windows 7. there was a v2.83 which seemed to resolve the stability issue on Windows 7 but the AVS community bitched (mainly in the AVS sub-forum) that it broke their presets so v2.81d was put back in. you'd need to find an older Winamp installer which shipped with v2.83 and using 7-zip to extract out the vis_avs.dll and use that.

as for users like yourself, hardly anyone has taken the time to post about it in the forums (no idea about via the site feedback). either way, you're either looking at a version that should work but doesn't show the presets as the authors would like (if you could even tell to begin with) or use a broken version that does the presets in the correct way - the choice is yours (and just reinforces something i've been trying to push to get AVS taken out of the main installer by default and just include either version so the one needed can be selected for those who do still want to use it).

-daz
DrO is offline   Reply With Quote
Old 23rd October 2012, 17:38   #3
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,167
Send a message via AIM to MrSinatra
Quote:
Originally Posted by DrO View Post
you'd need to find an older Winamp installer which shipped with v2.83 and using 7-zip to extract out the vis_avs.dll and use that.
5.601 and prob a few earlier.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
avs, visualization

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump