Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 8th July 2014, 21:34   #1
DarkShado
Junior Member
 
Join Date: Jul 2014
Posts: 5
Access Violation in module ntdll.dll Version 5.666 Build 3516

Ok i am getting the following error when I am closing Winamp
This is the ONLY program that I am having an issue with and
not quite sure why. I only get this when I am just closing
Winamp I have run winamp for a long time now and had no
problems in the past.


Winamp Error Feedback [DD33524E45EE404B89D539643E936534D3]

Winamp client version: 5.666 Build 3516
winamp caused an Access Violation (0xc0000005)
in module ntdll.dll at 0023:77c78e19.

Exception handler called in Winamp.


Now it opens up my email and creates a dump file which it tries to email to you
and it bounces back all the time. It is trying to email you at bug [at] winamp [dot] com
and it always bounces back to me saying it is undeliverable. What is up with that?


Winamp Client Version: 5.666 Build 3516
OS: Windows 7 (64 Bit) SP1
Video Card: AMD Radeon HD 7700 Series
Sound: Asus Xonar DG
Video Cam: Microsoft Life HD-5001
Headset: Logitech USB Headset H340

The machine is a Dell Optiplex 760 3.0 GHZ Duo CPU E8400 machine
it has 8 GB of RAM.

The original dump file which is was trying to email you can be
downloaded at
http://www.mediafire.com/download/j7...jgv/report.zip


I have attached a copy of the Winamp Info Tool output as well
at the link bellow.

http://www.mediafire.com/download/q7...07-08-2014.zip

I have uploaded a copy of a dxdiag report as well at
http://www.mediafire.com/view/x47yfy...a6w/DxDiag.txt

For all the files you can see
https://www.mediafire.com/folder/4p0rm8qh8i1g6/winamp

All the above information should give you more than enough
information to be able to troubleshoot this problem.

There are no 3rd party plugins as far as I know I just did a default install
of winamp.

All I do is click on the X in the top right corner of winamp and I am trying
to exit Winamp and then I start seeing the crash information coming up
on my screen.
Attached Files
File Type: zip Winamp_Info_Report_07-08-2014.zip (7.8 KB, 213 views)
File Type: zip report.zip (36.3 KB, 199 views)
File Type: txt DxDiag.txt (34.2 KB, 327 views)
DarkShado is offline   Reply With Quote
Old 8th July 2014, 22:12   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,780
Hi

Thanks for the detailed report. I'm still looking through the logs....

Does the problem still happen after installing the in_mp3 (and jtfe) update patches from here?
http://forums.winamp.com/showthread....373755#updates

If it still happens, then...

1) Are you using Winamp to manage any portable devices? Are any devices connected at the time?
(Android phone/pad, iPod, usb pen drive, etc)

2) Does the problem still happen if you disable the French Radio plugin?
With Winamp closed, temporarily move gen_LMPwa.dll from the Winamp\Plugins folder into some backup folder elsewhere.
DJ Egg is offline   Reply With Quote
Old 8th July 2014, 22:30   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
the crash is in pmp_android so could be any number of things if an android device is connected which could be causing it.

though is best to confirm if the issue still happens after removing gen_LMPwa.dll (either from what is mentioned above or running Winamp in it's safe-mode).
DrO is offline   Reply With Quote
Old 9th July 2014, 02:14   #4
DarkShado
Junior Member
 
Join Date: Jul 2014
Posts: 5
Quote:
Originally Posted by DJ Egg View Post
Hi

Thanks for the detailed report. I'm still looking through the logs....

Does the problem still happen after installing the in_mp3 (and jtfe) update patches from here?
http://forums.winamp.com/showthread....373755#updates

If it still happens, then...

1) Are you using Winamp to manage any portable devices? Are any devices connected at the time?
(Android phone/pad, iPod, usb pen drive, etc)

2) Does the problem still happen if you disable the French Radio plugin?
With Winamp closed, temporarily move gen_LMPwa.dll from the Winamp\Plugins folder into some backup folder elsewhere.
I do have an android phone but it is NOT connected when this is happening.

Ok so I installed the update above and it still is crashing. I am still getting
the same problem when I go to close Winamp.

I am not using Winamp to manage any kind of portable device there
is no iphone / android phone / ipod or USB pen device or android device
connected when it is crashing.

Ok what I did was I renamed gen_LMPwa.dll to gen_LMPwa.dll.bak
so it would no longer recognize it and I moved the plugin out of
the plugin directory as well to D:\Program Files (x86)\Winamp\backup

The program is still crashing with the same error message as before.

I attached the two dump files for the most recent crashes along
with this response.
Attached Files
File Type: zip report.zip (38.3 KB, 185 views)
File Type: zip report1.zip (30.3 KB, 185 views)
DarkShado is offline   Reply With Quote
Old 9th July 2014, 02:25   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
the crash is the same as before in pmp_android.dll. if there is definitely not an android device connected, then i'm not sure what is the cause as the crash issue is something i've seen come up on and off over the last 2 years but have never been able to locally replicate it with debug builds (or any build for that matter) to try to resolve it (as i'm not 100% that i can rely on the information in the crash dump).

i'll have to have a think and see if there's anything i can do to provide a better build for trying to track down what is going on. in the mean while, you're best renaming pmp_android.dll to pmp_android.off and check that it no longer crashes.
DrO is offline   Reply With Quote
Old 9th July 2014, 02:29   #6
DarkShado
Junior Member
 
Join Date: Jul 2014
Posts: 5
Quote:
Originally Posted by DrO View Post
the crash is in pmp_android so could be any number of things if an android device is connected which could be causing it.

though is best to confirm if the issue still happens after removing gen_LMPwa.dll (either from what is mentioned above or running Winamp in it's safe-mode).
Well to test your theory about it being the pmp_Android I went into the plugin
directory and moved that plugin (pmp_android.dll) out of the directory and
moved it to D:\Program Files (x86)\Winamp\backup so it was no longer in
the plugin directory and it is still crashing with the same error.

I attached the zip file with the dumps it created again along with this
response.
Attached Files
File Type: zip report.zip (29.9 KB, 178 views)
DarkShado is offline   Reply With Quote
Old 9th July 2014, 02:34   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's now doing it in pmp_usb.dll instead of pmp_android.dll (which i'd sort of expected since the two share a lot of the same source code). try the same thing with pmp_usb.dll and see what removing that does.
DrO is offline   Reply With Quote
Old 9th July 2014, 02:43   #8
DarkShado
Junior Member
 
Join Date: Jul 2014
Posts: 5
Ok so the only other thing I could think of doing was do a totally fresh
install. I totally uninstalled Winamp including all user settings and
everything. I made sure the whole winamp directory was gone
And I made sure everything was gone from under the C:\Users\Jamie\AppData directory as well.

I reinstalled it back into the directory D:\Program Files (x86)\Winamp
I selected current for the skin which did the Winamp Classic Skin version 2.0

And I am still getting the same error again and it crashed on exit.
I attached the dump file as well from when I did the reinstall
along with this message.
Attached Files
File Type: zip report.zip (30.0 KB, 180 views)
DarkShado is offline   Reply With Quote
Old 9th July 2014, 02:49   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
you've not applied the plug-in patches that are required when you re-installed.

and it's back to doing the same issue with pmp_android.dll. clearly there is something on your machine which is incorrectly causing the device discovery aspects to be triggered on closing when it shouldn't (in both pmp_android.dll and pmp_usb.dll). so after applying the required plug-in patches, remove both of those pmp_*.dll files and see if the crash persists.
DrO is offline   Reply With Quote
Old 9th July 2014, 02:51   #10
DarkShado
Junior Member
 
Join Date: Jul 2014
Posts: 5
Eureka!

Quote:
Originally Posted by DrO View Post
it's now doing it in pmp_usb.dll instead of pmp_android.dll (which i'd sort of expected since the two share a lot of the same source code). try the same thing with pmp_usb.dll and see what removing that does.
Ya I know I had not applied the changes I just thought if there was some
kind of corruption some where that a fresh install may help but it didn't.

I reinstalled the patch again that you told me to put in before.

Ok... I moved out both the pmp_android.dll and pmp_usb.dll out of the plugin
directory and moved them to D:\Program Files (x86)\Winamp\backup

and now it isn't crashing! So what one of these two modules or both contain
the problem that is the real question.

I tried it multiple times going in and out of winamp by clicking on the X in the
top right corner of the program and it isn't crashing now with those two
modules disabled.

Winamp Winamp... these bugs really whips the developer's ass LOL
When I did the reinstall I got to hear the Llama Whippin' Intro again LOL
I have not heard that in a while.

Well at least we found what plugins / modules it is. For now I will keep
those two disabled until you guys can come up with a patch for it.

If you need more info just let me know!

Last edited by DarkShado; 9th July 2014 at 04:26.
DarkShado is offline   Reply With Quote
Old 23rd September 2014, 22:38   #11
coliniain
Junior Member
 
Join Date: Sep 2014
Posts: 3
I recently had a bad crash at work just kept failing i was using sqr crossfader which may have been part of the problem. but i had to use revo uninstaller to monitor instalation of winamp and sqr then uninstalled again. i have reloaded winamp again without sqr plug in and has worked fine for a few weeks
coliniain is offline   Reply With Quote
Old 23rd September 2014, 22:40   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
you should also make sure you've got the required plug-in updates installed (as that can lead to such issues as well).

though as your post doesn't really relate to the specific issue in this thread, i'll be moving your post into it's own thread in a bit.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump