Old 29th July 2012, 08:49   #1
cj31387
Junior Member
 
Join Date: Oct 2010
Posts: 6
Winamp Volume Lowers to like 2% when playing a Midi File

Hi, I've had this problem for a while I make a lot of music im a composer, i often save out my electronic tracks as midi also and when i go to play them in winamp it always lowers the windows mixer volume to like 2% its really annoying. I've tried looking at preferences > input > the midi plugin > turning off volume control, that seems to work a little better but it still lowers my winamp volume to like 45%. This only happens with me for midi files.
cj31387 is offline   Reply With Quote
Old 30th July 2012, 07:54   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,684
If you have ReplayGain enabled, you should change the default 6 dB drop of volume for files without ReplayGain tags to 0 dB.

Also select "DirectMusic / Microsoft Synthesizer (with output)" as the device on the device tab of the midi player plug-in configuration options, along with setting the volume control to "none" on this tab.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v1909 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 30th July 2012, 08:13   #3
cj31387
Junior Member
 
Join Date: Oct 2010
Posts: 6
Yeah I've got both of those off but it still drops the volume to like 40%. Like I said before I turned volume control to off it was way worse but when it is off its better but still like 40%.
cj31387 is offline   Reply With Quote
Old 30th July 2012, 08:21   #4
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,684
Have you tried other device options in the midi plug-in? Have you rechecked the Windows volume mixer to see if the max volume allowed for midi is high enough?

There is also volume control in the DirectSound output plug-in. You can try disabling that.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v1909 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 30th July 2012, 08:29   #5
cj31387
Junior Member
 
Join Date: Oct 2010
Posts: 6
Yes on the windows mixer, and what other options should i try in the device options?
cj31387 is offline   Reply With Quote
Old 30th July 2012, 08:33   #6
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,684
The options available depend on your sound device. It can't hurt anything to try them all and see what results you get with each one.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v1909 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 30th July 2012, 08:40   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,684
On my system there is also a midi output volume control that is part of the sound device configuration accessed through the Windows control panel. It is on the Speakers Properties Levels tab.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v1909 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 18th December 2013, 23:55   #8
cj31387
Junior Member
 
Join Date: Oct 2010
Posts: 6
Reformatted and reinstalled winamp today. What fixes it for me is setting midi plugin to Direct Input / Microsoft Synth and setting the the volume controls to off in that.
cj31387 is offline   Reply With Quote
Old 22nd December 2013, 02:55   #9
franpa
Member
 
Join Date: Feb 2007
Location: australia, brisbane
Posts: 56
Send a message via Yahoo to franpa
Yeah, but then you're using the DirectMusic synthesiser :/ I've had this issue before as well and also never properly resolved it (I had to use the work around of using an alternative synthesiser like DirectMusic)
franpa is offline   Reply With Quote
Old 21st February 2014, 00:10   #10
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 105
Quote:
Originally Posted by Aminifu View Post
... select "DirectMusic / Microsoft Synthesizer (with output)" as the device on the device tab of the midi player plug-in configuration options, along with setting the volume control to "none" on this tab.
I just ran into problem and this solution fixed it. That was annoying. :O Thanks Aminifu.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
low volume, midi, volume

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump