Old 29th July 2010, 14:28   #241
nradisch
Senior Member
 
Join Date: Jun 2008
Location: Weston, CT
Posts: 250
RedSarah,

It could be that the other settings related to the encoder. Both the AAC and mp3 encoders do rather strange things if you give them invalid combinations of samplerate, channels and bitrate. I no longer have access to the documentation that lists the valid combinations, but common sense is a useful guide here.

For example, 8Khz, mono at 128kb would be pretty bizarre and would most likely give you an odd sounding result. I also seem to recall AAC going berserk if you ask it to do anything other than stereo at high bitrates.

Try changing the # of channels and the sample rate and see if that helps. For high bitrates you're generally going to want to use 44100hz stereo.

--Neil
nradisch is offline  
Old 29th July 2010, 15:02   #242
RedSarah
Junior Member
 
RedSarah's Avatar
 
Join Date: Jul 2010
Posts: 7
SC_TRANS2 BETA 6
THIS WORKS GREAT
;; ENCODER OPTIONS
;encoder=mp3
;mp3quality=1
;mp3mode=0
encoder=aacp
bitrate=22000
samplerate=44100
channels=2
aacpbitstreamformat=0


THIS DOESN'T
;; ENCODER OPTIONS
;encoder=mp3
;mp3quality=1
;mp3mode=0
encoder=aacp
bitrate=128000
samplerate=44100
channels=2
aacpbitstreamformat=0

This works great
;; ENCODER OPTIONS
encoder=mp3
mp3quality=1
mp3mode=0
;encoder=aacp
bitrate=22000
samplerate=44100
channels=2
;aacpbitstreamformat=0

THIS DOESN'T
;; ENCODER OPTIONS
encoder=mp3
mp3quality=1
mp3mode=0
;encoder=aacp
bitrate=128000
samplerate=44100
channels=2
;aacpbitstreamformat=0


any bitrate above 24kbs doesn't work audibly as expected on my sc_trans2 beta 6.
23 and 24 kbs bitrates have artifacts.
RedSarah is offline  
Old 29th July 2010, 15:44   #243
nradisch
Senior Member
 
Join Date: Jun 2008
Location: Weston, CT
Posts: 250
RedSarah,

I'm really not sure what's going on. I certainly never experienced any problems like this when I was at AOL. If you have some sample streams up and running somewhere that I could listen to, perhaps that will shed some light on the problem.

--Neil
nradisch is offline  
Old 29th July 2010, 15:44   #244
nradisch
Senior Member
 
Join Date: Jun 2008
Location: Weston, CT
Posts: 250
RedSarah,

I'm really not sure what's going on. I certainly never experienced any problems like this when I was at AOL. If you have some sample streams up and running somewhere that I could listen to, perhaps that will shed some light on the problem.

--Neil
nradisch is offline  
Old 29th July 2010, 16:30   #245
RedSarah
Junior Member
 
RedSarah's Avatar
 
Join Date: Jul 2010
Posts: 7
Sure, I'll message you the url.
RedSarah is offline  
Old 30th July 2010, 01:08   #246
nradisch
Senior Member
 
Join Date: Jun 2008
Location: Weston, CT
Posts: 250
For those following this thread, the problem was in sc_serv2. The buffer configurations were set too low for the bitrate causing continuous underruns. Once RedSarah changed the buffer configuration, everything worked correctly.

--Neil
nradisch is offline  
Old 30th July 2010, 05:03   #247
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
Thanks neil,
Added to my squidgy grey database for future ref.

And thanks on behalf of the community for spending so much time helping
out even though you have moved on from AOL.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 31st July 2010, 02:32   #248
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Hello everyone. Been a while since I have been keeping tabs on SHOUTcast and Radio Streaming...

Now I see I totally missed the SHOUTcast DNAS Version 2 and this Transcoder Release...

I am reading through the posts but I just saw one that was relevant to my scenario so I figured I'd quote it now:

Quote:
Originally Posted by nradisch View Post
RedSarah,

You do not need a license for AAC encoding in sc_trans. If it didn't work then there was probably something wrong in your config file.

--Neil
What I want to achieve is:

Use an Auto-DJ program like SpacialAudio's SAM for Automation & Request Handling.

I currently Stream 3 bitrates: 128K, 64K and 32K

I want to continue using AAC+v2 Encoding.

Does your quote there Neil mean I can transcode using AAC+v2 without needing any extra files? AAC+v2 encoding I was advised is not "free" similar to your standard mp3 remarks? either but I have bought my mp3 license anyway but the reason I bought it was to use AAC+v2 not standard Mp3.

I know the Winamp DSP has/had AAC+v2 encoder inbuilt for free. Can you confirm if I can transcode with AAC+v2 and how?


Which takes me to my next question, since I believe from reading I will be able to "Relay" another Stream my ideal scenario would be this:

Single 128Kbit AAC+v2 Stream > SHOUTcast DNAS or direct to the Transcoder? Which would then create a 128Kbit output to a SHOUTcast DNAS, a 64Kbit transcoded feed to another SHOUTcast DNAS and a 32Kbit Transcoded Stream to a SHOUTcast DNAS.

So I decrease my source bandwidth and can transcode on our main hub server.


Then I am hoping from reading this will also be possible, that the main "DNAS/Transcoder" that handles the original 128Kbit feed input has 2 "Source" inputs, so I can run an "Automated" feed but DJ's can log in and take over the feed which would then also get transcoded as above. When they log off it goes back to the Auto-DJ feed.


This is funny because I was looking into modifying Oddsocks StreamTranscoder V3 to try and achieve this functionality a while back and it seems SHOUTcast is getting closer to making this possible which is awesome.

Thanks for the information and great work by the Nullsoft/AOL/SHOUTcast team.

I'll leave my AAC+v2 web-player questions for another time I see a lot of take-up of these Flash based feeds so have a bit of catching up to do.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 31st July 2010, 11:26   #249
nradisch
Senior Member
 
Join Date: Jun 2008
Location: Weston, CT
Posts: 250
Rothgar,

AAC encoding is not "free", but in the case of sc_trans, AOL has paid the necessary licensing fees for you.

--Neil
nradisch is offline  
Old 31st July 2010, 23:25   #250
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by nradisch View Post
Rothgar,

AAC encoding is not "free", but in the case of sc_trans, AOL has paid the necessary licensing fees for you.

--Neil
Thanks Neil, just to clarify for others. Have they paid for it without having to buy the "mp3" license? Or it's paid for in the "mp3" license?

Also can you comment on my scenario and if I am able to accomplish it with the new Transcoder & DNAS?

Thanks again.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 1st August 2010, 10:40   #251
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
One recommendation that would make things easier for distribution on linux etc is not using spaces in the directories? i.e. 'sc_trans drop 02_22_2010' should be 'sc_trans_drop_02_22_2010'

I will be setting it up and testing soon.

Edit:

Ok so on the Debian box in the datacenter the sc_trans would just hang on starting and no log was generated in /tmp

I was running as "non root" and tried without any config file at all and with a config file no difference.

Switched to my local Debian server here and got an error:

dawgclan@dcsrv1:~/sc_trans_drop_02_22_2010/linux$ ./sc_trans ~/sc_trans_drop_02_22_2010/sc_trans_demo.conf
./sc_trans: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
dawgclan@dcsrv1:~/sc_trans_drop_02_22_2010/linux$ ls -al /usr/lib/libstdc++.so.6lrwxrwxrwx 1 root root 19 2009-11-25 03:50 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.10
dawgclan@dcsrv1:~/sc_trans_drop_02_22_2010/linux$


I tried sc_trans with and without configuration file and it's having trouble with the library?

This again is as "non root"

EDIT:

Ok that library error is fixed, forgot I was running 64bit on this box and it was missing 32bit libraries.

Now I get the same issue as the dedicated box it just sits there like it's frozen no output?

EDIT:

Ok well it's not "frozen" but it is definitely not outputting anything. I tried sending it a config file but makes no difference.

Doing a quick netstat I see it binds to some random port?

tcp 0 0 *:56885 *:* LISTEN 3479/sc_trans

The port changes each restart but going to that port on HTTP just shows:

Resource Not Found (Weblet)

I'll wait for some help I guess.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net

Last edited by Rothgar; 1st August 2010 at 13:09.
Rothgar is offline  
Old 1st August 2010, 22:35   #252
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Ok did another test today.

Seems if the config file is not specified there is no output? Is this a bug? Shouldn't it at least say specify a config file or something?

I then decided to take the sc_trans_demo.conf and edit it to a workable state and when I used this I got output.

My config file I was passing was invalid I assume because it was in the wrong format? I was using no "=" to separate the variables from the data.

I think this is also something that should be listed as a bug, if the config file is invalid it should say so?

Other than that I'll test more later after work when I try and fix my original config file.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 2nd August 2010, 11:28   #253
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Second test:

Bug: I commented and cleaned my config file to include"commented headers" etc.

When I started the sc_trans it wrote a new config file removing all my comments and including all my "commented" i.e ";" started lines in the new file as actual lines.

So the re-write config file option is bugged.

EDIT:

It put all the options in alphabetical order removing all comments...

Now everything is removed from their corresponding comment sections.

Bugged

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 2nd August 2010, 18:26   #254
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
I should probably elaborate:

If you have a configuration file that you have formatted and put everything in sections etc to group the data in a logical method example "sc_trans_demo.conf"

And then you use the "configrewrite=1" which I thought might of been a good feature for modifying settings through the web interface but retaining them on restarts etc. When the sc_trans exits, it will as it states re-write the configuration file.

However in doing this, it:

Re-writes the configuration file removing all original formatting and just printing 1 variable per line. i.e. "Trims" all white spaces between the variable and the "=" and the white-space around your values. It also removes any blank lines.

Removes any and all comments including any commented options you might of had. Any commented "headers" you had which are not relating to variables it removes. It also seems to print any commented variables back to their default values. i.e. ";;djbroadcasts=/my/path/i/commented/" becomes non commented "djbroadcasts=/home/hdc/uploads/recorded/"

Prints all the variables in alphabetical order removing any logical grouping you may of created.


I guess for now I have learned my lesson and won't use that option, I can only assume it was meant to be used as I mentioned however could be wrong but it looks like that is bugged? Or working as intended and will just be a PITA for future manual editing?

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 3rd August 2010, 03:32   #255
chrisjohnston
Junior Member
 
Join Date: Aug 2010
Posts: 2
Live capture & playlist error

I have my configuration setup correctly to stream mp3 files, this is good. Although I'm really looking to stream audio from the soundcard. Everything seems to be OK except the playlist error "Playlist is empty"

I placed a multitude of possible entries for the playlist such as the old method of dsp:/dev/audio although it doesn't work

I think the capture ability of sc_trans is broken. I have come to find out the playlist needs to exist and also needs to contain an entry.


Has anyone configured sc_trans with capture=1 for encoding live broadcasts from the soundcard input?

Does anyone have the old version of sc_trans to try since the only download available is a beta and it appears to be broken?
chrisjohnston is offline  
Old 3rd August 2010, 06:10   #256
chrisjohnston
Junior Member
 
Join Date: Aug 2010
Posts: 2
Quote:
Originally Posted by chrisjohnston View Post
Does anyone have the old version of sc_trans to try since the only download available is a beta and it appears to be broken?
Ok so the playlist file would need the path to the device such as
/dev/mixer matching what was placed into the config file capturedevice=/dev/mixer

Alsa is installed and configured correctly.This seems correct, can anyone validate this will work with sc_trans Beta 6?

In the log this line tells me something is wrong.
[captureUnix] Opening audio device /dev/mixer
[captureUnix] Audio card does not support 16 bit little endian data

I know this card records in 16-Bit having done so using arecord.

The hardware drivers are loaded and is listed below using lspci

Creative Labs CT4620 SBLive
Kernel driver in use: EMU10K1_Audigy
Kernel modules: snd-emu10k1


Does anyone have an idea what needs to be done to make this work??
chrisjohnston is offline  
Old 3rd August 2010, 08:40   #257
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Ok, the sc_trans will not print any output if the "log" option is commented. Even though it states it has defaults?

This is also irrespective of having screenlog=1

Once I enabled the "log" option and pointed it to a path I got output, so that definitely looks like a bug.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 3rd August 2010, 11:03   #258
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
chrisjohnston my emu 1212m(works with snd-emu10k1 module) worked with /dev/dsp if i remember correctly.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 3rd August 2010, 13:06   #259
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Ok now I really need some help :|

I have been trying all night to get sc_trans to play nice with my SHOUTcast 1 DNAS.

I am using protocol 1 so that should be correct?

sc_trans connects to the DNAS but no music plays and then after the timeout period it drops and does not reconnect.

I tried streaming from two different computers with no luck. I also tried changing between AAC and Mp3 no difference.

I tried this streaming direct to the djport and using the calendar "relay" option. Both have the same results.

All I see on the DNAS is:

<08/03/10@12:51:28> [source] connected from XXX.XXX.XXX.XXX
<08/03/10@12:51:28> [source] icy-nameawgclan Network Radio ; icy-genre:N/A
<08/03/10@12:51:28> [source] icy-pub:0 ; icy-br:128 ; icy-url:http://www.dawgclan.net
<08/03/10@12:51:28> [source] icy-irc:N/A ; icy-icq:48569749 ; icy-aim:RothgarMaulrur
<08/03/10@12:51:59> [source] no data (30s timeout). disconnecting.


I do not have a "playlist" setup with sc_trans as I want to relay a stream all the time and in the end transcode it.

any ideas? Thanks.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 4th August 2010, 06:50   #260
shadow_65
Junior Member
 
Join Date: Apr 2006
Posts: 11
question:
Is it possible to use sc_trans to transcode a current stream that is lets say 128kb/s mp3 to 24kb/s aacplus?
I know this may seem silly, but i am not sure if i am reading this right or not....
Also if you can, does someone wanna give me some pointers how to do that?
Thanks a million!
shadow_65 is offline  
Old 4th August 2010, 09:02   #261
bored_womble
Winamp's Womble
 
bored_womble's Avatar
 
Join Date: May 2004
Location: Wimbledon Common
Posts: 1,100
Quote:
Originally Posted by shadow_65 View Post
question:
Is it possible to use sc_trans to transcode a current stream that is lets say 128kb/s mp3 to 24kb/s aacplus?
I know this may seem silly, but i am not sure if i am reading this right or not....
Also if you can, does someone wanna give me some pointers how to do that?
Thanks a million!
I do not think this is possible but I remember it being a feature request.

BW

Without open minds the world will die. Open yours and correct the mistakes you are making right now.
bored_womble is offline  
Old 4th August 2010, 13:07   #262
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
How strange I thought I had read sc relay transcoding was already implemented.
Just looked again through the docs and its not.

Of course with slight adjustment to your setup you could give sc_trans your main 128k mp3 stream feed from your current encoder/source client and let sc_trans feed your dnas for both streams.


edit:
In the calendarxml docs
"url - url for source relay" <- this is where I read it.

So Long, and Thanks for All the Fish.

Last edited by Jkey; 4th August 2010 at 13:10. Reason: null
Jkey is offline  
Old 4th August 2010, 22:33   #263
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
How strange I thought I had read sc relay transcoding was already implemented.
Just looked again through the docs and its not.

Of course with slight adjustment to your setup you could give sc_trans your main 128k mp3 stream feed from your current encoder/source client and let sc_trans feed your dnas for both streams.


edit:
In the calendarxml docs
"url - url for source relay" <- this is where I read it.
I thought it was implemented:

- A new type of event as been added to the calendaring system that allows you to relay other stations. (see calendarxml.txt for more information)

- In adding the relay feature it was necessary to rewrite a large portion of the metadata handling. Hopefully the metadata will now change more reliably when switching between scheduled sources.


So it looked to me like it was implemented, however as mentioned both relaying and trying to stream to the sc_trans both seem to fail for me.

It connects to my DNAS v1 but does not play any music.

I am using the following config:

Quote:
;; Logging
log = 1
logfile = /home/Rothgar/sc_trans_drop_02_22_2010/linux/sc_$
screenlog = 1
;shuffledebug = 0
;shoutcastdebug = 1
;uvoxdebug = 0
;gaindebug = 0
;playlistdebug = 0
;mp3encdebug = 0
;mp3decdebug = 0
;resamplerdebug = 0
;rgcalcdebug = 0
;apidebug = 0
;calendardebug = 0
;capturedebug = 0
;djdebug = 1
;flashpolicyserverdebug = 0
;fileconverterdebug = 0
;sourcerelaydebug = 1
;sourceandendpointmanagerdebug = 1

;; Flash Security
;flashpolicyfile = crossdomain.xml
;flashpolicyserverport = Default = 0 (use 843 if you want to turn it on)

;; Metadata Control
streamtitle = Dawgclan Network Radio
streamurl = http://www.dawgclan.net
genre = Rap,Hip-Hip
aim = RothgarMaulrur
;irc = irc://dawgclan.street-creed.com:6667/dawgclan
icq = 48569749
public = 1
;usemetadata = 1
;metadatapattern = Default = *\%N.* or */%N.*
;displaymetadatapattern = Default = %R[ - ]%A[ - ]%N

;; Playlist Control
;playlistfile
;shuffle = 1
;xfade = 1
;xfadethreshold = 10
;playlists = Default = c:\playlist\ or /export/home/friends/p$
;archive = Default = c:\playlist\archived\ or /export/home/$

;; Calendar Events
calendarfile = /home/Rothgar/sc_trans_drop_02_22_2010/linux/cal$
calendarrewrite = 0

;; Live Capture
capture = 0
;capturedevice
;captureinput
;capturesamplerate = 44100
;capturechannels = 2


;; DJ Support
djport_0 = 9000
;djport2 = 9010
;djcipher = XXX
autodumpsourcetime = 30
;djbroadcasts = Default = c:\recorded\ or /home/hdc/uploads/reco$
djcapture = 0
;djfilepattern = "_%Y_%m_%d_%H_%M_%S."

;; DJ Defines (Multi):

djpassword_0 = XXX
djlogin_0 = XXX
djpriority_0 = 1

;; Mp3 Encoding Unlock
unlockkeyname = XXX
unlockkeycode = XXX

;; Encoder Options (Multi)
encoder_0 = aacp
bitrate_0 = 128000
samplerate_0 = 44100
channels_0 = 2
; 0 - ADTS 1 - ADIF 2 - LATM 3 - LOAS 4 - RAW 5 - ADTS_MP4
aacpbitstreamformat_0 = 0

;; Network Options (Multi)
;endpointname = - names the endpoint
outprotocol_0 = 1
serverip_0 = XXX.XXX.XXX.XXX
serverport_0 = 8010
password_0 = XXX
;uvoxstreamid = 1
;uvoxuserid =
;uvoxauth =
;uvoxradiometadata = - send old AOL radio style metadata $
;uvoxnewmetadata = 1
;uvoxmetadatafudgefactor = 0.0
;shoutcastmetadatafudgefactor = 0.0


;; Replay Gain Control
applyreplaygain = 0
;defaultreplaygain = 0.0
;djreplaygain = 0.0
;capturereplaygain = 0.0
calculatereplaygain = 0
;replaygaintmpdir = Default = (windows = %TMP% Linux = ????)
;replaygainrunahead = 2
;replaygaindontwrite = 0
;enhancereplaygain = 6.0

;; Other
adminport = 9999
adminuser = XXX
adminpassword = XXX
;vuimagedirectory = ""
;vuimagesuffix = jpg
;vuimagemimetype = image/jpeg
;configrewrite = 0
;serverbackupfile =
;serverintrofile =
Don't mind the $ that just means it went outside the screen I was copying from.

Now I may have things wrong as I am finding small issues as I go, like if you do not specify a "calendar.xml" DJ's can not log on it just says Invalid login... When I pointed it to a "calendar.xml" it allowed the login.

But I can't figure out why it connects to my SHOUTcast DNAS v1 but does not stream anything to it?

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 02:32   #264
shadow_65
Junior Member
 
Join Date: Apr 2006
Posts: 11
whenever I try and use the calendar.xml file and put in the data it always is able to get the metadata, and foreward it to the sc_serv2 application. The problem is that when i try to play the stream from that server (the relayed stream) It does not play anything.
Quote:
<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>
<calendar/>
<event type="relay" >
<relay url="http://server:8000"/>
<calendar starttime="00:00:00"/>
</event>
</eventlist>
<eventlist>
NOTE: I edited out the server address so I would not get slammed with hits wasting bandwidth.
shadow_65 is offline  
Old 5th August 2010, 09:14   #265
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
To relay a shoutcast v1 dnas you must add /; to the stream url.

Example:
code:
<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>
<event type="relay">
<relay priority="1" url="http://127.0.0.1:8000/;" />
<calendar starttime="00:00:00" />
</event>
</eventlist>




Hope this helps

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 10:55   #266
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Ok to clarify my situation, I can "relay" SHOUTcast v1 streams without the trailing / in calendar.xml so I don't think that is required.

I did some more tests tonight and I didn't pick up on the fact I was trying to connect to a test hub which was RIP only so I was getting a different error.

After adding myself to the RIP list I now see the sc_trans connects to the SHOUTcast DNAS v1 and streams for 30 seconds after which is gets disconnected by the DNAS? with the "30" second timeout error? sc_trans will not reconnect after this until I restart it either?

So is the SHOUTcast DNAS v1 for some reason incorrectly picking up the stream and flagging it as not playing then disconnecting or why is this happening?

Also why does sc_trans seemingly not reconnect to the DNAS after a disconnect?

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 11:34   #267
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
For me relaying a v1 dnas does not work without /;
sc_trans connects and then throws the timeout msg because the content-type
is returned as text/html.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 12:18   #268
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
For me relaying a v1 dnas does not work without /;
sc_trans connects and then throws the timeout msg because the content-type
is returned as text/html.
Weird works for me, I think I found my timeout 30 second issue as well. Which to me seems like a bug.

I added the "playlistfile" option and now the relay is fine? No disconnects after 30 seconds?

I tried to make just a blank playlist and that failed still says "playlist empty" in the console and the stream stops after 30 seconds.

I also tried pointing to a fake file in the playlist to trick it and that failed also still stops after 30 seconds.

I added a single mp3 and now all is fine.

If the sc_dnas does not find a song to play in the playlist it stops sending the stream data?

Also this may be using slightly more CPU as it may be playling the file in the background continuously even though I don't want to use a playlist?

Hopefully this can be fixed for next release

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 12:27   #269
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
There always needs to be at least one file in the playlist.
This even applies when using capture mode.

The guy (neil) who created this software,or at least made it what it is today
was let go by aol,I would not expect any updates soon.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 12:30   #270
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
There always needs to be at least one file in the playlist.
This even applies when using capture mode.

The guy (neil) who created this software,or at least made it what it is today
was let go by aol,I would not expect any updates soon.
Yeah I started getting the gist of that when reading through the thread but he mentioned there were others on the team?

I would like a feature request of making the Stream Title etc (Multi) so you can specify 1 per encode.

Other than that the small issue of having to have a playlist is fairly trivial.

EDIT:

Also maybe make the IRC use the irc:// protocol to make dynamic IRC links as opposed to the old method which doesn't seem to work at all these days?

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 12:34   #271
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
We will see what happens,remember the last version of sc_trans and its bugs
lasted about 10 years without an update.

Those bugs were minor ones too.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 12:44   #272
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
We will see what happens,remember the last version of sc_trans and its bugs
lasted about 10 years without an update.

Those bugs were minor ones too.
Didn't someone say they decompiled it? Maybe someone can build an unofficial version

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 13:03   #273
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
Never heard anything like that.

SC will miss neil's genius greatly,his influence on SC was amazing,
TAG loomis was a large part of the equation too,that guy retained his
passion for SC until he was canned,maybe he still does.I was always
impressed by both him and neil.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 13:11   #274
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
Never heard anything like that.

SC will miss neil's genius greatly,his influence on SC was amazing,
TAG loomis was a large part of the equation too,that guy retained his
passion for SC until he was canned,maybe he still does.I was always
impressed by both him and neil.
One thing I don't fully understand though is:

Was their sole jobs to work on SHOUTcast?

Because I mean in all honesty I find it hard to believe we have only made this much progress when the core has been around for so many years and I understand this is a "re-vamp" new protocols etc but in the end I guess I am a bit surprised that if they were dedicated resources how it takes so long to get to "Beta" builds given the time-frame we have seen?

I mean I can see Neil has tried to build a "testui" using Ajax etc and that the directory and things are new. Which is all cool and should be the way things are headed as it's more dynamic and flexible.

But if they just scrapped everything worked on a fresh project while borrowing the core components from the original SHOUTcast plus ideas from the Open Source alternatives that are available via Icecast etc. I don't see how it should have taken so long.

This is not meant to have a go at anyone or to be taken in the wrong way, I am just curious as to whether they SHOUTcast guys are dedicated resources and how many of them are there.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 13:35   #275
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
On an Off-topic question JKey:

I read you used to use the Linux streamTranscoder v3?

This is open-source yeah?

It can decode/encode aac+v2?

Can it by default either accept 2 input feeds (Automatic DJ + Scheduled DJ) while transcoding to say 3 different bitrates?

I was originally looking at streamTranscoder a number of years back.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 5th August 2010, 15:10   #276
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
I use my own transcoder for linux now, I developed it to meet my needs.
The aacplus encoder I created created was just an adapted version of libaacplus,
which is based on the available 3ggp reference code.

You can compile ffmpeg with this library too which can be useful in certain situations.

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 5th August 2010, 22:22   #277
Rothgar
Senior Member
 
Join Date: Jun 2001
Location: Victoria, B.C. Canada
Posts: 124
Send a message via ICQ to Rothgar Send a message via AIM to Rothgar
Quote:
Originally Posted by Jkey View Post
I use my own transcoder for linux now, I developed it to meet my needs.
The aacplus encoder I created created was just an adapted version of libaacplus,
which is based on the available 3ggp reference code.

You can compile ffmpeg with this library too which can be useful in certain situations.
Hmm I assume you don't give this out lol

I was thinking of paying someone a small amount to customize streamTranscoder v3, still tossing up whether it's worth it at this point.

Basically the sc_trans seems to do what I want as far as:

Have 2 feeds, one for an Automatic DJ and the other for live DJ's. With seemless transitions i.e. no "dead silence" it should pipe the data seamlessly when the DJ connects/disconnects.

The ability to prioritize DJ's is cool but not a major feature for me at the moment and the schedule idea is also very cool idea so you can allocate specific time slots.

I have so far been using aac+v2 so that is what I am mostly interested in at the moment and want to feed a single 128Kbit stream which is "relayed" to achieve 128Kbit, trans-coded to achieve 64Kbit and trans-coded for 32Kbit.

I want separate stream titles so that it says the "bitrate" in the titles like 128K, 64K etc to make it easier in directories to spot.

It would also be nice for changing the IRC link, however I am wondering if that is half related to the DNAS. As not specifying comes up as http://www.shoutcast.com/chat.phtml?dc=NA


The only other bug I came across in sc_trans is it said the "aacpbitstreamformat" was an invalid line?

I am not entirely sure what this achieves but I am curious as to how you currently configure the encoder for the Parametric Stereo, Independent Stereo etc options of AAC+v2 which would be nice to have also available.

Dawgclan Network
Genre: Rap/Hip-Hop
http://www.dawgclan.net
Rothgar is offline  
Old 6th August 2010, 12:36   #278
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
irc,icq,aim fields are not used in the shoutcast 2 protocol as far as I am aware.
I don't see a way to separate titles in the manor you describe with sc_trans.
The bitstream format is adts no other value works.
And as for the bitrate transcoding stuff you totally lost me,as I am high on pain
killers today because of tooth ache and a frozen shoulder

So Long, and Thanks for All the Fish.
Jkey is offline  
Old 6th August 2010, 14:16   #279
dannidj
Senior Member
 
dannidj's Avatar
 
Join Date: Jul 2004
Posts: 389
How do i get this Website thats come with SC-Trans to woork?
Betwen use aacp to encode with no prablome.
Here you can test my Stream with sc_trans 2 on Windows.

Daníel B. J. Guðrúnarson
Owner – Webmaster
Krúttin ehf
TAX Number – 131780
dannidj is offline  
Old 6th August 2010, 14:55   #280
Jkey
Forum King
 
Join Date: Jul 2004
Location: E*arth
Posts: 3,031
It is difficult to explain the web interface,if you do not understand the code or api that sc_trans uses for this feature.

All I can say is read everything until you understand,this can be hard I know.
Just keep on trying and never give up or think you cant do it !

So Long, and Thanks for All the Fish.
Jkey is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump