Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 15th August 2018, 20:21   #1
SoLoRiZe
Member
 
Join Date: Jul 2002
Location: UK
Posts: 83
Shoutcast stream buffering problem - possible cause pin pointed

Hi,

Over the past 5 months I have been having constant buffering problems on my
Shoutcast Streams. Which I think I have finally worked out where the problem could lie.

I have narrowed it down to the Windows 10, April 2018 Update (version 1803)
So just wondering if anyone else has had similar problems with buffering, since the
above Windows 10 update?


Background on my buffering problem and what I did to pinpoint where I think the problem is.

I have four Shoutcast streams that I run from my laptop at home using:
WinAMP: 5.666 Build 3516
DSP Plugin: 2.3.5 build 222
DNAS: 2.5.5.733
Shoutcast Streams:
256kbps MP3
128kbps MP3
64kbps AAC
12kbps AAC

I noticed that my 256kbps stream started buffering after approx. 5mins, every time
I connected. So I checked my 128kbps stream and that started to buffer after approx. 9mins.

With what I was seeing, it looked like it happened after a certain amount of data had been
sent. i.e. with the 128kbps (which is half the speed of the 256kbps stream), taking twice
the amount of time before the buffering occurred.

I also ran a continuous ping test to see if there were any latency problems.
I was getting: Pings ~8-20ms, so I ruled that being a problem.

I have plenty enough bandwidth for my required listeners slots, so know that is not a problem,
as have been running for years without this buffering problem. I have also checked my
router/modem connection speed and it still reports the same upload and download speed and
no problems reported. I also ran a speed test and that confirmed all was OK.

I tried switching from Wifi to wired Ethernet connection, but I still had the buffering problem.

I also turned off the router/modem for 2hours, turned it back on and had everything
connected back again, the buffering still occurred.

I flushed and renewed my DNS servers via ipconfig. Just on the off chance to see if that helped,
but it did not.

I then disabled all my streams, with the exception of the 256kbps stream.
Turned off my AntiVirus and Firewall and then rebooted my laptop.
Then tested again, but I still had the buffering problem.


Last-ditch attempt

After exhausting everything I could think of, I then decided to bite the bullet and restore
a previous backed-up 'disk image' of my whole system.

So after going incrementally back through all my backups I finally got to one that did not buffer
my streams, which I had taken back in March 2018 (Before this April Windows 10 update!)
So I let the system run for a couple of days and I did not experience any buffering, all worked
correctly and smoothly!

With everything looking good, I decided to step-through/install the various available Windows
updates to see if I started to get the buffering again... and low and behold! Once the
April 2018 Update (version 1803) was installed the buffering came back, so I had finally
pin pointed the culprit!


Conclusion

Now I am stuck as what to do, as I have dropped back to the working backup, but Windows 10
will automatically update me to the 1803 version at some point, and I will end up with the
buffering problem again.

I have looked online into the various ways to disable windows updates, but it looks like no
matter what you; edit/tweak etc.. Windows update will re-enable itself and force the updates.

From what I can see none of these are truly permanent ways of disabling the updates. And
even if I could do it permanently, this would mean my system would not get security fixes and
would gradually become vulnerable/unstable.


Lifeline?

So now I’m just hoping that someone on this forum know’s what in the Windows April 1803 update
may be affecting the shoutcast stream/buffer, and a possible fix/workaround etc.. that I can try.

Any help would be appreciated.

+.:: MRD Photography ::.+
http://www.mrdphotography.co.uk
SoLoRiZe is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
1803, buffering, windows 10

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump