Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 20th June 2012, 21:03   #1
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Post All Winamp 5.63 Official Plugin Bug Reports In This Thread

Report ALL Winamp 5.63 Plugin bugs in this thread ONLY.

ALL OTHER REPORTS WILL BE DELETED (YOU HAVE BEEN WARNED).

INCOMPLETE\LAME REPORTS (AKA: IMPOSSIBLE TO REPRODUCE) WILL BE IGNORED OR DELETED.



Here is a LIST of the Official Plugins and their Versions that shipped with 5.63

Input:
Nullsoft AVI Demuxer v0.7 [in_avi.dll]
Nullsoft CD Plug-in (MusicID 2.6) v3.92 [in_cdda.dll]
Nullsoft DirectShow Decoder v1.08 [in_dshow.dll]
Nullsoft FLAC Decoder v2.6 [in_flac.dll]
Nullsoft Flash Control Playback v1.1 [in_swf.dll]
Nullsoft Flash Video Decoder v1.4 [in_flv.dll]
Nullsoft LineIn plugin v3.12 [in_linein.dll]
Nullsoft Matroska Demuxer v0.7 [in_mkv.dll]
Nullsoft MIDI Player v3.5 [in_midi.dll]
Nullsoft Module Decoder v2.90 [in_mod.dll]
Nullsoft MP4 Demuxer v2.5 [in_mp4.dll]
Nullsoft MPEG Audio Decoder v4.98 [in_mp3.dll]
Nullsoft NSV Decoder v1.7 [in_nsv.dll]
Nullsoft Vorbis Decoder v1.6 [in_vorbis.dll]
Nullsoft Waveform Decoder v3.19 [in_wave.dll]
Nullsoft Windows Media Decoder v3.6 [in_wm.dll]

Output:
DirectSound Output v2.6 (d) [out_ds.dll]
WaveOut Output v2.13 (d) [out_wave.dll]
Nullsoft Disk Writer Plug-in v2.14 [out_disk.dll]

Visualization:
Advanced Visualization Studio v2.81d [vis_avs.dll] (reverted from v2.83)
MilkDrop v2.25 [vis_milk2.dll]
Nullsoft Tiny Fullscreen v2.12 [vis_nsfs.dll]

DSP/FX:
Nullsoft Signal Processing Studio DSP v0.39b [dsp_sps.dll]

CD Ripping Encoders:
FLAC Encoder 2.3 (libFLAC 1.2.1) [enc_flac.dll]
MP3 Encoder v1.36 [enc_lame.dll] (with lame_enc.dll 3.99.5)
MPEG-4 AAC Encoder v1.04 [enc_fhgaac.dll]
Ogg Vorbis Encoder v1.5 (aoTuV b6.03)
SHOUTcast MPEG-2 ADTS-AAC Encoder v1.04 [enc_fhgaac.dll]
WAV Encoder v1.02a [enc_wav.dll]
WMA Encoder v1.22a [enc_wma.dll]

General Purpose:
Nullsoft Global Hotkeys v1.91 [gen_hotkeys.dll]
Nullsoft Media Library v3.61 [gen_ml.dll]
Nullsoft Modern Skins Support v1.42 [gen_ff.dll]
Nullsoft Music User Database v1.0 [gen_orgler.dll]
Nullsoft Tray Control v2.41 [gen_tray.dll]
Jump To File Extra v1.2.5 (Build 1160) [gen_jumpex.dll]

Media Library:
Nullsoft Auto-Tagger v2.04 [ml_autotag.dll]
Nullsoft Bookmarks v1.21 [ml_bookmarks.dll]
Nullsoft Database Import/Export v2.4 [ml_impex.dll]
Nullsoft Device Manager v1.0 [ml_devices.dll]
Nullsoft Downloads v1.02 [ml_downloads.dll]
Nullsoft Format Converter v2.71 [ml_transcode.dll]
Nullsoft History v1.91 [ml_history.dll]
Nullsoft Local Media v3.04 [ml_local.dll]
Nullsoft Now Playing v3.9 [ml_nowplaying.dll]
Nullsoft Online Services v1.67 [ml_online.dll]
Nullsoft Playlist Generator v1.7 [ml_plg.dll]
Nullsoft Playlists v1.21 [ml_playlists.dll]
Nullsoft Podcasts v1.29 [ml_wire.dll]
Nullsoft Portable Music Player Support v1.32 [ml_pmp.dll]
Nullsoft Replay Gain Analyzer v1.2 [ml_rg.dll]
Nullsoft Rip & Burn v1.93 [ml_disc.dll]
Nullsoft Winamp Add-ons v1.1 [ml_addons.dll]

Portables:
Nullsoft Android Device Plug-in v1.6 [pmp_android.dll]
Nullsoft Creative NJB Plug-in v0.54 [pmp_njb.dll]
Nullsoft iPod Plug-in v0.84 [pmp_ipod.dll]
Nullsoft Microsoft PlaysForSure Plug-in v0.95 [pmp_p4s.dll]
Nullsoft USB Device Plug-in v1.5 [pmp_usb.dll]
Nullsoft Wi-Fi Device Plug-in v1.5 [pmp_wifi.dll]
Nullsoft ActiveSync Plug-in v0.18 [pmp_activesync.dll]

____________________________________________________________


Provide the following Information with every Report,
and with every CONFIRMATION of someone else's report:

Winamp 5.63 (5.6.3.3235) - clean install (with NO 3rd-party plugins)
Winamp Language Pack (if not using default English US)
Skin: eg. Bento, Winamp Modern, Winamp Classic (or all)
Windows OS, including Service Pack & Locale
System specs (mobo, cpu, ram)
Video Card, Video Card Drivers version
Sound Card, Sound Card Drivers version
DirectX version
Plugin (and version) affected by/causing the bug

A full, detailed, step-by-step method of reproduction

If applicable, also include Error Logs and/or FULL Error Messages.

The more information you provide US, the Faster we can or will help you.

To reproduce some bugs, we may also need a link to a zipped sample file
(eg. an .mp3, .aac, .wav, .mid file, etc, which exhibits the bug).
You can use stashbox.org, sendspace.com or mediafire.com for uploading, and then post the download link here. Note, if you have a Junior Member status, then submitted url's will only be visible to admins/mods.

If no-one responds, this does not mean that your report has been ignored. All posts are noted, even if no edit appears at the end of your post to say whether it has been reproduced or not.


Do NOT report ANY 3rd-party plugin bugs/issues here.
Report them to the author(s) instead and point them to the 5.55 SDK (more info)



Maintained by DJ Egg
DJ Egg is offline   Reply With Quote
Old 22nd July 2012, 22:24   #2
clockb0x
Junior Member
 
Join Date: Mar 2008
Posts: 6
Illegal characters not replaced when using Albumartist

This bug is in the pmp_usb.dll plugin. If you configure the file name format to include <Albumartist> rather than just <Artist>, Winamp does not do illegal character replacement and results in a failed transfer.

To reproduce:
  1. Configure a set of mp3s with the album artist tag set to "AC/DC", without quotes
  2. Set your music format to "...\<Albumartist>\<Album>\## - <Title>"
  3. Obtain a USB device formatted with FAT32
  4. Copy the songs to the device using "Send to" or "Sync", either way will fail

Similar behavior results with other illegal characters such as double quotes. Repeating the above steps with <Artist> instead of <Albumartist> will replace the illegal characters and transfer successfully.

This bug has been around since at least 5.6, which was the last time I tried to sync music using Winamp.

Winamp version: 5.63
OS: Windows 7 SP1
clockb0x is offline   Reply With Quote
Old 28th July 2012, 19:33   #3
Rapisho
Junior Member
 
Join Date: Jun 2011
Posts: 15
Winamp 5.63 (build 3235)
Clean install, no 3rd-party skins or plugins
Language Pack: German (Problem also occurs with English)
Skin: Bug occurs with all of Bento, Winamp Modern and Classic skins

OS: Windows 7 Professional (64-bit)
Locale: German
CPU: Intel i5 3570k @ 3.8GHz
Memory: 8GB RAM
Graphics: integrated
Sound: on board
DirectX11
Plug-In: Nullsoft Playlists v1.21 [ml_playlists.dll]

Problem:
Winamp does not open streams that are saved as playlist URLs (http://***.pls or http://***.m3u) in Media Library's imported playlists.
Error message: Error syncing to stream
Opening the same URL from bookmarks works.

Method of Reproduction:
1. Import a playlist that contains URLs to other playlists, sample playlist: http://www.mediafire.com/?8s838es2wfl31wi
2. Import the playlist in Media Library
3. Click on the imported playlist to view the streams/urls
3. Double click a stream/URL to a playlist file
Rapisho is offline   Reply With Quote
Old 29th July 2012, 17:12   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,601
Send a message via AIM to MrSinatra
Quote:
Originally Posted by clockb0x View Post
This bug is in the pmp_usb.dll plugin. If you configure the file name format to include <Albumartist> rather than just <Artist>, Winamp does not do illegal character replacement and results in a failed transfer.

To reproduce:
  1. Configure a set of mp3s with the album artist tag set to "AC/DC", without quotes
  2. Set your music format to "...\<Albumartist>\<Album>\## - <Title>"
  3. Obtain a USB device formatted with FAT32
  4. Copy the songs to the device using "Send to" or "Sync", either way will fail

Similar behavior results with other illegal characters such as double quotes. Repeating the above steps with <Artist> instead of <Albumartist> will replace the illegal characters and transfer successfully.

This bug has been around since at least 5.6, which was the last time I tried to sync music using Winamp.

Winamp version: 5.63
OS: Windows 7 SP1
wow, great catch. i wonder if this happens on droid too? winamp should change to use AA by default, then things like this wouldn't slip thru the cracks.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 30th July 2012, 17:07   #5
Hezer
Junior Member
 
Join Date: Jul 2012
Posts: 1
Portable devices playlist context menu

Right clicking a playlist on a portable device doesn't show context menu.
Works on Winamp 5.623 fine.

Tested with:
- Android (HTC Desire Z with Cyanogen 7) - Plugged with USB, haven't tested WIFI-Sync
- Apple iPod Nano (1st and 3rd gen)
- Apple iPod Classic (6th gen 160GB)
- Creative Zen X-Fi 16GB

Plugin: Portable Music Player Support (v1.32)
Winamp 5.63 (clean install, without 3rd-party plugins)
Skin: Bento
OS: Windows 7 Ultimate x64 SP1
System specs:
Asus Sabertooth P67
Intel Core i7 -2600K
12264MB Kingston HyperX 1600MHz
Video Card: Nvidia Geforce GTX570 (295.73 drivers) and DirectX 11
Sound Card: Creative Sound Blaster X-Fi Titanium (PAX Driver Suite V2.00)

Couldn't find that this was reported or known.
Hezer is offline   Reply With Quote
Old 7th October 2012, 23:47   #6
tlochner
Junior Member
 
Join Date: Mar 2010
Posts: 3
Found a Bug ...
Specifics Win7 x64 SP1, winamp 5.63, milkdrop visualization, using big bento or bento skin,
options ... Set auto start visualization when music starts
and when it starts ... the visualization window is blank or half size, visualization does
not start.
this may not happen to an admin account but sometimes it does.
it does always happen to the other stnd user accounts.

seems to work with classic skin, since classic skin must pull up its own window.
it appears to work ok when not in the big main window, but the big main window has the problem.

tony
tlochner@yahoo.com
tlochner is offline   Reply With Quote
Old 19th October 2012, 16:14   #7
fredj123
Junior Member
 
Join Date: Oct 2012
Posts: 1
Playlist Generator hickup

While scanning my Library with the ml_plg v1.7 winamp just crashes at phase 4/4 - each time at the same file # 265.

Operating System: Windows 7 Professional 64Bit
CPU: Intel Core i7
RAM: 32 GB

Winamp Version: 5.63 Pro (clean install without any third party plugin)
Plugin: Nullsoft Playlist-Generator v 1.7

Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: winamp.exe
Anwendungsversion: 5.6.3.3235
Anwendungszeitstempel: 4fec7b3e
Fehlermodulname: CddbMusicIDWinamp.dll
Fehlermodulversion: 2.6.206.203
Fehlermodulzeitstempel: 4bc506d8
Ausnahmecode: c0000005
Ausnahmeoffset: 00003ece
Betriebsystemversion: 6.1.7601.2.1.0.256.48
Gebietsschema-ID: 1031
Zusatzinformation 1: 0a9e
Zusatzinformation 2: 0a9e372d3b4ad19135b953a78882e789
Zusatzinformation 3: 0a9e
Zusatzinformation 4: 0a9e372d3b4ad19135b953a78882e789

The crash always happens at file #265 so it MIGHT be that I have a defective file in my library... how can I find out which file it is that leads to the winamp crashy behaviour?
After the crash the Gracenote database in %app_data%\Roaming\Winamp\Plugins\Gracenote is defective leading to "Unable to initialize plugin" error on opening the ml_plg settins dialog and hitting the "scan" button. Deleting the database files fixes the unable to initialize... only to lead to the crash at phase 4 scanning of file #265 ...

Already tried to (temprorarily) deactivate antivirus software, run winamp "as administrator"... without any change in winamp's behaviour.
fredj123 is offline   Reply With Quote
Old 31st October 2012, 05:27   #8
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,008
Send a message via Skype™ to thinktink
in_wave giving me fits when I hit stop button on any disk writer output plugin.

Steps to reproduce:
  1. Select any disk writer output plugin (even the official Nullsoft one does this.)
  2. Play a WAV file.
  3. Hit stop button before playback finishes.
What happens is Winamp won't stop playback, the WAV input plugin still keeps chugging even though Winamp appears completely frozen and unresponsive. After in_wave has finished processing the entire file Winamp finally unfreezes.

I've been working on my own custom disk writer plugin and for the longest time I thought it was my fault until I moved on to testing my plugin with a longer mp3 file and noticed that Winamp didn't hang when I hit stop in the middle of playback. I then went back to WAV files and it returned. I then installed Winamp into a new folder with no 3rd party plugins (including my own) and tested everything I could with the official disk writer plugin. All the file types except WAV behaved normally, WAV files would freeze the Winamp UI until it had processed the entire file.

It also does the same thing with seeking, in_wave will not seek if you have a disk writer output plugin selected. It didn't hang Winamp so it's not a big issue with me but I tested it while I had my disk writer plugin under the debugger. I noticed that the calls to flush() weren't happening until after in_wave finished processing the file.

It's seems as if in_wave isn't giving itself an opportunity to detect commands when it's allowed to dump all the buffers it can into the output plugin (as it would be in the case of disk writer plugins) whereas all the other plugins I was able to test do.

Screenshot of hang after hitting stop, Nunzio log, HJT log, and dxdiag log attached in zip archive.
Attached Files
File Type: zip bugreport.zip (70.4 KB, 211 views)
thinktink is offline   Reply With Quote
Old 2nd November 2012, 19:07   #9
sanyin
Junior Member
 
Join Date: Nov 2012
Posts: 5
aac quality

Encoding aac at any bitrate/quality/mode produces aac files of doubtfull quality. Tested with pure sine wave. They sound correct, but spectral display (audition) shows some strange "peaks" which souldn't be there, compared to other aac encoders (nero). I know they sounds good, but anyway...
sanyin is offline   Reply With Quote
Old 27th January 2013, 17:59   #10
bbgun06
Junior Member
 
Join Date: Jan 2013
Posts: 3
Nullsoft Tiny Fullscreen does not work

Winamp 5.63 (5.6.3.3235) - clean install (with NO 3rd-party plugins)
Skin: all, but it briefly worked under Bento - see below
Windows 7 Professional x64 SP1
System specs: ASUS P6T mobo, Intel Core i7 CPU 920 @ 2.67GHz
Video Card: nVidia GeForce GTX 680, Video Card Drivers version: 310.90
Sound Card: On-board HD audio
DirectX version: 11.0
Plugin (and version) affected by/causing the bug: Nullsoft Tiny Fullscreen v2.12 [vis_nsfs.dll]

Problem: NTF only shows a black screen when it is started. An error message appears in the background, which states: "Plug-in executed illegal operation. Restart of Winamp is recommended (2)" If you hit escape to exit the visualization, the message disappears, but you can see it using alt-tab. It does the same in every skin, however it did partially work under Bento by clicking on the Visualizations tab. The colors of the voiceprint were completely wrong, ex instead of reds and oranges it was random colors. It worked exactly once under Bento, and restarting did not help.

1. Start Winamp.
2. Play a song.
3. Click Options -> Visualization -> Select Plugin...
4. Select Nullsoft Tiny Fullscreen and any plugin module.
5. Click Start.
bbgun06 is offline   Reply With Quote
Old 27th May 2013, 06:07   #11
hvdheijden
Junior Member
 
Join Date: May 2013
Posts: 2
Crash after transferring certain ogg/m4a files to Android device

Winamp 5.63.3235 clean install, no 3rd party stuff, Bento skin
Windows 7 Enterprise SP1 64bit, up-to-date
Locale: German
Core i5-3450, 8GB RAM
Android device: Huawei G330 [USB]


When transferring specific ogg files to my Android device, Winamp crashes after transferring the file correctly.
Happens both when transcoding and not transcoding.
Reproducible every time.


Can be reproduced with ogg file created with vorbistools-1.2.0 (win32):
1 second silent wav input, title and artist tags set to "Winamp Test".
Test file download: http://www.sendspace.com/file/02mm11

I have several ogg files which cause this crash,
I have several ogg files which DO NOT cause this crash.
I have one m4a file which causes the same crash.


Steps to reproduce:
- connect Android device via USB: SD cards on I: and J:
J:\Winamp directory not existing, audio files in j:\Music existing
- start clean install of Winamp 5.63
- make Winamp manage J: device (known crash issue here)
- add ogg audio file from explorer to playlist via drag-n-drop
- drag'n'drop track from playlist to "Android drive J:"

Winamp transfers the file completely, then crashes.

My debugger give the following information with break-on-exception-thrown:
(Winamp itself does not catch the exception, goes directly to runtime,
see below)

First-chance exception at 0x07051efc in winamp.exe:
0xC0000005: Access violation reading location 0x00000000.

07BB1EF5 push edx
07BB1EF6 push dword ptr [ebp+8]
07BB1EF9 mov dword ptr [ebp-4],eax
07BB1EFC mov eax,dword ptr [ecx] <--
07BB1EFE call dword ptr [eax]
07BB1F00 test eax,eax

EAX = 072BFC90 EBX = 04ED3DE8 ECX = 00000000 EDX = 072BFC78
ESI = 07BB92AC EDI = 00000000 EIP = 07BB1EFC
ESP = 072BFC4C EBP = 072BFC70 EFL = 00010216

Call stack:
> pmp_android.dll!07bb1efc()
[Frames below may be incorrect and/or missing, no symbols loaded for pmp_android.dll]
pmp_android.dll!07bb11b0()
pmp_android.dll!07bb336e()
ml_pmp.dll!07a729e1()
ml_pmp.dll!07a72fab()
winamp.exe!00467197()
winamp.exe!0046756e()
kernel32.dll!@BaseThreadInitThunk@12() + 0x12 bytes
ntdll.dll!___RtlUserThreadStart@8() + 0x27 bytes
ntdll.dll!__RtlUserThreadStart@8() + 0x1b bytes

Relevant modules:
pmp_android.dll 07BB0000-07BC2000
ml_pmp.dll 07A60000-07A9F000
winamp.exe 00400000-00632000 (Version 5.06.3.3235)
hvdheijden is offline   Reply With Quote
Old 27th May 2013, 19:20   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
hvdheijden: can you see if it still happens with the 5.7 beta (see http://forums.winamp.com/showthread.php?t=356750), if so then if you can provide the crash dump which can be generated, that will make things easier to try to track down the cause of the issue.
DrO is offline   Reply With Quote
Old 1st June 2013, 14:03   #13
hvdheijden
Junior Member
 
Join Date: May 2013
Posts: 2
With Winamp 5.7 Beta, build 3392, I cannot reproduce such crashes. Seems to be fixed.
hvdheijden is offline   Reply With Quote
Old 15th June 2013, 21:52   #14
MBaldassari
Junior Member
 
Join Date: Oct 2006
Location: MA
Posts: 6
Abnormal program termination

Winamp 5.63 Classic Skin
Windows 7 Professional Service Pack 1
AMD Phenom II N640 Dual-Core Processor 2.90 GHz
4.00 GB RAM
64 bit OS

Program functions normally but on restart of Winamp displays old playlist regardless of changes.
Tried clearing playlist, adding new playlist, saving new playlist. Makes no difference.
Cleared out Library and replaced with music from a new folder. Winamp Library remembers all the changes when you restart the program.
On exit receive "Microsoft Visual C++ Runtime Library" window with the following message: Runtime Error! Program: C:\Program Files (x86)\Winamp\winamp.exe abnormal program termination". Must click OK to close error window.
MBaldassari is offline   Reply With Quote
Old 15th June 2013, 21:58   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
try the 5.7 beta (http://forums.winamp.com/showthread.php?t=356750) and if that doesn't help, provide a plug-ins list (http://forums.winamp.com/showthread....161361#plugins) and any crash reports (if any are able to be generated).
DrO is offline   Reply With Quote
Old 16th June 2013, 01:22   #16
MBaldassari
Junior Member
 
Join Date: Oct 2006
Location: MA
Posts: 6
Quote:
Originally Posted by DrO View Post
try the 5.7 beta (http://forums.winamp.com/showthread.php?t=356750) and if that doesn't help, provide a plug-ins list (http://forums.winamp.com/showthread....161361#plugins) and any crash reports (if any are able to be generated).
Installed the 5.7 beta version and the problem appears to be fixed
The only plugin at the time was PaceMaker.
I DJ with a Windows 8 computer: no problems of any kind.
This Windows 7 computer is dedicated to another function but I treat it as a music backup computer.
Never had this problem with XP or, originally, with Windows 7.
Thanks for your help.
MBaldassari is offline   Reply With Quote
Old 16th June 2013, 16:05   #17
DrO
 
Join Date: Sep 2003
Posts: 27,873
that's good to know it's fixed with the beta build as there's been a number of fixes for issues on closing so is good to see them working for such scenarios as yours.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump