Old 12th May 2008, 20:31   #1
misterguy8
Junior Member
 
Join Date: Nov 2007
Posts: 25
MP4 Video Playback Doesn't Work, Only Sound

My MP4 videos do not play on Winamp. I have the latest version 5531 for winamp.

I get sound but no video.

I know there was something about this on a post from 2003, but I'm not about to use the codecs sugested there since they more than half a decade old.

Please help me figure out how to make winamp play these videos. How do I get and install the codecs needed?

Thanks!
misterguy8 is offline   Reply With Quote
Old 12th May 2008, 22:02   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
http://forums.winamp.com/showthread....id=155680#mp4v <-- click!

Summary:
1. Install latest Gabest MP4 Splitter
2. Install latest SSE version of FFDShow
3. Make sure H.263, H.264, Other MPEG-4 (and any others of your choice) are enabled in ffdshow video decoder config.
4. Remove MP4 from in_mp4 config
5. Add MP4;M4V;MOV to in_dshow config

See above link for details & download url's
DJ Egg is offline   Reply With Quote
Old 12th May 2008, 22:11   #3
misterguy8
Junior Member
 
Join Date: Nov 2007
Posts: 25
Thank you DJ Egg.

I am concerned that the files may be corrupted if use this recommended course of action, or that they will no longer play back on my Archos 605 device because the video files will be altered from their original state after following these instructions.
misterguy8 is offline   Reply With Quote
Old 12th May 2008, 22:46   #4
misterguy8
Junior Member
 
Join Date: Nov 2007
Posts: 25
GOM Media Player works

forget it. too complicated. should just work. hopfully next release has it installed and working right off with no need to do a long list of tweaks.

GOM Media player is totally free and totally works. Very simple, but very good.
misterguy8 is offline   Reply With Quote
Old 12th May 2008, 22:58   #5
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
The files will not be modified in any way whatsoever. They will still be MP4 videos.
And Winamp doesn't write any metadata for formats associated with in_dshow anyway.

It's quite simple to setup really. Only takes a few minutes.

And no, I very much doubt that we'll be supporting MP4 video natively in the next release, because it would involve us applying for and purchasing a license for h.264 decoding first...

http://www.mpegla.com/news/n_03-11-17_avc.html
Quote:
Above 5 million units per year, the royalty is US $0.10 per unit
I think we get more downloads than that per month (with each new release),
so 5M x 10c = $500K/month ???
Quote:
The maximum royalty for these rights payable by an Enterprise (company and greater than 50% owned subsidiaries) is $3.5 million per year in 2005-2006, $4.25 million per year in 2007-08 and $5 million per year in 2009-10
So yeah, $5 million a year just for MP4 video support. Groovy! :-D
DJ Egg is offline   Reply With Quote
Old 12th May 2008, 23:06   #6
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
And just because someone does something for free, doesn't mean are doing it legally. Or even an American based company. AOL/Nullsoft, is an American company with laws and royalties and patents to deal with. "Not sued yet" is not the same thing as free and legal.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 19th May 2008, 05:28   #7
anneli000
Junior Member
 
Join Date: May 2008
Location: USA
Posts: 1
So, I just went through the steps and I was a little confused about the settings that you wanted changed. They were Winamp settings, not FFDShow settings. In the end, I've got my Mac-ripped mp4 files playing on my QuickTime player. I guess the Winamp settings were locking up the files so QT couldn't play the files in the first place.

Anyway, I'm happy. My files are playing.
anneli000 is offline   Reply With Quote
Old 14th July 2008, 20:42   #8
wiiiindy
Junior Member
 
Join Date: Jul 2008
Posts: 1
I followed the steps previously in this forum (see below). Now the video window opens when I try to play some MP4 files (before it didn't) but it remains gray while the sound plays - still no video. Other MP4 files play fine. Same for MPG files, some are ok, some no window opens, some get a window but no video. Sound is always fine.

All AVI, MPV, and MPEG files so far play fine.

Help appreciated.

Dell XPS Win XP WP2 fully patched.
128mb DDR ATI Radeon 9800
Winamp 5.54
Mcafee anti-virus (only).
=======================================
Summary:
1. Install latest Gabest MP4 Splitter
2. Install latest SSE version of FFDShow
3. Make sure H.263, H.264, Other MPEG-4 (and any others of your choice) are enabled in ffdshow video decoder config.
4. Remove MP4 from in_mp4 config
5. Add MP4;M4V;MOV to in_dshow config
wiiiindy is offline   Reply With Quote
Old 14th July 2008, 21:17   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
As MP4 is just a container format, the container can virtually contain just about anything. You'll need to find out what the actual video codec used inside the container is, then make sure said codec is enabled in ffdshow video decoder config.

You can use MediaInfo or G-Spot to find said information
http://mediainfo.sourceforge.net
http://www.free-codecs.com/download/GSpot.htm
DJ Egg is offline   Reply With Quote
Old 20th August 2008, 20:43   #10
Klaasmans
Junior Member
 
Join Date: Sep 2007
Posts: 3
The solution from DJ Egg regarding this problem worked fine. I now can watch the mp4-files within Winamp. Thank you DJ Egg!
Klaasmans is offline   Reply With Quote
Old 1st February 2009, 22:07   #11
milomilo963
Junior Member
 
Join Date: Feb 2009
Location: Bogotá
Posts: 1
thanks :)

Thanks

Grand job
milomilo963 is offline   Reply With Quote
Old 16th October 2015, 00:03   #12
Topaznz4
Junior Member
 
Join Date: Oct 2015
Posts: 1
Thanks Heaps
Topaznz4 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump