Old 18th February 2006, 12:20   #1
Mighty
Junior Member
 
Join Date: Nov 2000
Location: Israel
Posts: 10
Winamp with windows XP professional

I am using windows MP professional
My problem is when I insert a audio cd
I have a player syberlink powerdvd that plays audo disks also.
My windows program is installed in disk C
Now I installed winamp v5.13 in disc D
When I insert a disc it began to play with the syberlink poweredvd program.
I changed it and now I get a screen that windows gives me a choice to prefer programs such as cyberlink dvd, mediaplayer, to go to the music folder or not to take any action.
As I think, the winamp program should be de default program as I installed it the last, and I can not see it in the prefered programs.
If I double click a winamp file the winamp plays it, but the problem is when I insert a audio cd.

mabe I must install the winamp in the same directory as windows?
Please Help me
thanks
Mighty is offline   Reply With Quote
Old 18th February 2006, 13:28   #2
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Is "Launch Winamp for Audio CDs" checkmarked in Winamp > Prefs > File Types?

If the problem persists, you can use the registry fix from here:
http://forums.winamp.com/showthread....47#post1668247
DJ Egg is offline   Reply With Quote
Old 23rd February 2006, 10:04   #3
Mighty
Junior Member
 
Join Date: Nov 2000
Location: Israel
Posts: 10
Re: Winamp with windows XP professional

Quote:
Originally posted by Mighty
I am using windows MP professional
My problem is when I insert a audio cd
I have a player syberlink powerdvd that plays audo disks also.
My windows program is installed in disk C
Now I installed winamp v5.13 in disc D
When I insert a disc it began to play with the syberlink poweredvd program.
I changed it and now I get a screen that windows gives me a choice to prefer programs such as cyberlink dvd, mediaplayer, to go to the music folder or not to take any action.
As I think, the winamp program should be de default program as I installed it the last, and I can not see it in the prefered programs.
If I double click a winamp file the winamp plays it, but the problem is when I insert a audio cd.

mabe I must install the winamp in the same directory as windows?
Please Help me
thanks
The problem was solved but I can not see the icon of the winamp
Please help me to put the icon so I can see it


thanks
Mighty is offline   Reply With Quote
Old 23rd February 2006, 12:02   #4
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
The registry fix should've fixed that (did you use it?)

As far as I know, those same registry keys are also auto created if you checkmark "Associate with Audio CDs" on Screen 5 of the Installer Options
DJ Egg is offline   Reply With Quote
Old 23rd February 2006, 12:55   #5
Mighty
Junior Member
 
Join Date: Nov 2000
Location: Israel
Posts: 10
Re: Re: Winamp with windows XP professional

Quote:
Originally posted by Mighty
I was not understod
At the desktop I can see the icon but in the square that windows opens there are players that I can chose to use.
For example there is windows media player and I can see the icon, there is written play with winamp but there is no icon, so I would like to see the icon inthere
thanks
Attached Images
File Type: jpg winamp1.jpg (13.5 KB, 79 views)
Mighty is offline   Reply With Quote
Old 23rd February 2006, 13:32   #6
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
I guess that's because you didn't install Winamp to the default location of
C:\Program Files\Winamp\winamp.exe

You'll need to manually edit the autoplay.reg file in Notepad
and change this line to point to where winamp.exe is located

"DefaultIcon"="%ProgramFiles%\\Winamp\\winamp.exe,0"

eg. if Winamp is installed at C:\Winamp then change it to

"DefaultIcon"="C:\\Winamp\\winamp.exe,0"

or if it was installed to D:\Programme\Winamp then change it to

"DefaultIcon"="D:\\Programme\\Winamp\\winamp.exe,0"

etc

Save the edited .reg file then run it again.

Or if you're comfortable with manually editing the registry, you can edit this string value accordingly:

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers\WinampPlayMediaOnArrival

String:
"DefaultIcon"=
DJ Egg is offline   Reply With Quote
Old 23rd February 2006, 17:00   #7
Mighty
Junior Member
 
Join Date: Nov 2000
Location: Israel
Posts: 10
I did as you told me and it did not help so I decided to unistall the winamp and install in the default driver and the default folder, and it became ok
I whant to thank you for your kindness and pacience
I am very glad to be a part of such forum
Mighty
Mighty is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump