Old 20th July 2010, 12:57   #1
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
help with [yp_add] error connecting to yp.shoutcast.com

HI I need help resolving this issue. i have opened the ports on my router tcp and udp for ports 8000, 8001, and 80. I used all resources to clear up the nak error I was receiving. i finally sent the yp to 666. this cleared that up. But I cannot clear up the error connecting to yp.shoutcast.com. Most of the threads state to wait, its been 3 days. Any help is appreciated.

Thanks

Event log
<07/20/10@07:41:04> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<07/20/10@07:41:04> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<07/20/10@07:41:04> [main] initializing (usermax:32 portbase:8000)...
<07/20/10@07:41:04> [main] No ban file found (sc_serv.ban)
<07/20/10@07:41:04> [main] No rip file found (sc_serv.rip)
<07/20/10@07:41:04> [main] opening source socket
<07/20/10@07:41:04> [main] source thread starting
<07/20/10@07:41:04> [main] opening client socket
<07/20/10@07:41:04> [source] listening for connection on port 8001
<07/20/10@07:41:04> [main] Client Stream thread [0] starting
<07/20/10@07:41:04> [main] client main thread starting
<07/20/10@07:42:07> [source] connected from 192.168.1.102
<07/20/10@07:42:07> [source] icy-name:Gully Radio: Freshest Hip Hop And R&B ; icy-genre:Rap
<07/20/10@07:42:07> [source] icy-pub:1 ; icy-br:48 ; icy-url:http://www.Gully-Radio.com/redirect.....shoutcast.com
<07/20/10@07:42:07> [source] icy-irc:#shoutcast ; icy-icq:0 ; icy-aim:N/A
<07/20/10@07:42:29> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:42:51> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:43:13> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:43:36> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:43:58> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:44:20> [yp_add] error connecting to yp.shoutcast.com
<07/20/10@07:44:42> [yp_add] error connecting to yp.shoutcast.com
Coreldavid is offline   Reply With Quote
Old 20th July 2010, 14:05   #2
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
You have a firewall or software that is blocking outbound port 666. When you fix it, the nak error will most likely return. So my suggestion is to change YPORT back to 80, and then work to eliminate the original nak error.

http://www.bbnlive.com/shoutcast-firewalls.asp
dotme is offline   Reply With Quote
Old 21st July 2010, 03:17   #3
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
i have opened all ports on the router. if you click on the thumbnail below you will see. i even shut of my firewall and turned off all AV, and still nothing.

[IMG][/IMG]
Coreldavid is offline   Reply With Quote
Old 21st July 2010, 03:19   #4
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
Btw I did correct the 192 to 102.
Coreldavid is offline   Reply With Quote
Old 21st July 2010, 04:29   #5
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
in the port forwarding guide, it states to give the server a static ip, it would have to be an ip that the router gives out.

http://portforward.com/english/route.../ShoutCast.htm

any thoughts?
Coreldavid is offline   Reply With Quote
Old 21st July 2010, 04:47   #6
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Static private IP is best. Why? Because you forwarded ports to 102 and if the router gives the PC a new IP (like 103) you will break the port forwarding.

By the way your image shows a problem. And too many open ports.

Delete the two 80 and two 666 entries. They are not necessary. Also delete the UDP entry for 8000 (also unnecessary)

That should leave you with the TOP entry, which needs to be modified. You need to have 8000 for both internal and external port.

Make the changes, restart the server, hook up a source (stream to it) and check log for any errors. If you get errors post 'em
dotme is offline   Reply With Quote
Old 21st July 2010, 06:28   #7
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
ok, that worked. I know see this.

<07/21/10@01:23:41> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<07/21/10@01:23:41> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<07/21/10@01:23:41> [main] initializing (usermax:32 portbase:8000)...
<07/21/10@01:23:41> [main] No ban file found (sc_serv.ban)
<07/21/10@01:23:41> [main] No rip file found (sc_serv.rip)
<07/21/10@01:23:41> [main] opening source socket
<07/21/10@01:23:41> [main] source thread starting
<07/21/10@01:23:41> [main] opening client socket
<07/21/10@01:23:41> [source] listening for connection on port 8001
<07/21/10@01:23:41> [main] Client Stream thread [0] starting
<07/21/10@01:23:41> [main] client main thread starting
<07/21/10@01:23:41> [source] connected from 127.0.0.1
<07/21/10@01:23:42> [source] icy-name:Gully Radio: Freshest Hip Hop And R&B ; icy-genre:Rap
<07/21/10@01:23:42> [source] icy-pub:1 ; icy-br:48 ; icy-url:http://www.Gully-Radio.com/redirect.....shoutcast.com
<07/21/10@01:23:42> [source] icy-irc:#shoutcast ; icy-icq:0 ; icy-aim:N/A
<07/21/10@01:23:42> [dest: 64.12.243.203] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<07/21/10@01:23:42> [dest: 64.12.243.203] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 8192}(P: 0)
<07/21/10@01:23:43> [yp_add] yp.shoutcast.com added me successfully

but why do I not see my station? on www.shoutcast.com?
Coreldavid is offline   Reply With Quote
Old 21st July 2010, 06:33   #8
Coreldavid
Junior Member
 
Join Date: Jul 2010
Posts: 7
BTW, i set a few sample songs from the source to loop. The site is

http://70.181.39.42:8000/
Coreldavid is offline   Reply With Quote
Old 21st July 2010, 13:56   #9
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Quote:
Originally Posted by Coreldavid View Post
ok, that worked. I know see this.

<07/21/10@01:23:41> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<07/21/10@01:23:41> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<07/21/10@01:23:41> [main] initializing (usermax:32 portbase:8000)...
<07/21/10@01:23:41> [main] No ban file found (sc_serv.ban)
<07/21/10@01:23:41> [main] No rip file found (sc_serv.rip)
<07/21/10@01:23:41> [main] opening source socket
<07/21/10@01:23:41> [main] source thread starting
<07/21/10@01:23:41> [main] opening client socket
<07/21/10@01:23:41> [source] listening for connection on port 8001
<07/21/10@01:23:41> [main] Client Stream thread [0] starting
<07/21/10@01:23:41> [main] client main thread starting
<07/21/10@01:23:41> [source] connected from 127.0.0.1
<07/21/10@01:23:42> [source] icy-name:Gully Radio: Freshest Hip Hop And R&B ; icy-genre:Rap
<07/21/10@01:23:42> [source] icy-pub:1 ; icy-br:48 ; icy-url:http://www.Gully-Radio.com/redirect.....shoutcast.com
<07/21/10@01:23:42> [source] icy-irc:#shoutcast ; icy-icq:0 ; icy-aim:N/A
<07/21/10@01:23:42> [dest: 64.12.243.203] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<07/21/10@01:23:42> [dest: 64.12.243.203] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 8192}(P: 0)
<07/21/10@01:23:43> [yp_add] yp.shoutcast.com added me successfully

but why do I not see my station? on www.shoutcast.com?
Outstanding!! You got there. It can take a while (sometimes as short as 5 min, or as long as a couple of hours) to actually appear in the YP directory.

But that's a flawless logfile. Congratulations.
dotme is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump