Old 14th November 2010, 05:09   #1
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
WinAMP Crashes

I'm pretty pissed off. I don't mean to point the finger or place blame on anyone, but this is an issue that has come up recently, and now it has turned into a big problem.

Lately, WinAMP has been crashing A LOT. It started with syncing my iPod with an add-on I had installed. (Found here:http://sourceforge.net/projects/mlipod/)

When I would go to add a song to my iPod, it would start to sync.... freeze, then crash. After a reinstall of both winamp AND this add-on, everything worked fine again. This issue would happen every so offten, but was manageable as this plug in made album artwork work on my iPod as well as fixing other issues, such as the situation where my iPod would say it's playing one song, but play another.

Then the add-on had failed again, so I go to reinstall everything and WinAMP keeps crashing, when I plug my iPod in PERIOD. So I preform a fresh reinstall by completely removing winamp from my computer, then installing again. That worked. But I go to install the add-on, and winamp crashes. But this time, the crash was different. Windows would say the program has stopped responding and I would select close, but winamp wouldn't close. Even if I went into Task Manager and tried to end the process, winamp just wouldn't close. I tried logging off, then logging back on, but the winamp window would still be open! If I moved the cursor over it, it would show the clocking cursor, when I moved away, it would be the normal pointer. And the rest of the computer worked fine. The only way I was able to get it to close out, was to restart the computer. My computer shuts down quickly normally, but with this issue, my computer took forever to shut down. I tried, to experiment, uninstalling winamp, and restarting, and my computer restarted quickly as it should have. This leads me to believe that winamp was fighting to close as the computer was trying to shut down.

After a few repeated attempts of removing winamp fully, and starting fresh without the add-on, and winamp began to work again! But.... when I go to plug in my iPod, winamp crashes...fun stuff. At this point, I had to run out the door. So I unplugged my iPod (ejecting it before hand of course) and headed out. When I went to go listen to it on the road.....ummmm....where did all my music/pictures/movies go? Winamp had crashed, and looks like it took my iPod down with it.

After uninstalling winamp a final time, I decided, perhaps my iPod has become corrupt? I install iTunes. (for the first time since I go this iPod) I hate iTunes, and the funny thing is, I would open iTunes, plug my iPod in, and ITUNES would crash. Well that's cool. So I have no way of reformatting my iPod, so I was forced to use the Windows formatting way. (right clicking the devince in My Computer, and hitting format)

After that, WHOO HOO, iTunes is able to tell my that my iPod needs to be formatted. So I format my iPod and everything is dandy.

A few days later, surviving without music, I decide to try to install winamp again, without that add-on.

SUCCESS! Everything is working fine now, I have my media library back, all my settings that I like applied, and all my playlists set back up. I plug my iPod, and it works!

But what's this? I try to add a playlist and Winamp crashes. WHAT THE TRUCK!?! It has only let me add to small playlists prior to it freezing just now, it'll freeze when I try to add other playlists. These aren't big playlists either. About 18 songs each. But winamp still hates me.

My computer is virus free, and malware free. I have scanned my iPod, as well as the rest of my system over and over, and came back with nothing. I have even preformed a CHKDSK on my C drive, and still had this problem.

My PC Specs are:


OS: Win7 Pro (64-bit)
Anti-Vurs: avast! 5
Malware protection: Malwarebyte's
Processor: Intel Core 2 Quad
RAM: 8GB
HD Size: 1TB
iPod: iPod Classic 6G (160GB)
iPod firmware: 2.0.4





Please help me, I just wanna listen to Music. :'(
EmperorOfNight is offline   Reply With Quote
Old 14th November 2010, 08:16   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Hi. That's quite a story....

So Winamp is still crashing when adding playlists to your iPod?
And you're still using the unsupported 3rd-party ml_ipod plugin?

What version of Winamp?
Is it 5.581?

5.59 Beta has improved native support for newer iPod Classic models
and also has a few related bug fixes...

Note that ml_ipod & iTunes are incompatible with each other, as stated on the ml_ipod homepage.
If you still want to use ml_ipod however, you'd be best posting in the ml_ipod forum instead.
DJ Egg is offline   Reply With Quote
Old 14th November 2010, 19:28   #3
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
I am not using that add-on (3rd-party ml_ipod plugin) any more, I am using strictly whatever WinAMP comes installed with. And I do have the latest version of WinAMP. I'm worried about trying a beta, cause I don't want that to crash on me too, but... where would I obtain it?
EmperorOfNight is offline   Reply With Quote
Old 26th November 2010, 14:56   #4
hanneu
Junior Member
 
Join Date: Dec 2009
Location: Berlin, Germany
Posts: 7
Hello,
I have also some similar problems - everything was working fine between my ipod and winamp, until I updated to the last version - it was crashing all the time, when I try to sync. Also Winamp is crashing, when I try to add big amounts to the music library. So I tried to reinstall the prelast version, after cleaning my registry and everything. But still, Winamp has Problems to deal with more than 100 songs at a time. So i fed my library bit by bit and i am doing it also with my ipod ... I have now Winamp 5.572, windows xp.
Weird stuff ...
hanneu is offline   Reply With Quote
Old 27th November 2010, 20:50   #5
ainstalls
Junior Member
 
Join Date: Nov 2010
Posts: 9
i'm having similar problems. I do a little bit of djing. i work off of a external hardrive with over 100000 songs on it. My playlist is about 20000 songs. at least twice in each night Winamp freezes in the middle of songs.Not sure if my playlist is to big for this or what. My laptop is only a week old with windows 7 and a fast processor. Anyone have any ideas on how to help me with this issue. I am running the newest winamp.
ainstalls is offline   Reply With Quote
Old 27th November 2010, 21:41   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
http://forums.winamp.com/showthread....161361#plugins is needed.

-daz
DrO is offline   Reply With Quote
Old 28th November 2010, 12:02   #7
hanneu
Junior Member
 
Join Date: Dec 2009
Location: Berlin, Germany
Posts: 7
I only installed ml_ipod plugin after the one which came with winamp didn't worked. It crashed everytime I tried to sync, but so does the ml_ipod too, so i didn't help. The threshold seems to be around 230 songs, if i try to sync more it crashes.
Attached my plugin list.
Thanks for your help! And sorry for my english - i am not a native speaker.
Attached Files
File Type: txt my_plugin_list.txt (21.4 KB, 152 views)
hanneu is offline   Reply With Quote
Old 28th November 2010, 12:12   #8
hanneu
Junior Member
 
Join Date: Dec 2009
Location: Berlin, Germany
Posts: 7
@ainstalls I had some similar problems: When I try to enque a lot of songs (well around 100) from my media library it also crashes - sometimes. It seems to me, that Winamps has some problems to deal more with than 200 songs, no matter if it's syncing the ipod, media library or playlist. In my case it all started few weeks ago.
hanneu is offline   Reply With Quote
Old 29th November 2010, 01:22   #9
ainstalls
Junior Member
 
Join Date: Nov 2010
Posts: 9
crashing

yes i have over 100000 songs and winamp just cant keep up. does anyone recommend any other software etc that can be used for djing
ainstalls is offline   Reply With Quote
Old 30th November 2010, 00:03   #10
bascaves
Junior Member
 
Join Date: Mar 2009
Posts: 4
Winamp 5.581 crashes too often

Hello,

First of all I am a huge long time fan of winamp. But since version 5.581 it is crashes just too often. My PC H/W didn't change over the last year. I am still on WinXP SP3 updated to the latest.

WinXP SP3
4GB RAM


Winamp crashes when:

Just playing a song from my library.
Tries to play a WMA file
Using the buildin (IE) browsing, go to Topcharts or i.e. Our stage.

Everytime I use winamp for a while, like 1-2 hours of playing music there is at least one crash but often a couple in a few hours.

I hate to surrender to iTunes, Mediaplayer or drive into the arms of mediamonkey (which is the best of those alternatives).

But these crashes start working on my nerves.

BTW: these crash do sometimes get reported to Microsoft... but I bet Winamp support doesn't get told by Microsoft about them ;-)
Sometimes Winamp also crashes blank without any reporting..

Bas.

Winamp 5.581
Plugins, a bunch:
Flac, Advanced Control, Lyrics, HD MP3 ,etc.

These plugins where already there before I upgrade to 5.581.

Windows System : Microsoft Windows XP Professional 5.01.2600 (Service Pack 3)
Model: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
Mainboard: MICRO-STAR INTERNATIONAL CO.,LTD K9A2VM (MS-
7501)
BIOS: AMI V1.12 08/24/2010
Total Memory: 3.24GB DIMM DDR2
bascaves is offline   Reply With Quote
Old 30th November 2010, 00:23   #11
ainstalls
Junior Member
 
Join Date: Nov 2010
Posts: 9
crashing

my system is brand new 6gb dell running windows 7 and the newest winamp is terrible same problems crashing all the time . I just downloaded free mediamonkey and so far it took my 21000 song library and hasnt crashed yet. just tricky getting used to it
ainstalls is offline   Reply With Quote
Old 1st December 2010, 20:38   #12
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Almost fix.....sort of.....

I think I've found a solution, but of course WinAMP v.5.6 causes another issue with this. See WinAMP v5.6 issue

I had to do a lot of work on my iPod.

First, I completely formatted my iPod by right clicking my iPod (I have it set up as a portable hard disk as well) in My Computer and hitting format. I preformed a full format, and that took a while.

Second, before I formatted, my computer actually started telling me that the "hard disk" that I just plugged in has corrupt sectors and that I should run a CheckDisk on it. So that's what I did second.

Third, I opened iTunes and it would give me a message that my iPod needs to be formatted or "restored" so I let it do it's thing.

I so with the new WinAMP 5.6 installed I plug in my iPod and WinAMP behaves normally and cooperates with my iPod wonderfully. I am able to send multiple playlists to it without it crashing. Even a playlist that has about 200 songs on it, I'm able to send with no problem. I have one playlist with well over 3000 songs (no that's no a type-o) and I used to be able to send that with no problem, but now I am. But this is a HUGE playlist, so I'll have to take baby steps.

So will all my music happily added, I eject my iPod and...........................

where is all my music?

It doesn't show anything. No songs, no artists, no playlists, my iPod is blank. But when I open WinAMP I can see that all these playlists are there, and I can stream music from my iPod and the iPod will show "synchronizing" on the screen signaling that it is being used, but my iPod itself displays nothing.

*sigh* So close.....
EmperorOfNight is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump