Old 29th December 2010, 14:53   #1
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
sc_serv2 with sc_trans2 (uvox2.1) & djsupport

I have some trouble to connect sc_trans2 (latest build) with DSP 2.1.1

i receive the Cipher reveived message on the dsp
but sc_serv2 with sc_trans2 works great but not the dj connection

here sc_trans.log

code:

D msg:[DJPROTOCOLUVOX] State EMPTY
D msg:[DJPROTOCOLUVOX] State CIPHER
D msg:[DJPROTOCOLUVOX] State SENDREPLY
D msg:[DJPROTOCOLUVOX] State AUTHENTICATIONREQUEST
W msg:[DJPROTOCOLUVOX] Authentication string parse error (2.1::1766ce3b71e39bb2:f1b4eca6d4392a5aecbb43fb90d8a0f0)
D msg:[DJPROTOCOLUVOX] State SENDREPLY
D msg:[DJPROTOCOLUVOX] State KILL
D msg:[DJPROTOCOLUVOX] State KILL



here my configs of sc_trans2 and sc_serv2

code:

;sc_serv2 config
logfile=logs/logfile.log
w3clog=logs/sc_w3c.log
banfile=control/sc_serv.ban
ripfile=control/sc_serv.rip
dstip=ANY
srcip=ANY
yp2=1
requirestreamconfigs=1
publicserver=always
uvoxcipherkey=foobar

;server1
portbase_0=8000
streamauthhash_0=hash0
password_0=pass0
adminpassword_0=admpass0
streamid_0=1
streampath_0=/low.aac
maxuser_0=25

;server2
portbase_1=8000
streamauthhash_1=hash1
password_1=pass1
adminpassword_1=admpass1
streamid_1=2
streampath_1=/high.mp3
maxuser_1=75



code:

;sc_trans2 config
logfile=logs/sc_trans.log
screenlog=1
calendarrewrite=1
unlockkeyname=Max Mustermann
unlockkeycode=1234-1234-1234-124
djcipher=foobar

;encoder1
encoder_0=aacp
bitrate_0=32000
samplerate_0=44100
channels_0=2
aacformat_0=0
serverip_0=127.0.0.1
serverport_0=8000
password_0=pass0
uvoxstreamid_0=1
uvoxuserid_0=
uvoxauth_0=pass0
uvoxnewmetadata_0=1
outprotocol_0=3
endpointname_0=endpoint0

;encoder2
encoder_1=mp3
bitrate_1=96000
samplerate_1=44100
channels_1=2
mp3quality_1=0
mp3mode_1=0
serverip_1=127.0.0.1
serverport_1=8000
password_1=pass1
uvoxstreamid_1=2
uvoxuserid_1=
uvoxauth_1=pass1
outprotocol_1=3
endpointname_1=endpoint1

streamtitle=Description
streamurl=http://www.yoururl.tld
genre=Genre
public=1
djdebug=1
playlistfile=playlists/main.lst
calendarfile=calendar/dj_calendar.xml

djport=8020
djport2=8025

djlogin_0=andy
djpassword_0=djpass
djpriority_0=1

adminport=7999
adminuser=admin
adminpassword=admpass

vuimagedirectory=vuimages/

xerano is offline   Reply With Quote
Old 29th December 2010, 14:59   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
based on the error, i'd go with the wrong password having been entered into the dsp - if working with the DJ connection, then the DJ password and port needs to be used from the sc_trans configuration instead of the server configuration password / ports.

-daz
DrO is offline   Reply With Quote
Old 29th December 2010, 15:05   #3
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
ree

on dsp i setted to:

Address: ***.***.***.***
Port:=8025 (from sc_trans config)
User ID:=andy
Password=djpass

v1=UNCHECKED

someone wrong?

dj_calendar.xml

code:

<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>
<event type="dj">
<dj archive="0">andy</dj>
<calendar starttime="00:00:00" />
</event>
</eventlist>


Last edited by xerano; 29th December 2010 at 15:57. Reason: added content of dj_calendar.xml
xerano is offline   Reply With Quote
Old 29th December 2010, 15:13   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
based on what you've posted that looks to be correct. and the calendar/dj_calendar.xml file is definitely being loaded by sc_trans? (only other thing i can think off which might cause a failure to happen).

-daz
DrO is offline   Reply With Quote
Old 29th December 2010, 15:16   #5
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
Yes the xml is loaded
xerano is offline   Reply With Quote
Old 29th December 2010, 15:25   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
and what does the DSP report if you log the connection status messages?

i know the setup will work (and should do from the sc_trans + dsp_sc example configurations as that is how i got the examples created) unless something is interfering with the connection dsp_sc is making to sc_trans.

unfortunately i just don't have the time today to try out the configuration files you've posted (though they look very much like the example configuration files) though there must be some more information in the message logs (especially from enabling all of the debug logging options which may make it easier to see what is or isn't going on).

-daz
DrO is offline   Reply With Quote
Old 29th December 2010, 15:37   #7
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,026
Send a message via Skype™ to thinktink
Does the named dj in the calendar file match the djlogin_0 in sc_trans? I noticed in your sc_trans.conf post it's set to djlogin_0=andy but you didn't post your calendar file.

Did you modify dj_calendar.xml appropriately? If you didn't, shutdown sc_trans first and then modify the dj_calendar.xml file thusly:

PHP Code:
<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>

  <!-- if more DJ's are required in the system
       then we just add in more event blocks -->

  <event type="dj">
    <dj archive="1">andy</dj>
    <!-- for this example we will allow the DJ
         to connect to sc_trans at any time -->
    <calendar />
  </event>

</eventlist>
...then restart sc_trans.
thinktink is offline   Reply With Quote
Old 29th December 2010, 15:57   #8
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
calendar.xml

content of dj_calendar.xml

code:
<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>
<event type="dj">
<dj archive="0">andy</dj>
<calendar starttime="00:00:00" />
</event>
</eventlist>

xerano is offline   Reply With Quote
Old 29th December 2010, 15:59   #9
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
nothing changed i try debugging all on

code:

D msg:[CALENDARMGR] calendarMgr::timeSlice
D msg:[CALENDARMGR] id=1 is active. running deactivation check
D msg:[UVOX2] 15542 delta=11839 raw_credit=47378 credit=1369 BPS=4001
D msg:[UVOX2] 15542 readavail=88296 writespace=173848
D msg:[UVOX2] 15542 bytes sent=1376
D msg:[UVOX2] 11816 delta=11905 raw_credit=142232 credit=4007 BPS=11947
D msg:[UVOX2] 11816 readavail=262102 writespace=42
D msg:[UVOX2] 11816 bytes sent=4014
D msg:[UVOX2] 15542 delta=12165 raw_credit=48733 credit=1355 BPS=4006
D msg:[UVOX2] 15542 readavail=88321 writespace=173823



DSP Log

code:

2010-12-29 17:09:55 Logging starting
2010-12-29 17:09:56 Connecting
2010-12-29 17:09:56 Sending Cipher request
2010-12-29 17:09:56 Cipher Response received
2010-12-29 17:09:56 Sending Authorization
2010-12-29 17:09:56 Receiving Authorization Response
2010-12-29 17:09:56 Not Connected
2010-12-29 17:09:57 Connecting
2010-12-29 17:09:57 Sending Cipher request
2010-12-29 17:09:57 Cipher Response received
2010-12-29 17:09:57 Receiving Authorization Response
2010-12-29 17:09:57 Disconnecting
2010-12-29 17:09:57 Not Connected


Last edited by xerano; 29th December 2010 at 16:12. Reason: logging
xerano is offline   Reply With Quote
Old 29th December 2010, 16:39   #10
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,026
Send a message via Skype™ to thinktink
Turn all the debugs off except for djdebug and double check the calendar file again. It may have gotten rewritten by sc_trans. Did that once to me and I just about went insane 'till I remembered sc_trans can do that.

I tested the calendar file contents you posted and it works for me. Other than double checking your configs and your passwords I don't see anything wrong like DrO said.
thinktink is offline   Reply With Quote
Old 29th December 2010, 16:47   #11
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
hmmm

W msg:[DJPROTOCOLUVOX] Authentication string parse
error (2.1::1766ce3b71e39bb2:f1b4eca6d4392a5aecbb43fb90d8a0f0)
D msg:[DJPROTOCOLUVOX] State SENDREPLY
D msg:[DJPROTOCOLUVOX] State KILL
D msg:[DJPROTOCOLUVOX] State KILL
D msg:[DJPROTOCOLUVOX] State EMPTY
D msg:[DJPROTOCOLUVOX] State CIPHER
D msg:[DJPROTOCOLUVOX] State SENDREPLY
D msg:[DJPROTOCOLUVOX] State AUTHENTICATIONREQUEST
W msg:[DJPROTOCOLUVOX] Authentication string parse
error (2.1::1766ce3b71e39bb2:f1b4eca6d4392a5aecbb43fb90d8a0f0)

only djdebug=1
xerano is offline   Reply With Quote
Old 29th December 2010, 16:59   #12
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
iam entering my name "andy" (known as djlogin=andy) on User ID in the password field entering only the djpassword=djpass right?

legacymode off

maybe someone can write me the 2 config files ^^ and i try them out
xerano is offline   Reply With Quote
Old 29th December 2010, 17:29   #13
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
ok ok ok

i tested localy on my computer the latest sc_serv win32 & sc_trans win32 with untouched config i startet sc_serv sc_serv_basic.conf and sc_trans sc_trans_dj.conf but it is the same problem with the cipher received message on dsp!

on sc_serv_basic.conf i added uvoxcipherkey=foobar
on sc_trans_dj.conf i added djcipher=foobar

no changed
xerano is offline   Reply With Quote
Old 29th December 2010, 19:43   #14
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,026
Send a message via Skype™ to thinktink
Quote:
Originally Posted by xerano View Post
maybe someone can write me the 2 config files ^^ and i try them out
Click here!

Have you had a go at that yet?
thinktink is offline   Reply With Quote
Old 29th December 2010, 19:55   #15
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
same problem with your config generator all fine but dj connecting -> Cipher Response received
xerano is offline   Reply With Quote
Old 29th December 2010, 19:55   #16
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,026
Send a message via Skype™ to thinktink
If I'm understanding you correctly you might be entering the stuff wrong in the DSP:


If not using the legacy mode in the DSP then just type only the name of the dj in the [User ID] box and only the password in the [Password] box.

Also double check that you're using the latest beta of sc_trans and the SHOUTcast DSP just to be sure.

Attached Thumbnails
Click image for larger version

Name:	andy.jpg
Views:	1387
Size:	35.8 KB
ID:	48228  
thinktink is offline   Reply With Quote
Old 29th December 2010, 20:02   #17
xerano
Junior Member
 
Join Date: Apr 2007
Location: Germany
Posts: 28
SHOUTcast DNAS 2 (Build 10) 12/14/2010

SHOUTcast Transcoder 2 (Build 40) 12/14/2010

SHOUTcast DSP Plug-in v2.1.1 for Winamp 12/21/2010

all setted up as you and typed in the port of djport2 from sc_trans config

maybe u can help me over remote desktop like teamviewer u know?
xerano is offline   Reply With Quote
Old 29th December 2010, 20:08   #18
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,026
Send a message via Skype™ to thinktink
Sending you a PM...
thinktink is offline   Reply With Quote
Old 6th January 2011, 05:14   #19
RadioCzech
Junior Member
 
Join Date: Dec 2010
Posts: 6
Did you guys find solution?

Hi,
I'm having this same issue that I'm troubleshooting right now. I'm running all the latest apps on CentOS. I'm able to broadcast via playlist or by sending stream from winamp. However, when I try to connect to the DJ port (that is listening), my status page shows "Cipher Response Received" .. and nothing.

My dj passwords/ports/calender names all match.

Please let me know if you've found a solution for this.
Thank you.
RadioCzech is offline   Reply With Quote
Old 6th January 2011, 05:24   #20
RadioCzech
Junior Member
 
Join Date: Dec 2010
Posts: 6
changed djport= to djport2=

OK - got it to work.

What I did was - I had djport=xxxx vs djport2=xxxxx. After I changed the line to djport2 I was able to connect.
RadioCzech is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump