Old 10th February 2011, 02:48   #1
Son Of Kyuss
Junior Member
 
Join Date: Feb 2011
Posts: 6
.MKV Files in Winamp

Hey forum, whats happening!!??

I've been downloading various T.V shows recently and some of them have come down as .MKV files. When i try to play these in WinAMP i just get the audio track, no video at all. I have tried other players, but it's a pain in the ass when we sit down to have a Stargate or Supernatural season session and have to change players for every other episode!! I love using WinAMP and have done so for many years, everything in my Library is played through it, so if anybody knows a no-bullcrap method of getting these .MKV files to work, i'd really apppreciate it. Thanks in advance peoples.
Son Of Kyuss is offline   Reply With Quote
Old 10th February 2011, 02:52   #2
Son Of Kyuss
Junior Member
 
Join Date: Feb 2011
Posts: 6
By the way

I'm currently using WinAMP version 5.601 although it says 5.56 in the "About WinAMP" tab in "Help". I've got VLC Player and DivX Plus etc etc,so..... Thanks
Son Of Kyuss is offline   Reply With Quote
Old 11th February 2011, 04:09   #3
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
You may already have the required codecs if the DivX bundle installed them.

Try just adding MKV to the Directshow filter list in Winamp:

Go to Options - Preferences - Plugins - Input. Highlight Nulsoft Directshow Decoder and press Configure. Then add ;MKV to the end of the list and restart Winamp.

If that doesn't work then you either don't have the codecs or, if Windows7, Winamp can't select the correct one.

Let us know the OS version if you still can't play them.
CJ_Man is offline   Reply With Quote
Old 13th February 2011, 03:06   #4
Son Of Kyuss
Junior Member
 
Join Date: Feb 2011
Posts: 6
Thank you, thank you!!!

Thanks, did exactly what you suggested above and it's worked perfectly. Will the same work for Xvid (MPEG 4 Part 2) files also??? Btw i'm using Win XP Home SP3. Thanks again for your help ; )
Son Of Kyuss is offline   Reply With Quote
Old 13th February 2011, 13:29   #5
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by Son Of Kyuss View Post
Will the same work for Xvid (MPEG 4 Part 2) files also???
As DivX/Xvid files normally have an AVI extension Winamp should play them out of the box if the codec is present. Occasionally you may come across one with a DIVX extension, you can add that to the Directshow filter list if you don't want to rename the file.

For MP4 files (generally H.264) see the first paragraph of my post here: http://forums.winamp.com/showpost.ph...62&postcount=2 The rest is about Windows 7 so don't worry about it.
CJ_Man is offline   Reply With Quote
Old 13th February 2011, 19:17   #6
turpinator
Junior Member
 
Join Date: Feb 2011
Posts: 1
I'm having this exact problem, but adding it to direct show won't work. I am running Windows 7.
turpinator is offline   Reply With Quote
Old 14th February 2011, 08:32   #7
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by turpinator View Post
I am running Windows 7.
Okay, the codec tweaking program I was referring to in the post linked earlier is at http://www.codecguide.com/windows7_p...er_tweaker.htm Use the Preferred Decoder button to view and change the codec settings.

Do the changes as I laid out in the linked post. If you find you have no alternative filters for some/all of the formats required then I recommend you load the codec pack from http://www.cccp-project.net/download.php?type=cccp which also includes the Gabest splitter for MP4.

Let us know how you get on.
CJ_Man is offline   Reply With Quote
Old 5th May 2011, 14:08   #8
wanchoo
Junior Member
 
Join Date: Feb 2007
Location: India
Posts: 29
Thank you. Added ,MKV and the Video started playing beautifully but still no Audio. Kindly help a little bit more to receive the Audio.


Quote:
Originally Posted by CJ_Man View Post
You may already have the required codecs if the DivX bundle installed them.

Try just adding MKV to the Directshow filter list in Winamp:

Go to Options - Preferences - Plugins - Input. Highlight Nulsoft Directshow Decoder and press Configure. Then add ;MKV to the end of the list and restart Winamp.

If that doesn't work then you either don't have the codecs or, if Windows7, Winamp can't select the correct one.

Let us know the OS version if you still can't play them.
wanchoo is offline   Reply With Quote
Old 5th May 2011, 15:10   #9
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by wanchoo View Post
Thank you. Added ,MKV and the Video started playing beautifully but still no Audio. Kindly help a little bit more to receive the Audio.
The video is probably using either Dolby (AC3) or DTS audio. If you are lucky these codecs are installed on your system but not enabled.

I don't know what codec set you are using but if it includes the ffdshow audio codecs then you should be able to find an entry for this from the Start menu.

In ffdshow under the Codecs section you would set AC3 to liba52 and DTS to libdts.

If you can't find anything like this then you can download a stand-alone AC3 filter from: http://www.free-codecs.com/download/AC3_Filter.htm

Hopefully this will be all you need.
CJ_Man is offline   Reply With Quote
Old 6th May 2011, 04:07   #10
wanchoo
Junior Member
 
Join Date: Feb 2007
Location: India
Posts: 29
I downloaded and installed AC3_Filter but there is still no sound. How do I enable the filter for Winamp? In the Plug-ins Nullsoft Matroska Demuxer v0.7 [in.mkv.dll] is enabled. Thank you for your help.

I am eager to play mkvs with Winamp because it gives the best video display amongst all the other media players. TIA


Quote:
Originally Posted by CJ_Man View Post
The video is probably using either Dolby (AC3) or DTS audio. If you are lucky these codecs are installed on your system but not enabled.

I don't know what codec set you are using but if it includes the ffdshow audio codecs then you should be able to find an entry for this from the Start menu.

In ffdshow under the Codecs section you would set AC3 to liba52 and DTS to libdts.

If you can't find anything like this then you can download a stand-alone AC3 filter from: http://www.free-codecs.com/download/AC3_Filter.htm

Hopefully this will be all you need.
wanchoo is offline   Reply With Quote
Old 6th May 2011, 05:34   #11
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by wanchoo View Post
I downloaded and installed AC3_Filter but there is still no sound.
While the video is playing go File - View File Info and post what is shown under Currently Used Filters.

Also what version of Windows are you using?
CJ_Man is offline   Reply With Quote
Old 6th May 2011, 05:49   #12
wanchoo
Junior Member
 
Join Date: Feb 2007
Location: India
Posts: 29
I am using Windows XP Pro.

CoreAVC Video Decoder is shown as the currently used filter. Your expertise is beyond compare. I wish I knew half as much.


Quote:
Originally Posted by CJ_Man View Post
While the video is playing go File - View File Info and post what is shown under Currently Used Filters.

Also what version of Windows are you using?
wanchoo is offline   Reply With Quote
Old 7th May 2011, 09:54   #13
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by wanchoo View Post
I am using Windows XP Pro.

CoreAVC Video Decoder is shown as the currently used filter.
So it can't find any audio codec to use. Well I don't know what damn codec your MKV has then. All I can do is suggest the following setup, which is the one I currently use.

Firstly uninstall the ACFilter. If it isn't working for you then there is no point keeping it and it could cause problems later.

Then download the CCCP codec pack from:
http://www.cccp-project.net/download.php?type=cccp

The CCCP installation includes a copy of Media Player Classic. I would deselect this as the bundled version is no longer current anyway.

Once CCCP is installed go Start -> Programs -> Combined Community Codec Pack -> Settings and you should see that the check box for CoreAVC is enabled. If so place a tick in there. As the CoreAVC decoder is working fine for you this should ensure it remains your primary h.264 decoder.

Make sure that ALL the boxes under FFDShow Audio Decoders are ticked. Then press Next and then Apply.

In Winamp go to the Input plugins section under Preferences and remove ;M4V;MP4 from the MP4 demuxer extension list so only M4A remains. Then open the configuration box for the Directshow decoder and add them there after MKV. This will result in any video files likely to contain h.264 being sent to the external filters.

Restart Winamp and pray!

With the above settings and codecs Winamp should be able to play just about anything. Please report back on how you get on.
CJ_Man is offline   Reply With Quote
Old 8th May 2011, 03:40   #14
wanchoo
Junior Member
 
Join Date: Feb 2007
Location: India
Posts: 29
Actually I downloaded the ffdshow codec and installed it after unregistering the CoreAVC codec. It had both the Video as well as Audio components in it. I then started getting both video and audio components on playing mkv files with Winamp.

The problem was that the video display was not half as good as with the CoreAVC codec. I have earlier used CCCP codecs but not with Winamp. They too are good but do not give a video display like CoreAVC.

After struggling to make CoreAVC install its audio component I have given up in frustration and restored an earlier image thus getting rid of all the new fangled codecs that I had installed. Anyway like every other Media Player, Winamp too doesn't synchronize the video and audio components which remain out of sync.

Regards and thank you for all your help.

Amarnath Wanchoo


Quote:
Originally Posted by CJ_Man View Post
So it can't find any audio codec to use. Well I don't know what damn codec your MKV has then. All I can do is suggest the following setup, which is the one I currently use.

Firstly uninstall the ACFilter. If it isn't working for you then there is no point keeping it and it could cause problems later.

Then download the CCCP codec pack from:
http://www.cccp-project.net/download.php?type=cccp

The CCCP installation includes a copy of Media Player Classic. I would deselect this as the bundled version is no longer current anyway.

Once CCCP is installed go Start -> Programs -> Combined Community Codec Pack -> Settings and you should see that the check box for CoreAVC is enabled. If so place a tick in there. As the CoreAVC decoder is working fine for you this should ensure it remains your primary h.264 decoder.

Make sure that ALL the boxes under FFDShow Audio Decoders are ticked. Then press Next and then Apply.

In Winamp go to the Input plugins section under Preferences and remove ;M4V;MP4 from the MP4 demuxer extension list so only M4A remains. Then open the configuration box for the Directshow decoder and add them there after MKV. This will result in any video files likely to contain h.264 being sent to the external filters.

Restart Winamp and pray!

With the above settings and codecs Winamp should be able to play just about anything. Please report back on how you get on.
wanchoo is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump