Old 12th February 2011, 05:44   #1
skywalka
Member
 
Join Date: Feb 2002
Posts: 73
mp4 Only Audio Plays

Hi guys.

I can play mp4 videos in VLC & WMP but in Winamp there is only audio. The Nullsoft video logo is displayed.

Can anyone point me in the right direction?

--==WishList==--
Disable the locking of files like WMP does.
Cascading, iconed context menu.
skywalka is offline   Reply With Quote
Old 12th February 2011, 06:58   #2
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 167
In Winamp go to the Input plugins section under Preferences and remove ;M4V;MP4 from the MP4 demuxer extension list so only M4A remains. Then open the configuration box for the Directshow decoder and add them there along with MKV so the list looks something like mine:

MPG;MPEG;M2V;AVI;MKV;M4V;MP4

Close Winamp and open the codec tweaking program I referred you to in the other thread. You want to have alternative codecs for H.264 MP4V VC1 and AAC available. You may not need them all for the specific files you want to play now, but I think you will eventually.

This happens because MS changed the codec architexture in Windows 7 and it no longer uses Directshow filters, but Winamp needs them. VLC is unaffected because it installs with it's own codecs, but it doesn't share them.
CJ_Man is offline   Reply With Quote
Old 12th February 2011, 22:55   #3
skywalka
Member
 
Join Date: Feb 2002
Posts: 73
Thanx 4 taking the time to explain that.

--==WishList==--
Disable the locking of files like WMP does.
Cascading, iconed context menu.
skywalka is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump