Old 17th October 2011, 09:13   #41
MikeRiverra
Junior Member
 
Join Date: May 2011
Posts: 2
Auth hash

Quote:
Originally Posted by DrO View Post

-daz
Hi Dro,

I've sent you one PM regarding one auth hash, please help me ... because my station is down since yesterday and i'm loosing listeners ...

I don't know what happened, but now it does not recognize my auth key for one of my stations.

Later Edit: sorry for posting here this problem, I have solve it right now by searching the answers on forum

Best Regards,
Cosmin

Last edited by MikeRiverra; 17th October 2011 at 11:49.
MikeRiverra is offline  
Old 17th October 2011, 15:30   #42
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
MikeRiverra: i'll check out your pm's in the next few hours (along with all of the other ones i've received from being on holiday all of last week - had hoped my signature change made that obvious).

---------------------------------------

@anyone else who posted in this thread in the last few days: the posts made by / relating to the user 'pools' have been removed. said user has a lifetime forum ban (*) (and i will not personally help after previous run-ins) and should not be replied to unless you're happy to do so privately. and just to note, this user has caused the same issue on other forums, even causing the codemasters forum to stop accepting new user registrations for a while due to his anti-social behaviour.

(*) the only reason for keep this account alive is bryan007/pokemons/pools/insert 100+ other ban evasion, will just keep posting / making new accounts and wasting everyone's time - hence one of the reasons there is no specific eta on a new v2 DNAS release.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 23rd October 2011, 16:58   #43
rsg
Junior Member
 
Join Date: Oct 2011
Posts: 3
Problem with 64-bit V2 DNAS + Transcoder 2

Hello,

I have been experimenting with the 64-bit V2 DNAS and Transcoder 2. I am able to broadcast and things will generally run smoothly - that is until people begin to connect from external IPs, which then crashes the server. The crash, however, is never immediate, and I have been unable to finger the culprit.

I do not believe it is my ISP, as V1 works fine.

I do not think it has to do with the audio files, as I ran through a long playlist with V2 yesterday while connected via 127.0.0.1 with Winamp and there were no problems.

I do not think it is the transcoder because, again, no problems with V1 DNAS + transcoder 2.

I have tried a great number of config options and these made no difference.
The only thing that appears to be somewhat related is that the crashes seem to begin when people connect with the SHOUTcast web player. I have spent days reading through the forum and numerous posts, as well as Googling the tips of my fingers off, but all to no avail.

I will attach the transcoder and server logs for the last crash event.

Thanks

Win7 64-bit/Intel Core II Duo/6 gig ram
Attached Files
File Type: txt rsg_log.txt (9.4 KB, 228 views)
rsg is offline  
Old 23rd October 2011, 20:52   #44
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
rsg: can you confirm what versions of the tools you are using please (i.e. that you're on DNAS build 29 and Transcoder build 54 - the current versions at the time of this reply).

i assume you are referring to the DNAS crashing? also as you're using Win7, i'd hope there's something in the system event logs about the crash since there's nothing of use in the log file to do with any sort of crash.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 24th October 2011, 12:55   #45
rsg
Junior Member
 
Join Date: Oct 2011
Posts: 3
Hi DrO,

DNAS build 29 / Transcoder build 54 affirmative.

Yes, it appears to be the DNAS crashing first.

There are a number of items in the system event logs pertaining to both the DNAS and Transcoder. I will go through and see if there is anything revealing. However, scanning such things is not my area of expertise, so to speak. Is there anything in particular that you might want me to send/post?

I will be trying a few other ideas in the meantime.

Thanks for your reply - I know you are busy.

Cheers,

rsg
rsg is offline  
Old 24th October 2011, 13:08   #46
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
rsg: pm sent with a link to a test build to try out.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 16th November 2011, 03:14   #47
WHITELIONX
Junior Member
 
Join Date: Nov 2011
Posts: 10
Nevermind I got everything working as to exactly how I want/need it to work

Last edited by WHITELIONX; 16th November 2011 at 05:38.
WHITELIONX is offline  
Old 2nd January 2012, 22:27   #48
GeorgeT
Junior Member
 
Join Date: Nov 2011
Posts: 3
Bad password

Hi I have a problem, the client cannot connect to the server. The program writes a bad password Even if the password is correct. When you enter the ip and port to the browser indicates that the server is ok. What is it?
Sorry for my english :-)
sc_serv.log
Quote:
2012-01-03 00:19:35 I msg:[MAIN] Logger updating log file to use
2012-01-03 00:19:35 I msg:[MAIN] Loaded config from sc_serv.conf
2012-01-03 00:19:35 I msg:[MAIN] Calculated CPU count is 2
2012-01-03 00:19:35 I msg:[MAIN] Starting 2 network threads
2012-01-03 00:19:35 I msg:[MICROSERVER] Listening for connection on port 9040
2012-01-03 00:19:35 I msg:[MICROSERVER] Listening for connection on port 9041
2012-01-03 00:19:49 I msg:[SRC 92.243.xxx.xxx:31433 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:19:49 E msg:[SRC 92.243.xxx.xxx:31433 sid=1] connection denied. Bad password.
2012-01-03 00:19:58 I msg:[SRC 92.243.xxx.xxx:31435 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:19:58 E msg:[SRC 92.243.xxx.xxx:31435 sid=1] connection denied. Bad password.
2012-01-03 00:19:59 I msg:[SRC 92.243.xxx.xxx:31438 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:19:59 E msg:[SRC 92.243.xxx.xxx:31438 sid=1] connection denied. Bad password.
2012-01-03 00:20:00 I msg:[SRC 92.243.xxx.xxx:31440 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:20:00 E msg:[SRC 92.243.xxx.xxx:31440 sid=1] connection denied. Bad password.
2012-01-03 00:20:00 I msg:[SRC 92.243.xxx.xxx:31442 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:20:00 E msg:[SRC 92.243.xxx.xxx:31442 sid=1] connection denied. Bad password.
2012-01-03 00:20:00 I msg:[SRC 92.243.xxx.xxx:31444 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:20:00 E msg:[SRC 92.243.xxx.xxx:31444 sid=1] connection denied. Bad password.
2012-01-03 00:20:01 I msg:[SRC 92.243.xxx.xxx:31446 sid=1] SHOUTcast 1 source connection.
2012-01-03 00:20:01 E msg:[SRC 92.243.xxx.xxx:31446 sid=1] connection denied. Bad password.
GeorgeT is offline  
Old 3rd January 2012, 12:26   #49
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
well the DNAS keeps getting the wrong password from the source which is trying to connect (clarification of what you are using as the source would be useful), so either it is wrong in the source you're using or you've found a new bug in the DNAS (which i doubt).

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 3rd January 2012, 23:45   #50
GeorgeT
Junior Member
 
Join Date: Nov 2011
Posts: 3
Quote:
Originally Posted by DrO View Post
well the DNAS keeps getting the wrong password from the source which is trying to connect (clarification of what you are using as the source would be useful), so either it is wrong in the source you're using or you've found a new bug in the DNAS (which i doubt).

-daz
I uninstalled the shoutcast server, cleared the registry and deleted the remaining files, but it still writes bad password :-(
GeorgeT is offline  
Old 4th January 2012, 08:50   #51
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
i can only go on what you've posted and without _any_ of the information i've asked for in my prior reply, there is _nothing_ i can do to aid in tracking down your issue which i still think is due to the wrong details being entered in the source (whatever that is) that you are using.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 4th January 2012, 16:47   #52
GeorgeT
Junior Member
 
Join Date: Nov 2011
Posts: 3
I'm sorry :-) So I use Virtual DJ 7 PRO

sc_serv.conf

code:
;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

password=f3ntM2Cx
adminpassword=administrator
portbase=9040
requirestreamconfigs=1
logfile=sc_serv.log
w3clog=sc_w3c.log
publicserver=never
banfile=sc_serv.ban
ripfile=sc_serv.rip

streamid=1



Sorry, but I do not understand. What source? :-(
GeorgeT is offline  
Old 4th January 2012, 17:21   #53
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
Quote:
Originally Posted by GeorgeT View Post
Sorry, but I do not understand. What source? :-(
Quote:
Originally Posted by GeorgeT View Post
So I use Virtual DJ 7 PRO
that would be the source you're using. Not one i'm frequented with so i'd have to assume that it's working as a v1 source.

from the config file, it should just require 'f3ntM2Cx' to be set as the password and that should be it. if not, remove the requirestreamconfigs=1 part from the file as that will lessen some of the checks made when a source connects.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 20th February 2012, 12:52   #54
dz0ny
Junior Member
 
Join Date: Feb 2012
Posts: 1
Hi, am using monit to monit shoutcast server service status for client. However when performin http request to stat file I've got error indicating that http response is malformed.
Quote:
HTTP error: Illegal Content-Length response header 'Content-Length:549'
Using browser it works just fine(no error there).

Host uses SHOUTcast Server v2.0.0.29/posix(bsd).

monit code
Quote:
check host shoutcast with address stream.xxxxxxxxx.xx
if failed url http://stream.xxxxxxxxx.xx:8000/stats?sid=1
and content != ".*<STREAMSTATUS>0<\/STREAMSTATUS>.*"
timeout 10 seconds for 1 cycles then alert
status page xml is(its nonexistent stream for purpose of testing, however it also does't work for proper stream)
Quote:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?><SHOUTCASTSERVER><CURRENTLISTENERS>0</CURRENTLISTENERS><PEAKLISTENERS>0</PEAKLISTENERS><MAXLISTENERS>60</MAXLISTENERS><UNIQUELISTENERS>0</UNIQUELISTENERS><AVERAGETIME>0</AVERAGETIME><SERVERGENRE></SERVERGENRE><SERVERURL></SERVERURL><SERVERTITLE></SERVERTITLE><SONGTITLE></SONGTITLE><NEXTTITLE></NEXTTITLE><STREAMHITS>0</STREAMHITS><STREAMSTATUS>0</STREAMSTATUS><STREAMPATH>/stream/2/</STREAMPATH><BITRATE>0</BITRATE><CONTENT></CONTENT><VERSION>2.0.0.29 (posix(bsd))</VERSION></SHOUTCASTSERVER>
dz0ny is offline  
Old 21st February 2012, 10:46   #55
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
never having heard of monit before, i can only assume from what you've posted it doesn't like how things are returned since if it's ok in a browser then it cannot be completely broken. would probably say this is more something to direct towards monit to better advise than here (as it's not something i'm in a position to look into for some time to come).

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 24th February 2012, 10:05   #56
endrogeri
Junior Member
 
Join Date: Feb 2012
Posts: 1
segmentation fault when try to connect yp2 server

Hi!

Please help me, I have Segmentation fault at more then 500 user. Last msgs this:

2012-02-24 11:54:05 D msg:[YP2] pvt_update key=1
2012-02-24 11:54:05 D msg:[YP2] pvt_update key=2
then connect and die:
2012-02-24 11:54:05 I msg:[YP2] Connecting to yp.shoutcast.com

I use linux, stable debian version. I can send debug if you need. 64bit version, 1.8 core2duo and 4gb ram.
endrogeri is offline  
Old 24th February 2012, 10:25   #57
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
all i can direct you at is the suggestions made in point #4 at http://forums.winamp.com/showthread.php?p=2790357#known (which is the first post of this thread...) and set the maxuser limit to ~500 and run a secondary DNAS instance until the issue is fully investigated and fixed (i.e. when i get the proper time to look into a fix for whatever is going on).

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 22nd March 2012, 23:55   #58
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
as people seem to have a complete issue with reading the log files and / or noticing the error (and warning) messages, i'm considering making the console output like in the attached screenshot (at least for the Windows builds - still need to sort out changes for the non-Windows builds).

my point really is, is this going to really annoy people (since it won't be able to toggled on/off) or is it actually going to make things easier to identify if there is a problem when using console output? since it passed the gf test as she's little knowledge about such things but at least recognised there was an issue even without knowing what things meant.

-daz
Attached Thumbnails
Click image for larger version

Name:	dnas_error_highlighting.png
Views:	274
Size:	9.1 KB
ID:	49527  

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 23rd March 2012, 05:17   #59
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 4,719
Send a message via AIM to MrSinatra
do u mean a wrapper like v1 was? i liked the way i could watch connections in v1.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is online now  
Old 23rd March 2012, 08:15   #60
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
this is just showing the output shown in the Windows console window. i've no plans to bring back a v1 wrapper like the Windows build had. the emphasis now is more on using the web interfaces for the management and viewing of information about what is going on.

not saying there isn't a chance of an external wrapper but as i've not done linux gui programming in years, it's not too high up on things i want to work on since i'd prefer to provide something which is consistent across all platforms as is done with the v2 DNAs in it's console form now.

-daz

If you have issues with Winamp or still want to get it, ensure
you get v5.666 build 3516 and the required plug-in updates
DrO is offline  
Old 23rd May 2012, 01:31   #61
zetaf
Member
 
Join Date: Jul 2007
Posts: 61
am just curious, when can we see a stable release of this script?
zetaf is offline  
Old 1st June 2012, 16:01   #62
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
what script?

-daz
DrO is offline  
Old 2nd June 2012, 01:52   #63
NitrofishRadio
Junior Member
 
Join Date: May 2012
Posts: 18
LOL @ DrO... Pretty stable once you get it setup correctly. My server does not come down unless I shut it down.

I did have some problems at first, but this was due to bad ID3 tags and invalid configuration. With the help of these forums and some pretty nice people, it's all sorted out and running rock solid delivering my stream.
NitrofishRadio is offline  
Old 20th June 2012, 11:11   #64
smfrockstation
Junior Member
 
Join Date: Nov 2007
Posts: 4
Quote:
Originally Posted by GeorgeT View Post
Hi I have a problem, the client cannot connect to the server. The program writes a bad password Even if the password is correct. When you enter the ip and port to the browser indicates that the server is ok. What is it?
Sorry for my english :-)
sc_serv.log


I found same error when I start DNAS 2 B.29 64bit

Shoutcast Log :
********************************
2012-06-20 17:09:15 I msg:[DST 61.63.39.74:59109 sid=1] SHOUTcast 1 client connection accepted. Java/1.6.0_29
2012-06-20 17:09:16 E msg:[DST 61.63.39.74:59109 sid=1] Socket error while waiting to send data. err=Broken pipe(32)
2012-06-20 17:09:16 I msg:[DST 61.63.39.74:59109 sid=1] SHOUTcast 1 client connection closed (1 seconds) [Bytes: 13032] Agent: `Java/1.6.0_29'
2012-06-20 17:09:16 I msg:[DST 61.63.39.74:59130 sid=1] SHOUTcast 1 client connection accepted.
2012-06-20 17:09:16 I msg:[DST 61.63.39.74:59129 sid=1] SHOUTcast 1 client connection accepted. Lavf53.13.0
2012-06-20 17:09:16 I msg:[DST 61.63.39.74:59131 sid=1] SHOUTcast 1 client connection accepted. NSPlayer/4.1.0.3856
2012-06-20 17:09:16 I msg:[SRC 61.63.39.74:59133 sid=1] SHOUTcast 1 source connection.
2012-06-20 17:09:16 E msg:[DST 61.63.39.74:59131 sid=1] Socket error while waiting to send data. err=Connection reset by peer(104)
2012-06-20 17:09:16 E msg:[SRC 61.63.39.74:59133 sid=1] connection denied. Bad password.

********************************

messages log :
********************************
Jun 20 17:09:16 metal kernel: sc_serv[7141]: segfault at 0000000000000000 rip 000000320dc60694 rsp 0000000042a4c7b0 error 4
********************************

Then my shoutcast will crashed and stopped. It crashed twice a day.
Please help !!!

My Machine > CentOS 5.x 64bit
smfrockstation is offline  
Old 20th June 2012, 11:17   #65
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
/me bangs head on desk

smfrockstation: this has been covered in you previous thread -> http://forums.winamp.com/showthread.php?t=345581 though at least you've now provided actual information which confirms it as issue #6 from the known issues.

the fix is to block 61.63.39.74 by doing something like is described in http://forums.winamp.com/showpost.ph...90&postcount=5 until an updated DNAS is released.

-daz
DrO is offline  
Old 20th June 2012, 11:26   #66
smfrockstation
Junior Member
 
Join Date: Nov 2007
Posts: 4
Thank you very much.
Now I have just blocked the ip 61.63.39.74 from iptables.
smfrockstation is offline  
Old 21st July 2012, 02:29   #67
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
It's done something like this for the past couple days... is it a metadata issue causing it to do this? The server connection isn't dropping when this happens.

Edit:

This is when using the most up-to-date version of sc_serv and sc_trans.

I looked in the sc_trans log as well, but there's not really anything of interest in there.

PHP Code:
AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:42:41    D    msg:gotResponseRequest key=13 cmd=2
Response body=***91;
<yp version="2"><resp seq="1"><updatefreq>600</updatefreq><publicip>199.15.252.149</publicip></resp></yp>
***93;
Response code=***91;200***93;
2012-07-20 21:42:41    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:43:25    D    msg:***91;YP2***93; pvt_update key=15
<?xml version="1.0" encoding="utf-8"?>
<yp version="2">
<cmd op="update" seq="1">
<id>122123</id>
<authhash>HIDDEN</authhash>
<source>Promo Only</source>
<stats>
<listeners>0</listeners>
<avglistentime>0</avglistentime>
<newsessions>0</newsessions>
<connects>0</connects>
</stats>
<metadata>
    <title seq="1">The Cab - La La (Feelgud Remix)</title>
    <title seq="2">Shelly E. Johnson - All Things Beautiful</title>
    <title seq="3">Travis Ryan - Fearless</title>
    <title seq="4">City Harbor - Somebody Tell Them (Radio Version - Cold Ending)</title>
    <soon>Shelly E. Johnson - All Things Beautiful</soon></metadata>
</cmd>
</yp>
2012-07-20 21:43:25    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:43:45    E    msg:***91;YP2***93;  ***91;YP2***93;  Could not resolve host address yp.shoutcast.com Restarting in one minute
2012-07-20 21:43:45    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:45:05    E    msg:***91;YP2***93;  ***91;YP2***93;  Could not resolve host address yp.shoutcast.com Restarting in one minute
2012-07-20 21:45:05    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:45:30    D    msg:***91;SRC 199.15.252.149:50313 sid=1***93; Cacheable metadata received
2012-07-20 21:45:30    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:45:30    D    msg:***91;SRC 199.15.252.149:50313 sid=1***93; Cacheable metadata reset due to span change
2012-07-20 21:45:30    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console - write issue
2012-07-20 21:45:30    I    msg:***91;SRC 199.15.252.149:50313 sid=1***93; Got complete metadata message type=3902 ***91;780 bytes***93; id=1 span=1 content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata>
<COMM language="eng">Promo Only - www.promoonly.com - Distribution of this file is strictly prohibited.</COMM>
<TALB>Contemporary Christian July 2012</TALB>
<TBPM>73</TBPM>
<TCON v1="12"></TCON>
<TENC>Promo Only</TENC>
<TIT2>All Things Beautiful</TIT2>
<TMED>008058</TMED>
<TPE1>Shelly E. Johnson</TPE1>
<TPUB>Maranatha!</TPUB>
<TRCK>9</TRCK>
<W000>nolan@wnolfm.com______________</W000>
<extension>
    <title seq="1">Shelly E. Johnson - All Things Beautiful</title>
    <title seq="2">Travis Ryan - Fearless</title>
    <title seq="3">City Harbor - Somebody Tell Them (Radio Version - Cold Ending)</title>
    <title seq="4">Kaci Battaglia - Body Shots (feat. Ludacris)</title>
    <soon>Travis Ryan - Fearless</soon>
</extension>
</metadata>
nwgator is offline  
Old 22nd July 2012, 23:47   #68
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
nwgator: what am i meant to be looking at in the above log snippet? the 'Error writing to console - write issue' messages?

-daz
DrO is offline  
Old 23rd July 2012, 13:23   #69
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
attached (with my details removed, heh) is something i'm toying with for Windows users (it will not officially be part of the DNAS).

as something which will start / stop a v2 DNAS and show the different messages highlighted according to their level (which the console output on internal DNAS builds has been doing for a few months) then it's doing what is needed.

there are other things which need to be implemented (like tracking of the source connections and configuration of the DNAS to use, the ability to filter by message type, etc) which is why i'm not putting out a test / preview build until a) i'm happy with it not going to blow up and cause me complaints (this is unofficial so is done off my own back) and b) needs the newer v2 DNAS since it expects the slimmer log output it provides.


i may also look into a non-Windows version but that is low on my priorities and seems to be less of a 'complaint' compared to the wonderfully vocal Windows users who've repeatedly complained.

and in all honesty, i'd be more tempted to try to make a Windows 8 / Metro style interface though i really don't know if that even allows for redirection of console output (i doubt it) so that may not be viable / requires a different way of trying to do things.

-daz
Attached Thumbnails
Click image for larger version

Name:	gui_wip.png
Views:	198
Size:	58.0 KB
ID:	49810  
DrO is offline  
Old 23rd July 2012, 15:49   #70
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 4,719
Send a message via AIM to MrSinatra
dumb question:

is this the v1 style terminal wrapper? will it have easy access to edit config txt?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is online now  
Old 23rd July 2012, 16:11   #71
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
Quote:
Originally Posted by MrSinatra View Post
is this the v1 style terminal wrapper?
it's an equivalent of what the v1 DNAS natively provided but is targeted at the v2 DNAS only (is no point in trying to develop something for a DNAS which is not under development).

it's no more different than the few other wrappers which have been created, just i'm aiming for something which is small and just does what it's supposed to do i.e. just embeds the DNAS's output in a Windows themed window with similar log output highlighting to the DNAS's upcoming output and allows for starting / stopping it without having to use the (seemingly deemed evil) command-line.

Quote:
Originally Posted by MrSinatra View Post
will it have easy access to edit config txt?
i still haven't decided what i am or am not going to implement in it (especially for starting off on things). though making it open the config file in the associated text editor is just a one line call (and is what the v1 wrapper did anyway - when it worked). i am toying with the idea of an integrated editor (well just embedding an edit control) so then things can maybe be a bit more automated.

as so far the only thing other than start / stop actions is a menu action which allows for going directly to the DNAS's server admin summary page (/admin.cgi?sid=0) since that seems to be one of those things which keeps coming up as something people struggle to find (especially from Windows users).

-daz
DrO is offline  
Old 23rd July 2012, 19:00   #72
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
Quote:
Originally Posted by DrO View Post
nwgator: what am i meant to be looking at in the above log snippet? the 'Error writing to console - write issue' messages?

-daz
Not exactly sure... I set all the log files to 777 and see if the stream disconnects. It seems at times almost if the shoutcast server times out for a few seconds and is inaccessible, then comes back later... I know it's not the server dropping connection, because on the same box, I have an IRC eggdrop that doesn't lose connection throughout the process.

EDIT: The only thing of interest in the log I posted really was
PHP Code:
2012-07-20 21:43:25    E    msg:virtual void AOL_logger::consoleLogger_element::log(const AOL_logger::message&) Error writing to console write issue 
2012
-07-20 21:43:45    E    msg:***91;YP2***93;  ***91;YP2***93;  Could not resolve host address yp.shoutcast.com Restarting in one minute 
Not exactly sure why it would do that.
nwgator is offline  
Old 23rd July 2012, 20:49   #73
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
it could be the DNAS maxing out on the file descriptors it's able to use (if you're getting more than 300 concurrent clients then things can get a bit 'quirky' in relation to "the shoutcast server times out for a few seconds and is inaccessible, then comes back later".

with the yp resolution issue, it's not ideal but try setting ypaddr=64.12.96.225 and see if that makes a difference (it should resolve but either the DNAS is caching something incorrectly or the host isn't getting the correct DNS record for things).


and with the logger write error, setting screenlog=0 will sort that out as the shell the DNAS was started to run in seems to have expired so it'll keep spamming that out.

-daz
DrO is offline  
Old 24th July 2012, 02:19   #74
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
I've turned on debugging for everything and if it happens again I'll let you know.
The problem doesn't happen that often.
nwgator is offline  
Old 24th July 2012, 02:25   #75
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
in all honesty i don't think that's going to help out too much in trying to determine the cause but hopefully i'll be proved wrong (though will be fun if it does happen especially in trying to match a b29 log output to what the internal builds generate).

-daz
DrO is offline  
Old 24th July 2012, 06:39   #76
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
I'm seeing a few of these as I look through the log... any ideas? This is on Debian 64-bit.

PHP Code:
2012-07-24 01:59:25    E    msg:***91;DST 186.89.69.88:57071 sid=1***93; Socket error while waiting to send dataerr=Connection reset by peer(104)
2012-07-24 02:09:27    E    msg:***91;DST 208.20.225.130:53615 sid=2***93; Socket error while waiting to send dataerr=Connection reset by peer(104
nwgator is offline  
Old 24th July 2012, 11:27   #77
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
that is generally normal when a connection ends, without context of what those messages relate to it's hard to say if it's a true error or not, though it is most likely not.

most of those sort of messages will be hidden away whenever the next release happens since they are mainly for debugging and are just the raw codes reported when the underlying socket connections close (hence why it is normal to see them).

-daz
DrO is offline  
Old 24th July 2012, 17:40   #78
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
Quote:
Originally Posted by DrO View Post
that is generally normal when a connection ends, without context of what those messages relate to it's hard to say if it's a true error or not, though it is most likely not.

most of those sort of messages will be hidden away whenever the next release happens since they are mainly for debugging and are just the raw codes reported when the underlying socket connections close (hence why it is normal to see them).

-daz
I went back in the logs when I noticed the problem that I had mentioned up there occurred again. Those were the only things in the log that were errors.. weird. the content surrounding them looked normal to me. I don't have 300 clients connected at one point, but I am using port 80... could that pose any problems?

You were right about having debugging turned on for everything not helping. Now I just have a massive log file lol.

It's stable for the most part, just these little hiccups every once in a while are irritating. Could something like this be fixed with an update to the DNAS?
nwgator is offline  
Old 25th July 2012, 01:10   #79
DrO
Winamp Team
 
DrO's Avatar
 
Join Date: Sep 2003
Posts: 25,998
Quote:
Originally Posted by nwgator View Post
I went back in the logs when I noticed the problem that I had mentioned up there occurred again. Those were the only things in the log that were errors.. weird. the content surrounding them looked normal to me. I don't have 300 clients connected at one point, but I am using port 80... could that pose any problems?
it shouldn't make a difference what port things are running on unless there's some external aspect affecting how things like DNS resolution are happening. i've never directly seen the issue happen let alone for anyone to have it happen reliably that it could be debugged against so i'm really not sure what is the cause. it could even just be the timing of the those connections to the YP coincided with us doing updates on it or the load balancer not handling things properly, just don't know.

Quote:
Originally Posted by nwgator View Post
You were right about having debugging turned on for everything not helping. Now I just have a massive log file lol.
that's why so much is hidden via the debugging options, though i think i've almost halved the amount of log output that happens under normal usage for what will become the next public build.

Quote:
Originally Posted by nwgator View Post
It's stable for the most part, just these little hiccups every once in a while are irritating. Could something like this be fixed with an update to the DNAS?
i'm aware that a new public build needs to be released (if only to stop the insane number of new authhash that people keep re-making because they've not read the docs / example configs), but doing that has been dependent upon initially a whole slew of YP updates making it publically (which is now done). but there are some remaining issues which need to be resolved (mainly against relaying and the associated backupurl handling) as well as the documentation + setup process being re-done (the docs alone is a weeks work).

since in all honesty there's no point from my side of the fence in giving out what is a notably improved build (as there are a lot of newer builds being used out in the wild via our partners which has validated that being the case) when people still cannot install it or have the doc updates to know what can be done with the new features or get their heads around editing 2 things in an example config file and going to one page at the most basic to get things up and listed (hence having to make a more integrated setup UI for it).

yes there probably should have been more incremental updates instead of what is now at a 101 line changelog (and that's me being frugal on what i've added to it). but then most people seem to be adverse to frequent updates and actually it's probably worked out better in this case to just wait longer so that i do catch and fix all of the issues which i can and provide one large update addressing them all in one go so it is more appealing as something for people to install or actually use to update a v1 setup and without needing people to keep updating their DNAS (as i've been repeatedly told from a lot of people that they don't like doing since they then loose their peak numbers and uptime).

-daz
DrO is offline  
Old 25th July 2012, 01:26   #80
nwgator
Member
 
Join Date: Oct 2008
Location: Jacksonville, FL
Posts: 72
Thanks for the response. I understand. Let me know if I can help out in any way, especially if you need more testers

It's sad that people are ignorant of the documentation/examples. I understood them fine.
nwgator is offline  
Closed Thread
Go Back   Winamp Forums > SHOUTcast > SHOUTcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump