Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Closed Thread
Thread Tools Search this Thread Display Modes
Old 29th July 2011, 18:01   #1
DrO
 
Join Date: Sep 2003
Posts: 27,873
SHOUTcast Transcoder 2 Beta (Build 51) 07/29/2011

Presenting the latest BETA drop of the SHOUTcast Transcoder for broadcasters, developers and testers. This build is our latest GM release candidate and introduces new features as listed in the “Changes” section below, as well as addresses bugs reported in the previous BETA builds.

This BETA release is now available for the following platforms:
  • Windows 32-bit and 64-bit versions) (Windows 2000 and up)
  • Windows 64-bit (Windows XP64 and up)
  • Linux
  • Linux 64-bit
  • Mac OS X (Intel)
  • BSD 8.x


Downloads

You can download the updated version of the transcoder from the direct downloads for the operating system version you require:

Changes
  • Fixed DJ and Relay connections using AAC not working (build 48 specific)
  • Fixed loading playlists specified by an absolute file path not working on non-Windows versions (build 48 specific)
  • Fixed loading playlist entries with wildcard searches e.g. *.* not being recognised (build 48 specific)
  • Fixed ID3v2.x tag reading issue causing a crash with certain tag combinations
  • Fixed 'configrewrite' to no longer write some old / invalid configuration options when enabled
  • Fixed playlists to explicitly only allow supported file types to be loaded (based on file extension)
  • Fixed playlist loading checks to now be case-insensitive
  • Fixed first playlist event from calendar.xml not being registered (build 48 specific)
  • Fixed to no longer send titles with UTF-8 characters the DNAS will not accept (resolves some connection issues)
  • Fixed non-english title compatibility with v1 DJ sources i.e. titles with accented characters, was leading to dropped v2 DNAS connections
  • Fixed some MP3 encoding keys not working when used in non-Windows installs despite being valid
  • Fixed some configuration combinations causing broadcasting to not start when they should
  • Changed 'playlists', 'archive' and 'djbroadcasts' defaults to be more sensibly named and also to be relative to the folder from the running Transcoder instance
  • Changed some log messages from appearing where not applicable or from excessively appearing
  • Upgraded Fraunhofer AAC Encoder library to newest version (fixes high bitrate upsampling bug and slight quality improvements)
  • Other miscellaneous code changes, crash fixes and improvments


Getting Started

If you already have a running instance of the transcoder then with this build you will need to make some changes to the configuration file otherwise it will not work the same as pre-upgrade.

The change needed is to move all of the multi options e.g. outprotocol from _0 to _1 with the number of the options e.g.

If you have the following on the left then they will need to be changed to what is shown on the right:

outprotocol_0=3 -> outprotocol_1=3
outprotocol_1=1 -> outprotocol_2=1



Otherwise there should not be any issues with replacing your current version with this new version.

If this is a new install then make sure to read through the information in the 'docs' folder along with the example configuration files provided in this new version which should make it easier to get started.



Reporting Issues

If you do come across an issue with the transcoder, then please do post in this thread with as much information as possible about what you're doing at the time, the system you are using and anything else which will make it easier to understand what is or isn't going on with your install.



MP3 Broadcasting License

In order to unlock the MP3 broadcasting capabilities of this transcoder, you will need to purchase a MP3 license key. Click here to purchase.



Known Issues

The following are known issues with the v2 DNAS raised in previous releases but not currently fixed / fully confirmed as needing to be fixed (i.e. intended behaviour):
  • With some metadata (primarily if running in v2 mode), when they are read / received then they may have characters incorrectly removed / changed. This is due to some additional processing happening on the metadata which is causing some of the utf-8 encoding to be incorrectly changed / lost which leads them to be filtered / replaced with a different value at a later stage in handling. This will be resolved in a later build and is related to some of the build 51 fixes to prevent invalid metadata being sent to the DNAS which will cause the connection to be dropped.
  • Relaying of SHOUTcast streams does not properly work when trying to relay a SHOUTcast 2.0 based stream. This is due to not fully supporting some of the SHOUTcast 2.0 protocols which has been internally fixed for the next release.


Additional Information

Windows versions of the transcoder are built with a dependency against the Microsoft Visual C++ 2008 SP1 Redistributable Package. If sc_trans is unable to start due to a dependency issue then you will need to install the correct version of the package so it can run which depends on the version of sc_trans you are attempting to run:

32-bit - http://www.microsoft.com/downloads/e...d-3802b2af5fc2
64-bit - http://www.microsoft.com/downloads/e...4-157cfdffee4e


This new version has been tested on a number of current Linux versions (Ubuntu, Fedora, CentOS) so should hopefully run on other versions as well and without any dependency or locale related issues (as affected prior versions).


Discussion about the previous version of the server including changelogs can be found in the following threads
-daz
DrO is offline  
Old 29th July 2011, 18:22   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
A few users have helped to test out a number of playlist and file metadata related issues which have been in the Transcoder since the prior build and also some of the older ones. Hopefully this will resolve some of the stability issues which have plagued the earlier versions (ignoring build 48 which was a bit of a bum version).

Secondly this version adds back in AAC DJ & Relay support. Hopefully there will not be any crashes whilst using it though it is a possibility based on experiences during testing but i'm hoping that will not be the case (when i come back to things after a week's holiday!).

-daz
DrO is offline  
Old 1st August 2011, 16:55   #3
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
Build 51:

The password_x required even with outprotocol_x=3 bug is fixed.

The always-relative file paths in the playlist bug is fixed.

The replaygain uses only the enhancereplaygain value and ignores the file bug (http://forums.winamp.com/showpost.ph...3&postcount=50) remains.

The playlist script issues/ambiguity remains: http://forums.winamp.com/showpost.ph...3&postcount=53

(and for completeness, the question I have over metadata: http://forums.winamp.com/showpost.ph...6&postcount=54)
DaWolfey is offline  
Old 1st August 2011, 18:40   #4
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
I've found a serious bug with this build, it is mangling utf8 idv3 tags, sending them to scserv (shoutcast 2 protocol) and causing it to crash.

Trans build 48 and Serv build 28 worked perfectly (at least, with the test mp3s i sent at it) as does Trans 48 and Serv 29

Trans 51 however, sends the metadata in some way that Serv really hates, causing it to crash on one of my test mp3s, with:

Quote:
2011-08-01 18:56:14 D msg:[SRC 127.0.0.1:53329 sid=2] Cacheable metadata reset due to span change
std::runtime_error'
what(): XML parser error: not well-formed (invalid token) at line 6
Aborted
and mangle all the non latin characters in all the others.

I could apply the tags to a silent mp3 if that would be useful (so long as the john cage doesn't sue me)
DaWolfey is offline  
Old 2nd August 2011, 22:43   #5
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
Is there a way to reduce the buffer length or otherwise reduce the time it takes from Trans selecting a song (or using the nextsong weblet command) to it being sent to Serv?

I have reduced the Serv buffer to 1 second, but there doesn't seem to be a buffer length option for the Transcoder.
DaWolfey is offline  
Old 4th August 2011, 01:21   #6
gaurav_verma22
Junior Member
 
Join Date: Aug 2011
Posts: 16
Is this the same issue that you are talking about?

Please advise if this is the same issue with the latest build of sc_trans that you talking about.. Everything seemed to be going well, until the UTF8 tags hit and then the server become unresponsive

2011-08-03 18:01:48 I msg:[MP3ENC] 1896902636/44100/2/64000 MP3 setup complete
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Broadcast setup
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Negotiating buffer sizes
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Negotiated buffer size is 160KB
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Negotiating payload sizes
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Negotiated payload size is 16377
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Configuring ICY-NAME[Listen to Nectar of Pure Bhakti: Srimad Bhagavatam Maha Puran]
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Configuring ICY-GENRE [Hindu/Vedic/Bhakti/Devotional/Krishna/Vyas]
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Configuring ICY-URL [http://www.shoutcast.com]
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Configuring ICY-PUB [0]
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Flush metadata
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Standby
2011-08-03 18:01:48 I msg:[UVOX2] 1617140436 Streaming
2011-08-03 18:01:49 I msg:[UVOX2] 1617140436 Sending metadata 3902 [487 bytes] content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata>
<TIT2>A_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_A</TIT2>
<extension>
<title seq="1">A_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_A</title>
<title seq="2">B_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_B</title>
<title seq="3">C_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_C</title>
<title seq="4">D_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_D</title>
<soon>B_Srimad_Bhagavatam_Canto1_Ch_1_thru_6_Part_B</soon>
</extension>
</metadata>

2011-08-03 18:06:38 E msg:[UVOX2] 1617140436 [UVOX2] 1617140436 socket send error.
2011-08-03 18:06:38 E msg:[UVOX2] 1617140436 Waiting 30 seconds
2011-08-03 18:07:04 I msg:[UVOX2] 1617140436 Creating stream socket
2011-08-03 18:07:04 I msg:[UVOX2] 1617140436 Connecting to stream host
2011-08-03 18:07:04 W msg:[UVOX2] 1617140436 Error connecting to stream host [waiting 30s]
2011-08-03 18:07:30 I msg:[UVOX2] 1617140436 Connecting to stream host
2011-08-03 18:07:30 W msg:[UVOX2] 1617140436 Error connecting to stream host [waiting 30s]
2011-08-03 18:07:56 I msg:[UVOX2] 1617140436 Connecting to stream host
gaurav_verma22 is offline  
Old 5th August 2011, 02:42   #7
frogstomp19
Junior Member
 
Join Date: Jul 2011
Posts: 2
I'm now having the same problem as gaurav_verma22.

2011-08-04 22:34:43 I msg:[MAIN] Logger updating log file to use
2011-08-04 22:34:43 I msg:[MAIN] Loaded config from sc_trans_capture.conf
2011-08-04 22:34:43 I msg:[MAIN] TimeMultiplier = 1, TimeShift = 0
2011-08-04 22:34:43 E msg:[CALENDARMGR] Could not load calendar file (calendar.xml) XML parser error: no element found at line 1
2011-08-04 22:34:43 I msg:[VUPUSH] 101 VU images loaded for left channel
2011-08-04 22:34:43 I msg:[VUPUSH] 101 VU images loaded for right channel
2011-08-04 22:34:43 I msg:[PLAYLISTMGR] Playlist load from file playlists\main.lst
2011-08-04 22:34:43 W msg:[PLAYLISTMGR] The playlist entry playlists\.\music\shoutcast.mp3 generated no entries
2011-08-04 22:34:43 I msg:[PLAYLISTMGR] Caching playlist playlists\main.lst
2011-08-04 22:34:43 I msg:[PLAYLISTMGR] Load complete
2011-08-04 22:34:43 I msg:[MAIN] Streaming thread starting
2011-08-04 22:34:43 I msg:[RESAMPLER] Deactivated 44100/2 == 44100/2
2011-08-04 22:34:43 I msg:[SOURCEANDENDPOINTMANAGER] Encoder thread 1 starting
2011-08-04 22:34:43 I msg:[SOURCEANDENDPOINTMANAGER] Broadcast thread 1 starting
2011-08-04 22:34:43 I msg:[MAIN] Starting audio capture
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] Building directShow graph objects
2011-08-04 22:34:43 I msg:[SOURCERELAY] Thread starting
2011-08-04 22:34:43 I msg:[UVOX2] 23750 Giving replay gain calculator a head start
2011-08-04 22:34:43 I msg:[AAC] AAC setup complete
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] Locating capture device
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] Begin audio devices
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] device [Stereo Mix (Realtek High Defini]
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] End audio devices
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] Using device `Stereo Mix (Realtek High Defini'
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] Begin audio inputs
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] input [Master Volume]
2011-08-04 22:34:43 D msg:[CAPTUREWIN32] End audio inputs
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] Graph built.
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] Graph running.
2011-08-04 22:34:43 I msg:[MAIN] Playlist decoder thread starting
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] EVENT 13
2011-08-04 22:34:43 I msg:[CAPTUREWIN32] EVENT 14
2011-08-04 22:34:43 I msg:[RGCALC] Thread running
2011-08-04 22:34:43 I msg:[UVOX2] 23750 Running
2011-08-04 22:34:43 I msg:[UVOX2] 23750 Creating stream socket
2011-08-04 22:34:43 I msg:[DECODE] Giving replay gain calculator a head start
2011-08-04 22:34:43 I msg:[DECODE] Begin decoding
2011-08-04 22:34:43 I msg:[BROADCASTSTALLMANAGER] Timed content set to TRUE
2011-08-04 22:34:43 I msg:[UVOX2] 23750 Connecting to stream host
2011-08-04 22:34:44 W msg:[UVOX2] 23750 Error connecting to stream host [waiting 30s]
2011-08-04 22:35:14 I msg:[UVOX2] 23750 Connecting to stream host
frogstomp19 is offline  
Old 8th August 2011, 13:24   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by DaWolfey View Post
The replaygain uses only the enhancereplaygain value and ignores the file bug (http://forums.winamp.com/showpost.ph...3&postcount=50) remains.
will need to check that out - isn't an area i've really tinkered with so is likely it isn't working correctly as expected.

Quote:
Originally Posted by DaWolfey View Post
The playlist script issues/ambiguity remains: http://forums.winamp.com/showpost.ph...3&postcount=53
will have to check that out and get back to you about that.

Quote:
Originally Posted by DaWolfey View Post
(and for completeness, the question I have over metadata: http://forums.winamp.com/showpost.ph...6&postcount=54)
that would be a sensible addtion to allow for metadata to be read from the playlist and use that if the metadata isn't oresent or disabled (only thing i'm not keen on is having to add in another config option to facilitate this considering there's a load of complaints about there being to many options in the Transcoder already).

Quote:
Originally Posted by DaWolfey View Post
I've found a serious bug with this build, it is mangling utf8 idv3 tags, sending them to scserv (shoutcast 2 protocol) and causing it to crash. ... Trans 51 however, sends the metadata in some way that Serv really hates
there were changes made which fixed a load of metadata issues which other users had been happening which from what i've heard back have fixed stability (seems one of the tests has managed well over a week now which was only making a few hours before the fix). if you can see below, but also post a copy of the metadata from the sc_trans log file then that may make it clearer to see what is being sent which isn't liked. it is noted in the first post that there might be some 'quirks'. also are you just playing things from a playlist or is this happening via a DJ connection?

Quote:
Originally Posted by DaWolfey View Post
I could apply the tags to a silent mp3 if that would be useful (so long as the john cage doesn't sue me)
that would be useful (or even on the mp3 shipped with the sc_trans distro) and email that to me (address is on my site from my signature).

Quote:
Originally Posted by DaWolfey View Post
Is there a way to reduce the buffer length ... but there doesn't seem to be a buffer length option for the Transcoder.
that would be because there isn't an option (funnily enough someone else asked about that today). it is something i've got on my wishlist of things for the Transcoder, just not sure on an eta for when it'd be implemented.

-daz
DrO is offline  
Old 8th August 2011, 17:38   #9
mixfeever
Junior Member
 
Join Date: Dec 2010
Posts: 10
Hi,

I've two problem :
- How the metadata are sent ? I can read them like the Build 48. Where is the difference ?
- When a DJ connect, the sc_trans is disconnect some seconds from the server :

Quote:
2011-08-08 14:20:16 W msg:[STREAM] 2058061424 Disconnecting from stream host [waiting 10s]
2011-08-08 14:20:17 I msg:[SHOUTCASTMETADATA] Metadata string []
2011-08-08 14:20:17 I msg:[SHOUTCASTMETADATA] Sending metadata
2011-08-08 14:20:26 I msg:[STREAM] 2058061424 Creating stream socket
2011-08-08 14:20:26 I msg:[STREAM] 2058061424 Resolving stream host
2011-08-08 14:21:41 I msg:[DJMGR] DJ `root' is done.
2011-08-08 14:21:59 I msg:[STREAM] 2058061424 Connected to host server
2011-08-08 14:21:59 I msg:[STREAM] 2058061424 Host server gave success (OK2)
2011-08-08 14:21:59 I msg:[STREAM] 2058061424 Stream to live1.mixfeever.com established
2011-08-08 14:21:59 I msg:[STREAM] 2058061424 Sending stream information
2011-08-08 14:21:59 I msg:[BROADCASTSTALLMANAGER] Timed content set to FALSE
2011-08-08 14:21:59 I msg:[DECODE] Next file is /root/sc_new/../MP3/Inna - Club Rocker.mp3
2011-08-08 14:21:59 I msg:[DJMGR] No DJ currently active. Run permission granted for `root'
2011-08-08 14:21:59 I msg:[DJPROTOCOLSHOUTCAST] Connected
2011-08-08 14:22:00 I msg:[DJMGR] DJ `root' is done.
I want to re-install build 48, where i can find the download link ?

Thanks for your help

Regards
mixfeever is offline  
Old 8th August 2011, 17:54   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by mixfeever View Post
How the metadata are sent ? I can read them like the Build 48. Where is the difference ?
that doesn't make any sense. you need to make it clearer what you mean.

Quote:
Originally Posted by mixfeever View Post
When a DJ connect, the sc_trans is disconnect some seconds from the server
you've not said what DNAS you're connecting to, the version, what protocol (it looks like you're using the v1 protocol but clarification would be nice). also the disconnect is happening before anything with the DJ connection appears to happen so it could just be coincidence or is an issue with the files you're playing when there isn't a DJ connected.

-daz
DrO is offline  
Old 8th August 2011, 20:48   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by gaurav_verma22 View Post
2011-08-03 18:06:38 E msg:[UVOX2] 1617140436 Waiting 30 seconds
2011-08-03 18:07:04 I msg:[UVOX2] 1617140436 Creating stream socket
2011-08-03 18:07:04 I msg:[UVOX2] 1617140436 Connecting to stream host
2011-08-03 18:07:04 W msg:[UVOX2] 1617140436 Error connecting to stream host [waiting 30s]
2011-08-03 18:07:30 I msg:[UVOX2] 1617140436 Connecting to stream host
2011-08-03 18:07:30 W msg:[UVOX2] 1617140436 Error connecting to stream host [waiting 30s]
2011-08-03 18:07:56 I msg:[UVOX2] 1617140436 Connecting to stream host
based on the part i've quoted from you post, there appears to be nothing for the Transcoder to connect to. the metadata you posted doesn't appear to contain any invalid utf-8 characters but then it's possible they've gotten mangled by the forum. as such i think your issue is best continued in your other thread -> http://forums.winamp.com/showthread.php?t=333200 (which is a consolidation of all you've posted as it's too confusing having different snippets of you issue in 4 different locations).

-daz
DrO is offline  
Old 8th August 2011, 21:08   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by frogstomp19 View Post
2011-08-04 22:34:43 E msg:[CALENDARMGR] Could not load calendar file (calendar.xml) XML parser error: no element found at line 1
that's the first issue which shouldn't but might be causing issues i.e. you need to check the calendar.xml file and see why it's causing that issue.

Quote:
Originally Posted by frogstomp19 View Post
2011-08-04 22:34:43 I msg:[UVOX2] 23750 Connecting to stream host
2011-08-04 22:34:44 W msg:[UVOX2] 23750 Error connecting to stream host [waiting 30s]
2011-08-04 22:35:14 I msg:[UVOX2] 23750 Connecting to stream host
is the DNAS running? is it on the port the Transcoder has been told to connect to? As that error usually happens if there is no DNAS able to be found (either from not running or not being on the specified port).

-daz
DrO is offline  
Old 8th August 2011, 23:24   #13
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
There are two crashing problems. There is the first I described earlier related to the Transcoder, but there is a second one related to the DNAS and Shoutcast 2 clients. I have posted that in the DNAS thread.
DaWolfey is offline  
Old 9th August 2011, 08:55   #14
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Small bug, to do with uninstall

I installed DNAS and TRANS in the same folder (windows 7 by the way)

I uninstalled TRANS - which removed all the TRANS stuff, but it removed the DNAS entry in the Programs and Features list, and left the TRANS one in there

Is it just me or are shoutcast users getting dumber?
jaromanda is offline  
Old 9th August 2011, 09:32   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
jaromanda: will check it out for when the next drop happens.

-daz
DrO is offline  
Old 9th August 2011, 09:34   #16
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
In this thread I am always referring to this build of the Transcoder. The other thread is for that build of the DNAS and issues related to it.
DaWolfey is offline  
Old 9th August 2011, 11:59   #17
mixfeever
Junior Member
 
Join Date: Dec 2010
Posts: 10
Quote:
Originally Posted by DrO View Post
that doesn't make any sense. you need to make it clearer what you mean.

you've not said what DNAS you're connecting to, the version, what protocol (it looks like you're using the v1 protocol but clarification would be nice). also the disconnect is happening before anything with the DJ connection appears to happen so it could just be coincidence or is an issue with the files you're playing when there isn't a DJ connected.

-daz
Hello,

Sorry for my english.
I meant build 40 and not build 48.

- Have you change encoding of metadata (ISO to UTF8 or else ?) between build 40 to build 51 ?

- I connect my radio to a liquidsoap server (Shoutcast v1). I'have already a DJ connecting to the server, but when a DJ with a high level connect, connection is droped. Nor a coincidence, it's always when a new DJ connect to the sc_trans server.

Can you send me a link to the build 40 please ? This version work perfectly for my usage.

Thanks
mixfeever is offline  
Old 9th August 2011, 15:23   #18
DrO
 
Join Date: Sep 2003
Posts: 27,873
builds 48 and 51 changed a number of things when it comes to the processing of metadata from sources and also from played files (you've not actually specified what scenario is causing you issue) which fixed a large number of abort crashes (which needs to be resolved still in the expat library used on non-Windows versions) and connection issues for most users (was always the potential it might cause some issues - hence the note in the first thread).

with v2 usage, things were done to ensure only valid UTF-8 characters are sent to the v2 DNAS (or a v2 compatible server) in the metadata (though this may have some quirks based on DaWolfey's issues). with v1 usage, nothing has been done to change the style of metadata output.

i've never heard of the liquidsoap server, if this is a 3rd party thing then i'm not sure there is much i can do as compatibility is only guaranteed between the officially provided tools.

so am i right in thinking that you're doing DJ -> Transcoder -> liquidsoap ? if so then it almost sounds like liquidsoap is too sensitive to changes in the handled DJ connections in the Transcoder (though you've not provided much information on the format being used).


i cannot provide a link to build 40 as it is a) no longer supported and b) is not allowed under the change of AAC libraries used and the license that exerts. this is probably harse but when running anything marked as 'beta', it's best to keep any copies of versions downloaded. however if you can provide more information then we can look to get things fixed as its likely if you're seeing an issue, then someone else is (and my gut feeling is its probably related to DaWolfey's issues).

-daz
DrO is offline  
Old 9th August 2011, 17:31   #19
mixfeever
Junior Member
 
Join Date: Dec 2010
Posts: 10
Hello,

I will try to explain better issues, but my English is not the best.

When a DJ is connected on the transcoder or when it's a playlist, the metadata sent is not the same than the build 40 and i cannot show correctly the information.

I've this in my log :
2011-08-09 15:43:33 I msg:[SHOUTCASTMETADATA] Metadata string [Sak Noel - Loca People]
2011-08-09 15:43:33 I msg:[SHOUTCASTMETADATA] Sending metadata

But in the shoucast v1 server (The shoutcast server is implemented in liquidsoad) i've [ - Sak Noel ] (No title and artist is moved to title. I've no problem with the build 40.

I run transcoder on Linux (32bit) : Ubuntu 10.04 and all is in MP3

Maybe i've to add a Metadata option in my config file ? But i think this config is used only for playlist.

Sorry if it's difficult to understand me

Last edited by mixfeever; 9th August 2011 at 18:50.
mixfeever is offline  
Old 9th August 2011, 20:22   #20
DrO
 
Join Date: Sep 2003
Posts: 27,873
that example made it a lot clearer.

maybe it doesn't like the change from %R[ - ]%A[ - ]%N to %R[ - ]%N for the displayMetadataPattern config option which i changed way back in February hence slipping my mind. so maybe liquidsoap expects the older version (i couldn't tell from a quick look at their docs).

-daz
DrO is offline  
Old 10th August 2011, 08:12   #21
mixfeever
Junior Member
 
Join Date: Dec 2010
Posts: 10
Quote:
Originally Posted by DrO View Post
that example made it a lot clearer.

maybe it doesn't like the change from %R[ - ]%A[ - ]%N to %R[ - ]%N for the displayMetadataPattern config option which i changed way back in February hence slipping my mind. so maybe liquidsoap expects the older version (i couldn't tell from a quick look at their docs).

-daz
Hello,

So, i try with a classic sc_serv (v1) on ubuntu and the problem is the same

2011-08-10 10:10:44 I msg:[TITLEUPDATE] Receiving DJ metadata "Max - Test1"
2011-08-10 10:10:44 I msg:[TITLEUPDATE] Relaying DJ metadata
2011-08-10 10:11:02 I msg:[SHOUTCASTMETADATA] Metadata string [Max - Test1]
2011-08-10 10:11:02 I msg:[SHOUTCASTMETADATA] Sending metadata

But on the server : "Current Song: Max"

Have you a solution for that or i've to wait the next version ?

Thanks
mixfeever is offline  
Old 10th August 2011, 08:29   #22
DrO
 
Join Date: Sep 2003
Posts: 27,873
have you tried displayMetadataPattern=%R[ - ]%A[ - ]%N in your Transcoder config file?

if it's doing it with the true v1 DNAS (though that is no longer really supported) then i really think you need to send me copies of your config files (email is on my site from my signature) so i can try things out as i currently have no idea why you're seeing something no one else is.

-daz
DrO is offline  
Old 12th August 2011, 10:21   #23
DrO
 
Join Date: Sep 2003
Posts: 27,873
mixfeever's confirmed the fix - turned out the DJ connections weren't being url-escaped which the v1 DNAS expected (bit of a whoopsie on my part related to all of the metadata tweaks which have been going on in the Transcoder recently).

-daz
DrO is offline  
Old 12th August 2011, 12:08   #24
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by jaromanda View Post
I uninstalled TRANS - which removed all the TRANS stuff, but it removed the DNAS entry in the Programs and Features list, and left the TRANS one in there
Quote:
Originally Posted by DrO View Post
jaromanda: will check it out for when the next drop happens
Just had a quick chance to check and have fixed this for when new installers are created - the joys of shared NSIS installer scripts. will also get the DSP script checked out as that's probably affected as well. thanks for point it out.

-daz
DrO is offline  
Old 15th August 2011, 21:18   #25
lyov
Junior Member
 
Join Date: Jan 2011
Posts: 48
Hello DrO,
I have same utf-8 chars problem with new sc_trans
lyov is offline  
Old 15th August 2011, 21:40   #26
DrO
 
Join Date: Sep 2003
Posts: 27,873
such as? what connection type? what media?
just saying you have problems is not useful for me to start working on a fix.

-daz
DrO is offline  
Old 16th August 2011, 09:42   #27
lyov
Junior Member
 
Join Date: Jan 2011
Posts: 48
I sent You pm please find it.
lyov is offline  
Old 19th August 2011, 21:34   #28
glenn385
Junior Member
 
Join Date: Aug 2011
Posts: 1
shoutcast download issues

i get a : sc_trans_win64_07_29_2011.exe is not commonly downloaded and could hurt your computer, warning when i try yo update my plugin for winamp what can i do to fix this problem
glenn385 is offline  
Old 19th August 2011, 21:38   #29
DrO
 
Join Date: Sep 2003
Posts: 27,873
firstly that sounds like something Internet Explorer shows for any installers which are not signed - something i need to get changed.

secondly, the Transcoder is not for Winamp, for Winamp you would need the Source DSP. might be a good idea to clarify what it is you're using / trying to do before attempting to install any sort of updates.

-daz
DrO is offline  
Old 23rd August 2011, 05:21   #30
maksimilian
Junior Member
 
Join Date: Jan 2011
Posts: 9
russian files in utf-8 after upgrade to latest version shows like 5@2=K9 - 14C;0-!5@28A

got back some old build, all ok

debian 6.0 x64 + latest shoutcast2 latest version
maksimilian is offline  
Old 23rd August 2011, 09:57   #31
DrO
 
Join Date: Sep 2003
Posts: 27,873
maksimilian: it should be fixed for the next release of the Transcoder seeing as i spent most of the weekend just gone (when i shouldn't have been) working on fixing such issues. additionally it is in the known issues that there are some metadata related issues with the current build (that affects builds 48 and 51 from all of the other metadata fixes which were introduced).

-daz
DrO is offline  
Old 25th September 2011, 14:32   #32
Matrix2000
Junior Member
 
Join Date: Sep 2011
Posts: 21
Metadat

Sorry i have translate with Google:

I have the problem when a DJ is connected to the meta data are not transferred correctly.

Whenever a space between them is missing the rest.
However, if the playlist sc_trans2 AutoDJ say there is no problem.
He also updated the station did not name. There is always car and DJ who goes on the air if nothing happens
e.g. Xavier Naidoo -

Then there is only "Xavier" the rest is gone!
Vlt. Who can help me there.

Sam Broadcaster 4.9.1
sc_trans_linux_x64_07_29_2011 or SC_TRANS v2 Build 51
sc_serv 1.9.8

2011-09-25 16:01:42 I msg:[TITLEUPDATE] Receiving DJ metadata "Phil Collins - Both Sides Of The Story"
2011-09-25 16:01:42 I msg:[TITLEUPDATE] Relaying DJ metadata
2011-09-25 16:01:52 I msg:[SHOUTCASTMETADATA] Metadata string [Phil Collins - Both Sides Of The Story]
2011-09-25 16:01:52 I msg:[SHOUTCASTMETADATA] Sending metadata

Metadata is correct in screenlog but in player only "Phil" and rest is gone!

greets


German:

Ich habe das Problem wenn ein DJ sich connected das die Metada nicht fehlerfrei übertragen werden.

immer wenn ein leerzeichen dazwischen ist fehlt der rest.
Wenn jedoch sc_trans2 mit der Playlist sprich AutoDJ läuft gibt es kein Problem.
Desweiteren aktualisiert er auch nicht den Stations Namen. Es steht immer Auto DJ und wenn wer auf Sendung geht tut sich nichts
z.B. Xavier Naidoo – Dieser Weg

Dann steht da nur “Xavier” der rest ist weg!
Vlt. kann mir da wer helfen.

Sam Broadcaster 4.9.1
sc_trans_linux_x64_07_29_2011 bzw. SC_TRANS v2 Build 51
sc_serv 1.9.8

mfg

Hier noch ein Auszug aus dem screenlog (wo es richtig dargestellt wird):

2011-09-25 16:01:42 I msg:[TITLEUPDATE] Receiving DJ metadata "Phil Collins - Both Sides Of The Story"
2011-09-25 16:01:42 I msg:[TITLEUPDATE] Relaying DJ metadata
2011-09-25 16:01:52 I msg:[SHOUTCASTMETADATA] Metadata string [Phil Collins - Both Sides Of The Story]
2011-09-25 16:01:52 I msg:[SHOUTCASTMETADATA] Sending metadata

Im Screenlog passt es nur im player etc. wird nur "Phil" angezeit und das wars

Vielleicht weiß wer nen Rat ich weiß nicht mehr weiter sitze schon seit gestern nacht!
mfg
Matrix2000 is offline  
Old 25th September 2011, 16:58   #33
DrO
 
Join Date: Sep 2003
Posts: 27,873
Matrix2000: it's a known issue with the current build - it is fixed internally but there is no eta on when a fixed version will be released.

-daz
DrO is offline  
Old 25th September 2011, 19:06   #34
Matrix2000
Junior Member
 
Join Date: Sep 2011
Posts: 21
thx,
i have installed the dnas2.
it works perfectly but for 3 streams i have must install 3 sc_serv`s
great work is cool
Matrix2000 is offline  
Old 25th September 2011, 19:08   #35
DrO
 
Join Date: Sep 2003
Posts: 27,873
er, you shouldn't need to have 3 sc_serv's installed with the v2 tools unless you're providing 1000's of client connections per stream...

-daz
DrO is offline  
Old 25th September 2011, 19:29   #36
Matrix2000
Junior Member
 
Join Date: Sep 2011
Posts: 21
yes but only works with dsp for winamp?
we send only with sam broadcaster
greets Matrix
Matrix2000 is offline  
Old 27th September 2011, 09:20   #37
DrO
 
Join Date: Sep 2003
Posts: 27,873
current versions of SAM support the v2 DNAS as multiple sources and have done for a few months now (as they were the first partner to add v2 support).

-daz
DrO is offline  
Old 27th September 2011, 09:44   #38
Matrix2000
Junior Member
 
Join Date: Sep 2011
Posts: 21
thank you for answering the
However, if I have registered several streams he has always
taken only one stream.
I can post the config here?
Matrix2000 is offline  
Old 27th September 2011, 10:05   #39
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm really struggling to follow what you mean by that post specifically the 'if I have registered several streams he has always taken only one stream.' part

-daz
DrO is offline  
Old 27th September 2011, 10:35   #40
Matrix2000
Junior Member
 
Join Date: Sep 2011
Posts: 21
even if I have three streams sc_serv.conf entered into.
He has always taken only a stream.
for example port 8000,8002,8006 then he has always started the only 8006er.

streamid_1=1
streampath_1=DSL
serverip_1=** ip removed **
serverport_1=8000
streamid_2=2
streampath=ISDN
serverip_2=** ip removed **
serverport_2=8002
streamid_3=3
streampath_3=Tester
serverip_3=** ip removed **
serverport_3=8006



;NETWORKING
;=============================
namelookups=0
;portbase=8000
;autodumsourcetime=30
maxheaderlinesize=2048
maxheaderlinecount=100
adminpassword=*** Pass removed***
password=*** Pass removed ***
maxuser=100
streamadminpassword=*** Pass removed ***
streampassword=*** Pass removed ***
configrewrite=0
songhistory=10
;cpucount=0
admincssfile=v2

this is a small excerpt from the config
Matrix2000 is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump