Old 25th July 2011, 16:23   #1
DrO
 
Join Date: Sep 2003
Posts: 27,873
SHOUTcast DNAS 2 RC2 (Build 28) 07/29/2011

This build is our latest GM release candidate and introduces new features as listed in the “Changes” section below, as well as addresses bugs reported in the previous RC build.

This release is now available for the following platforms:
  • Windows 32-bit and 64-bit versions) (Windows 2000 and up)
  • Windows 64-bit (Windows XP64 and up)
  • Linux
  • Linux 64-bit
  • Mac OS X (Intel)
  • BSD 8.x

Downloads

You can download the updated version of the DNAS v2 from the direct downloads for the operating system version you require:
Changes

Build 28 (07/25/2011):
  • Added listen.asx to the /listen* playlist options available (so now pls, m3u and asx are available on a stream)
  • Added detection of sc_serv.ini if no configuration file was passed on loading (detects v1 configuration files)
  • Added 'type=xml' parameter to the 'updinfo' action to allow for v2 style XML metadata titles to be manually done
  • Changed streampath handling to allow '/' to be used again (was disabled in build 27)
  • Fixed kicking of listeners failing to respond / taking multiple attempts to react
  • Other miscellaneous code changes, improvments and related documentation updates
  • Everything else listed since the first v2 beta release (build 7)


Getting Started

If you already have a running instance of the DNAS v2 then there should not be any issues with replacing your current version with this new version.

If this is a new install then make sure to read through the information in 'docs\getting_started.txt' along with the example configuration files provided in this new version which should make it easier to get started. Alternatively you should consider looking at the configuration builder which is included in the 'config_builder' folder.

Finally, all copies of the documentation can also be found online at http://wiki.winamp.com/wiki/SHOUTcast_Broadcaster


Reporting Issues

If you do come across an issue with the DNAS v2, then please do post in this thread with as much information as possible about what you're doing at the time, the system you are using and anything else which will make it easier to understand what is or isn't going on with your install.

Posts relating to authhash management issues will be ignored as this is not the thread for posting such issues.


Known Issues

The following are known issues with the v2 DNAS raised in previous releases but not currently fixed / fully confirmed as needing to be fixed (i.e. intended behaviour):
  • If the external IP is bound to a different device than the primary on the machine then the server will not work as expected (e.g. eth1 instead of eth0)
  • Listing a relayed stream when using the YP2 mode is known to not work and will return a 474 error code from the attempt to connect to the YP. Setting the server as non-public or using the v2 DNAS in legacy mode (yp2=0) will allow the stream to be listed but means you lose all of the YP2 features. This requires a YP update which is planned to happen soon after this release.
  • Some characters in titles (usually below ascii value 32) will cause the DNAS to drop the source connection as the title is processed. This will not be changed in the DNAS and will instead require sources to ensure they send titles without invalid titles. The Transcoder and Source DSP will be receiving these updates soon.


Additional Information

Windows versions of the DNAS v2 are built with a dependency against the Microsoft Visual C++ 2008 SP1 Redistributable Package. If sc_serv is unable to start due to a dependency issue then you will need to install the correct version of the package so it can run which depends on the version of sc_serv you are attempting to run:

32-bit - http://www.microsoft.com/downloads/e...d-3802b2af5fc2
64-bit - http://www.microsoft.com/downloads/e...4-157cfdffee4e


Discussion about the previous version of the server including changelogs can be found in the following threads
-daz
DrO is offline  
Old 28th July 2011, 05:39   #2
Smelter
Major Dude
 
Smelter's Avatar
 
Join Date: Jan 2004
Posts: 1,141
any ETA on crossdomain policy file server integration?

Copy paste from the transocder pls...

Or did I miss that addition?
Smelter is offline  
Old 28th July 2011, 10:22   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's still on the todo list and will probably appear in one of the 2.0.x releases.

-daz
DrO is offline  
Old 29th July 2011, 16:53   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
minor update today (07/29/2011) which fixes a bug in the config builder (invalid config groups if more than 2 encoders are specified) and adds a tos.txt for the non-windows installers. there is no functional changes made to the DNAS itself.

-daz
DrO is offline  
Old 29th July 2011, 16:58   #5
SC_faisal
SHOUTcast (Alumni)
 
Join Date: Sep 2008
Posts: 162
Amazing milestone! This is essentially our GM / release build. This is the result of more than 1.5 years of hard work! The work continues but this is our 2.0 GM release.

Awesome work Darren and thanks to countless beta testers for sending in bug reports and being patient thru the months... Hope your patience pays off in what is a great release.

Cheers
f.
SC_faisal is offline  
Old 30th July 2011, 18:51   #6
DaWolfey
Junior Member
 
Join Date: Aug 2004
Posts: 18
I don't know if this is a DNAS problem, but it seems like it might be - or i'm stupid.

I have sc_trans connecting to sc_serv, when it connects it is using Shoutcast 2.
I know this becase in the sc_serv log:

Quote:
2011-07-30 18:01:22 I msg:[SRC 127.0.0.1:53400 sid=2] stream configuration complete. [
type=SHOUTcast 2
..
sc_serv is configured for yp2 mode (yp2=1).

My problem is that no matter what I do, my media player (Both Winamp 5.6.1 and Foobar 1.17) always connects in shoutcast 1 mode. Here is the debug log:

Quote:

2011-07-30 18:48:25 D msg:[MICROSERVER] Connection received from 192.168.202.10:61446
2011-07-30 18:48:25 D msg:[THREADRUNNER] thread 0 amt=5
2011-07-30 18:48:25 D msg:[THREADRUNNER] Adding microConnection to thread 0
2011-07-30 18:48:25 D msg:[THREADRUNNER] thread 0 amt=6
2011-07-30 18:48:25 D msg:[THREADRUNNER] Adding protocol_HTTPStyle to thread 0
2011-07-30 18:48:25 D msg:[THREADRUNNER] Removing microConnection from thread 0
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [accept:*/*]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [connection:close]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [host:g2.gbsfm.dev]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [icy-metadata:1]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [ultravox-transport-type:TCP]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] http header [user-agent:WinampMPEG/5.62, Ultravox/2.1]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] Request [GET]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] Url [/g3]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] Protocol[HTTP]
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446] Version [1.0]
2011-07-30 18:48:25 D msgrotocol_shoutcast1Client
2011-07-30 18:48:25 D msg:[THREADRUNNER] thread 0 amt=6
2011-07-30 18:48:25 D msg:[THREADRUNNER] Adding protocol_shoutcast1Client to thread 0
2011-07-30 18:48:25 D msg:[THREADRUNNER] Removing protocol_HTTPStyle from thread 0
2011-07-30 18:48:25 D msg:state_AttachToStream
2011-07-30 18:48:25 D msg:[STATS] System wide client total now 1
2011-07-30 18:48:25 D msg:[DST 192.168.202.10:61446 sid=2] Sending [ICY 200 OK
icy-notice1:<BR>This stream requires <a href="http://www.winamp.com/">Winamp</a><BR>
icy-notice2:SHOUTcast Distributed Network Audio Server/posix(linux x86) v2.0.0.28<BR>
icy-name:My Test Server
icy-genre:Misc
icy-url:http://www.shoutcast.com
content-type:audio/aacp
icy-pub:0
icy-metaint:8192
icy-br:56

]
2011-07-30 18:48:25 I msg:[DST 192.168.202.10:61446 sid=2] SHOUTcast 1 client connection accepted. WinampMPEG/5.62, Ultravox/2.1
2011-07-30 18:48:25 D msg:state_InitiateStream
No mention of shoutcast 2, its as if Winamp is asking to connect in shoutcast 1 mode.

So is there some config i've missed with sc_serv, or is winamp not using shoutcast 2?


This is the sc_serv startup:

Quote:
2011-07-30 18:49:21 I msg:[SHOUTcast] DNAS/posix(linux x86) v2.0.0.28 (Jul 25 2011) starting up...
2011-07-30 18:49:21 I msg:[MAIN] PID: 22988
2011-07-30 18:49:21 I msg:[MAIN] Loaded config from sc_serv.conf
2011-07-30 18:49:21 I msg:[MAIN] Calculated CPU count is 1
2011-07-30 18:49:21 I msg:[MAIN] Starting 1 network threads
2011-07-30 18:49:21 I msg:[MICROSERVER] Listening for connection on port 8001
2011-07-30 18:49:21 D msg:[THREADRUNNER] thread 0 amt=0
2011-07-30 18:49:21 D msg:[THREADRUNNER] Adding microServer to thread 0
2011-07-30 18:49:21 I msg:[MICROSERVER] Listening for connection on port 8002
2011-07-30 18:49:21 D msg:[THREADRUNNER] thread 0 amt=1
2011-07-30 18:49:21 D msg:[THREADRUNNER] Adding microServer to thread 0
2011-07-30 18:49:21 D msg:[THREADRUNNER] thread 0 amt=2
2011-07-30 18:49:21 D msg:[THREADRUNNER] Adding yp1 to thread 0
2011-07-30 18:49:21 D msg:[THREADRUNNER] thread 0 amt=3
2011-07-30 18:49:21 D msg:[THREADRUNNER] Adding yp2 to thread 0
DaWolfey is offline  
Old 31st July 2011, 11:53   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
DaWolfey: ergh, lack of a case insensitivity check. as that's a biggish issue, i'm going to get new builds run off now so they can be uploaded early monday (along with the sc_trans ones mentioned in my other post). and then i'm definitely out for the week...

and as a comment on the players you've tried against, only Winamp 5.61 or 5.62 currently properly work as SC2 clients.

-daz
DrO is offline  
Old 1st August 2011, 16:45   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
version fixing DaWolfey's bug report is now available via http://forums.winamp.com/showthread.php?t=332841

-daz
DrO is offline  
Closed Thread
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump